iSpindel - Aufbau und Betrieb

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1651

Beitrag von universam » Mittwoch 8. November 2017, 22:31

Wie schon von Jens geschrieben kannst du Leerzeichen weglassen, und die letzte Addition reicht auf 2 Nachkommastellen völlig aus.

Kannst du mal bitte deinen Konsolenlog schicken, es sollten eig. mehr wie 2 stellen für SG übertragen werden.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 1907
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#1652

Beitrag von Tozzi » Mittwoch 8. November 2017, 22:39

Wie läuft denn das überhaupt, mit SG?
Würde ich auch ganz gerne in meinem lokalen Server mit einbauen.
Das ging irgendwie an mir vorbei, ich hatte aber auch schon Anfragen deshalb (und würde das selber auch ganz gerne nutzen).
Viele Grüße aus München
Stephan

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1653

Beitrag von universam » Mittwoch 8. November 2017, 22:54

SG oder °P unterscheidet sich lediglich durch die das Polynom welches den Umrechnungsfaktor definiert. Oder mit anderen Worten, die 'Gravity' ist einheitenfrei und völlig frei, wenn ich SG will muss ich mein Excel oder das online Tool entsprechende Referenzen liefern.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 1907
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#1654

Beitrag von Tozzi » Mittwoch 8. November 2017, 23:10

Danke, jetzt hab ich's kapiert. :Ahh
Dann muss ich mir mal überlegen, wie ich das auf dem Frontend umsetzen kann. Geht letztlich "nur" um die Achsenbeschriftung.
Viele Grüße aus München
Stephan

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1655

Beitrag von universam » Mittwoch 8. November 2017, 23:23

fsl hat geschrieben:
Mittwoch 8. November 2017, 21:43
. In jedem Fall werden die Werte für den Extraktgehalt nur mit zwei Nachkommastellen übermittelt, was relativ witzlos ist. Es ist eben schon relevant, ob man bei 1,020 oder bei 1.029 ist, wenn schlicht 1.02 angezeigt wird. Kann man die iSpindel also nicht wirklich für Messungen in SG anstatt °P benutzen? Ich dachte eigentlich, das irgendwo anders gelesen zu haben.
Um nicht komplett an Vergesslichkeit zu leiden habe ich noch mal nachgestellt, also ich weiss nicht welche FW version du hast aber das stimmt so nicht!
Beispiel:
{"tilt":85.28551,"temperature":29.3125,"battery":4.030769,"gravity":31.19521}

Was am anderen Ende mit dem den Daten gemacht wird, das ist eine andere Geschichte...
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

fsl
Neuling
Neuling
Beiträge: 2
Registriert: Mittwoch 8. November 2017, 21:26

Re: iSpindel - Aufbau und Betrieb

#1656

Beitrag von fsl » Mittwoch 8. November 2017, 23:37

Hallo Jens und Sam,

erstens funktioniert es mit der von Jens vorgeschlagenen Schreibweise jetzt super, auch mit dem Polynom dritten Grades.

Und zweitens hat Sam vollkommen Recht: der Konsolenausgabe entehme ich, dass an Ubidots mit sechs Nachkommastellen übergeben wird.

Code: Alles auswählen

calling Ubidots
{"tilt":41.7549,"temperature":26.875,"battery":4.2805,"gravity":1.018536}Sender: Ubidots posting
POST /api/v1.6/devices/iSpindel-1?token=XXX HTTP/1.1
Host: things.ubidots.com
User-Agent: ESP8266
Connection: close
Content-Type: application/json
Content-Length: 73
Das kommt dort auch so an und wird auf er Seite mit den einzelnen Messwerten auch angezeigt.

Lediglich auf der Übersichtsseite, wenn man unter "Devices" auf die Spindel klickt und dann die vier Werte sehen kann, rundet (nicht: schneidet ab) Ubidots das auf zwei Nachkommastellen. Daraus, und aus dem Umstand, dass im iSpindel-Portal auch nur zwei Nachkommastellen angezeigt werden, bin ich fälschlicherweise davon ausgegangen, dass auch nur so viele übermittelt werden.

Das hier betrifft wohl die Ausgabe auf dem iSpindel-Hotspot-Portal:

Code: Alles auswählen

a: 10942	628	12432	absTilt: 41.75	T: 28.54	V: 4.28	owT: 26.87	Gravity: 1.02
Also: alles funktioniert bestens. Vielen herzlichen Dank für die prompte Hilfe und sorry für die etwas überhastete Annahme, dass der Extraktgehalt nur mit zwei Nachkommastellen übermittelt wird.

Grüße,
Felix

Klaus53123
Posting Junior
Posting Junior
Beiträge: 34
Registriert: Montag 30. Oktober 2017, 07:48

Re: iSpindel - Aufbau und Betrieb

#1657

Beitrag von Klaus53123 » Mittwoch 8. November 2017, 23:42

Tozzi hat geschrieben:
Mittwoch 8. November 2017, 23:10
Danke, jetzt hab ich's kapiert. :Ahh
Dann muss ich mir mal überlegen, wie ich das auf dem Frontend umsetzen kann. Geht letztlich "nur" um die Achsenbeschriftung.
ich bin mir nicht sicher ob ich Deine Aussage richtig verstehe. Aber zwischen SG und Plato gibt es eine nichtlineare Beziehung die sich sehr genau (R^2=0,9998....) mit einer Gleichung vierter Ordnung abbilden lässt.

Bei Brauerei Müggeland gibt es einen Online Umrechner zwischen SG und Plato

LG
Klaus

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 1907
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#1658

Beitrag von Tozzi » Donnerstag 9. November 2017, 01:33

Hallo Klaus,

danke für den Link, den hatte ich noch gar nicht gesehen.
Mir ging es aber primär darum, einen Weg zu finden, wie ich auf dem lokalen Server (Raspi) feststellen kann, welche Einheit da übermittelt wird von der iSpindel, SG oder Plato bzw. %mas, um die Diagramm Achse entsprechend beschriften zu können.
Ich werde wohl einen "Schalter" einbauen, und falls der nicht angegeben ist, einen "good guess" machen. SG bewegt sich ja in einem engen Rahmen.
Viele Grüße aus München
Stephan

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 2164
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1659

Beitrag von DerDerDasBierBraut » Donnerstag 9. November 2017, 07:53

Sie sind ja nur fürs Auge, aber Ich finde es auch immer schöner, wenn die richtigen Einheiten hinter den Werten stehen. Möglicherweise lohnt es sich wegen der Einheiten auch mal mit Ubidots zu sprechen. Deren API unterstützt momentan das explizite Anlegen von Variablem MIT richtiger Einheit und das implizite automatische Anlegen von Variablen beim Senden von Daten, OHNE Einheit.
Wenn die Einheiten dort zusammen mit den Werten als optionale Parameter gesendet werden könnten (damit sie dort auch implizit mit Einheit angelegt werden), dann könnte die iSpindel die richtige Einheit mitteilen, unabhängig vom Ziel der Daten (Ubi, LocalServer, iSpindel.de ... ). Für die Einheit von Gravity wäre in der iSpindel Konfig eine zusätzliche Option nötig.

Hatte Sam nicht gerade ein Gipfeltreffen mit dem Ubi CEO und eine Wunschliste aus dem Forum? :Wink
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
--------------------
Viele Grüße aus Ahrensburg
Jens

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 1907
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#1660

Beitrag von Tozzi » Donnerstag 9. November 2017, 17:47

Das wäre wohl die sauberste Lösung, ja.
Inzwischen werde ich es so lösen, dass man dem Diagramm einfach einen Toggle mitgibt falls man SG ablesen möchte bzw. man in der Datenbank hinterlegen kann, welche iSpindel welche Einheit liefert.
Viele Grüße aus München
Stephan

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1661

Beitrag von universam » Donnerstag 9. November 2017, 18:18

War ein tolles Meeting mit Agustin der CEO von Ubidots!
Er ist sehr begeistert von unserem Treiben und als angehender Hobbybrauer wollte er auch gleich unbedingt eine eigene iSpindel!
Wir haben 8 Punkte aus verschiedenen Feedback in die Diskussion gebracht was er auch direkt mitgenommen hat. Wir sind noch weiter in Verhandlung wie man das umsetzen kann. Ich will nicht vorweg nehmen aber es sieht so aus dass er die größten Mankos entfernen kann ohne unbedingt kostenpflichtigen Account zu erwarten.

Übrigens wusstet ihr, dass die erste iSpindel im Account generell kostenlos ist und keine Dots verschlingt?

Mehr später wenn sicher ist was geht oder nicht.

Unter anderem haben sie eben auch ermöglicht dass die variablen impliziert erstellt werden, also falls nicht vorhanden werden Sie nach Bedarf erstellt. Dabei gibt es kein Unit Label und in Anbetracht dass es außer Plato und SG ja auch weitere Maßeinheiten gibt soll sich jeder seine Label der Einheiten selbst erstellen können, der Variabel Name Gravity trifft es genau.
Das ist auch eher ein Feature, genauso wie bei Spannung, Temperatur und Winkel und gehört ins UI.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Klaus53123
Posting Junior
Posting Junior
Beiträge: 34
Registriert: Montag 30. Oktober 2017, 07:48

Re: iSpindel - Aufbau und Betrieb

#1662

Beitrag von Klaus53123 » Freitag 10. November 2017, 12:07

so, ich habe auch noch eine Frage zur Kalibrierung der Batteriespannung. Ich habe die Tapete hier durchsucht aber nichts gefunden. Falls ich falsch gesucht habe, verzeiht mir das bitte....

Meine Spindel sendet bei voll geladener Batterie eine Spannung von 4,3xy V. Im Portal der Spindel ist bei der Spannungskalibrierung ein Wert von 180,xy (glaube ich) hinterlegt. Der kam mit der Firmware mit. Wie eiche ich das nun? Wie berechne ich den richtigen Wert?

Danke für Eure Hilfe

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1663

Beitrag von universam » Freitag 10. November 2017, 12:51

https://github.com/universam1/iSpindel/ ... ocs/FAQ.md

Unter:
Wie kann ich die Spannungsanzeige kalibrieren?
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Klaus53123
Posting Junior
Posting Junior
Beiträge: 34
Registriert: Montag 30. Oktober 2017, 07:48

Re: iSpindel - Aufbau und Betrieb

#1664

Beitrag von Klaus53123 » Freitag 10. November 2017, 12:53

Danke... und Mist: ich dachte ich hätte alles gelesen :Ahh :Ahh :Ahh

Gimbel
Posting Junior
Posting Junior
Beiträge: 55
Registriert: Dienstag 8. Januar 2008, 20:02

Re: iSpindel - Aufbau und Betrieb

#1665

Beitrag von Gimbel » Sonntag 12. November 2017, 11:49

Hallo Zusammen,
ich habe eine Frage zur Genauigkeit ?
Wie hoch darf die Abweichung sein ? (+ - %)
Meine Anzeige ist 0,46 Plato bei Vorgabe von 0 Plato.
Ist das in der Toleranz ?

Grüße
Gimbel

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 2164
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1666

Beitrag von DerDerDasBierBraut » Sonntag 12. November 2017, 12:19

Die Genauigkeit kannst du selbst direkt mit dem Polynom beeinflussen. Erstelle es mit dem aktuellen Plato-Winkel-Paar bei 0°P neu und die Abweichung ist weg.
0,5°P wäre für mich aber völlig OK, weil allein schon der Kurvenverlauf, ungeachtet der Werte, aussagekräftig genug ist.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
--------------------
Viele Grüße aus Ahrensburg
Jens

Gimbel
Posting Junior
Posting Junior
Beiträge: 55
Registriert: Dienstag 8. Januar 2008, 20:02

Re: iSpindel - Aufbau und Betrieb

#1667

Beitrag von Gimbel » Sonntag 12. November 2017, 13:59

Danke für die schnelle Antwort.
Muss ich das neue Polynom auch in der Ispindel programmieren oder reicht es den Polynom in Ubidots zu Ändern.

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 2164
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1668

Beitrag von DerDerDasBierBraut » Sonntag 12. November 2017, 14:50

Das sind zwei verschiedene Dinge. Das Polynom in der Spindel berechnet die Ausgabewerte in der Variable "Gravity". Das Polynom in Ubidots berechnet die dort angelegte "Plato" Variable. Du kannst beide unabhängig voneinander benutzen oder nur einen davon.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
--------------------
Viele Grüße aus Ahrensburg
Jens

Gimbel
Posting Junior
Posting Junior
Beiträge: 55
Registriert: Dienstag 8. Januar 2008, 20:02

Kalibrirung mit Ubidots

#1669

Beitrag von Gimbel » Dienstag 14. November 2017, 20:34

Hallo Ispindler,
habe folgendes Problem .
Ich will die Spindel kalibrieren. Spindeleinstellung 3 min.
Ubidots aktualsiert die Wert nicht mach 3 min.
Ich bin ca. 5 m von meinen Router weg.
Was ist das Problem ?
Gibt es eine Altanative zu Obidots nicht mit Tozzi Idee.
Grüße
Gimbel

Benutzeravatar
Alien_TM
Posting Klettermax
Posting Klettermax
Beiträge: 111
Registriert: Montag 11. Januar 2016, 14:50

Re: Kalibrirung mit Ubidots

#1670

Beitrag von Alien_TM » Dienstag 14. November 2017, 22:18

Gimbel hat geschrieben:
Dienstag 14. November 2017, 20:34
Ubidots aktualsiert die Wert nicht mach 3 min.
Ich bin ca. 5 m von meinen Router weg.
Grüße
Gimbel
Bist du sicher, das die Spindel automatisch sendet? (blinkt die blaue LED alle 3min?)

Prüfe, ob auf der Hauptplatine R3 der 470Ω und bei R1 der 4,7kΩWiderstand is... (wenn du die beiden zufällig beim Löten vertauscht, sendet die Spindel nur beim Einschalten, nicht das mir das passiert wäre... :redhead )

Punkt 3 Hauptplatine https://dl.dropbox.com/s/s95dsfn3c269hm ... ung_DE.pdf

...Alex

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 2164
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1671

Beitrag von DerDerDasBierBraut » Mittwoch 15. November 2017, 01:09

Moin Gimbel,
nach mal bitte ein Trace vom Boot der Spindel und lass es so lange laufen, bis die Spindel nach 3 Minuten wieder aufwacht.
https://youtu.be/6xDW5GbIbUw
Denke dran die Daten zu anonymisieren, wenn Du sie hier postest.

Falls nach 3 Minuten nichts geloggt wird, dann stimme ich Alex zu. Irgendwas passt dann mit dem 470 Ohm Widerstand nicht (vertauscht, kalte Lötstelle, kaputt, etc.)
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
--------------------
Viele Grüße aus Ahrensburg
Jens

alfagero
Neuling
Neuling
Beiträge: 6
Registriert: Freitag 27. Oktober 2017, 12:29

Re: iSpindel - Aufbau und Betrieb

#1672

Beitrag von alfagero » Donnerstag 16. November 2017, 05:15

Moin!

habe auch meine Ispindel aufgebaut. Hat alles gut geklappt. Temperatur und Winkelanzeige funktionieren prima. Beim Kalibrieren zeigt sich aber: irgendwas funktioniert da nicht so richtig.
Meine Spindel schwimmt immer relativ flach auf dem "Eichwasser"(ca. 60 Grad/Tilt).
Die Werte sind nicht plausibel:
winkel plato
61,05 0
59,44 20
61,5 15
62,94 10
58,73 7,5
61,31 5
63,08 2,5

Habt Ihr noch irgendwo ein Gewicht eingebaut ? Ich bin ziemlich ratlos.
ein Tipp wäre super..

Viele Grüße
Gero

Benutzeravatar
mwx
Neuling
Neuling
Beiträge: 3
Registriert: Mittwoch 11. Oktober 2017, 07:37

Re: iSpindel - Aufbau und Betrieb

#1673

Beitrag von mwx » Donnerstag 16. November 2017, 05:37

Hallo

Du hast wohl die Gewichte vergessen. Du mußt am unteren Ende am besten auf der Batterie Seite 10-20g Gewichte einbauen. So das Du in Wasser ca. 25 Grad hast.

Gruß, Michael

Benutzeravatar
Karel
Posting Klettermax
Posting Klettermax
Beiträge: 201
Registriert: Sonntag 29. März 2015, 18:26
Wohnort: Luxemburg

Re: iSpindel - Aufbau und Betrieb

#1674

Beitrag von Karel » Donnerstag 16. November 2017, 07:24

Moin
Mein Dank an Alle die an diesem Projekt arbeiten. Meine schwimmt nun auch und sendet auch fleissig Daten. Daher nochmals Danke an @DerDerDasBierBraut und @Glassart für die anfängliche Unterstützung.

Frage: habe versucht eine neue Variable per Ubidots: fx derived (Anleitung von DerDerDasBierBraut über youtube) und Plato genannt wird aber nicht erkannt....
Gruss
Karel

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 2164
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1675

Beitrag von DerDerDasBierBraut » Donnerstag 16. November 2017, 07:46

Moin Karel,

typische Fehler und Lösungen dafür wären:

a) "Komma" anstatt "Punkt" als Dezimaltrennzeichen verwendet:
>> FX derived Variable nochmal löschen und neu anlegen, Punkt als Dezimaltrennzeichen verwenden (s.Video)

b) Problem beim Ersetzen vom Text "tilt" durch die Device-Variable "tilt":
>> FX derived Variable nochmal löschen und neu anlegen, Polynom anschauen, die "Device Tilt Variable" so oft in die Formelzeile einbauen wie nötig, den Rest des Polynoms vor, zwischen und hinter den "lilanen Tilts" einfügen (s.Video)

c) alles richtig gemacht, geht trotzdem nicht:
>> FX derived Variable nochmal löschen und neu anlegen, anschließend kurz warten, bis die historischen Werte nachberechnet wurden
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
--------------------
Viele Grüße aus Ahrensburg
Jens

alfagero
Neuling
Neuling
Beiträge: 6
Registriert: Freitag 27. Oktober 2017, 12:29

Re: iSpindel - Aufbau und Betrieb

#1676

Beitrag von alfagero » Donnerstag 16. November 2017, 12:26

mwx hat geschrieben:
Donnerstag 16. November 2017, 05:37
Hallo

Du hast wohl die Gewichte vergessen. Du mußt am unteren Ende am besten auf der Batterie Seite 10-20g Gewichte einbauen. So das Du in Wasser ca. 25 Grad hast.

Gruß, Michael
Danke Michael!

den Teil hatte ich wohl überlesen. War bei dem Kit auch nichts dabei. Super. Werde es heute Abend mal probieren

alfagero
Neuling
Neuling
Beiträge: 6
Registriert: Freitag 27. Oktober 2017, 12:29

Re: iSpindel - Aufbau und Betrieb

#1677

Beitrag von alfagero » Donnerstag 16. November 2017, 18:00

mhh. trotz der Gewichte (4 Muttern=24 g) zeigt die Spindel 60 Grad an. Wenn ich die Spindel horizontal ausrichte, erreiche ich auch keine 0 oder 90 Grad. Gibt es irgendwo eine bessere Anleitung als bei github ? Finde die dort ziemlich lückenhaft/rudimentär.

glassart
Posting Freak
Posting Freak
Beiträge: 769
Registriert: Mittwoch 1. Juli 2015, 11:50

Re: iSpindel - Aufbau und Betrieb

#1678

Beitrag von glassart » Donnerstag 16. November 2017, 18:05

dann scheint das Problem wohl eher beim GY521 zu liegen -prüfe einmal deine Lötstellen bzw. welche LED du ausgelötet hast.
Es gibt 2 Modelle von GY mit unterschiedlicher LED-Position.

VG Herbert

Titto
Neuling
Neuling
Beiträge: 4
Registriert: Dienstag 7. November 2017, 11:09

Re: iSpindel - Aufbau und Betrieb

#1679

Beitrag von Titto » Donnerstag 16. November 2017, 20:00

Hallo an alle Forenmitglieder,

ich war bis jetzt ein stiller Mitleser. Mit eurer Hilfe habe ich angefangen von einem vagen Interesse hin zu einer Lektüreauswahl bis zur Ausrüstung für meine ersten Sude alle meine Fragen beantworten können. Vielen Dank schon mal dafür. An die ISpindel habe ich mich auch ran gewagt und eigentlich hat es auch wunderbar geklappt, dachte ich.
Ich habe das Set mit Schlitten und Platine von 3d Mechatronics gekauft und den Aufbau auch gut hinbekommen. Das Thermometer fand ich sehr fummelig anzubringen. Aber ansonsten war alles ok. Ich konnte auch Wlan-Modul flashen. Aber jetzt habe ich ein Problem.
Ich bekomme die ISpindel nicht angezeigt bei mir am Rechner (Windows 10). Wenn ich das richtig verstanden habe, muss ich den Resetknopf mehrmals drücken und dann das WLan anwählen und dann über die IP-Adresse auf die ISpindel zugreifen. Aber da tut sich bei mir nichts.
Wenn ich die IPindel anschlate, blinkt die blaue LED einige Male schnell. Danach tut sich nichts.
Komisch finde ich auch, dass ich nicht das Gefühl habe den Resetknopf "drücken" zu können. Der scheint sehr fest zu sitzen. Ist das wirklich ein "drückbarer" Knopf?
Die Batteriespannung habe ich gemessen. Sie hat 4,18 Volt. Ich bin jetzt am überlegen, ob der Resetknopf tatsächlich einfach kaputt ist. Wie gesagt, er scheint sich absolut nicht zu bewegen. Ich habe den kompletten Thread durchgelesen bzw. überflogen um Hinweise zu bekommen. Falls ich die Antwort überlesen habe tut es mir Leid. Aber vielleicht kann mir ja doch noch jemand helfen.

Viele Grüße
Christoph

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1680

Beitrag von universam » Donnerstag 16. November 2017, 20:04

Erster Schritt ist eigentlich immer die log Ausgabe sich anzuschauen.
In der FAQ steht wie das geht.
Wenn das dir keine Idee liefert poste diese Ausgabe mal hier, dann finden wir das Problem schon.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Benutzeravatar
Dyrdlingur
Posting Klettermax
Posting Klettermax
Beiträge: 246
Registriert: Sonntag 17. November 2013, 08:31
Wohnort: Höhenkirchen bei München

Re: iSpindel - Aufbau und Betrieb

#1681

Beitrag von Dyrdlingur » Donnerstag 16. November 2017, 20:10

Hallo Christoph,
Universam hat dir ja schon den entsprechenden Tip gegeben. Zum Thema „Resetknopf drücken“: Solange deine iSpindle noch nicht initial konfiguriert ist, sollte das meiner Erinnerung nach nicht notwendig sein.
VG Klaus

Titto
Neuling
Neuling
Beiträge: 4
Registriert: Dienstag 7. November 2017, 11:09

Re: iSpindel - Aufbau und Betrieb

#1682

Beitrag von Titto » Donnerstag 16. November 2017, 20:15

Wow, das ging schnell. Vielen Dank, ich probiere das mal.

Titto
Neuling
Neuling
Beiträge: 4
Registriert: Dienstag 7. November 2017, 11:09

Re: iSpindel - Aufbau und Betrieb

#1683

Beitrag von Titto » Donnerstag 16. November 2017, 20:29

Ja mist, da habe ich wieder das gleiche Problem. Ich kann die Spindel anschließen, den Com Port ermitteln (bei mir Com4). Dann gebe ich die 115200 ein (obwohl ich keine Ahnung habe, was das ist). Danach startet das Putty-Fenster mit dem leuchtend grünen "Button" links oben. Wenn ich dann auf den Resetknopf "drücke" passiert gar nichts.

Grüße
Christoph

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 2164
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1684

Beitrag von DerDerDasBierBraut » Donnerstag 16. November 2017, 20:35

Das ist ein normaler kleiner Mikrotaster, bei dem man das Schalten spürt.
Hast du ihn versehentlich irgendwo mit zugeklebt oder mit dem Lötkolben festgebruzzelt?

Du könntest ersatzweise mal probieren die beiden Lötpunkte des Tasters auf der Wemos Platine zu brücken.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
--------------------
Viele Grüße aus Ahrensburg
Jens

Titto
Neuling
Neuling
Beiträge: 4
Registriert: Dienstag 7. November 2017, 11:09

Re: iSpindel - Aufbau und Betrieb

#1685

Beitrag von Titto » Donnerstag 16. November 2017, 20:55

Wow, das mit dem Brücken klappt. Dann bekomme ich auch eine Anzeige und konnte die Spindel sogar einrichten. Dann habe ich wohl irgendwie den Schalter gebruzzelt. Das ist ja ärgerlich. Ich werde mir dann wohl einen neuen Wemos besorgen müssen und beim nächsten mal etwas vorsichtiger sein. Jedesmal den Schalter zu brücken ist mir zu blöd. Hoffentlich habe ich ansonsten nichts geschrottet. Wie gesagt, bis auf bei dem Thermometer dachte ich eigentlich nicht, dass ich irgendwo zu lange den Lötkolben draufgehalten habe.
Folgendes zeigt mir Putty (nach dem einrichten) an:

Euch schon mal vielen Dank. Vom meinem ersten Igespindeltem Bier werde ich euch auf jeden Fall was zukommen lassen. Ihr seid echt die Wucht.

{"Na me":"iSpindel_Titto","Token":"XXX ","Sleep":900,"S erver":"","API":0,"Port":80,"URL":"","Vfact":191.8,
:"XXX","POLY":"-0.00031*tilt^2+0.557*tilt-14.054","aX":0,"aY":0,"aZ":0}
woke n from deepsleep, normal mode
Spl 0: 66.17
Spl 1: 66.36
Spl 2: 66.41
Spl 3: 66.62
Spl 4: 66.45
Spl 5: 66.63
Spl 6: 66.42

a: 4732 -14808 5340 absTilt: 66.42 T : 27.40 V: 4.14 owT: 25.25 Gravity: 21.58
After waiting 3502ms, result 3
IP: 192.168.2.109


calling Ubidots
{"tilt":66.42464,"temperature":25.25,"battery":4.139 729,"gravity":21.57673}Sender: Ubidots posting
POST /api/v1.6/devices/iSpindel_Titto?token=
TTP/1.1
Host: things.ubidots.com
User-Agent: ESP8266
Connection: close
Content-Type: application/json
Content-Length: 75

POST /api/v1.6/devices/iSpindel_Titto?token TTP/1.1
Host: things.ubidots.com
User-Agent: ESP8266
Connection: close
Content-Type: application/json
Content-Length: 75


Final-sleep: 900s; RT:7642

Benutzeravatar
mwx
Neuling
Neuling
Beiträge: 3
Registriert: Mittwoch 11. Oktober 2017, 07:37

Re: iSpindel - Aufbau und Betrieb

#1686

Beitrag von mwx » Freitag 17. November 2017, 14:19

Habe grade meinen ersten Sud mit iSpindel fast fertig. Wunderbares Teil! Danke an alle die das erfunden haben
b.png

alfagero
Neuling
Neuling
Beiträge: 6
Registriert: Freitag 27. Oktober 2017, 12:29

Re: iSpindel - Aufbau und Betrieb

#1687

Beitrag von alfagero » Samstag 18. November 2017, 10:34

schönes sauberes Diagramm!
Glückwunsch.

Meine Probleme mit der Winkelanzeige konnte ich auch lösen. Hatte den Schlitten noch mal aus dem Gehäuse gezogen und sauber waagerecht ausgerichtet und kalibriert. Danach zeigt die Winkelanzeige plausible Werte.

Gimbel
Posting Junior
Posting Junior
Beiträge: 55
Registriert: Dienstag 8. Januar 2008, 20:02

Re: iSpindel - Messgemauigkeit

#1688

Beitrag von Gimbel » Samstag 18. November 2017, 12:42

Hallo Zusammen,
wie kann ich die Genauigkeit der Spindel beeinflussen ?
Anbei meine Exeltabelle.

Tilt Plato Abweichung
16,77 0 -0,77 °P
21,07 2,43 -0,15 °P
28,27 5,83 0,31 °P
42,23 10,19 -0,75 °P
52,92 14,56 0,48 °P
51,26 14,4 0 0,14 °P
43,46 10,87 -0,53 °P
30,82 6,9 0,36 °P
26,93 5,84 0,86 °P
21,69 3,18 0,34 °P

An welcher Schraube muss ich drehen ?
+- 0,5 Plato Genaugikeit sollte schon sein.
Grüße
Gimbel

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1689

Beitrag von universam » Samstag 18. November 2017, 12:50

Du kannst das iterativ machen, war ne gute Idee von Jens: Die Werte bei jedem Sud hinzufügen, dadurch erhältst du einen besseren Mittelwert mit der Zeit und die Kurve wird genauer.
In der Firmware kannst du auch ein Polynom 3. Grades verwenden wenn es besser passt.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

kaiserstuhl123
Neuling
Neuling
Beiträge: 4
Registriert: Sonntag 5. Februar 2017, 14:51

Re: iSpindel - Aufbau und Betrieb

#1690

Beitrag von kaiserstuhl123 » Samstag 18. November 2017, 15:26

Hallo Leute,

toll was ihr hier auf die Beine gestellt habt :).
Hab mir auch eine gegönnt ( bestellt bei 3d-mechatronics), laut der Anleitung alles zusammengelötet, allerdings taucht die Spindel weder im Wlan noch bei mir am Pc auf.
Habe bereits versucht die Log Ausgabe anschzuschauen, allerdings taucht die Spindel leider überaupt nicht am Pc auf.
Die blaue Wlan? Led am Wemos leuchtet dauerhaft wenn ich den Schalter einschalte.
Laut Anleitung hab ich die Led auf der kleinen Platine entfernt, außerdem den Kondensator auf der Wemos Platine.
Hatte vielleicht jemand eine Idee was ich falsch gemacht haben könnte?

Vielen dank für die Mühe schonmal im vorraus.

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1691

Beitrag von universam » Samstag 18. November 2017, 15:32

Hast du sie erfolgreich geflasht?
Ich hoffe du meinst Diode, nicht Kondensator!
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

kaiserstuhl123
Neuling
Neuling
Beiträge: 4
Registriert: Sonntag 5. Februar 2017, 14:51

Re: iSpindel - Aufbau und Betrieb

#1692

Beitrag von kaiserstuhl123 » Samstag 18. November 2017, 15:55

Hallo,
danke schonmal für die schnelle Antwort.
Nein leider noch nicht, weil sie weder im Wlan noch als Com auftaucht.
Also in der Anleitung steht definitv Kondensator?(Lötanleitung bei 3d-mechatronics)

universam
Posting Senior
Posting Senior
Beiträge: 484
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1693

Beitrag von universam » Samstag 18. November 2017, 16:07

Das ist Quatsch, weiß nicht warum er jetzt ne Anleitung dazu legt... Muss ich mal nachhaken, einzig Relevante steht in meinem Repo.

Du sagtest der Wemos leuchtet blau? Dann ist noch nicht alle Hoffnung verloren. Wenn du ein Terminal aufmachst musst du soweit kommen dass du irgendeine Ausgabe von dem Wemos siehst. Dann sollte es auch mit dem flashen klappen. Ohne Flashen ist das Ding ja hirnlos, also kannst du alles weitere auch vergessen.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste