iSpindel - Aufbau und Betrieb

craftworx
HBCon Supporter
HBCon Supporter
Beiträge: 22
Registriert: Samstag 21. März 2015, 19:32

Re: iSpindel - Aufbau und Betrieb

#1001

Beitrag von craftworx » Mittwoch 19. April 2017, 10:05

Super, danke, Jens! Dann harre ich mal aus. :thumbsup

DerDerDasBierBraut hat geschrieben:
craftworx hat geschrieben:Hallo zusammen,
altbekanntes Thema: gibt es mittlerweile einen Händler, wo man passende XL-Petlinge beziehen kann? Seit http://cachers-world.de/ keine mehr anbietet, bin ich auf der Suche. Trotz scheinbar identischer Maße (4x15cm) gibt es bei den Händlern sehr unterschiedliche Petlinge, die teils konisch zulaufen. Und dann passt die Platine trotz Abfeilens nicht mehr rein.
Bitte habe noch etwas Geduld. 3D Mechatronics hat 1000 Petlinge und 1700 schwarze Deckel bestellt. Das Material kommt aus anderen EU Staaten.
Der Transport dauert etwas. Ich gebe hier Bescheid, sobald man den "iSpindel Norm-Petling" in Bremen bestellen kann. :Greets

TomTom
Posting Junior
Posting Junior
Beiträge: 42
Registriert: Sonntag 15. Januar 2017, 09:08
Wohnort: Oberottmarshausen

Re: iSpindel - Aufbau und Betrieb

#1002

Beitrag von TomTom » Mittwoch 19. April 2017, 22:35

Servus beinand,
meine Gärung mit der unkalibrierten Spindel ist jetzt beendet. Ich habe nun die Kalibrierung bei 0°Plato mit 25,25°Tilt durchgeführt. Sieht in dem Excelsheet ganz gut aus.
Folgende Messreihe ist rausgekommen:
°Plato °Tilt
0 25,25
2,5 33,56
5 41,35
7,5 48,40
10 54,04
15 62,73
20 67,85

jetzt habe ich noch das Problem mit meinem Office2007, dass dieses den Dienst mit einer Fehlermeldung 400 beim Berechnen der Formel verweigert.

Würde bitte einer hier aus dem Forum die Werte mal bei sich einsetzen, und mir den Wert nennen, den ich dann noch eintagen muss.

Vielen Dank :Drink
Thomas

Benutzeravatar
MachdenDeckelRund
Posting Klettermax
Posting Klettermax
Beiträge: 145
Registriert: Freitag 13. Mai 2016, 20:51
Wohnort: Ingolstadt

Re: iSpindel - Aufbau und Betrieb

#1003

Beitrag von MachdenDeckelRund » Mittwoch 19. April 2017, 23:21

TomTom hat geschrieben:Servus beinand,
meine Gärung mit der unkalibrierten Spindel ist jetzt beendet. Ich habe nun die Kalibrierung bei 0°Plato mit 25,25°Tilt durchgeführt. Sieht in dem Excelsheet ganz gut aus.
Folgende Messreihe ist rausgekommen:
°Plato °Tilt
0 25,25
2,5 33,56
5 41,35
7,5 48,40
10 54,04
15 62,73
20 67,85

jetzt habe ich noch das Problem mit meinem Office2007, dass dieses den Dienst mit einer Fehlermeldung 400 beim Berechnen der Formel verweigert.

Würde bitte einer hier aus dem Forum die Werte mal bei sich einsetzen, und mir den Wert nennen, den ich dann noch eintagen muss.

Vielen Dank :Drink
Thomas
Servus Thomas,

Plato = 0.007013043*(tilt)*(tilt) - 0.208042982*(tilt) + 1.166276766
Unbenannt.JPG
Gruß
Ralf.
Brauen ist Wellness für die Seele.

Benutzeravatar
Chrissi_Chris
Posting Freak
Posting Freak
Beiträge: 2073
Registriert: Donnerstag 22. Dezember 2016, 10:51
Wohnort: Damme

Re: iSpindel - Aufbau und Betrieb

#1004

Beitrag von Chrissi_Chris » Donnerstag 20. April 2017, 06:05

[quote="quasarmin" Die Intervalle erfolgten stündlich.
Die Batteriespannung sank in der Zeit laut Anzeige von 4.16V auf 4.10V.

Gruß
Armin[/quote]

Hm... :Grübel das klingt gut wenn ich meine Spindel so beobachte erreicht sie bei vollständiger Ladung 3,88 V und nach dem ersten Sud ca 10-14 Tage liegt es bei ca. 3,72V wieso kommt meine nichtmal über 4V ?
Intervall ist bei mir auf 300sekunden

LG Chris

Benutzeravatar
MachdenDeckelRund
Posting Klettermax
Posting Klettermax
Beiträge: 145
Registriert: Freitag 13. Mai 2016, 20:51
Wohnort: Ingolstadt

Re: iSpindel - Aufbau und Betrieb

#1005

Beitrag von MachdenDeckelRund » Donnerstag 20. April 2017, 21:07

Hm... :Grübel das klingt gut wenn ich meine Spindel so beobachte erreicht sie bei vollständiger Ladung 3,88 V und nach dem ersten Sud ca 10-14 Tage liegt es bei ca. 3,72V wieso kommt meine nichtmal über 4V ?
Intervall ist bei mir auf 300sekunden

LG Chris
Hallo Chris,

meine Spindel hat laut Anzeige und Messung mit Voltmeter auch nur 3,8V am Akku. Da bist Du nicht alleine...
Gernot hat mir seine Hilfe angeboten für die Fehlerbeseitigung. Ich habe da leider keinen Plan von der Materie, kann dann aber gerne berichten, woran es lag.

Vg
Ralf
Brauen ist Wellness für die Seele.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1006

Beitrag von DerDerDasBierBraut » Donnerstag 20. April 2017, 21:20

Die Nennspannung der NCR18650 Zellen ist 3,7V. Diese Spannung versucht der Akku möglichst lange konstant zu halten.
Schaut euch die Kennlinie an.
https://engineering.tamu.edu/media/4247 ... 650ncr.pdf
Bei 25°C kann der randvolle Akku in den ersten paar Prozent der Entladung 3,8V haben, über 25°C irgendwas bei 4V. Nach 2-3 % Entladung ist er schon bei 3,7V.

Die 220k Widerstände für die Spannungsmessung haben Toleranzen, die die Spannungsanzeige beeinflussen. Wollt ihr immer über 3,7V sehen? Dann lötet euch einen 180 kOhm Widerstand ein. An der Akkulaufzeit verändert der kleinere Widerstand erstmal nichts. Lediglich der "Überlebensmodus" der Spindel wird bei zu hoch gemessener Spannung später aktiv und der Akku wird dadurch am Ende schneller leer.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
quasarmin
Posting Senior
Posting Senior
Beiträge: 451
Registriert: Montag 25. Januar 2016, 18:14
Wohnort: Eckernförde

Re: iSpindel - Aufbau und Betrieb

#1007

Beitrag von quasarmin » Donnerstag 20. April 2017, 21:50

Moin

ich verwende diese grünen Panasonic-Zellen, mit eingebauten Laderegler.

Nun habe ich meine 4 iSpindeln (derzeit alle arbeitslos) nachgemessen:

Spannungsanzeige im Testmodus / Digital-Messgerät (Voltcraft VC270)

4,09V / 4,07V
4,13V / 4,07V
4,14V / 4,06V
3,87V / 3,88V

Alle Spannungen sind Ruhespannungen bei kurzen Testbetrieb bei 22°C.
Die ersten beiden Werte stammen von Spindel die 14 Tage im Betrieb waren und noch nicht wieder aufgeladen wurden.
Wie schon geschrieben habe ich ausgesuchte 220k Widerstände verwendet.

Das Digitalmultimeter habe ich schon mit geeicheten Geräten (aus unsere QS-Ausstattung) verglichen, das ist ok.

Bevor nun einige eine Glaubenkrise bekommen, letztlich sollte mein Beitrag darauf hinweisen, dass nach 14 Tagen untergärig die Spannung nur um 0,06V fiel.
Der Akku ist bei stündlicher Abtatstung quasi in Ruhrspannung.

Gruß
Armin

Benutzeravatar
flensdorfer
Posting Freak
Posting Freak
Beiträge: 662
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: iSpindel - Aufbau und Betrieb

#1008

Beitrag von flensdorfer » Donnerstag 20. April 2017, 22:08

quasarmin hat geschrieben:Bevor nun einige eine Glaubenkrise bekommen, letztlich sollte mein Beitrag darauf hinweisen, dass nach 14 Tagen untergärig die Spannung nur um 0,06V fiel.
Kann ich bestätigen. Meine Akkuspannung (geliefert von der iSpindel) fiel über 3 Wochen untergärig von 4.14V auf 4.09V. Den Akku hatte ich 2 Tage vor dem Einsatz aufgeladen und die Spindel dann bis zum Schwimmen ausgeschaltet.
Gruß, Arne

Anfänger in der 20l-Klasse

Benutzeravatar
universam
Posting Freak
Posting Freak
Beiträge: 518
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1009

Beitrag von universam » Donnerstag 20. April 2017, 22:17

Leute,

Nix mit umlöten. Nehmt euch ein Messgerät und lest die echte Akku Spannung ab. Dann macht ihr Dreisatz mit dem angezeigten Werft und multipliziert auf den Faktor den ihr in der Konfiguration stehen habt.

Mehr ist es nicht, folglich bekommt ihr dann auch den richtigen Wert angezeigt.

Gruß
Sam
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Benutzeravatar
marsabba
Posting Freak
Posting Freak
Beiträge: 1316
Registriert: Samstag 8. Oktober 2011, 22:05

Re: iSpindel - Aufbau und Betrieb

#1010

Beitrag von marsabba » Donnerstag 20. April 2017, 22:28

Verbesserungsvorschlag:
Im COnfig-Menü sollte man besser die gemessene Batteriespannung eingeben, und die Spindel macht den Dreisatz und berechnet den Umrechnungsfaktor selber.

Grüße
Martin

noizy
Posting Junior
Posting Junior
Beiträge: 26
Registriert: Sonntag 11. Dezember 2016, 19:37
Wohnort: Wien

Re: iSpindel - Aufbau und Betrieb

#1011

Beitrag von noizy » Freitag 21. April 2017, 00:01

Nochmal zum Thema "Einfluß von Schaum / Kräusen verringern":

Meine neue Test-Spindel hat nun ein "verdrehtes" und modifiziertes Innenleben: Die abgerundete Seite schwimmt oben, und das Tariergewicht wird kurz vor jeder Messung kurz verschoben, um ein Nicken zu bewirken. Davon erhoffe ich mir Neigungsmessungen mit geringerem Fehler - ähnlich wie wenn man die Spindel oben mit dem Finger antippen würde, um das Anheben durch Schaum wegzukriegen. Ich vermute auch, daß das abgerundete Ende weniger stark durch Schaum beeinflusst wird, als der kantige Deckel + Rille. Eine kleine Unbequemlichkeit meiner Bauweise ist allerdings, daß die Elektronik zum Laden (und dzt. auch zum Ein/Ausschalten) aus dem Petling gezogen werden muß.

Nach dem Wecken wird "genickt", ein paar Sekunden gewartet, dann Messung wie bisher. Servo-Control kommt von D1; zum Stromsparen schalte ich die Versorgung des Linearservos (Modellbau) mit einem P-FET über D4 ein/aus.

Im Versuch funktioniert es gut; am Wochenende mache ich dann was Obergäriges zum Testen.

Warum einfach, wenn's kompliziert auch geht?
Grüße,
Roland.
Dateianhänge
iSpindel-reverse2.jpg

Kägi
Neuling
Neuling
Beiträge: 5
Registriert: Freitag 3. Februar 2017, 10:45

Re: iSpindel - Aufbau und Betrieb

#1012

Beitrag von Kägi » Freitag 21. April 2017, 07:34

Moin Zusammen

Ist davon auszugehen das dies der Schaum Einfluss war das die Winkelkurve nun deutlich wieder in die andere Richtung läuft?
Was ist eure Meinung zur Temperaturkurve?
Gärfass ist in einem Klimsschrank mit fix 21 Grad.

https://app.ubidots.com/ubi/public/getd ... WvrEUJaerQ

Eiswette
Neuling
Neuling
Beiträge: 9
Registriert: Donnerstag 15. Dezember 2016, 13:10

Re: iSpindel - Aufbau und Betrieb

#1013

Beitrag von Eiswette » Freitag 21. April 2017, 17:29

Hallo nochmals,

ich habe jetzt unsere zweite Spindel zusammengebaut.
Mit der Neigungsmessung stimmt wohl etwas nicht, denn stelle ich die Spindel senkrecht (auf den Deckel), so gibt die Spindel einen Wert von 20° aus.
Ich hab die Platine benutzt und augenscheinlich steht der Sensor ziemlich, bis fast genau, senkrecht. So genau kann ich das nicht mit dem Auge abschätzen.
Wo kann ich den Fehler suchen?

Schönes Wochenende euch allen! :Drink

Jan

joergp
Neuling
Neuling
Beiträge: 8
Registriert: Sonntag 23. April 2017, 01:05

Re: iSpindel - Aufbau und Betrieb

#1014

Beitrag von joergp » Sonntag 23. April 2017, 01:19

Ich bin neu hier, also erst einmal „Hi!“.

Seit Anfang des Jahres braue ich mit Brewie („Bierbrauautomat“, siehe brewie.org) Bier und bin stolz auf die moderaten Ergebnisse. Nachdem Dichtemessung schnell ein Thema wurde, bin ich auf euer Projekt gestoßen und habe mir sofort den Bausatz bestellt, gebaut und erfolgreich in meinem 4. Sud eingesetzt.

Da ich die Hausautomatisierung Loxone einsetze, kam der Wunsch auf, dort die Werte von der iSpindel zu erfassen. Daher habe ich die Programmierung um die notwendigen Elemente erweitert (Felder zum Login, Http Get mit Authentifizierung etc.). Das lässt sich auch gut für andere Web Services adaptieren, die eine Authentifizierung benötigen. Meine Erweiterungen habe ich soeben als Pull-Request an universam geschickt.

Für alle, die auf einem Mac unterwegs sind: ich compiliere mittlerweile direkt auf die iSpindel – eine tolle Anleitung dazu befindet sich hier: https://blog.rjdlee.com/getting-started ... n-mac-osx/

An dieser Stelle noch herzlichen Dank an die Macher und die anderen Unterstützer dieses Projekt, das wirklich hilfreich ist (und geeky).

Jörg
Dateianhänge
loxone-app-screenshot.png

noizy
Posting Junior
Posting Junior
Beiträge: 26
Registriert: Sonntag 11. Dezember 2016, 19:37
Wohnort: Wien

Re: iSpindel - Aufbau und Betrieb

#1015

Beitrag von noizy » Sonntag 23. April 2017, 11:42

Hallo,

mein Versuch mit der "nickenden Spindel" im Obergärigen läuft - sieht bis jetzt sehr gut aus, auch Stromverbrauch ist unauffällig. Wie schon mit der normalen Spindel, ist die Dichte angeblich zunächst angestiegen (ca. +0.5), und erst mit dem Anspringen der Gärung geht es normal abwärts.

Und wieder einmal ist die Kalibrierung etwas daneben. Wahrscheinlich sitzt der Schlitten nach jedem Auf/Zuschrauben etwas anders, deshalb als Nächstes:
Drahtlose Ladung mit Qi-kompatiblem Modul, Reedkontakt für das Reset, und ein neuer Punkt "On/Off" ins Setup. Wenn man die Spindel damit "Off" schaltet, wird einfach ein extrem langes Wakeup-Intervall plus Überspringen aller Mess- und Sendefunktionen gesetzt. So müsste man die Spindel nie mehr aufschrauben - besser für Kalibrierung und Deckeldichtung. Ladeflächen gibt es auch bei IKEA, und zum Aktivieren des Access Point Modus (= Setup) fährt man mit einem Magneten neben dem Reedkontakt ein paar Mal hin und her.

Bitte um Kommentare...

Grüße,
Roland.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1016

Beitrag von DerDerDasBierBraut » Sonntag 23. April 2017, 12:29

Das Nicken der Spindel finde ich sehr interessant, Roland.
Nachdem ich meinen ersten Sud wegen einer "iSpindel Infektion" wegschütten musste, werde ich meine Spindeln definitiv immer zum gründlichen Reinigen auseinanderbauen und auch die Petlinge von Zeit zu Zeit austauschen. Reed, Induktivlademodul und "nie wieder öffnen" sind eine nette Spielerei, die aber nicht mit der Hygiene im Kaltbereich zusammenpassen. Kann natürlich jeder machen wie er will. Für die "Standardversion" der Spindel halte ich die "nie-wieder-öffnen-Spindel" für gefährlicher als die tägliche Probenentnahme über Hahn oder Deckel.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1651
Registriert: Mittwoch 1. Juli 2015, 11:50
Wohnort: Gunskirchen OÖ

Re: iSpindel - Aufbau und Betrieb

#1017

Beitrag von glassart » Sonntag 23. April 2017, 12:39

sehe ich auch so, Jens :Grübel

Im Bereich des Gewindes bleiben einfach Hopfen/Eiweißreste die weg müssen.
Ich habe jetzt 3 Sude hintereinander ohne zu öffnen ( auch ohne Infektion :Pulpfiction ) gefahren und jetzt geöffnet /geladen und im Gewindebereich eine schöne Schmutzansammlung gesehen!
Vielleicht hatte ich Glück oder die Tatsache, dass ich die Spindel am Kopf stehend massiv mit Alkohol desinfiziere dass ich noch keine Infektion hatte :Grübel
Auch in Oxipro getaucht sollte schon einiges bringen ( habe ich auch gemacht) nur der Schmutz geht damit nicht weg .

Wäre interessant wie andere damit umgehen

VG Herbert

noizy
Posting Junior
Posting Junior
Beiträge: 26
Registriert: Sonntag 11. Dezember 2016, 19:37
Wohnort: Wien

Re: iSpindel - Aufbau und Betrieb

#1018

Beitrag von noizy » Sonntag 23. April 2017, 14:16

Danke!
Gutes Argument, die Kontamination... Ja, mit diesem Behälter wird es keine Alternative zum Zerlegen nach jeder Verwendung geben.

On/Off im Setup und Wireless Charging ist für mich interessant, weil wegen des umgedrehten Petlings beim Deckelnähe kein Platz für Schalter oder Stecker ist; dort habe ich Akku und Tariergewicht. Bin neugierig, wieviel Zeugs sich im Gewinde absetzt, wenn der Deckel nie an die Oberfläche kommt.

Grüße,
Roland.

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1651
Registriert: Mittwoch 1. Juli 2015, 11:50
Wohnort: Gunskirchen OÖ

Re: iSpindel - Aufbau und Betrieb

#1019

Beitrag von glassart » Sonntag 23. April 2017, 15:25

Hi Roland,

ziemlich sicher wird dir noch wesentlich mehr durch die verkehrte Verwendung des Petlings ablagern und den Deckelwulst bis zum Gewinde anfüllen.
Bei mir waren es nicht 3 sondern schon 4 Sude die ich ohne Öffnung der Spindel vergoren habe ( Dauerbetrieb mit Zykluszeit 10 min! - keine Abschaltung dazwischen).

Aber ich werde nach der momentanen Gärung eine Reinigung mit alkalischem Chlor- Reiniger probieren und dann erst aufschrauben und kontrollieren wie es gewirkt hat.

Das mit dem Kippen sollte aber im Normalaufbau auch funktionieren, oder :Grübel

VG Herbert :Drink

NemoBräu
Neuling
Neuling
Beiträge: 5
Registriert: Montag 17. April 2017, 18:57

Re: iSpindel - Aufbau und Betrieb

#1020

Beitrag von NemoBräu » Sonntag 23. April 2017, 15:55

universam hat geschrieben:Poste mal dein Serial Output indem du ein Terminal Programm laufen lässt.
Garantiere dir das wird Welten eröffnen! :Greets
Hallo, hier ein Hardcopy der Console nach 4-maligem Betätigen der Reset-Taste.
Bei Überprüfen von Platine und Schaltplan ist mir aufgefallen, daß ich keine Verbindung zwischen IN+ des TP4056 und dem WEmos erstellt habe (im Schaltplan orange eingezeichent). Allerdings erschließt sich mir der Sinn dieser Verbindung auch nicht. Könnte es daran liegen? Danke im Voraus für Eure Hilfe!
Dateianhänge
Konsole.jpg
Konsole.jpg (53.51 KiB) 7511 mal betrachtet

noizy
Posting Junior
Posting Junior
Beiträge: 26
Registriert: Sonntag 11. Dezember 2016, 19:37
Wohnort: Wien

Re: iSpindel - Aufbau und Betrieb

#1021

Beitrag von noizy » Sonntag 23. April 2017, 16:42

Hallo Herbert,
wäre es für die Messung nicht am Besten, wenn bei jeder Dichte nur der zylindrische Teil (und nie der Deckel) eintaucht? Das ist der Grund für meinen "reverse"-Versuch.
Die Petlinge sind dafür leider etwas zu kurz. Ich könnte versuchen, ein geeignetes Gefäß aus Glas zu bekommen - ev. kann man das zu akzeptablen Kosten anfertigen lassen, mit einem Labor-Silikonstöpsel als Verschluß. Damit wären auch Bedenken wg. Sterilisierbarkeit des Schraubdeckels weg.

Gelegentlich ruht sich die Spindel an der Wand aus, durch das Nicken entfernt sie sich wieder.

So sieht das Nicken aus (ab Sekunde 15):
https://www.dropbox.com/s/8kip2708y1mdm ... 9.MTS?dl=0

Grüße,
Roland.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1022

Beitrag von DerDerDasBierBraut » Sonntag 23. April 2017, 17:04

NemoBräu hat geschrieben: Hallo, hier ein Hardcopy der Console nach 4-maligem Betätigen der Reset-Taste.
Bei Überprüfen von Platine und Schaltplan ist mir aufgefallen, daß ich keine Verbindung zwischen IN+ des TP4056 und dem WEmos erstellt habe (im Schaltplan orange eingezeichent). Allerdings erschließt sich mir der Sinn dieser Verbindung auch nicht. Könnte es daran liegen? Danke im Voraus für Eure Hilfe!
Stelle die Baudrate mal bitte 115200, drücke 1x auf Reset und poste nochmal die Ausgaben während des Bootens.

Das orange Kabel ist optional. Es ermöglicht das Laden des Akkus über den USB Port des Wemos.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

NemoBräu
Neuling
Neuling
Beiträge: 5
Registriert: Montag 17. April 2017, 18:57

Re: iSpindel - Aufbau und Betrieb

#1023

Beitrag von NemoBräu » Sonntag 23. April 2017, 17:41

Moin Jens, danke für die schnelle Antwort. Hier neu mit 115200 geflasht und nach 1x reset:
Dateianhänge
Konsole1.jpg
Konsole1.jpg (26.52 KiB) 7465 mal betrachtet

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1024

Beitrag von DerDerDasBierBraut » Sonntag 23. April 2017, 18:09

Hm, das ergibt keinen Sinn. Bitte lade Dir das komplette Repo noch einmal als Zip runter, entpacke die Spindel Firmware auf dem lokalen Rechner und flashe die Spindel neu.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1651
Registriert: Mittwoch 1. Juli 2015, 11:50
Wohnort: Gunskirchen OÖ

Re: iSpindel - Aufbau und Betrieb

#1025

Beitrag von glassart » Sonntag 23. April 2017, 18:12

@ Roland,

das "Knickvideo" sieht sehr gut aus!
Ein Problem mit einem längeren Petling bleibt -bei Scahumdecken von bis zu 15 cm taucht der Deckel immer im Schaum unter -leider :crying

Vg Herbert :Drink

NemoBräu
Neuling
Neuling
Beiträge: 5
Registriert: Montag 17. April 2017, 18:57

Re: iSpindel - Aufbau und Betrieb

#1026

Beitrag von NemoBräu » Sonntag 23. April 2017, 19:22

Moin Jens,
jau, das war´s. Ich hatte die .bin direkt von Github gezogen. Nun mit entpacken etc. funktionierte es auf Anhieb.
Ich habe schon an meinen, zugegebener Maßen sehr angestaubten, Lötkünsten gezweifelt. Manchmal sind die Wege halt krumm.
Die Spindel möchte ich nicht in unser Netz hängen, deswegen werde ich nun mal meinen alten Raspberry mit CrafbeerPi
konfrontieren und hoffe, die Spindel hier einbinden zu können.
Danke für Deine Aufbauhilfe!
Gruß in den Norden Jörg

omegator77
Posting Junior
Posting Junior
Beiträge: 67
Registriert: Mittwoch 15. Februar 2017, 18:26
Wohnort: Ober Mumbach

Re: iSpindel - Aufbau und Betrieb

#1027

Beitrag von omegator77 » Sonntag 23. April 2017, 22:17

Hi,

Auf die Idee bin ich ja noch gar nicht gekommen! Hatte allerdings schon drüber nachgedacht Loxone auch als Brausteuerung zu verwenden! :-)
joergp hat geschrieben:Ich bin neu hier, also erst einmal „Hi!“.

Seit Anfang des Jahres braue ich mit Brewie („Bierbrauautomat“, siehe brewie.org) Bier und bin stolz auf die moderaten Ergebnisse. Nachdem Dichtemessung schnell ein Thema wurde, bin ich auf euer Projekt gestoßen und habe mir sofort den Bausatz bestellt, gebaut und erfolgreich in meinem 4. Sud eingesetzt.

Da ich die Hausautomatisierung Loxone einsetze, kam der Wunsch auf, dort die Werte von der iSpindel zu erfassen. Daher habe ich die Programmierung um die notwendigen Elemente erweitert (Felder zum Login, Http Get mit Authentifizierung etc.). Das lässt sich auch gut für andere Web Services adaptieren, die eine Authentifizierung benötigen. Meine Erweiterungen habe ich soeben als Pull-Request an universam geschickt.

Für alle, die auf einem Mac unterwegs sind: ich compiliere mittlerweile direkt auf die iSpindel – eine tolle Anleitung dazu befindet sich hier: https://blog.rjdlee.com/getting-started ... n-mac-osx/

An dieser Stelle noch herzlichen Dank an die Macher und die anderen Unterstützer dieses Projekt, das wirklich hilfreich ist (und geeky).

Jörg
Grüße aus dem Odenwald!

omegator77
Posting Junior
Posting Junior
Beiträge: 67
Registriert: Mittwoch 15. Februar 2017, 18:26
Wohnort: Ober Mumbach

Re: iSpindel - Aufbau und Betrieb

#1028

Beitrag von omegator77 » Sonntag 23. April 2017, 22:17

Hi,

Auf die Idee bin ich ja noch gar nicht gekommen! Hatte allerdings schon drüber nachgedacht Loxone auch als Brausteuerung zu verwenden! :-)
joergp hat geschrieben:Ich bin neu hier, also erst einmal „Hi!“.

Seit Anfang des Jahres braue ich mit Brewie („Bierbrauautomat“, siehe brewie.org) Bier und bin stolz auf die moderaten Ergebnisse. Nachdem Dichtemessung schnell ein Thema wurde, bin ich auf euer Projekt gestoßen und habe mir sofort den Bausatz bestellt, gebaut und erfolgreich in meinem 4. Sud eingesetzt.

Da ich die Hausautomatisierung Loxone einsetze, kam der Wunsch auf, dort die Werte von der iSpindel zu erfassen. Daher habe ich die Programmierung um die notwendigen Elemente erweitert (Felder zum Login, Http Get mit Authentifizierung etc.). Das lässt sich auch gut für andere Web Services adaptieren, die eine Authentifizierung benötigen. Meine Erweiterungen habe ich soeben als Pull-Request an universam geschickt.

Für alle, die auf einem Mac unterwegs sind: ich compiliere mittlerweile direkt auf die iSpindel – eine tolle Anleitung dazu befindet sich hier: https://blog.rjdlee.com/getting-started ... n-mac-osx/

An dieser Stelle noch herzlichen Dank an die Macher und die anderen Unterstützer dieses Projekt, das wirklich hilfreich ist (und geeky).

Jörg
Grüße aus dem Odenwald!

gezzanet
Neuling
Neuling
Beiträge: 2
Registriert: Mittwoch 22. März 2017, 04:46

Re: iSpindel - Aufbau und Betrieb

#1029

Beitrag von gezzanet » Montag 24. April 2017, 01:49

PLease entschuldige meine schlechte Sprache. Ich baue die Ispindle und fragte mich nach dem Schlitten-Design. Die Batterie scheint in einem Winkel im Schlitten zu sein. Ist das für den Einstellwinkel? Welchen Winkel sollte die Batterie sein oder spielt es keine Rolle? Vielen Dank :Grübel

noizy
Posting Junior
Posting Junior
Beiträge: 26
Registriert: Sonntag 11. Dezember 2016, 19:37
Wohnort: Wien

Re: iSpindel - Aufbau und Betrieb

#1030

Beitrag von noizy » Montag 24. April 2017, 10:18

-> Schlitten-Design, Batteriewinkel:
Wenn die Batterie schräg im Schlitten sitzt, hat sie "tiefer unten" im Petling Platz. Ich habe Petlinge mit geringfügig größeren Abmessungen, deshalb habe ich mir einen eigenen Schlitten gedruckt. Auf dem ist die Batterie nicht schräg - das ist kein Problem.
Ich gebe den Spindel-Entwurf gerne weiter: Ist in FreeCad, also beliebig veränderbar!

Grüße,
Roland.

Benutzeravatar
der_dennis
Posting Freak
Posting Freak
Beiträge: 889
Registriert: Freitag 12. Dezember 2014, 12:59
Wohnort: Bamberg

Re: iSpindel - Aufbau und Betrieb

#1031

Beitrag von der_dennis » Dienstag 25. April 2017, 10:25

Wie kann man im Dashboard eigentlich alte Werte löschen? Also mein Graph zeigt die Werte seit 05.03. an, langsam wird das unübersichtlich
We have joy, we have fun
we have Bratwurscht in the Pfann!

Benutzeravatar
der_dennis
Posting Freak
Posting Freak
Beiträge: 889
Registriert: Freitag 12. Dezember 2014, 12:59
Wohnort: Bamberg

Re: iSpindel - Aufbau und Betrieb

#1032

Beitrag von der_dennis » Dienstag 25. April 2017, 10:33

Danke, aber was mach ich damit? Die zip runterladen, entpacken und die exe starten?
We have joy, we have fun
we have Bratwurscht in the Pfann!

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1033

Beitrag von DerDerDasBierBraut » Dienstag 25. April 2017, 11:16

der_dennis hat geschrieben:Wie kann man im Dashboard eigentlich alte Werte löschen?
Hi Dennis,
alternativ zu Peters Vorschlag:
https://hobbybrauer.de/forum/viewtopic. ... 60#p206560
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
der_dennis
Posting Freak
Posting Freak
Beiträge: 889
Registriert: Freitag 12. Dezember 2014, 12:59
Wohnort: Bamberg

Re: iSpindel - Aufbau und Betrieb

#1034

Beitrag von der_dennis » Dienstag 25. April 2017, 11:38

Ah, jetzt! Variante 5 hat geklappt. Vielen Dank euch beiden! :thumbup
We have joy, we have fun
we have Bratwurscht in the Pfann!

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 976
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1035

Beitrag von emilio » Dienstag 25. April 2017, 13:05

beryll hat geschrieben:Öhm... Also, runterladen ist schon mal nicht schlecht :-)
Zip entpacken ist auch ok...

Dann öffnest Du die Datei "delete_all_values_ispindel.bat" mit einem Editor (Notepad++ oder was auch immer) und ersetzt die 2 erforderlichen Werte für die ID der Variable und des Token Deines Ubidot-Accounts.
Du brauchst für jede Variable dann eine Zeile mit dem "curl"-Befehl, da die vars ja unterschiedliche ID's haben (logischerweise).

Dann speichern und die BAT aufrufen, entweder mit Doppelklick oder Du rufst die Datei in der cmd auf.

VG Peter
Die Anleitung dazu gibt's übrigens auch bei GitHub
https://github.com/universam1/iSpindel/ ... ripting.md

HelDi
Posting Junior
Posting Junior
Beiträge: 68
Registriert: Donnerstag 21. April 2016, 09:39
Wohnort: Neufahrn bei Freising

Re: iSpindel - Aufbau und Betrieb

#1036

Beitrag von HelDi » Mittwoch 26. April 2017, 17:43

Ein herzliches "Hallo" in die Runde.

Ich habe mittlerweile die 2. Spindel zusammengelötet und bei beiden das gleiche Phänomen.
Die Spindeln senden brav 1 Mal an Ubidots. Allerdings nur 1x nachdem man den Resettaster betätigt hat.

Hier mal die "Mitschrift" aus HTerm nach Druck auf Reset:

Code: Alles auswählen

sl<\0>l??|<\0>?l?|<3><4><\f><\f>?<\f>l?<4>b|??<3>?<18>?s?c?<4>c??gg?dnn???<\f>c<28>x??lrlslp?o?<24><3><\f><4>?<4>d<4>??<\f><\f><\f>#<4>n?|<3>l?<\f><\f>?#??oo?<\0>l??l <3>?<19><19>no<4>l`<3><7><2>gs???o<4><\f>c<\f>?<15>d<7>s??o<\f><\f>b<\f>?<15>$?<3><4><4><\f><\f><\f><\f><\f>l`<3>??g?<3><\n>FW 3.4.4<\n>1.5.4(baaeaebb)<\n>mounting FS... mounted!<\n>reading config file<\n>opened config file<\n><\n>parsed json<\n>parsed config:<\n>{"Name":"HelDi2","Token":"*Token*","Sleep":90,"Server":"","API":0,"Port":80,"URL":"","Vfact":191.80}<\n>woken from deepsleep, normal mode<\n>Spl 0: 66.55<\n>Spl 1: 66.54<\n>Spl 2: 66.55<\n>Spl 3: 66.55<\n>Spl 4: 66.52<\n>Spl 5: 66.56<\n>Spl 6: 66.56<\n><\n>a: 14512<9>8628<9>1060<9>absTilt: 66.55<9>T: 24.12<9>V: 4.08<9>owT: 22.56<\n>After waiting 0.00 s, result 3<\n>192.168.178.37<\n>UBIDOTS: posting<\r><\n>POST /api/v1.6/devices/HelDi2?token=*Token* HTTP/1.1<\r><\n>Host: things.ubidots.com<\r><\n>User-Agent: HelDi2<\r><\n>Connection: close<\r><\n>Content-Type: application/json<\r><\n>Content-Length: 49<\r><\n><\r><\n>{"tilt":66.55,"temperature":22.56,"battery":4.08}HTTP/1.1 200 OK<\r><\n>Server: nginx<\r><\n>Date: Wed, 26 Apr 2017 15:05:25 GMT<\r><\n>Content-Type: application/json<\r><\n>Transfer-Encoding: chunked<\r><\n>Connection: close<\r><\n>Vary: Accept-Encoding<\r><\n>Vary: Accept, Cookie<\r><\n>Allow: POST, OPTIONS<\r><\n><\r><\n>6a<\r><\n>{"battery": [{"status_code": 201}], "tilt": [{"status_code": 201}], "temperature": [{"status_code": 201}]}<\r><\n>0<\r><\n><\r><\n><\n>sleeping: 90sec<\n>
Dann, nach 90 Sekunden:

Code: Alles auswählen

sd<\0>l??|<\0>?l?|<3><\f><\f><\f>?<4>d?<4>c|??<2>?<19>?s?cl?c??gn?doo???<\f>c<28>8??dslsd<27>?s??n?c?ocp<\0>?
Danach ist Ruhe. Es passiert nichts mehr.

Dabei ist die Firmwareversion unerheblich. Ich habe verschiedene getestet.

Hat dieses Problem schonmal jemand beobachtet?
Kann das an der verwendeten WEMOS-Version liegen?
Meine haben die Version: 2.1.0

Edit:
mittlerweile gibt es sogar eine Version 2.2.0:
https://www.aliexpress.com/store/produc ... 0.0.DIK8PX

Hammer
Posting Junior
Posting Junior
Beiträge: 47
Registriert: Donnerstag 8. Dezember 2016, 12:28
Wohnort: Stockstadt am Main

Re: iSpindel - Aufbau und Betrieb

#1037

Beitrag von Hammer » Mittwoch 26. April 2017, 19:43

Hallo,
Hast du den 470 Ohm Widerstand geprüft?
Ggf. Mal mit einem 360 Ohm probieren.

Grüße Stefan

HelDi
Posting Junior
Posting Junior
Beiträge: 68
Registriert: Donnerstag 21. April 2016, 09:39
Wohnort: Neufahrn bei Freising

Re: iSpindel - Aufbau und Betrieb

#1038

Beitrag von HelDi » Donnerstag 27. April 2017, 17:07

Habe die Widerstände mal durchgemessen.
die 470 Ohm und 4,7 KOhm sind im eingebauten zustand genau wie angegeben.
Beim 220 KOhm wird nur etwa 144,6 KOhm angezeigt? Ist das gewollt?

noizy
Posting Junior
Posting Junior
Beiträge: 26
Registriert: Sonntag 11. Dezember 2016, 19:37
Wohnort: Wien

Re: iSpindel - Aufbau und Betrieb

#1039

Beitrag von noizy » Donnerstag 27. April 2017, 19:43

Hallo HelDi,
falls die Widerstände im eingebauten Zustand gemessen wurden: "Wer misst, misst Mist". Das gilt besonders bei hochohmigen Teilen. R2 (220 kOhm) ist der Vorwiderstand zum Analogeingang des Wemos. Das hat selbst noch einen Spannungsteiler, der diesen Pin auf die am ESP8266-A0 zulässige Spannung (1V) reduziert. Die 220kOhm sind so dimensioniert, daß die Akkuspannung schön meßbar wird (der ESP lebt von 3.3V, der Akku hat deutlich mehr).
----
Kann mir bitte jemand sagen, warum in der Schaltung zwischen RST und D0 ein Widerstand (R1 = 470 Ohm) ist? Ich kann im Source nicht finden, wofür D0 verwendet wird.

Grüße,
Roland.

Benutzeravatar
universam
Posting Freak
Posting Freak
Beiträge: 518
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1040

Beitrag von universam » Donnerstag 27. April 2017, 19:50

Das ist der RTC Port der einen Reset auslöst um ihn aus dem Standby zu holen.

Du kannst auch stattdessen eine Schottky Diode BAT43 einsetzen! Anode zum RST Pin.
Oder geh mit dem Widerstand auf ~350 Ohm runter.
Gruß
Sam
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Dr.Edelherb

Re: iSpindel - Aufbau und Betrieb

#1041

Beitrag von Dr.Edelherb » Sonntag 30. April 2017, 12:11

Gibt es die Excel Datei zum kalibrieren auch für Open Office?
Da funktioniert die Excel Version leider nicht.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1042

Beitrag von DerDerDasBierBraut » Sonntag 30. April 2017, 12:24

Dr.Edelherb hat geschrieben:Gibt es die Excel Datei zum kalibrieren auch für Open Office?
Da funktioniert die Excel Version leider nicht.
Nein. Schicke mir die bekannten Plato-Winkel-Paare per PN und Du bekommst das Polynom im Laufe des Nachmittags zurück.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Dr.Edelherb

Re: iSpindel - Aufbau und Betrieb

#1043

Beitrag von Dr.Edelherb » Sonntag 30. April 2017, 12:24

Ist noch nicht aktuell, erst in ca. 2 Wochen, aber ich komme drauf zurück, vielen Dank !

Benutzeravatar
universam
Posting Freak
Posting Freak
Beiträge: 518
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#1044

Beitrag von universam » Montag 1. Mai 2017, 15:41

:achtung Firmware 5.1.2 is raus!

Nach einigem Testen kann ich jetzt das große Firmware update freigeben.
Danke für das Feedback von einigen hier, hat noch mal einiges an Feinschliff gegeben!

Die größten Neuerungen kann man hier lesen: viewtopic.php?f=58&t=11826&p=202963&hil ... +5#p202963

Die fertige .bin gibt es wie immer im Repo, noch unter /bin/testing
https://github.com/universam1/iSpindel

Einmal die 5.x Firmware aufgespielt, ist zukünftiges Update über den Browser ein wahrer Genuss!

Gruß
Sam
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1045

Beitrag von DerDerDasBierBraut » Montag 1. Mai 2017, 16:42

Danke Sam. Wird gleich auf alle Spindeln geflasht, die nicht gerade im Jungbier baden :Drink
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
Ernie
Posting Senior
Posting Senior
Beiträge: 384
Registriert: Donnerstag 24. März 2016, 15:04

Re: iSpindel - Aufbau und Betrieb

#1046

Beitrag von Ernie » Montag 1. Mai 2017, 17:05

Moinsen,

hat jemand eine Formel und den aktuellen Alkoholgehalt in Ubidots mit anzuzeigen ?

Das müsste ja irgenwie Plato Maximumwert im Verhältnis Plato Minimalwert zu berechnen sein.

Oder ? :Waa


LG
Ernie

:Drink
Die deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7521
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#1047

Beitrag von DerDerDasBierBraut » Montag 1. Mai 2017, 18:27

Alkoholgehalt in % = (STW - Restextrakt) / 2

Die STW musst Du als festen Wert eingeben. Für den RE kannst Du die errechnete Plato Variable nutzen.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

liuto
Posting Klettermax
Posting Klettermax
Beiträge: 250
Registriert: Donnerstag 26. Mai 2016, 14:39
Wohnort: Sankt Augustin

Re: iSpindel - Aufbau und Betrieb

#1048

Beitrag von liuto » Montag 1. Mai 2017, 22:22

Cool, Sam, danke für die neue Version.

Habe natürlich gerade meine Hauptspindel im heute gebrauten Imperial Stout versenkt gehabt. Da zeigt sie jetzt 17,5°P statt der echten 21,5°P an. In dem Bereich ist die Kalibrierung nicht so richtig brauchbar bei meiner blöden Gewichtsanordnung, mein Fehler. Bei meinem letzten Pils habe ich aus Polen die Gärung beobachtet, am Ende hatte ich 2,7°P konventionell gespindelt vs. 2,74°P von der iSpindel. Keine Ahnung, wer recht hatte...

BTW, hat schon mal jemand geschafft, die Firmware vom iPhone upzudaten? In meine Dropbox abspeichern geht, auswählen auch, aber der Updateknopf im Access Point ist ausgegraut.

Gruß vom dankbaren liuto. Die iSpindel ist der Hammer.

Benutzeravatar
CptCalamari
Posting Junior
Posting Junior
Beiträge: 64
Registriert: Samstag 13. Dezember 2014, 14:26

Re: iSpindel - Aufbau und Betrieb

#1049

Beitrag von CptCalamari » Dienstag 2. Mai 2017, 12:35

Hallo zusammen,

erstmal ein großes Lob an euch alle!
Sehr schönes Projekt!

Ich habe mir natürlich auch eine iSpindel zugelegt und wollte diese die nächsten Tage die Kalibrierung durchführen.
Zwei Fragen an euch,..
- ist bei der Kalibrierung bei 0°P nur der Winkel von ca 25° wichtig, oder kommt es auch drauf an wo ich die trimmgewichte befestige? ( in der Spitze des petlings/ mittig auf dem Schlitten, da da Platz wäre)
- gibt es eine maximale Toleranz die der Winkel bei 0°P abweichen darf?

Vielen Dank für die Rückmeldung jetzt schonmal !

Gruss
Wo man trinkt, da lass dich nieder, denn bösen Menschen ist das Bier zu wider.

Benutzeravatar
der_dennis
Posting Freak
Posting Freak
Beiträge: 889
Registriert: Freitag 12. Dezember 2014, 12:59
Wohnort: Bamberg

Re: iSpindel - Aufbau und Betrieb

#1050

Beitrag von der_dennis » Dienstag 2. Mai 2017, 12:44

Servus,

meine Spindel ist leider über Nacht ausgefallen. Das letzte mal hat sie um 00:53 Uhr gesendet, seit dem ist Funkstille. Habe die Spindel jetzt aus dem Gärfass genommen und den Reset-Knopf gedrückt, die Batteriespannung liegt bei 4.03V. Beim Test über das iPhone funktioniert auch alles. Hat jemand eine Idee, warum sie plötzlich den Dienst versagt?
We have joy, we have fun
we have Bratwurscht in the Pfann!

Antworten