iSpindel - Aufbau und Betrieb

mast
Posting Junior
Posting Junior
Beiträge: 12
Registriert: Montag 3. Februar 2014, 12:58

Re: iSpindel - Aufbau und Betrieb

#2101

Beitrag von mast » Dienstag 13. März 2018, 13:30

Hi Jens & Stephan

danke für eure schnellen Antworten! Werd am Wochenende versuchen das in Ruhe meine Lötstellen am GY zu optimieren :) Diese Lötstellen waren natürlich die, die mir nicht so gut gelungen sind aber eigentlich doch zu halten schienen ;)

Cheers,
Martin

Benutzeravatar
mwx
Posting Klettermax
Posting Klettermax
Beiträge: 208
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2102

Beitrag von mwx » Dienstag 13. März 2018, 13:50

Tozzi hat geschrieben:
Montag 12. März 2018, 22:44
Leider gibt es anscheinend momentan keinen passenden Treiber für High Sierra (Mac OS 10.13.x).
Die verfügbaren verursachen Kernel Panic.
Wenn da jemand was passendes findet, bin ich für Hinweise dankbar.
Hallo Stephan,

damit geht es: https://mac-usb-serial.com

Habe das grade mit einem frischen Wemos und einem ebenfalls frischen iMacPro ausprobiert. Ging ohne Probleme und auch ohne Reboot (ansonsten habe ich mich genau an Deine Anleitung gehalten).

Gruß, Michael

Benutzeravatar
universam
Posting Freak
Posting Freak
Beiträge: 518
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2103

Beitrag von universam » Dienstag 13. März 2018, 14:26

Der Knaller, muss man tatsächlich für Treiber zahlen :Pulpfiction
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Benutzeravatar
mwx
Posting Klettermax
Posting Klettermax
Beiträge: 208
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2104

Beitrag von mwx » Dienstag 13. März 2018, 14:29

universam hat geschrieben:
Dienstag 13. März 2018, 14:26
Der Knaller, muss man tatsächlich für Treiber zahlen :Pulpfiction
Wenn's funktioniert finde ich €7,90 aushaltbar .. aber ja es nervt auch ein bisschen

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 3795
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2105

Beitrag von Tozzi » Dienstag 13. März 2018, 17:16

universam hat geschrieben:
Dienstag 13. März 2018, 14:26
Der Knaller, muss man tatsächlich für Treiber zahlen :Pulpfiction
Ja, weil der Hersteller es nicht für nötig hält, passende Mac Treiber anzubieten.
Deshalb muss man auf Drittanbieter zurückgreifen.
Out-of-the-box unterstützt Mac OS viele USB Geräte, für die man unter Windows einen extra Treiber braucht (unter anderem auch den Braumeister Controller), aber der Wemos D1 Mini ist leider nicht dabei...
Viele Grüße aus München
Stephan

Benutzeravatar
brennenhorster
Posting Junior
Posting Junior
Beiträge: 11
Registriert: Montag 13. November 2017, 16:03
Wohnort: Langenhagen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2106

Beitrag von brennenhorster » Donnerstag 15. März 2018, 12:58

universam hat geschrieben:
Sonntag 11. März 2018, 14:32
Hast du die Diode schon entfernt? Wenn nein sollte er laufen. Das USB Kabel sollte auch ein echtes sein, nicht blos ein Ladekabel.
Auf dem WEMOS? ja. Aber der ist tot....

Nun hab ich mir 3 neue Bestellt und vor dem Löten versucht zu flashen. Das geht. jetzt hab ich die Diode auf dem WEMOS entfernt und Zag ist macht das Ding nichts mehr....
Warum muss die Diode raus?


Gruß


Benni
Wind is erst wenn die Schafe keine Locken mehr haben....

Jano
Posting Junior
Posting Junior
Beiträge: 26
Registriert: Donnerstag 7. Januar 2016, 09:40
Wohnort: Lauchröden

Re: iSpindel - Aufbau und Betrieb

#2107

Beitrag von Jano » Donnerstag 15. März 2018, 13:08

Damit nur über den laderegler der Akku geladen werden kann.
Gruß Sven

Benutzeravatar
brennenhorster
Posting Junior
Posting Junior
Beiträge: 11
Registriert: Montag 13. November 2017, 16:03
Wohnort: Langenhagen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2108

Beitrag von brennenhorster » Donnerstag 15. März 2018, 13:19

Jano hat geschrieben:
Donnerstag 15. März 2018, 13:08
Damit nur über den laderegler der Akku geladen werden kann.
Danke für die schnelle Antwort.

Das heißt aber das der WEMOS solo über seinen USB Port trotzdem noch laufen muss oder??
Wind is erst wenn die Schafe keine Locken mehr haben....

Benutzeravatar
universam
Posting Freak
Posting Freak
Beiträge: 518
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2109

Beitrag von universam » Donnerstag 15. März 2018, 15:45

Nein, dann nur noch mit der Speisung durch den Akku. Wenn du deinen Wemos Solo wieder laufen lassen willst, dann überbrücke die Stelle an der die Diode war oder speise ihn mit 5v an dem Pin.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

stefan78h
Posting Senior
Posting Senior
Beiträge: 480
Registriert: Sonntag 27. November 2016, 21:09

Re: iSpindel - Aufbau und Betrieb

#2110

Beitrag von stefan78h » Freitag 16. März 2018, 08:19

kurze frage als unwissender...

Wenn ich den Bausatz bestelle... was brauche ich dann noch?
Wo werden die Daten gespeichert?

Danke
Gruß
stefan
Gruß
stefan

Benutzeravatar
mwx
Posting Klettermax
Posting Klettermax
Beiträge: 208
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2111

Beitrag von mwx » Freitag 16. März 2018, 08:24

Moin

der Bausatz ist soweit komplett, nach dem Zusammenbau mußt Du die Firmware drauf flashen und konfigurieren. Die Daten werden per Wlan verschickt. Da gibt es mehrere Varianten. Du kannst das alles im Detail hier nachlesen: https://github.com/universam1/iSpindel

Gruß, Michael

clmnsk
Posting Klettermax
Posting Klettermax
Beiträge: 128
Registriert: Freitag 10. März 2017, 00:12

Re: iSpindel - Aufbau und Betrieb

#2112

Beitrag von clmnsk » Freitag 16. März 2018, 08:40

Gewichte braucht man noch, oder?
Grüße, Clemens
---
Hendi - 34L Topf - 32L Thermobehälter

Benutzeravatar
mwx
Posting Klettermax
Posting Klettermax
Beiträge: 208
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2113

Beitrag von mwx » Freitag 16. März 2018, 08:41

clmnsk hat geschrieben:
Freitag 16. März 2018, 08:40
Gewichte braucht man noch, oder?
Ja, stimmt.

stefan78h
Posting Senior
Posting Senior
Beiträge: 480
Registriert: Sonntag 27. November 2016, 21:09

Re: iSpindel - Aufbau und Betrieb

#2114

Beitrag von stefan78h » Freitag 16. März 2018, 09:11

sorry das ich nochmal frage... Muss da ein Server laufen oder würde das auch über eienn USB-Speicher an der Fritzbox gehen?
Gruß
stefan

Benutzeravatar
mwx
Posting Klettermax
Posting Klettermax
Beiträge: 208
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2115

Beitrag von mwx » Freitag 16. März 2018, 09:25

stefan78h hat geschrieben:
Freitag 16. März 2018, 09:11
.. oder würde das auch über eienn USB-Speicher an der Fritzbox gehen?
Das glaube ich nicht, allerdings kenne ich mich mit Fritzboxen nicht aus.

Die üblicherweise benutzen die Leute hier entweder https://ubidots.com oder den Server von Stephan (https://github.com/DottoreTozzi/iSpindel-TCP-Server) oder basteln etwas selber. Steht aber wie gesagt auch alles in der Doku.

Griuß, Michael

stefan78h
Posting Senior
Posting Senior
Beiträge: 480
Registriert: Sonntag 27. November 2016, 21:09

Re: iSpindel - Aufbau und Betrieb

#2116

Beitrag von stefan78h » Freitag 16. März 2018, 09:31

ok, so ganz klar ist mir alles noch nicht...
werde es mal zusammen Löten, wird sich dann ergeben.

Danke
Gruß
stefan

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 3795
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2117

Beitrag von Tozzi » Freitag 16. März 2018, 22:18

Wenn Du die Fritz Box modifizieren kannst/willst:
https://freetz.org

Dann kannst Du darauf auch mein Skript laufen lassen.
Eine sehr elegante Lösung, aber alles andere als trivial.
Ansonsten halt entweder die Online Lösung (Ubidots) oder ein RaspberryPi oder ein MacMini.
Oder komplett selber basteln (PHP oder sowas).
Viele Grüße aus München
Stephan

TomTom
Posting Junior
Posting Junior
Beiträge: 37
Registriert: Sonntag 15. Januar 2017, 09:08
Wohnort: Oberottmarshausen

Re: iSpindel - Aufbau und Betrieb

#2118

Beitrag von TomTom » Freitag 23. März 2018, 08:09

Servus beinand,
bekommt ihr momentan Daten von Ubidots angezeigt? Bei mir ist heute Morgen nur "There was an Error Loading Yours data".
Danke schon mal...

TomTom
Posting Junior
Posting Junior
Beiträge: 37
Registriert: Sonntag 15. Januar 2017, 09:08
Wohnort: Oberottmarshausen

Re: iSpindel - Aufbau und Betrieb

#2119

Beitrag von TomTom » Freitag 23. März 2018, 09:23

Jetzt geht's wieder

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2120

Beitrag von Pottkieker » Montag 26. März 2018, 17:04

Moin zusammen,
in den letzten Tagen hatte ich keine Gelegenheit mich hier zu melden.
Den Lötfehler habe ich hoffentlich korrigiert. Die Spindel meldet sich auch, aber ich glaube das sie den in Tiefstschlaf geht und ich weiß nicht wie ich sie wecken kann. folgendes zeigt sie dann

woken from deepsleep, normal mode
Spl 0: 69.82
Spl 1: 69.85
Spl 2: 69.88
Spl 3 : 69.83
Spl 4: 69.78
Spl 5: 69.74
Spl 6: 69.87
a: 5466 15114 -3296 absTilt: 69.84 T: 25.07 V: 4.09 owT: 21.87 Gravity: 23.33
After waiting 5102 ms, result 6
Rescue Wifi credentials
failed to connect

Final-sleep: 0s; RT:6999

Was kann ich tun?
Gruß
horst

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2121

Beitrag von DerDerDasBierBraut » Montag 26. März 2018, 17:55

Welches Intervall hast du in der Konfiguration eingestellt?
Es könnte sein, dass der 470 Ohm Widerstand wieder das Problem mit dem Aufwachen verursacht. Hast du einen 390 Ohr Widerstand da, den du stattdessen einlöten kannst?
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
flensdorfer
Posting Senior
Posting Senior
Beiträge: 488
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: iSpindel - Aufbau und Betrieb

#2122

Beitrag von flensdorfer » Dienstag 27. März 2018, 17:34

Moin,

nachdem meine Spindel brav funkt, wenn sie auf dem Schreibtisch liegt und nix mehr sagt, sobald sie schwimmt, möchte ich eine Frage zur Klärung stellen:

Wenn der DS18B20 z.B. wegen eines Kontaktproblems keinen validen Messwert, bricht die Spindel dann das Versenden des Datenpaketes ab und verfällt wieder in den Tiefschlaf?

Ich habe es manchmal, dass die Config-Seite -127°C anzeigt und ich dann den Sensor etwas bewegen muss, bis ein valider Messwert kommt. Ich vermute nun mal, dass durch das Zuschrauben des Petlings der Sensor nun wieder etwas bewegt wird und er wieder nur -127°C liefert.
Und ich meine, dass dies erst seit 5.8.x oder gar 5.7.x so ist - im letzten Sud (schon über 4 Monate her) schwamm die Spindel noch mit 5.6.0 und die funkte brav und mit allen anderen Releases vorher ebenso. Kann aber auch nur Zufall gewesen sein.
Gruß, Arne

Anfänger in der 20l-Klasse

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2123

Beitrag von DerDerDasBierBraut » Dienstag 27. März 2018, 21:05

Moin Arne,
ja, das liegt eindeutig an dem Wackelkontakt.

Die ganz alte Firmware konnte im Fehlerfall noch -127°C als Temperatur senden. Ist natürlich nur halb so nützlich :-).
Ich meine, dass seit die Config-Seite die WLAN Zugangsdaten speichern kann, keine Datenpakete ohne Sensordaten mehr versendet werden.
Was hält dich davon ab zum Lötkolben zu greifen, wenn das Problem bekannt ist?
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
flensdorfer
Posting Senior
Posting Senior
Beiträge: 488
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: iSpindel - Aufbau und Betrieb

#2124

Beitrag von flensdorfer » Dienstag 27. März 2018, 23:43

Moin Jens,

danke fü die Bestätigung meiner Vermutung :thumbup
Was mich abhält? Aktuell nur die Zeit, aber mir ist so, als wenn da in wenigen Tagen ein längeres Wochenende ansteht. Da sollte ich das schaffen und bis dahin darf die Spindel weiter schwimmen. Dann weiß ich, wo sie ist.

Ich habe hier auch noch so eine paar wasserdichte Sensoren mit 1m Kabel rumliegen. Könnte ich auch die einsetzen (Kabel natürlich auf wenige cm gekürzt und damit den Sensor einfach in die Spitze verlegen?
Gruß, Arne

Anfänger in der 20l-Klasse

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2125

Beitrag von DerDerDasBierBraut » Dienstag 27. März 2018, 23:53

Klar, das geht. Wenn du es einfach haben willst (und etwas weniger schön) lötest du den DS18B20 von der Platine und die 3 Kabel vom neuen Sensor direkt auf den Wemos (bzw. unten auf der Platine an die Wemos Pins).
- Datenkabel (gelb bzw. weiß) an Wemos D6
- VCC (rot) an Wemos VCC
- GND (schwarz) an Wemos GND

Der 4k7 Ohm Widerstand muss auf der Platine bleiben.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
flensdorfer
Posting Senior
Posting Senior
Beiträge: 488
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: iSpindel - Aufbau und Betrieb

#2126

Beitrag von flensdorfer » Mittwoch 28. März 2018, 08:32

Nix Platine - Lochraster :D
Das werde ich schon hinbekommen. Vielleicht verlängere ich auch einfach den ausgelöteten DS18B20 mit Schaltdraht, den habe ich hier noch rumliegen.

Merci!
Gruß, Arne

Anfänger in der 20l-Klasse

thomas111
Posting Junior
Posting Junior
Beiträge: 11
Registriert: Dienstag 27. Februar 2018, 08:31

Re: iSpindel - Aufbau und Betrieb

#2127

Beitrag von thomas111 » Donnerstag 29. März 2018, 00:00

Hallu zusammen,
ich habe jetzt endlich mal meine iSpindel kalibriert. Mit Zuzker bei ca.20°C. Die Werte schauen so aus:

°Winkel******* °Plato*******Abweichung °

25,85***********0************-0,24 °P
28,78***********1,4**********0,00 °P
30,87**********2************-0,23 °P
32,06**********2,95**********0,25 °P
33,5***********3,4***********0,13 °P
34,97**********4,2***********0,35 °P
37,28**********5*************0,23 °P
39,22**********5,4**********-0,14 °P
41**************6,2**********-0,05 °P
43,3***********7,2***********0,03 °P
45,78**********7,8**********-0,36 °P
47,67**********8,9**********-0,02 °P
50,72**********10***********-0,14 °P
52,2***********10,8**********0,06 °P
55,25**********12************0,03 °P
57,37**********12,8**********-0,03 °P
59,46**********13,6**********-0,07 °P
60,14**********14,1**********0,15 °P
61,65**********14,6**********0,04 °P

Plato Formel:
0.000153413*tilt^2 + 0.386450953*tilt - 9.850571134


Schaut das plausibel aus? Ich habe es jetzt nach der Kalibrierung ins Wasser reingetaucht, wird aber 0,23°P bei Wassertemperatur 22,4°C angezeigt, warum? Ist es normale Abweichung?

Noch eine dumme Frage ... werden die Plato Werte irgendie mit der Temperatur korrigiert oder muss man das noch sepparat machen?

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2128

Beitrag von DerDerDasBierBraut » Donnerstag 29. März 2018, 00:15

0,23°P Abweichung wäre für mich mehr als OK. Persönlich bin ich ohnehin kein Freund der "überpräzisen" Kalibrierung in Zucker. Viel zu "steril" das Ganze. Wirf die Spindel mal in einen richtigen Sud und nimm echte Werte mit echten Störgeräuschen.

Ziemlich weit unten auf der Seite:
http://braumagazin.de/article/ispindel-der-aufbau/

Die Polynomermittlung in Excel unterstützt keine temperaturkorrigierten Werte.
Dieses Tool schon: http://www.ispindel.de/tools/calibratio ... ration.htm
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

thomas111
Posting Junior
Posting Junior
Beiträge: 11
Registriert: Dienstag 27. Februar 2018, 08:31

Re: iSpindel - Aufbau und Betrieb

#2129

Beitrag von thomas111 » Donnerstag 29. März 2018, 00:24

Vielen Dank! Ich werde am Freitag ein untergäriges brauen und live messen. Wie offt sollte ich diese Messung machen? 1x am Tag? Ich werde bei der Temperatur ca. 9°C vergären. Sollte reichen oder?

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2130

Beitrag von DerDerDasBierBraut » Donnerstag 29. März 2018, 00:31

Lass den Gäreimer bitte zu und lies dir auch den Abschnitt darunter durch ("Schnellstart ohne Kalibrierung").
Oder mach es wie du möchtest. Die iSpindel ist im Grunde kein Messinstrument sondern eher ein "hochsensibles Instrument zur Erkennung von Messwertveränderungen".

Abschnitt "Das Messinstrument?" >> http://braumagazin.de/article/ispindel-die-idee/
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
schlupf
Posting Freak
Posting Freak
Beiträge: 777
Registriert: Sonntag 5. Juni 2016, 15:51
Wohnort: Lentföhrden

Re: iSpindel - Aufbau und Betrieb

#2131

Beitrag von schlupf » Donnerstag 29. März 2018, 08:43

DerDerDasBierBraut hat geschrieben:
Donnerstag 29. März 2018, 00:15
Die Polynomermittlung in Excel unterstützt keine temperaturkorrigierten Werte.
Dieses Tool schon: http://www.ispindel.de/tools/calibratio ... ration.htm
Nebenbei gefragt: Macht Temperaturkorrektur bei der Kalibrierung überhaupt Sinn?
Die durch Temperatur veränderte Dichte ist doch dieselbe für die klassische und die iSpindel und darauf kommt es doch an.
Meiner Ansicht nach, ist es nur sinnvoll eine Temperaturkorrektur "rückwärts" zu machen, wenn man den Vergleichswert mit dem Refraktometer ermittelt.

Viele Grüße,
Sebastian

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2132

Beitrag von DerDerDasBierBraut » Donnerstag 29. März 2018, 08:53

Selbst optisch absolut gleich aufgebaute iSpindeln verhalten sich bei mir bei Temperaturänderungen unterschiedlich. Bei einigen fällt der Tilt beim Abkühlen, bei anderen steigt er. Ich kalibriere das bei mir nicht, weil ich die Spindel nur zum beobachten des Extraktabbaus verwende. Verändere ich die Temperatur ist mir der kleine Knick in der Kurve egal, weil ich mich auf diese Anomalie einstellen kann und weiß, dass sie existiert.
Mit dem oben verlinkten Online Kalibrierungstool könnte man Formeln mit "tilt" und "temperature" basteln, um seine Kurve temperaturfest zu machen. Der errechnete "Platowert" wird trotzdem nie genau stimmen. Also viel Aufwand für wenig Nutzen. :-)
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
flensdorfer
Posting Senior
Posting Senior
Beiträge: 488
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: iSpindel - Aufbau und Betrieb

#2133

Beitrag von flensdorfer » Donnerstag 29. März 2018, 12:44

Sehe ich genauso. Auch mir reicht das Bild des Extraktabbaus völlig aus.
Gruß, Arne

Anfänger in der 20l-Klasse

clmnsk
Posting Klettermax
Posting Klettermax
Beiträge: 128
Registriert: Freitag 10. März 2017, 00:12

Re: iSpindel - Aufbau und Betrieb

#2134

Beitrag von clmnsk » Donnerstag 29. März 2018, 16:49

Nach knapp zwei Monaten sind meine PCBs von pcbs.io dann auch mal da.
Kann ich nicht so empfehlen, oder laaaange Zeit einplanen.
Die gehen wohl von China in die USA und dann zu uns.

Also endlich mal wieder löten.

Edit: Ich hab noch 5g Gewichte abzugeben.
Grüße, Clemens
---
Hendi - 34L Topf - 32L Thermobehälter

Benutzeravatar
Silicium
Neuling
Neuling
Beiträge: 4
Registriert: Freitag 30. März 2018, 13:51
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2135

Beitrag von Silicium » Freitag 30. März 2018, 14:06

Moin zusammen.

ich hab mal zwei Fragen:

Wie genau ist das Teil denn?
Ich habe kuerzlich meinen Chinarefraktometer von HuM gegen eine Bierspindel ersetzt, weil
das Ergebnis der Refraktometers dermassen ungenau war.

Die zweife Frage:

Wie genau ist das ganze im Bezug auf den Alkoholgehalt?
Wenn ich spindle dann zapfe ich das Bier ab, unten ist weniger alkohol.
Mit der iSpindel befindet sich das Messgeraet oben wo sich der Alkohol sammelt.
Wie wirkt sich das ganze auf das Ergebnis aus?

Verkauft jemand von euch fertig zusammengebaute iSpindeln, oder alternativ, wo kann ich die
Platinenlayouts finden? Im Gitrepo is leider nix.


Liebe Gruesse

mrhyde
Posting Junior
Posting Junior
Beiträge: 43
Registriert: Mittwoch 7. Juni 2017, 14:16

Re: iSpindel - Aufbau und Betrieb

#2136

Beitrag von mrhyde » Freitag 30. März 2018, 14:16

Silicium hat geschrieben:
Freitag 30. März 2018, 14:06
Verkauft jemand von euch fertig zusammengebaute iSpindeln, oder alternativ, wo kann ich die
Platinenlayouts finden? Im Gitrepo is leider nix.
Du findest das alles hier:
https://www.3d-mechatronics.de/

Es stehen auch eine Menge details im neuen Braumagazin und im GITrepo ist auch ein link zu www.ispindel.de.

thomas111
Posting Junior
Posting Junior
Beiträge: 11
Registriert: Dienstag 27. Februar 2018, 08:31

Re: iSpindel - Aufbau und Betrieb

#2137

Beitrag von thomas111 » Samstag 31. März 2018, 08:46

DerDerDasBierBraut hat geschrieben:
Donnerstag 29. März 2018, 00:31
Lass den Gäreimer bitte zu und lies dir auch den Abschnitt darunter durch ("Schnellstart ohne Kalibrierung").
Oder mach es wie du möchtest. Die iSpindel ist im Grunde kein Messinstrument sondern eher ein "hochsensibles Instrument zur Erkennung von Messwertveränderungen".

Abschnitt "Das Messinstrument?" >> http://braumagazin.de/article/ispindel-die-idee/
Danke nochmals für deine Arbeit hier!
Ich habe den Sinn der iSpindel jetzt denke ich endlich schon verstanden :).

Jetzt ist das Ding im Eimer mit Jungbier, war gestern sehr-sehr fleissig und habe 2 Bierchen gebraut. Was ich jetzt aber nicht verstehe ist ... warum ist mein "gravity" Parameter immer bei 0? Ich habe jetzt per ubidots "°P" Variable mit der Kalibrierung-ausegechneter Platoformel hinzugefügt, da wird alles gut berrechnet, da der "tilt" Parameter funktioniert.

Aber warum funktioniert "gravity" Parameter nicht mehr?

Ideen?

mrhyde
Posting Junior
Posting Junior
Beiträge: 43
Registriert: Mittwoch 7. Juni 2017, 14:16

Re: iSpindel - Aufbau und Betrieb

#2138

Beitrag von mrhyde » Samstag 31. März 2018, 10:04

thomas111 hat geschrieben:
Samstag 31. März 2018, 08:46

Jetzt ist das Ding im Eimer mit Jungbier, war gestern sehr-sehr fleissig und habe 2 Bierchen gebraut. Was ich jetzt aber nicht verstehe ist ... warum ist mein "gravity" Parameter immer bei 0? Ich habe jetzt per ubidots "°P" Variable mit der Kalibrierung-ausegechneter Platoformel hinzugefügt, da wird alles gut berrechnet, da der "tilt" Parameter funktioniert.

Aber warum funktioniert "gravity" Parameter nicht mehr?

Ideen?
Ich hatte das auch beim test mal und da war die Formel in der Ispindel nicht mehr vorhanden. Da gab es bei Gravity immer nur eine 0

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2139

Beitrag von Pottkieker » Sonntag 1. April 2018, 17:43

Hallo Zusammen,
ich habe auf anraten den Widerstand gewechselt, den Speicher komplett gelöscht und die neue Firmware auf gespielt, neu konfiguriert ( Intervall auf 10 sec ), jetzt sendet sie alle 10 sec. Leider sehe ich bei Ubidot keine Anzeige. Putty zeigt failed to connect.
Frohe Ostergrüße
Horst

Benutzeravatar
universam
Posting Freak
Posting Freak
Beiträge: 518
Registriert: Dienstag 20. September 2016, 16:43
Wohnort: Selters
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2140

Beitrag von universam » Montag 2. April 2018, 12:20

Dein Wlan Passwort wird nicht stimmen.
iSpindel - die DIY elektronische Spindel
Brauhelferlein - die mini Brausteuerung

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2141

Beitrag von Pottkieker » Montag 2. April 2018, 13:22

VielenDank, wert ich überprüfen

Benutzeravatar
manno_matze
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 21. November 2017, 22:07
Wohnort: Hamburg

Re: iSpindel - Aufbau und Betrieb

#2142

Beitrag von manno_matze » Montag 2. April 2018, 15:53

Moin zusammen,
habe heute das erste Mal die iSpindel nach dem Brauen ins Gärfass gegeben. Das Interval steht auf 1.800s und zu Beginn, als sie im Desinfektionsbad stand, hat sie auch 2mal gesendet. Seit dem Versenken im 30L Speidelgärfass (plastik) nicht mehr. Das waren die letzten Werte:
iSp_02042018.JPG
Hat jemand ne Ahnung, warum sie nicht mehr sendet? Hatte das Fass nochmal kurz aufgemacht, da schwamm sie fein in der Mitte vom Fass und alles sah trocken aus im Inneren des Petlings... :Grübel Komisch ist auch, dass nach 45min Ubidots auf an hour ago umspringt (oder is das normal?).

LG
Matze
"Das haben wir noch nie probiert, also geht es sicher gut!" :Drink
Pippi Langstrumpf

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2143

Beitrag von DerDerDasBierBraut » Montag 2. April 2018, 22:04

Moin, das kann normal sein. War die Spindel denn schon teilweise unter Kräusen? Die schirmen mächtig ab. Der RSSI von -77 beim letzten Lebenszeichen deutet auf einen recht schwachen WLAN Empfang hin. Ein Repeater in der Nähe des Gäreimers wird es richten. Bei mir funktioniert dieser preiswerte AVM FRITZ!WLAN Repeater 300E sehr gut.

Ubidots rundet die Zeitangaben in den Kacheln. Irgendwann geht es nur noch im Stunde- oder Tagestakt weiter. Also auch OK.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
manno_matze
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 21. November 2017, 22:07
Wohnort: Hamburg

Re: iSpindel - Aufbau und Betrieb

#2144

Beitrag von manno_matze » Montag 2. April 2018, 22:27

DerDerDasBierBraut hat geschrieben:
Montag 2. April 2018, 22:04
Moin, das kann normal sein. War die Spindel denn schon teilweise unter Kräusen? Die schirmen mächtig ab. Der RSSI von -77 beim letzten Lebenszeichen deutet auf einen recht schwachen WLAN Empfang hin. Ein Repeater in der Nähe des Gäreimers wird es richten. Bei mir funktioniert dieser preiswerte AVM FRITZ!WLAN Repeater 300E sehr gut.
Hi Jens,
danke! Hab gerade gesehen, dass die Kleine nach 3h doch fleißig angefangen hat zu funken. Die Küche hat eine unfassbar schlechte WLAN-Abdeckung hab ich dadurch erstmal realisiert, da werde ich doch mal deinen Repeater-Tipp aufgreifen! Bis dahin zieht das Fass um! :Bigsmile
Kräusen gab es noch nicht, die kommen hoffentlich die nächsten Tage. Hab dein Diagramm vom Februar darauf hin gefunden (zwecks Aussetzer) und bin gespannt wie sich das mit dem Empfang in dieser Phase verhält!
Grüße
"Das haben wir noch nie probiert, also geht es sicher gut!" :Drink
Pippi Langstrumpf

MichaGE
Neuling
Neuling
Beiträge: 6
Registriert: Freitag 21. April 2017, 12:41

Re: iSpindel - Aufbau und Betrieb

#2145

Beitrag von MichaGE » Montag 2. April 2018, 23:46

Nabend zusammen,

schlechter W-LAN Empfang ist genau mein Thema.... Ich vergäre im Keller im Kühlschrank und bis dahin reicht mein W-LAN Netz beim besten Willen nicht. Und deswegen machte eine iSpindel bisher keinen Sinn.
Gibt es denn mittlerweile eine oder mehr Lösungen, wie man diese tolle Erfindung dennoch nutzen kann - ich bin da doch nicht der einzige...?

Z.B. Kann die iSpindel die Daten doch abspeichern und irgendwie per Wlan oder sogar bluetooth auf meinen Rechner funken, sobald dieser in Reichweite ist? Oder man stellt einen Raspberry Pi auf den Kühlschrank, der stellt einen W-Lan Router dar, und wenn ich mit Notebook oder iPhone in den Keller gehe, rufe ich die Daten von diesem ab?

Danke und schöne Ostern gehabt zu haben ;)

clmnsk
Posting Klettermax
Posting Klettermax
Beiträge: 128
Registriert: Freitag 10. März 2017, 00:12

Re: iSpindel - Aufbau und Betrieb

#2146

Beitrag von clmnsk » Montag 2. April 2018, 23:53

MichaGE hat geschrieben:
Montag 2. April 2018, 23:46
Nabend zusammen,

schlechter W-LAN Empfang ist genau mein Thema.... Ich vergäre im Keller im Kühlschrank und bis dahin reicht mein W-LAN Netz beim besten Willen nicht. Und deswegen machte eine iSpindel bisher keinen Sinn.
Gibt es denn mittlerweile eine oder mehr Lösungen, wie man diese tolle Erfindung dennoch nutzen kann - ich bin da doch nicht der einzige...?

Z.B. Kann die iSpindel die Daten doch abspeichern und irgendwie per Wlan oder sogar bluetooth auf meinen Rechner funken, sobald dieser in Reichweite ist? Oder man stellt einen Raspberry Pi auf den Kühlschrank, der stellt einen W-Lan Router dar, und wenn ich mit Notebook oder iPhone in den Keller gehe, rufe ich die Daten von diesem ab?

Danke und schöne Ostern gehabt zu haben ;)
Ich benutze im Keller einen Original TILT.
Da geh ich mit dem Handy runter, empfange die Daten per Bluetooth innerhalb von Sekunden und mache nen Screenshot.
Grüße, Clemens
---
Hendi - 34L Topf - 32L Thermobehälter

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2147

Beitrag von DerDerDasBierBraut » Dienstag 3. April 2018, 00:04

Du kannst dir im Keller den lokalen RasPi iSpindel Server von Tozzi hinstellen.
(Die Software braucht endlich einen prägnanten Namen :-) )
Hier gibt es dazu was zum Lesen. http://braumagazin.de/article/raspyspindel/
Die Konfiguration geht auch ohne Linux Kenntnisse kinderleicht. Habe sogar ich geschafft.
Alternativ könnten PowerLan Adapter und ein AccessPoint im Keller vielleicht eine andere Möglichkeit sein.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2148

Beitrag von wwershofen » Dienstag 3. April 2018, 00:09

Hallo,
bin seit Ostersamstag nun auch stolzer Besitzer einer iSpindel und habe heute den Bausatz von 3D-Mechatronics soweit zusammengelötet.Aktuell lädt der Akku noch, aber ich konnte natürlich nicht abwarten und habe zwischendurch schon mal nach einem 4adrigen-USB-Kabel gesucht und dieses hoffentlich auch gefunden. Jedenfalls sagt mir NodeMCU bei dem aktuellen Kabel, dass er den seriellen Port erkannt hat und diesen auf COM3 routet, wenn ich die Spindel einschalte. Das ist aber schon alles... AP und STA MAC auf der Startseite bleiben leider auf "Waiting MAC" stehen.
Ansonsten sieht eigentlich alles soweit normal aus: Die blaue LED am WiFi-Modul blinkt im Sekundentakt, wenn eingeschaltet ist und die Ladelampe leuchtet rot, wenn das USB-Kabel an der Ladebuchse hängt.

Ist eventuell die Akku-Spannung noch zu niedrig und die MAC-Adresse wird deswegen nicht übertragen? Falls der Zustand sich auch bei vollem Akku nicht ändern sollte, wie kann ich auf Fehlersuche gehen?

Viele Grüße
Wolfgang

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4457
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2149

Beitrag von DerDerDasBierBraut » Dienstag 3. April 2018, 00:38

Ungewöhnlich. Kannst du denn die Firmware flashen oder kommt eine Fehlermeldung? Lade den Akku trotzdem besser erstmal komplett auf. Das Kabel ist 4adrig, wenn der COM Port erkannt wird.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2150

Beitrag von wwershofen » Dienstag 3. April 2018, 08:25

Moin,
Flashen hat mit vollem Akku heute morgen funktioniert. Die MAC-Adressen wurden allerdings erst angezeigt, nachdem ich auf dem Flash-Button geklickt hatte.
Die Spindel kommt jetzt korrekt in den Config-Modus und ich kann mich zum Portal verbinden. Der Temperatursensor zeigt allerdings -127°C an, da muss ich wohl nochmal bei...

Außerdem scheint er mir die WLAN-Einstellungen nicht zu sichern. Die verfügbaren Netze werden angezeigt und wenn ich die Zugangsdaten eingebe und sichere, zeigt er mit auch die Bestätigung an, dass ich 10 Sekunden warten sollte um zu prüfen, ob die Verbindung funktioniert. Ein Restart der Spindel wird offensichtlich auch ausgeführt, aber anschließend bin ich wieder im Config-Menu mit der Meldung "Not network configured"...

Muss ich mir dann heute abend nach der Arbeit nochmal anschauen...

Antworten