iSpindel - Aufbau und Betrieb

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3001

Beitrag von JackFrost » Dienstag 28. Januar 2020, 11:16

Wie hoch ist die Spannung gemessen zwischen B- und GND.
Wenn das mehr als ein paar mV sind dann ist vermutlich der Unterspannungsschutz kaputt am Laderegler.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

braunoob
Posting Junior
Posting Junior
Beiträge: 51
Registriert: Samstag 23. Februar 2013, 10:55

Re: iSpindel - Aufbau und Betrieb

#3002

Beitrag von braunoob » Donnerstag 30. Januar 2020, 20:18

Ich habe den Eindruck, zu blöd zu sein für die Kalibrierung meiner ersten iSpindel.
Ich will's mit der Zuckerwasser-Variante machen. Da besagt die Anleitung auf ispindel.de, 400ml Wasser + 100g Zucker. Allerdings reicht die Menge bei weitem nicht, damit die Spindel frei schwimmt. Ich müsste vermutlich die 5-fache Menge oder mehr anrühren, damit das klappt. Und dann mit der entsprechend vervielfachten Wassermenge nach und nach verlängern, für die einzelnen Messpunkte.
Da bin ich ja ratz fatz bei 25-30 Litern. Ist zwar jetzt kein Problem, aber ich wundere mich eben über die niedrigen Mengen, die in der Anleitung angegeben wurden.

Hab ich nen Denkfehler?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3003

Beitrag von JackFrost » Donnerstag 30. Januar 2020, 20:45

Kalibrier sie mit dem ersten Sud, ist einfacher und das CO2 hast du auch drinnen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

konkret
Posting Klettermax
Posting Klettermax
Beiträge: 256
Registriert: Freitag 29. September 2017, 08:23

Re: iSpindel - Aufbau und Betrieb

#3004

Beitrag von konkret » Donnerstag 30. Januar 2020, 22:15

Du kannst auch einfach 5lit. der höchsten Konzentration machen, und dann die Hälfte wegschütten und wieder mit Wasser aufüllen usw.. bis zur niedrigsten Stufe. Dann hast immer das gleiche Volumen.
Aber so wie in der Anleitung gehts nicht, das Volumen ist zu gering.

irrwisch
Posting Freak
Posting Freak
Beiträge: 964
Registriert: Sonntag 21. Januar 2018, 08:33

Re: iSpindel - Aufbau und Betrieb

#3005

Beitrag von irrwisch » Donnerstag 30. Januar 2020, 22:57

Kein so großen Aufriss machen.

Mach’s einfach bei deinem nächsten Sud:
Drei Werte reichen die man vôllig nebenbei bekommt:
1. in reinem Wasser
2. bei bekannter Stammwürze
3. bei bekanntem Restextrakt

Letztere beide Werte misst man ja in der Regel eh immer.
Mit den drei Werten kriegt man dann schon eine ganz brauchbare Kurve.

Und dabei nicht vergessen, dass die iSpindel nur ein Schätzeisen ist.

sunepedersen
Neuling
Neuling
Beiträge: 2
Registriert: Mittwoch 26. Oktober 2016, 20:12

Re: iSpindel - Aufbau und Betrieb

#3006

Beitrag von sunepedersen » Freitag 31. Januar 2020, 11:48

Gibt es irgendwo an dem man nur die platine kaufen kann?

Benutzeravatar
mwx
Posting Freak
Posting Freak
Beiträge: 756
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#3007

Beitrag von mwx » Freitag 31. Januar 2020, 12:57

Gruß, Michael

Gerührt und nicht geschüttelt: Magnetrührer Controller

Brockbier
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Samstag 20. April 2019, 20:27

Re: iSpindel - Aufbau und Betrieb

#3008

Beitrag von Brockbier » Sonntag 2. Februar 2020, 15:10

Hallo Zusammen,

vor ein paar Wochen habe ich mir nun auch die iSpindel gegönnt, allerdings bekomme ich diese nun nicht zum laufen. Dabei habe ich wohl 2 Fehler (Hardware- und Softwareseitig). Nach dem ich die letzten 20 Seiten hier durchforstet habe konnte ich keine passende Lösung finden ausser das ich jetzt wohl alle Kontakte gemessen habe die es gibt :D u.a. Ground - 5,0 V: 3,03 V/ Ground - 3,3 V: 2,27 V

Fehlerbilder sind folgende:
- Nach dem Laden leuchtet die blaue LED wie sie soll, die rote flackert allerdings ganz leicht. Beim Einschalten leuchten beide LEDs. Die LED vom WEMO blinkt nur kurz auf sofern ich alles am Ladestrom habe, im Batteriemodus leuchtet nichts --> Lademodul defekt?
- Ich kann den WEMO nicht flashen, da kein PORT erkannt wird nachdem ich ihn angeschlossen habe.

Nun frage ich mich ob ich ein Montagsmodell habe oder einfach nur irgendwo großen Bockmist fabriziert habe.

Ich hoffe ihr könnt mir weiterhelfen.

P.S.: Habe das Set von 3D Electronics zum selber montieren

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3009

Beitrag von JackFrost » Sonntag 2. Februar 2020, 16:22

Miss mal am Ladecontroller die Pins GND gegen B-.
Vermutlich ist der Ladecontroller defekt.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Brockbier
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Samstag 20. April 2019, 20:27

Re: iSpindel - Aufbau und Betrieb

#3010

Beitrag von Brockbier » Sonntag 2. Februar 2020, 21:02

danke für die schnelle Antwort. Schnell mal nachgemessen und da kommt 0 an.
Wie bekomme ich den Ladecontroller denn am besten wieder entlötet ohne großen Schaden anzurichten? Der Aufbau ging ja recht fix, andersherum erscheint mir das nahezu unmöglich :D

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3011

Beitrag von JackFrost » Sonntag 2. Februar 2020, 21:06

Wenn die Spannung zwischen B- und GND 0V bzw nur ein paar mV ist, dann ist der Unterspannungsmosfet ok.
Wie hoch ist die Akkuspannung aktuell ?

Ich kann dir anbieten, das ich dir den tausche wenn er wirklich defekt ist.
Mim Saitenschneider den alten ab. Die Stifte raus und die Lötstellen vom Zinn befreien und den neuen rein.
Ich müsste nur wissen welches Zinn du genommen hast, damit ich die richtigen Spitzen nehme.
Regler würde ich den mit der Miniusb nehmen, der kostet so 3,49€ und dann halt noch der Versand zu mir und zu dir.
Als Großbrief 2x 1,55 €

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Brockbier
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Samstag 20. April 2019, 20:27

Re: iSpindel - Aufbau und Betrieb

#3012

Beitrag von Brockbier » Sonntag 2. Februar 2020, 21:43

Danke für dein Angebot und die Hilfe. Werde mich nächste Woche nochmal selber versuchen und dann entsprechend nochmal auf dich zurückkommen ;-)

Gruß und einen schönen Restsonntag

Benutzeravatar
Innuendo
Posting Senior
Posting Senior
Beiträge: 454
Registriert: Freitag 2. März 2018, 09:43
Wohnort: Oberbergischer Kreis

Re: iSpindel - Aufbau und Betrieb

#3013

Beitrag von Innuendo » Dienstag 4. Februar 2020, 18:51

Hallo Ihrs,

Feature-Wunsch: Temperatur Offset (optional, Std: 0.0)

Firmware: 6.2 (Fehler tritt auch bei anderen Versionen auf)
Fehler: Temperatur konstant 3.8°C unter tatsächlicher Temperatur

Der DS18B20 muss eigentlich nicht kalibriert oder eingestellt werden. Meine iSpindel benötigt aber ein Offset.

Innu

Airbusfahrer
Neuling
Neuling
Beiträge: 4
Registriert: Freitag 24. Januar 2020, 21:34

Re: iSpindel - Aufbau und Betrieb

#3014

Beitrag von Airbusfahrer » Donnerstag 6. Februar 2020, 17:34

Hallo Spindelprofis!

Wenn ich bei meinen beiden Spindeln die Offset Calibration unter Maintenance durchführe, wird der Tilt korrekt auf 89,9x justiert. Danach scheint aber die Tiltanzeige nicht mehr zu stimmen. Selbst bei senkrecht gehaltener Spindel geht der angezeigte Tilt nichtmehr unter 60. Das Problem besteht unabhängig bei 2 neuen Spindeln, bei einer wurde wegen dem gleichen Fehler schonmal ein neuer Gyro verbaut. Keine Änderung.
Nach neuem Flashen der Software bewegt sich der Tilt zwischen 0-90°, allerdings ist dann der Offset wieder bei ca 10°.
Nach der Offset Calibration erneut der gleiche Fehler, kein Tilt unter 60°

Was hab ich falsch gemacht?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3015

Beitrag von JackFrost » Donnerstag 6. Februar 2020, 19:19

Die Spindel liegt oder steht beim Offset Justieren ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3016

Beitrag von DerDerDasBierBraut » Donnerstag 6. Februar 2020, 19:27

Airbusfahrer hat geschrieben:
Donnerstag 6. Februar 2020, 17:34
Was hab ich falsch gemacht?
Nichts. Die Offset Kalibrierung hat noch nie richtig funktioniert und ihr Sinn erschließt sich mir bis heute nicht.
Das "Kalibrieren" wird durch die Interpolation mit dem Polynom erledigt. Ob der Rohwertebereich zwischen 0 und 90 oder zwischen 10 und 80 liegt ist eigentlich total egal. Selbst, wenn man nur die Tiltwerte anschaut und nicht die berechnete "Gravity"
Setz die Firmware nochmal zurück und fass die Offset Kalibrierung einfach nicht mehr an.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Airbusfahrer
Neuling
Neuling
Beiträge: 4
Registriert: Freitag 24. Januar 2020, 21:34

Re: iSpindel - Aufbau und Betrieb

#3017

Beitrag von Airbusfahrer » Donnerstag 6. Februar 2020, 23:36

JackFrost hat geschrieben:
Donnerstag 6. Februar 2020, 19:19
Die Spindel liegt oder steht beim Offset Justieren ?

Gruß JackFrost
Sie liegt möglichst eben da, wie in der Anleitung beschrieben. Der Tilt passt sich ja dann auch fast den 90° an. Danach tritt der beschriebene Fehler auf.

DerDerDasBierBraut hat geschrieben:
Donnerstag 6. Februar 2020, 19:27
Airbusfahrer hat geschrieben:
Donnerstag 6. Februar 2020, 17:34
Was hab ich falsch gemacht?
Nichts. Die Offset Kalibrierung hat noch nie richtig funktioniert und ihr Sinn erschließt sich mir bis heute nicht.
Das "Kalibrieren" wird durch die Interpolation mit dem Polynom erledigt. Ob der Rohwertebereich zwischen 0 und 90 oder zwischen 10 und 80 liegt ist eigentlich total egal. Selbst, wenn man nur die Tiltwerte anschaut und nicht die berechnete "Gravity"
Setz die Firmware nochmal zurück und fass die Offset Kalibrierung einfach nicht mehr an.
Danke für die Erläuterungen. So hab ichs gemacht, neu geflasht und nun konnte ich in der "Hilfswürze" (Zuckerlösung) die Spindeln kalibrieren.
Ich dachte halt, je genauer die Grundeinstellung, desto genauer werden die Messwerte.
Verwirrendes Feature, wann soll man die Offset Kalibrierung denn dann nutzen?

Braini
Posting Junior
Posting Junior
Beiträge: 23
Registriert: Dienstag 11. September 2018, 11:27

Re: iSpindel - Aufbau und Betrieb

#3018

Beitrag von Braini » Dienstag 11. Februar 2020, 11:35

Gryps hat geschrieben:
Freitag 7. September 2018, 19:39
Nebenfrage falls das hier mal funktioniert: Wie bekomme ich den Wert der Stammwürze beim Gärstart (hier 26,5) automatisch in die Formel eingebaut? Meine bisherigen Versuche scheiterten (auch hier) erbärmlich. :crying
Habe dasselbe Problem und bisher keine Antworten gefunden. Geht das irgendwie?

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3019

Beitrag von DerDerDasBierBraut » Dienstag 11. Februar 2020, 11:48

Baut eine fx-Derived Variable für die Stammwürze, die tatsächlich etwas rechnet.
Also zum Beispiel:
"iSpindel000->tilt" - "iSpindel000->tilt" +12

"iSpindel000->tilt" - "iSpindel000->tilt" ergibt 0, rechnet aber und stellt Ubidots zufrieden ...
12 ist die STW. Dieser Wert kann bei jedem Gärstart angepasst werden.

Auf die (konstanten) Werte dieser fx-Derived Variable könnt ihr dann für weiteren Berechnungen zugreifen.

Dies ist getestet auf Ubidots for Education. Mit dem "neuen" kostenfreien Ubidots habe ich keine Erfahrungen.
1.jpg
keine iSpindel, aber das Prinzip ist ersichtlich
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Braini
Posting Junior
Posting Junior
Beiträge: 23
Registriert: Dienstag 11. September 2018, 11:27

Re: iSpindel - Aufbau und Betrieb

#3020

Beitrag von Braini » Dienstag 11. Februar 2020, 12:50

Danke für den Tipp. Die Möglichkeit einfach den höchsten, oder ersten gemessenen Wert als Variable anzulegen geht wohl nicht?

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3021

Beitrag von DerDerDasBierBraut » Dienstag 11. Februar 2020, 13:31

Nein, das funktioniert nicht, weil man im Device keine Variablen anlegen kann, die auf Aggregatfunktionen (min,max,sum,avg,...)
zurückgreifen.

Was man eigentlich bräuchte wäre eine Festwertvariable im Device und eine Widget, mit dem man den Wert dieser Festwertvariable bequem ändern kann. Gibt es aber nicht.
Aber du kannst gerne man den Ubidots Support auf eine Lösung ansprechen. Je öfter die damit konfrontiert werden, desto eher könnten neue Features entstehen.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
Braufex
HBCon Supporter
HBCon Supporter
Beiträge: 883
Registriert: Montag 6. August 2018, 22:22
Wohnort: Kreis Augsburg

Re: iSpindel - Aufbau und Betrieb

#3022

Beitrag von Braufex » Dienstag 11. Februar 2020, 16:20

Ich mach das ähnlich.
Einfach eine Variable mit 0 multiplizieren und dann den gewünschten Wert addieren.
Wichtig: Kommastellen mit Punkt trennen, nicht mit Komma.
So schreibt Ubidots meine Extraktmessungen und die Ink-Bird-Solltemperatur (Luft) des Kühlschrankes mit.
z.B.: Tilt*0+2.8
Gruß Erwin

Grantler1
Neuling
Neuling
Beiträge: 2
Registriert: Dienstag 11. Februar 2020, 22:10

Re: iSpindel - Aufbau und Betrieb

#3023

Beitrag von Grantler1 » Dienstag 11. Februar 2020, 22:25

Hallo Spindelexperten,

ich habe mir neulich eine Spindel zugelegt, habe aber Probleme bei der Inbetriebnahme. Vermutlich ist es auch mein Fehler weil ich basteltechnisch eher minderbegabt bin. Mein Problem ist, dass sich das WEMOS nich flashen lässt. Bin mir auch nicht sicher ob es vom node MCU flasher erkannt wird, auch nach einigen Minuten zeigt sich nichts im Fortschrittsbalken. Die LED der Spindel blinkt blau. Das einzige was ab und zu aufpopt ist connect.world (), require ("gpio"), require "wifi". Das Wlan "ESP-xxx" wird von anderen Geräten erkannt.

Ich muss zugeben zu dem minderbegabt kommt auch noch ungeduldig, sodass ich vor dem flashen des WEMOS erst die Spindel nach Anleitung zusammengelötet habe (ich weiss... RTFM und im nachhinein... die Diode die man rauslöten sollte wird schon einen Sinn gehabt haben, andererseits sollte man im nachhinein ja auch noch frimwareupdates flashen können?). Lässt sich da noch was retten oder ist das Ding hinüber?

Danke und Gruß,
Nik

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3024

Beitrag von JackFrost » Dienstag 11. Februar 2020, 22:34

Steck die Spindel zum Laden an und Versuch dann zu Flashen.
Wenn die Diode draußen ist, dann hat der Wemos keine Verbindung zu VUSB damit kommt die Versorgung nur noch vom Akku.
Wenn die Diode nicht draußen ist und man das USB Kable anschließt dann wird der Gyro von den 5V VUSB zerstört.

Vermutlich ist dein Akku zu leer. Daher probiere ob es geht wenn das Ladekabel mit dran ist.

Gruß JackFrost
Zuletzt geändert von JackFrost am Donnerstag 13. Februar 2020, 11:19, insgesamt 1-mal geändert.
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Grantler1
Neuling
Neuling
Beiträge: 2
Registriert: Dienstag 11. Februar 2020, 22:10

Re: iSpindel - Aufbau und Betrieb

#3025

Beitrag von Grantler1 » Donnerstag 13. Februar 2020, 08:57

Danke für den Tipp.

So hat es geklappt.

Gruß
Nik

Benutzeravatar
Innuendo
Posting Senior
Posting Senior
Beiträge: 454
Registriert: Freitag 2. März 2018, 09:43
Wohnort: Oberbergischer Kreis

Re: iSpindel - Aufbau und Betrieb

#3026

Beitrag von Innuendo » Freitag 14. Februar 2020, 07:48

Hallo,
Visualisierung mit Grafana und InfluxDB. Beides läuft auf meinem RaspberryPi neben CBPi. Ein erster Entwurf iSpindel Dashboard
ispindel_influxdb.jpg
Innu

Braini
Posting Junior
Posting Junior
Beiträge: 23
Registriert: Dienstag 11. September 2018, 11:27

Re: iSpindel - Aufbau und Betrieb

#3027

Beitrag von Braini » Freitag 14. Februar 2020, 21:43

Frage zur Visualisierung auf Ubidots. Ich möchte den ganzen bisherigen Gärverlauf sehen, logisch. Geht das irgendwie, auch wenn ich Durchschnittswerte von z.B. 1h-, oder 6h-Phasen einstelle? Irgendwie zeigt es mir dann immer nur die letzten 24h an. :Grübel

irrwisch
Posting Freak
Posting Freak
Beiträge: 964
Registriert: Sonntag 21. Januar 2018, 08:33

Re: iSpindel - Aufbau und Betrieb

#3028

Beitrag von irrwisch » Freitag 14. Februar 2020, 22:13

Im Dashboard kannst du ein Startdatum einstellen B wann er die Daten anzeigen soll.
Zumindest beim „neuen“ industrial Ubidots.
Beim alten Education ubidots bin ich mir nicht sicher.
Im Zweifel einfach einen neuen Account bei industrial.ubidots.com machen.

Braini
Posting Junior
Posting Junior
Beiträge: 23
Registriert: Dienstag 11. September 2018, 11:27

Re: iSpindel - Aufbau und Betrieb

#3029

Beitrag von Braini » Freitag 14. Februar 2020, 22:50

Oh mann, manchmal sucht man einfach zu weit... danke! :Ahh :Drink

Benutzeravatar
Spike_19
HBCon Supporter
HBCon Supporter
Beiträge: 329
Registriert: Sonntag 18. Oktober 2009, 00:09
Wohnort: Ibbenbüren
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#3030

Beitrag von Spike_19 » Montag 17. Februar 2020, 09:03

Guten Morgen
Ich habe nun seit einem Monat meine iSpindel in Betrieb und schicke die Daten fleißig an Ubidots. Bis jetzt läuft das Teil einwandfrei und zeigt mir sehr schön den Gärverlauf an. Bis gestern. Anscheinend ist meine Probezeit bei Ubidots abgelaufen und zum "wieder Aktivieren" möchten die eine horrende monatliche Gebühr für haben. Das hatte ich mir irgendwie anders vorgestellt. Gibt es eine wirklich kostenfreie Plattform, wo man die Daten hochladen kann? Bzw. bekomme ich die Spindel (die jetzt im Fermenter steckt) wieder aktiviert ohne sie an den Rechner zu schließen?
Gruß Christoph

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3031

Beitrag von DerDerDasBierBraut » Montag 17. Februar 2020, 09:12

Hast du einen Industrial Account bei Ubidots erstellt? Der ist natürlich nicht kostenfrei zu haben.
Ubidots STEM ist kostenlos bis zu 3(?) Geräte https://ubidots.com/stem/
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
Braufex
HBCon Supporter
HBCon Supporter
Beiträge: 883
Registriert: Montag 6. August 2018, 22:22
Wohnort: Kreis Augsburg

Re: iSpindel - Aufbau und Betrieb

#3032

Beitrag von Braufex » Montag 17. Februar 2020, 09:43

Hallo Jens,
bei mir läuft es bis jetzt auf "Ubidots for Education".
Was sind denn die Vor -und Nachteile zu STEM?
Gibt es da Unterschiede?

Gruß Erwin

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3033

Beitrag von DerDerDasBierBraut » Montag 17. Februar 2020, 09:48

Ich nutze auch Ubidots for Education. In STEM sehe ich nur Nachteile und Geldschneiderei (nur ein Dashboard, nur 3 Geräte, Features die die Welt nicht braucht).

Bevor die Frage von den neuen iSpindel Usern kommt nehme ich die Antwort gleich vorweg:
Ubidots for Education ist alt. Bestandskunden bleiben (bisher) in diesem Lizenzmodell und werden (bisher) nicht zur Umstellung auf STEM genötigt. Neukunden können allerdings keinen neuen Ubidots for Education Account mehr erstellen.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

irrwisch
Posting Freak
Posting Freak
Beiträge: 964
Registriert: Sonntag 21. Januar 2018, 08:33

Re: iSpindel - Aufbau und Betrieb

#3034

Beitrag von irrwisch » Montag 17. Februar 2020, 09:58

Man kann nen kostenlosen Account bei ubidots industrial machen.
Mir gefällt das wesentlich besser als das alte Ubidots.
Vor allem geht da mehr als ein device.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3035

Beitrag von DerDerDasBierBraut » Montag 17. Februar 2020, 10:08

irrwisch hat geschrieben:
Montag 17. Februar 2020, 09:58
Man kann nen kostenlosen Account bei ubidots industrial machen.
Mir gefällt das wesentlich besser als das alte Ubidots.
Vor allem geht da mehr als ein device.
Erkläre man ein bisschen wie man den Industrial Account auf "kostenlos" umstellt und was dort besser ist.
Könnte auch Spike_19 bei seiner Frage weiterhelfen :-) https://hobbybrauer.de/forum/viewtopic. ... 98#p368898

STEM hat übrigens 3 kostenfreie Geräte, Education 4.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
Spike_19
HBCon Supporter
HBCon Supporter
Beiträge: 329
Registriert: Sonntag 18. Oktober 2009, 00:09
Wohnort: Ibbenbüren
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#3036

Beitrag von Spike_19 » Montag 17. Februar 2020, 11:57

DerDerDasBierBraut hat geschrieben:
Montag 17. Februar 2020, 10:08
irrwisch hat geschrieben:
Montag 17. Februar 2020, 09:58
Man kann nen kostenlosen Account bei ubidots industrial machen.
Mir gefällt das wesentlich besser als das alte Ubidots.
Vor allem geht da mehr als ein device.
Erkläre man ein bisschen wie man den Industrial Account auf "kostenlos" umstellt und was dort besser ist.
Könnte auch Spike_19 bei seiner Frage weiterhelfen :-) https://hobbybrauer.de/forum/viewtopic. ... 98#p368898

STEM hat übrigens 3 kostenfreie Geräte, Education 4.
Ja bitte. Versuche das gerade, aber der leitet mich immer wieder zur Seite mit den verschiedenen Abo angeboten...bis über 1700$. :Mad2
Im Chat bei Ubidots meldet sich niemand auf meine Fragen.

irrwisch
Posting Freak
Posting Freak
Beiträge: 964
Registriert: Sonntag 21. Januar 2018, 08:33

Re: iSpindel - Aufbau und Betrieb

#3037

Beitrag von irrwisch » Montag 17. Februar 2020, 12:35

Vergesst es.

Offenbar hab ich doch nur einen STEM Account.
Ich hab mich wohl nur immer bei industrial.ubidots.com eingelogt, was mit einem STEM Account auch geht.

Nichtsdestotrotz gefällt mit der STEM Account besser.
Beim alten Education ging bei mir nur 1 (!!!) Device im Gegensatz zu anderen wo auch 3 gingen diesem Thread nach (vielleicht haben die das irgendwann mal geändert) und außerdem find ich das Dashboard nun besser bedienbar als das alte von Education.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3038

Beitrag von DerDerDasBierBraut » Montag 17. Februar 2020, 12:58

irrwisch hat geschrieben:
Montag 17. Februar 2020, 12:35
Beim alten Education ging bei mir nur 1 (!!!) Device im Gegensatz zu anderen wo auch 3 gingen diesem Thread nach (vielleicht haben die das irgendwann mal geändert) und außerdem find ich das Dashboard nun besser bedienbar als das alte von Education.
Stimmt. Sorry. Mein Fehler. :Ahh
Beim Education war (ist) ein Device kostenfrei drin. Alle weiteren kosten Credits. Das hatte ich innerlich verdrängt.

Vielleicht noch als Hinweis (werbefrei und uneigennützig :Wink ):
Wer regelmäßig beim Education-Konto draufzahlt oder mit den 3 Devices beim STEM nicht auskommt kann ggf. mal einen Blick auf BrewFather werfen. Das ist eine ziemlich gute Webapp zur Rezept und Lagerverwaltung, Richtung KBH und Beersmith. Kostet im Schnitt 2 EUR pro Monat und es können unlimitiert viele iSpindeln und andere Devices ohne Aufpreis eingerichtet werden. Einzige Einschränkung ist "maximal ein Datenpunkt pro 15 Minuten pro Device". Die iSpindeldaten werden automatisch dem Sud - und somit dem Brauprotokoll - zugeordnet. Ubidots benutze ich seither eigentlich nicht mehr.

Sieht z.B. bei meinem aktuellen Kveik Raw Ale so aus:
Raw Ale.JPG
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
flensdorfer
Posting Freak
Posting Freak
Beiträge: 653
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: iSpindel - Aufbau und Betrieb

#3039

Beitrag von flensdorfer » Montag 17. Februar 2020, 13:13

Hat schon mal jemand die remote config probiert? Ich habe das mal testweite in Tozzis iSpindle.py bzw. der DB aktiviert und auch die DB-Tabelle befüllt. Die Spindel hat sich danach nach wenigen Aufwachzyklen auf ewig schlafen gelegt - sprich überhaupt nichts mehr gesendet. Reset erweckte sie für einige Zyklen wieder zum Leben.

Nun habe ich Remote_config in Tozzis python-script wieder deaktiviert und seit dem macht die Spindel seit einer Woche, was sie soll.

Ach ja: Spindel ist 6.2.0
Gruß, Arne

Anfänger in der 20l-Klasse

Benutzeravatar
CastleBravo
Posting Freak
Posting Freak
Beiträge: 514
Registriert: Donnerstag 14. Dezember 2017, 14:09

Re: iSpindel - Aufbau und Betrieb

#3040

Beitrag von CastleBravo » Montag 17. Februar 2020, 16:47

Hallo zusammen!

Ich bräuchte eure Unterstützung. Meine Spindel mag nicht mehr. Habe die Spannungen bzgl. B+/- /Out+/- geprüft und am Akku, sollte nach euren Erklärungen passen. Wenn ich die Spindel per USB Kabel an meinen Mac anschließe und mittels "ls -la /dev/cu.*" nach angeschlossenen Geräten suche, dann wird die Spindel nicht angezeigt. So wie ich das verstanden habe, heißt das ja, dass das WEMOS sich in die ewigen Jagdgründe verabschiedet hat und ausgetauscht werden muss. Ist das soweit korrekt?

Beim googeln nach WEMOS D1 MINI werden einem sehr viele Geräte angezeigt und da ich mich hiermit nicht so gut auskenne wie Frage, ob mir jemand sagen kann, welches Gerät ich bestellen muss.

Vielen Dank für eure Unterstützung und viele Grüße!

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3041

Beitrag von JackFrost » Montag 17. Februar 2020, 16:57

Wie ist die Spannung zwischen GND und +5V. Bitte mit beiden Schalter Stellungen messen. Es könnte auch der Schalter sein.

Die blaue LED leuchtet auch nicht mehr , oder ?
Welche Spannungen hattest du gemessen ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
CastleBravo
Posting Freak
Posting Freak
Beiträge: 514
Registriert: Donnerstag 14. Dezember 2017, 14:09

Re: iSpindel - Aufbau und Betrieb

#3042

Beitrag von CastleBravo » Montag 17. Februar 2020, 17:07

Die gemessenen Spannungen waren:
B+ / B-: 4,2V
B+ / Out-: 4,2V
B- / Out-: 0V
Batterie: 4,2V

Die blaue LED leuchtet nur beim laden sonst nicht.
Der Schalter sieht in der Tat korrodiert aus, hat Rostflecken.
Die Spannung zwischen VCC und GND ist bei beiden Schalterstellungen 0V.

Heißt das, dass der Schalter der Übertäter ist?

Viele Grüße

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3043

Beitrag von JackFrost » Montag 17. Februar 2020, 17:22

Da sieht eher aus als wäre de Schalter defekt.
Der Schalter hat unten fünf Pins, oder ?
Miss mit den Multimeter mal den Strom zwischen dem Mittleren und jeweils der direkt links und rechts. Am besten in der höchsten Einstellung.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
CastleBravo
Posting Freak
Posting Freak
Beiträge: 514
Registriert: Donnerstag 14. Dezember 2017, 14:09

Re: iSpindel - Aufbau und Betrieb

#3044

Beitrag von CastleBravo » Montag 17. Februar 2020, 19:01

Ja der Schalter hat 5 Pins. Ich habe jetzt den Strom zwischen dem mittleren und den jeweils benachbarten Pins gemessen, von oben aus betrachtet.
Pin(Mitte) / Pin (rechts davon): 0 mA
Pin(Mitte) / Pin (links davon): 1,7 mA
Pin(Mitte) / äußerste Pins: 0 mA

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1369
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3045

Beitrag von JackFrost » Montag 17. Februar 2020, 19:33

Hast du gesehen ob sie gelaufen ist ? Wenn nein, dann Brücke die beiden Pins Mitte und Links mit der Messpitze vorsichtig. Wenn die Spindel dann sendet und läuft ist der Schalter defekt.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
CastleBravo
Posting Freak
Posting Freak
Beiträge: 514
Registriert: Donnerstag 14. Dezember 2017, 14:09

Re: iSpindel - Aufbau und Betrieb

#3046

Beitrag von CastleBravo » Montag 17. Februar 2020, 20:19

Hab ich gemacht, aber da sendet nichts. Auch die LEDs sind tot. Die leuchten nur beim Laden. Komischerweise kann ich auch den o. g. Strom (Pin(Mitte) / Pin (links davon)) nicht mehr messen. Zeigt jetzt 0 an.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3047

Beitrag von DerDerDasBierBraut » Montag 17. Februar 2020, 20:20

Miss mal bitte direkt am Wemos zwischen VCC und GND.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
CastleBravo
Posting Freak
Posting Freak
Beiträge: 514
Registriert: Donnerstag 14. Dezember 2017, 14:09

Re: iSpindel - Aufbau und Betrieb

#3048

Beitrag von CastleBravo » Montag 17. Februar 2020, 20:23

Da liegen 0V an.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6906
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3049

Beitrag von DerDerDasBierBraut » Montag 17. Februar 2020, 20:31

Dann ist der Schalter defekt.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
CastleBravo
Posting Freak
Posting Freak
Beiträge: 514
Registriert: Donnerstag 14. Dezember 2017, 14:09

Re: iSpindel - Aufbau und Betrieb

#3050

Beitrag von CastleBravo » Montag 17. Februar 2020, 20:33

Macht Sinn, ist ganz schön oxidiert das Ding. Dann tausch ich den mal aus. Vielen Dank für eure Hilfe!

Antworten