iSpindel - Aufbau und Betrieb

dagoep
Posting Junior
Posting Junior
Beiträge: 58
Registriert: Donnerstag 31. Oktober 2019, 06:06

Re: iSpindel - Aufbau und Betrieb

#3201

Beitrag von dagoep » Montag 25. Mai 2020, 13:27

Ich habe eins ohne Blei genommen. Entlötpumpe und Litze habe ich beides. Ich versuche es einfach mal sobald der neue Lagesensor da ist.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3202

Beitrag von JackFrost » Montag 25. Mai 2020, 13:31

Wenn du noch Flussmittel damit auch gut einstreichen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

dagoep
Posting Junior
Posting Junior
Beiträge: 58
Registriert: Donnerstag 31. Oktober 2019, 06:06

Re: iSpindel - Aufbau und Betrieb

#3203

Beitrag von dagoep » Montag 25. Mai 2020, 14:04

Danke für den Tipp. Wenn es nicht klappt, zwicke ich die Leiste durch und löte Stift für Stift raus.

dagoep
Posting Junior
Posting Junior
Beiträge: 58
Registriert: Donnerstag 31. Oktober 2019, 06:06

Re: iSpindel - Aufbau und Betrieb

#3204

Beitrag von dagoep » Mittwoch 27. Mai 2020, 10:37

OK, neuer Laderegler und neues WEMOS ist verbaut. Leider funktioniert die Spindel immer noch nicht.

Es ist möglich, dass ich beim Auslöten des Ladereglers die Platine beschädigt habe. An 3 Stiften hängt noch eine Metallhülse (vermutlich um die Ober/Unterseite der Platine zu verbinden)

Ich glaube ich breche an dieser Stelle jetzt ab. Das Vertrauen in die ISpindel habe ich sowieso schon verloren. Ich hätte Angst, dass mir eine abgesoffene Spindel einen Sud versaut.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3205

Beitrag von JackFrost » Mittwoch 27. Mai 2020, 11:17

dagoep hat geschrieben:
Mittwoch 27. Mai 2020, 10:37
OK, neuer Laderegler und neues WEMOS ist verbaut. Leider funktioniert die Spindel immer noch nicht.

Es ist möglich, dass ich beim Auslöten des Ladereglers die Platine beschädigt habe. An 3 Stiften hängt noch eine Metallhülse (vermutlich um die Ober/Unterseite der Platine zu verbinden)

Ich glaube ich breche an dieser Stelle jetzt ab. Das Vertrauen in die ISpindel habe ich sowieso schon verloren. Ich hätte Angst, dass mir eine abgesoffene Spindel einen Sud versaut.
Mach mal ein paar Bilder und schick mir die.
Fädeldraht hilft da noch.

Zur Not schick sie mir, das bekommt man. Schon hin.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3206

Beitrag von JackFrost » Mittwoch 27. Mai 2020, 20:46

Ich hab die Platine von mir etwas überarbeitet.

Damit man sich das Auslöten der Diode sparen kann hab ich eine ideale Diode auf die Platine gesetzt.
Leider gibt es die nur als SMD. Ich werde noch einen Bypass machen, so das man sie nutzen kann oder nicht,
dann muss aber die Diode am Wemos D1 wieder raus.

Die ideale Diode trennt die 4,2V vom Laderegler von den 5V des USB. Im Gegensatz zu einer Diode oder Schottky Diode ist der Spannungsverlust
deutlich keiner. Diode ~0,7 V , Schottky ~0,3V und ideale Diode 0,05 V. Damit ist sie für den Betrieb an dem Lion Akku ideal.

Die Verschaltung ist so, das selbst wenn die iSpindel über die Steckbrück aus ist, über den USB betrieben werden kann. Es reicht also kurz an
den USB, flashen und gut ist. Man kann dann nicht vergessen die iSpindel nach dem flashen auszuschalten.
iSpindel top.png

Dann müsste nur noch die LED am Gyro raus.
Da der MPU-6050 nicht mehr für neue Desings empfohlen wird, hab ich als alternative den Nachfolger auf die Unterlage gepackt. Man kann also den Gyro gantz normal verlöten oder den Nachfolger direkt auf die Platine setzen. Dieser ist jedoch nicht leicht zu löten.
Ich werde den neuen Gyro noch auf die alternative Adresse setzen, so kann zwischen alt und neu in der Software unterschieden werden. So das man hier nichts Einstellen müsste
iSpindel bottom.png
Ich bin noch am Überlegen ob ich eine alternative für den Laderegler auf die Platine packe, so das man sie nutzen kann wenn der TP nicht mehr verfügbar ist.

Laderegler und Lion-Schutz solllen noch draufpassen. Dann wäre es nur eine Platine und der Wemos und alles ist etwas dünner.

Das Layout ist noch nicht fertig,

Die Größe von 45 x 30 mm Platine kann als 2x3 Panel gefertigt werden. So das es bei 10 Panels 60 Platinen werden.
Damit sollte der Nachschub für die Zukunft gesichert sein.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

nPlusEins
Posting Junior
Posting Junior
Beiträge: 47
Registriert: Sonntag 7. Februar 2016, 17:03
Wohnort: Karlsruhe

Re: iSpindel - Aufbau und Betrieb

#3207

Beitrag von nPlusEins » Mittwoch 27. Mai 2020, 23:40

Ich hab mich ein bisschen in die iSpindel Thematik eingelesen - ich brauche das unbedingt :Smile
Mir fehlt aber etwas der Überblick welche Variante denn aktuell die Beste ist bzw. empfehlenswerte zum Nachbauen ist. Gefühlt wird in jeder Baubeschreibung ein anderes Design verwendet. 3Drucker hätte ich, kann Lochraster löten. Platinen bestellen und bestücken etc. wär aber auch möglich für mich ... hab also eigentlich beste Voraussetzungen.

Was ist denn am Besten hinsichtlich:
* festem Sitz der Platine u. Akku etc. im PETling (ich vermute das ist wichtig für konsistente Ergebnisse)
* Kosten für den Aufbau

Was ich auch nicht herausfinden konnte: sitzt der DS18B20 bei allen Varianten in der Spitze vom PETling?

Ich suche sozusagen den State of the Art :Smile Wenn es nen günstigen Bausatz gibt wär das ok. Kann aber auch einfach die nötigen Module bei Aliexpress und co. bestellen, Kleinkram gibts hoffentlich auch beim Elektronikhändler vor Ort.

Gruß
xblax

clmnsk
Posting Klettermax
Posting Klettermax
Beiträge: 249
Registriert: Freitag 10. März 2017, 00:12
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#3208

Beitrag von clmnsk » Donnerstag 28. Mai 2020, 20:02

Ich finde die PCB Version im kleinen Petling aktuell am besten:
https://www.pcbway.com/project/sharepro ... l_4_0.html
Grüße, Clemens
---
Hendi - 34L Topf - 32L Thermobehälter
10L Topf BIAB - Kühlschlange - Ikea 10L PP-Container

Aux
Posting Junior
Posting Junior
Beiträge: 23
Registriert: Montag 19. November 2018, 08:02
Wohnort: Augsburg

Re: iSpindel - Aufbau und Betrieb

#3209

Beitrag von Aux » Freitag 29. Mai 2020, 08:08

Gibt es die kleine Petling Variante bereits irgendwo fertig zum kaufen? Mir fehlt leider gerade die Zeit für viel Löten. Bzw. Ist der kleine Petling eher dicht?

Bockelsbock
Posting Klettermax
Posting Klettermax
Beiträge: 212
Registriert: Donnerstag 22. August 2019, 10:40

Re: iSpindel - Aufbau und Betrieb

#3210

Beitrag von Bockelsbock » Freitag 29. Mai 2020, 17:45

Gibt es fertig auf der Homepage zu kaufen. Musst nur auswählen gelötet und geflashed!
In dem Bock steckt jede Menge Craft

Mit einem leichten Hang zu Bockbieren!

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3211

Beitrag von ak59 » Freitag 29. Mai 2020, 22:13

Bockelsbock hat geschrieben:
Freitag 29. Mai 2020, 17:45
Gibt es fertig auf der Homepage zu kaufen. Musst nur auswählen gelötet und geflashed!
Hi,

sorry, welche Homepage? Die von oben? Dann war ich zu dusslig. Ich frag nur, weil ich auf der von 3D-M... gescheitert bin.

Gruß,

Andreas

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3212

Beitrag von JackFrost » Freitag 29. Mai 2020, 23:47

ak59 hat geschrieben:
Freitag 29. Mai 2020, 22:13
Bockelsbock hat geschrieben:
Freitag 29. Mai 2020, 17:45
Gibt es fertig auf der Homepage zu kaufen. Musst nur auswählen gelötet und geflashed!
Hi,

sorry, welche Homepage? Die von oben? Dann war ich zu dusslig. Ich frag nur, weil ich auf der von 3D-M... gescheitert bin.

Gruß,

Andreas
Der Shop von 3D-M wurde verkauft. Aktuell kann es sein das er nicht aktiv.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

vonfritz
Posting Junior
Posting Junior
Beiträge: 22
Registriert: Freitag 22. Februar 2019, 18:04
Wohnort: Italien

Re: iSpindel - Aufbau und Betrieb

#3213

Beitrag von vonfritz » Samstag 30. Mai 2020, 10:45

Aux hat geschrieben:
Freitag 29. Mai 2020, 08:08
Gibt es die kleine Petling Variante bereits irgendwo fertig zum kaufen? Mir fehlt leider gerade die Zeit für viel Löten. Bzw. Ist der kleine Petling eher dicht?
Ja, ich kann Ihn (Filippo) fragen
ob er auch nach Deutschland versendet oder kannst ihn selber fragen wenn duTelegram benutzt: https://t.me/cherryphilip
photo_2020-05-30_10-30-41.jpg
Salute e buona birra

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7533
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3214

Beitrag von DerDerDasBierBraut » Samstag 30. Mai 2020, 11:06

vonfritz hat geschrieben:
Samstag 30. Mai 2020, 10:45
Aux hat geschrieben:
Freitag 29. Mai 2020, 08:08
Gibt es die kleine Petling Variante bereits irgendwo fertig zum kaufen? Mir fehlt leider gerade die Zeit für viel Löten. Bzw. Ist der kleine Petling eher dicht?
Ja, ich kann Ihn (Filippo) fragen
ob er auch nach Deutschland versendet oder kannst ihn selber fragen wenn duTelegram benutzt: https://t.me/cherryphilip

photo_2020-05-30_10-30-41.jpg
Ich finde die Platine mit dem gedrehten Wemos ganz witzig. Bringt vielleicht wirklich was, wenn die Antenne weiter aus dem Jungbier herausragt.
Falls jemand eine Sammelbestellungen für die passenden Petlinge in Litauen organisiert wäre ich mit 30 Stück dabei. Und 6 "Filippo 4.0" Platinen.
Wäre vielleicht nur ganz hilfreich, wenn der Filippo mit seinem Geocaching Shop unter Landsmännern abklärt, dass die Petlinge wirklich aus einer Charge stammen, alle gleich groß sind und die Platine wirklich passt.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
Archie
Posting Senior
Posting Senior
Beiträge: 404
Registriert: Montag 4. Mai 2015, 19:56

Re: iSpindel - Aufbau und Betrieb

#3215

Beitrag von Archie » Samstag 30. Mai 2020, 11:32

Hallo,
die Idee mit der Sammelbestellung ist prima. ich wäre mit jeweils 3 Petlingen und 3 Platinen dabei.
Aber vielleicht ist dieser Thread der falsche Ort für Bestellungswünsche, dann meinen Beitrag einfach löschen.

Gruß
Archie

Benutzeravatar
ralfsteck
Posting Junior
Posting Junior
Beiträge: 74
Registriert: Mittwoch 20. März 2019, 09:50

Re: iSpindel - Aufbau und Betrieb

#3216

Beitrag von ralfsteck » Samstag 30. Mai 2020, 11:40

Ich wäre mit 2x beides dabei.
Gruß, Ralf
Weizenfanatiker, Bottichmaischer und Brauschrauber vom Bodensee.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7533
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3217

Beitrag von DerDerDasBierBraut » Samstag 30. Mai 2020, 12:01

Archie hat geschrieben:
Samstag 30. Mai 2020, 11:32
Aber vielleicht ist dieser Thread der falsche Ort für Bestellungswünsche, dann meinen Beitrag einfach löschen.
Stimmt. Erstmal müsste sich jemand melden, der die Detailklärungen in die Hand nimmt und die SB organisieren möchte. Danach wäre ein separater Thread im passenden Unterforum angebracht.
Auf mich braucht ihr nicht warten. Ich organisiere das nicht und bestelle einfach meinen Kram mit :-).
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

StefanBrautBier
Neuling
Neuling
Beiträge: 1
Registriert: Samstag 13. Juni 2020, 21:53

Re: iSpindel - Aufbau und Betrieb

#3218

Beitrag von StefanBrautBier » Samstag 13. Juni 2020, 22:02

Hallo zusammen,

ich habe jetzt schon so einige Foreneinträge - auch der lieben internationalen Kollegen - durchstöbert und finde nicht so recht eine Antwort bzw. einen Hinweis zu meinem Problem. Ich hatte die iSpindel bis vor kurzem im Einsatz. Jetzt wollte ich Sie bei meinem letzten Hellen wieder einsetzen, aber es kamen einfach online keine Daten an. Nach ein paar Versuchen habe ich das Problem eingrenzen können - meinen neuen Vodafonerouter. Mobiles Netz mit dem Smartphone klappt, WLAN der Schwiegereltern klappt - nur mein Heim WLAN will nicht. Bevor ich mir einen neuen Rouer kaufe, wollte ich mal im Forum nachfragen, ob es eine Möglichkeit gibt, meinem Router zu sagen, das er doch meine Messsensorik bitte ins Internet lässt.

Putty gibt folgenden Code aus:

woken from deepsleep, normal mode
Samples:42 min:66.84 max:66.92 time:759
x: 7950 y: 13616 z: -564
Tilt: 66.88
Tacc: 25.60
Volt: 4.89
Temp: 25.00
Gravity: -5.84
After waiting 5971ms, result 6
Rescue Wifi credentials
failed to connect

Final-sleep: 10s; RT: 7273

Hat jemand eine Idee?

Beste Grüße

Stefan

gfranke
HBCon Supporter
HBCon Supporter
Beiträge: 13
Registriert: Mittwoch 25. März 2020, 13:09

Re: iSpindel - Aufbau und Betrieb

#3219

Beitrag von gfranke » Samstag 13. Juni 2020, 22:08

Hallo,

bei einer Sammelbestellung wäre ich auch dabei. Sollte es einen separaten Thread geben - bitte den Link hier posten.

Viele Grüße

Götz

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7533
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3220

Beitrag von DerDerDasBierBraut » Samstag 13. Juni 2020, 22:20

StefanBrautBier hat geschrieben:
Samstag 13. Juni 2020, 22:02
Hat jemand eine Idee?
Der Wemos in der iSpindel kann nur 2,4 GHz WiFi.
Falls dein neuer Access-Point vielleicht Dual Band (2.4GHz / 5GHz) unterstützt und die 2,4 GHz in der Konfiguration deaktiviert sind, dann könnte sich die iSpindel nicht auf das verbleibende 5 GHz WiFi verbinden.

Nur als Idee. Anderenfalls finde heraus, wo du in deinem Netzwerk mit dem Wireshark ansetzen kannst, um den Verbindungsaufbau der iSpindel zu sniffern. Vielleicht bietet der Router selbst einen Monitoring Port oder eine andere Möglichkeit, die WiFi Pakete zu capturen.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
McMelloW
Posting Junior
Posting Junior
Beiträge: 60
Registriert: Montag 30. Dezember 2019, 20:36
Wohnort: Harderwijk, Nederland

Re: iSpindel - Aufbau und Betrieb

#3221

Beitrag von McMelloW » Mittwoch 17. Juni 2020, 18:59

Hat jemand bereits Erfahrung mit der neuen Firmware 6.3.1 für die iSpindel
Regards McMelloW

Rockska
Posting Junior
Posting Junior
Beiträge: 30
Registriert: Dienstag 17. Oktober 2017, 07:21

Re: iSpindel - Aufbau und Betrieb

#3222

Beitrag von Rockska » Sonntag 21. Juni 2020, 17:39

Hi,
ich habe mir Dezember 17 ein komplettes Set der ispindel gekauft, bin aber leider nie mehr dazu gekommen dieses überhaupt
erst anzufangen. Hat zufällig noch jemand eine Aufbau-Anleitung parat? Leider finde ich nichts im Netz, die 3DM Seite wurde verkauft, bzw. die Links führen leider ins nichts.

Liebe Grüße
Mark

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7533
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3223

Beitrag von DerDerDasBierBraut » Sonntag 21. Juni 2020, 17:56

"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
flensdorfer
Posting Freak
Posting Freak
Beiträge: 662
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: iSpindel - Aufbau und Betrieb

#3224

Beitrag von flensdorfer » Montag 22. Juni 2020, 13:57

McMelloW hat geschrieben:
Mittwoch 17. Juni 2020, 18:59
Hat jemand bereits Erfahrung mit der neuen Firmware 6.3.1 für die iSpindel
Der Frage möchte ich mich mal anschließen :Waa
Gruß, Arne

Anfänger in der 20l-Klasse

Rockska
Posting Junior
Posting Junior
Beiträge: 30
Registriert: Dienstag 17. Oktober 2017, 07:21

Re: iSpindel - Aufbau und Betrieb

#3225

Beitrag von Rockska » Donnerstag 25. Juni 2020, 07:24

Habe meine 2017er Spindel mit Schlitten gestern zusammen gelötet... war ansich kein Problem.
Schalte ich den Schalter nach rechts, blinkt es im Sekundentakt blau und ich finde auch das Wlan ESP*** kann dort jedoch keine Config-Seite aufrufen.
Vermute, weil nichts geflashed wurde.

Dafür wollte ich dann die Spindel über den Port des Wemos an den PC anschließen, aber es tut sich nix. Egal ob die Spindel an ist, aus ist etc... oder der Wemos alleine vom Rest getrennt. Mehrere USB-Ports probiert... Woran könnte das liegen?

Seitersbräu
Neuling
Neuling
Beiträge: 3
Registriert: Sonntag 27. Januar 2019, 09:57

Re: iSpindel - Aufbau und Betrieb

#3226

Beitrag von Seitersbräu » Donnerstag 25. Juni 2020, 21:29

Hallo und guten Abend,
ich wollte mit die Platine für die Spindel hier bestellen https://pcbs.io/share/zZwRq
Sieht alles gut aus, bis man auf bezahlen klickt (egal ob Paypal oder Kreditkarte).
Es geht ein Popup auf ... "Loading payment dialog"
Dann passiert nichts mehr, egal ob ich es mit Safari, Firefox, IE oder Crome probiere.
Popupblocker sind deaktiviert.

Hat das Jemand im neuen Jahr schon mal probiert ?

Gruß

nPlusEins
Posting Junior
Posting Junior
Beiträge: 47
Registriert: Sonntag 7. Februar 2016, 17:03
Wohnort: Karlsruhe

Re: iSpindel - Aufbau und Betrieb

#3227

Beitrag von nPlusEins » Donnerstag 25. Juni 2020, 21:51

Seitersbräu hat geschrieben:
Donnerstag 25. Juni 2020, 21:29
Hallo und guten Abend,
ich wollte mit die Platine für die Spindel hier bestellen https://pcbs.io/share/zZwRq
Sieht alles gut aus, bis man auf bezahlen klickt (egal ob Paypal oder Kreditkarte).
Es geht ein Popup auf ... "Loading payment dialog"
Dann passiert nichts mehr, egal ob ich es mit Safari, Firefox, IE oder Crome probiere.
Popupblocker sind deaktiviert.

Hat das Jemand im neuen Jahr schon mal probiert ?

Gruß
Die Seite sieht irgendwie auch etwas unseriös aus finde ich, da würd ich glaube ich keine Daten eingeben wollen. Kein Impressum, keine Infos wer dahiner steht.

Ich hab allerdings vor kurzem erfolgreich das iSpindel PCB 4.0 (https://github.com/cherryphilip74/iSpindel-PCB) bei JLCPCB bestellt gehabt. Hat 13.42€ inkl. Versand für 5 Stück gekostet und kam in unter 2 Wochen an. Dafür warte ich jetzt bestimmt noch länger auf die restlichen Teile von Aliexpress :crying

Falls du die Gerberdaten der Platine hast geht das absolut einfach auch als Laie auch bei jedem anderen PCB Hersteller.

Seitersbräu
Neuling
Neuling
Beiträge: 3
Registriert: Sonntag 27. Januar 2019, 09:57

Re: iSpindel - Aufbau und Betrieb

#3228

Beitrag von Seitersbräu » Freitag 26. Juni 2020, 12:25

Ja aber auch bei Philippo (cherryPhillip) gibt es nur noch die SMD Variante in lang. Keine Short Version . Bei PCBWays.com kann man die Lang Variante bestellen aber für über 30 $. Ich muss weitersuchen.

nPlusEins
Posting Junior
Posting Junior
Beiträge: 47
Registriert: Sonntag 7. Februar 2016, 17:03
Wohnort: Karlsruhe

Re: iSpindel - Aufbau und Betrieb

#3229

Beitrag von nPlusEins » Freitag 26. Juni 2020, 13:00

Seitersbräu hat geschrieben:
Freitag 26. Juni 2020, 12:25
Ja aber auch bei Philippo (cherryPhillip) gibt es nur noch die SMD Variante in lang. Keine Short Version . Bei PCBWays.com kann man die Lang Variante bestellen aber für über 30 $. Ich muss weitersuchen.
Ja ich hab die Lang Variante bestellt, aber eben bei JLCPCB für ca. 13€ statt für über 30€ bei PCBWays. Die Gerberdaten gibts bei Github (alter Commit): https://github.com/cherryphilip74/iSpin ... _Rev_A.zip

Das kann man einfach bei JLCPCB und co. hochladen und zahlt dann keinen überteuerten Preis.

Seitersbräu
Neuling
Neuling
Beiträge: 3
Registriert: Sonntag 27. Januar 2019, 09:57

Re: iSpindel - Aufbau und Betrieb

#3230

Beitrag von Seitersbräu » Freitag 26. Juni 2020, 22:16

Danke nPlusEins, das hat geholfen. :thumbup

Benutzeravatar
Luigi
HBCon Supporter
HBCon Supporter
Beiträge: 70
Registriert: Samstag 4. Februar 2017, 19:54
Wohnort: Kirchseeon

Re: iSpindel - Aufbau und Betrieb

#3231

Beitrag von Luigi » Sonntag 28. Juni 2020, 10:12

Seitersbräu hat geschrieben:
Donnerstag 25. Juni 2020, 21:29
Hallo und guten Abend,
ich wollte mit die Platine für die Spindel hier bestellen https://pcbs.io/share/zZwRq
Sieht alles gut aus, bis man auf bezahlen klickt (egal ob Paypal oder Kreditkarte).
Es geht ein Popup auf ... "Loading payment dialog"
Dann passiert nichts mehr, egal ob ich es mit Safari, Firefox, IE oder Crome probiere.
Popupblocker sind deaktiviert.

Hat das Jemand im neuen Jahr schon mal probiert ?

Gruß
Servus Dirk, :thumbup

also ich hatte ja bereits während Corona dort bestellt, per paypal bezahlt und nach knapp 2 Monaten kamen dann auch die Platinen an. Die lange Bearbeitungszeit könnte auch an Corona und dem Shutdown in den USA gelegen haben. Qualität ist super. Mag die kleinere Platinenversion irgendwie lieber. Aber ist sicher Geschmackssache...

Viele Grüße
Lui
Dateianhänge
img_2159.jpg
Lieber Bier im Bauch, als Wasser im Kopf! :Drink

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3232

Beitrag von ak59 » Montag 29. Juni 2020, 10:29

Hallo,
ich hab zum 1. Mal eine (nicht feinkalibrierte) iSpindel im Gärfass und bisher (9 Tage) sah alles recht gut aus. Heute morgen sehe ich aber einen unerwarteten Anstieg:
spindel.jpg
Ich hätte 2 Erklärungen dafür
- irgendwas (Heferückstände?) an der Spindel hat sich gelöst, dadurch fehlt nun etwas Auftrieb
- irgendwas ist nicht mehr ok - Flüssigkeit in der Spindel?

Ohne Herausnehmen der Spindel kann ich letzteres wohl nicht prüfen, aber wenn ich es richtig sehe, hätte sich dann die Spindel wieder etwas mehr aufrichten müssen.

Soll ich die Spindel besser rausnehmen oder sieht das ok aus?

Viele Grüße,

Andreas

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7533
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3233

Beitrag von DerDerDasBierBraut » Montag 29. Juni 2020, 10:34

Kräusen fallen zusammen, anhaftende Brandhefe trocknet, anhaftende CO2 Bläschen lösen sich, schwebende Hefe sedimentiert ....
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3234

Beitrag von ak59 » Montag 29. Juni 2020, 11:01

... dacht ich mir fast, danke für die Beruhigung ;-)

Gruß,

Andreas

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3235

Beitrag von ak59 » Montag 29. Juni 2020, 11:15

Rockska hat geschrieben:
Donnerstag 25. Juni 2020, 07:24
Habe meine 2017er Spindel mit Schlitten gestern zusammen gelötet... war ansich kein Problem.
Schalte ich den Schalter nach rechts, blinkt es im Sekundentakt blau und ich finde auch das Wlan ESP*** kann dort jedoch keine Config-Seite aufrufen.
Vermute, weil nichts geflashed wurde.

Dafür wollte ich dann die Spindel über den Port des Wemos an den PC anschließen, aber es tut sich nix. Egal ob die Spindel an ist, aus ist etc... oder der Wemos alleine vom Rest getrennt. Mehrere USB-Ports probiert... Woran könnte das liegen?
Hi,

falls das noch akut ist: ich kann eigentlich nur für 'nen Mac sprechen - meine Windows-Kenntnisse sind etwas eingerostet. Müsste die HW nicht erkannt werden? Adequat zum Mac würde ich einen Treiber als nötig ansehen, der über den USB-Port eine serielle Schnittstelle einrichtet.

Gruß,

Andreas

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3236

Beitrag von JackFrost » Montag 29. Juni 2020, 11:52

Der Wemos alleine, wenn die Diode entfernt wurde läuft nicht ohne die anderen Platinen.

Hast du ein unbekanntes Gerät im Gerätemanager wenn der Wemos angesteckt ist ?

Hast du evtl. beim entfernen der Diode was anderes beschädigt neben der USB Buchse ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Rockska
Posting Junior
Posting Junior
Beiträge: 30
Registriert: Dienstag 17. Oktober 2017, 07:21

Re: iSpindel - Aufbau und Betrieb

#3237

Beitrag von Rockska » Montag 29. Juni 2020, 15:25

JackFrost hat geschrieben:
Montag 29. Juni 2020, 11:52
Der Wemos alleine, wenn die Diode entfernt wurde läuft nicht ohne die anderen Platinen.

Hast du ein unbekanntes Gerät im Gerätemanager wenn der Wemos angesteckt ist ?

Hast du evtl. beim entfernen der Diode was anderes beschädigt neben der USB Buchse ?

Gruß JackFrost
Danke für deine Rückmeldung.
Hab mir die Stelle mit der Diode genau angeschaut, dort ist, bis auf die fehlende Diode nichts zu sehen...
Auch ist nichts in Windows zu erkennen, kein Gerät, kein Piep, das etwas angesteckt wurde nix. Habe alle USB-Ports probiert,
dachte es liegt vllt an 2.0 oder 3.0... 3 verschiedene Kabel... die Batterie getauscht und auch direkt im Lademodus versucht.

Passiert leider nix... Ich hab früher in SMD Motorencontroller eines Mikrokopters gelötet... sooo schwer war das Projekt hier ja jetzt nicht.
mhhh.....

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3238

Beitrag von ak59 » Montag 29. Juni 2020, 16:05

Rockska hat geschrieben:
Montag 29. Juni 2020, 15:25
JackFrost hat geschrieben:
Montag 29. Juni 2020, 11:52
Der Wemos alleine, wenn die Diode entfernt wurde läuft nicht ohne die anderen Platinen.

Hast du ein unbekanntes Gerät im Gerätemanager wenn der Wemos angesteckt ist ?

Hast du evtl. beim entfernen der Diode was anderes beschädigt neben der USB Buchse ?

Gruß JackFrost
Danke für deine Rückmeldung.
Hab mir die Stelle mit der Diode genau angeschaut, dort ist, bis auf die fehlende Diode nichts zu sehen...
Auch ist nichts in Windows zu erkennen, kein Gerät, kein Piep, das etwas angesteckt wurde nix. Habe alle USB-Ports probiert,
dachte es liegt vllt an 2.0 oder 3.0... 3 verschiedene Kabel... die Batterie getauscht und auch direkt im Lademodus versucht.

Passiert leider nix... Ich hab früher in SMD Motorencontroller eines Mikrokopters gelötet... sooo schwer war das Projekt hier ja jetzt nicht.
mhhh.....
Hi,

ich hab' da noch 'nen Verdacht: kann es sein, daß Dein USB-Kabel keine Daten durchschleift? Ich musste mir extra eins kaufen - alle meine 7 vorrätigen hatten ein Problem bzw. fehlten da wohl die Datenleitungen.

Gruß,

Andreas

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3239

Beitrag von JackFrost » Montag 29. Juni 2020, 16:15

Miss bitte mal die Spannungen wie in dem Wiki https://hobbybrauer.de/forum/wiki/doku. ... D=ispindel

Nur um sicher zugehen, das alle Spannungen passen.

Hast du einen zweiten Wemos den du testen könntest ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

wannenbraeu
Posting Klettermax
Posting Klettermax
Beiträge: 297
Registriert: Dienstag 9. Oktober 2012, 14:08

Re: iSpindel - Aufbau und Betrieb

#3240

Beitrag von wannenbraeu » Freitag 3. Juli 2020, 18:24

Hallo zusammen

Als ich die Teile bestellt habe, hatte es leider keine TP4056 Lademodule. Ich habe darum das Wemos D1 Battery Shield bestellt. Ich dachte, das passt gut :-)

Nun sieht es aber so aus als wäre das nicht ideal, da dieses Shield eine 5V Step-up Schaltung drauf hat, welche konstant den Akku etwas leert.

Ich habe nun den Schaltplan neu gezeichnet. Kann bitte jemand, der etwas mehr von Elektronik versteht als ich, den kontrollieren und ein Feedback geben?

Danke vielmals und Gruss
Dateianhänge
iSpindel mit Wemos Battery Shield_bb.jpg

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3241

Beitrag von JackFrost » Freitag 3. Juli 2020, 20:25

Der Stepup selber braucht auch Strom, und der Leckstrom der Kondensatoren wird dir die maximale Betriebszeit der iSpindel etwas senken.
Das Wemos D1 Battery Shield hat keinen Unterspannungsschutz. Du kannst also den Akku unter 2,5 V entladen, wenn du keine Zelle mit eigenem
Schutz nimmst. Wenn du die Zelle dann laden willst, kann sie sich aufblöhen oder gar das Brennen anfangen.

Daher lieber einen Laderegeler mit Unterspannungsschutz nehmen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3242

Beitrag von ak59 » Freitag 10. Juli 2020, 16:05

Hallo zusammen,

nachdem ich eine gebrauchte iSpindel aus Zeitknappheit ohne weitere Kalibrierung in mein Gärfass gegeben hatte und der Kurvenverlauf eigentlich recht gut aussah, wollte ich mich mal dranmachen, sie besser zu kalibrieren, um dann auch weitere Werte zu erhalten. Im Leitungswasser zeigte sie etwa 25° an, aber geschätzt und grob nachgemessen waren es eher 45°. Nun steht sie aufrecht auf dem Tisch und zeigt etwa 13° an.

Sehe ich das richtig, daß das nur an dem bereits vorhandenem Poly-dingsbums liegen kann und nur nochmal von Anfang an neu kalibrieren muss? Natürlich ändere ich vorher alle Gewichte so ab, dass ich etwa 25° Abweichung von Senkrechten habe?

Viele Grüße,

Andreas

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3243

Beitrag von JackFrost » Freitag 10. Juli 2020, 17:40

ak59 hat geschrieben:
Freitag 10. Juli 2020, 16:05
Hallo zusammen,

nachdem ich eine gebrauchte iSpindel aus Zeitknappheit ohne weitere Kalibrierung in mein Gärfass gegeben hatte und der Kurvenverlauf eigentlich recht gut aussah, wollte ich mich mal dranmachen, sie besser zu kalibrieren, um dann auch weitere Werte zu erhalten. Im Leitungswasser zeigte sie etwa 25° an, aber geschätzt und grob nachgemessen waren es eher 45°. Nun steht sie aufrecht auf dem Tisch und zeigt etwa 13° an.

Sehe ich das richtig, daß das nur an dem bereits vorhandenem Poly-dingsbums liegen kann und nur nochmal von Anfang an neu kalibrieren muss? Natürlich ändere ich vorher alle Gewichte so ab, dass ich etwa 25° Abweichung von Senkrechten habe?

Viele Grüße,

Andreas
Das Polynom ist nur für die Umrechnung Winkel in Dichte.
Wenn die Spindel bei 0° und 90°nicht annähernd diese Werte ( +/- ein paar Grad ) anzeigt, dann passt was nicht.
Die SPindel sollte aber auf 10s Intervall stehen oder im Config Modus sein, damit die Werte oft gemessen werden und nicht noch
eine falsche Berechnung wegen evtl. Bewegung drinnen ist.
DIe Spindel auch mal für 10 Minuten ausschalten, bei meiner war es mal so das die WInkel nicht mehr gestimmt haben und dann ging es wieder.
Du kannst sie komplett zurücksetzen und damit auch die Kalibrierung des Sensors löschen, sofern diese mal gemacht wurde.
Wenn sie dann wieder nicht die Werte nicht richtig anzeigt dann am besten den Gyro tauschen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3244

Beitrag von ak59 » Freitag 10. Juli 2020, 22:50

Hi,

erstmal danke. Ich hatte mal angefangen eine iSpindel nach Schaltplan zusammenzulöten, noch ohne Spindelsoftware. Ein Arbeitsschritt hatte ich so in Erinnerung, den GY samt Wemos möglichst ruhig liegen zu lassen und dabei Werte auszulesen - hatte nichts mit Dichte zu tun. Am Ende waren die Ergebnisse zurückzuschreiben - das meinte ich.

Anders ausgedrückt: ich kann ja den Sensor für eine andere Anwendung auch schräg einbauen. Dann muss ich aber doch noch festlegen, in welcher Stellung 0° liegen, oder.

Ich seh mir das erstmal an meiner Selbstbauspindel an. Wie gesagt waren die Winkelveränderungen an sich aus meiner Sicht plausibel.

Gruß,

Andreas

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7533
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3245

Beitrag von DerDerDasBierBraut » Freitag 10. Juli 2020, 23:06

Mach dich damit nicht fertig. "Tilt" ist nicht "Grad", sondern der absolute Wert eines berechneten eulerschen Winkels. Bedeutet, dass die Neigungen der X-, Y- und Z-Achse einen Wert zwischen 0 und 90 ergeben. Diese Idealwerte erreicht man nie und das ist auch gar nicht erforderlich für die allgemeine Funktion iSpindel oder die Genauigkeit Messung.
Sorge einfach dafür, dass Tilt in Leitungswasser über 10 liegt und in der Anstellwürze deiner stärksten Platobombe nicht über 80.
In den Grenzbereichen 0-10 und 80-90 ist die Genauigkeit recht grobkörnig.

Damals gab es in der iSpindel Konfiguration mal einen Punkt "Maintenance", in der man "Tilt" bei exakt waagerecht liegendem Schnitten auf 90 setzen konnte. Somit war "Tilt" bei senkrechtem Schlitten annähernd "0".
Ich weiß nicht, ob es diese Option in der aktuellen Firmware noch gibt. Sie war jedenfalls Spielerei und hatte keinerlei positive Effekte auf die Genauigkeit. Wenn die iSpindel schwamm, dann war diese Eichung gleich wieder obsolet, weil durch den Rollwinkel schon wieder Werte größer 0 gemessen wurden. Der Rollwinkel ist bei einer schwimmenden Spindel im wahren Leben nie "0", weil die Trimmgewichte und die horizontale Gewichtsverweilung der Bauteile nie 100% exakt ausbalanciert sind.

Kurz zusammengefasst:
Vergiss das Thema. Es bringt dir keine Vorteile.
Tilt ist KEIN Winkel in Grad. Wenn du beim Bewegen Werte <10 und > 80 erreichst, dann ist alles mehr als perfekt.

PS:
Die iSpindel ist ein unheimlich nützliches und vielseitig nutzbares Schätzeisen.
Versuch nicht ein Messgerät daraus zu bauen. Das kann nicht funktionieren!
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

ak59
Posting Senior
Posting Senior
Beiträge: 344
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3246

Beitrag von ak59 » Samstag 11. Juli 2020, 09:48

Hi,

wenn dort nicht der Winkel angezeigt werden soll, vereinfacht sich das alles auf die grobe Ausrichtung im Leitungswasser und ein paar Messungen. Und daß die anderen Werte nur Näherungen darstellen, war mir klar, aber alleine den Kurvenverlauf sah ich recht hilfreich an, um den Verlauf der Gärung zu beobachten.

Danke,

Andreas

Rockska
Posting Junior
Posting Junior
Beiträge: 30
Registriert: Dienstag 17. Oktober 2017, 07:21

Re: iSpindel - Aufbau und Betrieb

#3247

Beitrag von Rockska » Samstag 11. Juli 2020, 10:13

Ich bekomme meine Spindel einfach nicht ans Laufen... wenn jemand mal danach schauen mag,
ich zahle hin und Rückversand und natürlich was fürs danach schauen. Oder kaufe mir einfach den Tilt :)

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1862
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3248

Beitrag von JackFrost » Samstag 11. Juli 2020, 10:15

Rockska hat geschrieben:
Samstag 11. Juli 2020, 10:13
Ich bekomme meine Spindel einfach nicht ans Laufen... wenn jemand mal danach schauen mag,
ich zahle hin und Rückversand und natürlich was fürs danach schauen. Oder kaufe mir einfach den Tilt :)
Was läuft denn nicht ?
Ich kann sie mir schon anschauen wird aber bisserl dauern.
Wenn du willst, schreib mir eine PN, dann machen wir den Rest aus

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Römergärtenbier
Posting Junior
Posting Junior
Beiträge: 88
Registriert: Freitag 8. April 2016, 06:53
Wohnort: Niedernhausen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#3249

Beitrag von Römergärtenbier » Sonntag 12. Juli 2020, 22:09

Hallo zusammen,

Ich hatte die iSpindel 3 Monate nicht in Betrieb. Nachdem sie heute nun wieder Messwerte an Ubidots funkt, dort aber keine Messreihen gespeichert werden, habe ich das Device bei ubidots gelöscht und auch die Firmware 6.3.1 aufgespielt. Nun bietet mir die Configurationsseite der iSpindel ein Feld "Path / URI" an, bei dem ich nicht weiss, was dort einzutragen ist. Messwerte kommen zwar an, zumindest zeigt ubidots immer aktuelle Messwerte, aber eben keine Messreihen. Selbst ein neuer Token hat keinen Effekt. In der Übersicht der Variablen steht nur 'No Data Available'.

Jetzt weiss ich nicht, ob es an der iSpindel liegt oder an ubidots? Naja, auf jeden Fall bei mir, aber ich weiss nicht, wo ich noch suchen soll.

Ich habe einen ubidots for education account mit aktuell ca. 1800 credits.

Kennt jemand das Problem? Hat jemand einen Tipp? Muss ich, und wenn ja was, in "Path / URI" eintragen? Oder funktioniert Ubidots seit heute nicht?

Schönen Abend!

Jan

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7533
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3250

Beitrag von DerDerDasBierBraut » Sonntag 12. Juli 2020, 22:18

Verstehe ich nicht ganz.
Du siehst unter "Devices" die aktuellen Daten der iSpindel?
Falls ja, richte die Datenquelle in den Dashboard Widgets neu ein. Falls Nein ... Wo siehst du die iSpindeldaten in Ubidots?
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Antworten