Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

Antworten
Ntvfrank
Posting Junior
Posting Junior
Beiträge: 96
Registriert: Mittwoch 24. Dezember 2014, 19:33

Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

#1

Beitrag von Ntvfrank » Samstag 9. Dezember 2017, 21:15

Moin moin,

habe die Edimax SP-1101W WLAN Steckdose in der Brausteuerung von Emilio einwandfrei zum Laufen bekommen, beim Craftbeerpi habe ich allerdings Probleme.

Ich habe in der Version 3.0 das Plugin installiert, allerdings ging obwohl ich die richtige Adresse eingegeben habe gar nichts. Laut Beschreibung sollte man die Adresse wie folgt einstellen:

http://192.168.178.43:5000/smartplug.cgi

es funktionierte aber nicht.

Habe dann ein bisschen im Internet gesucht und mit dieser Einstellung

http://192.168.178.43:10000/smartplug.cgi

lässt sich die Steckdose einschalten, kann sie aber nicht mehr ausschalten.


Habt ihr einen Tipp was ich falsch mache?


Viele Grüße aus Rheinhessen

Ntvfrank
Posting Junior
Posting Junior
Beiträge: 96
Registriert: Mittwoch 24. Dezember 2014, 19:33

Re: Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

#2

Beitrag von Ntvfrank » Dienstag 19. Dezember 2017, 18:11

Moin moin,

Problem gelöst, es gibt ein Patch den man manuell installieren muss und dann geht´s.

Viele Grüße aus Rheinhessen

Frank

Gottfried
Posting Junior
Posting Junior
Beiträge: 23
Registriert: Donnerstag 18. August 2016, 21:33

Re: Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

#3

Beitrag von Gottfried » Mittwoch 20. Dezember 2017, 08:44

Guten Morgen, Hallo Frank.
Wo finde ich den Patch, wie manuell installieren?
Danke für die Hilfe.
MfG Gottfried

kabelbrand
Posting Junior
Posting Junior
Beiträge: 69
Registriert: Donnerstag 6. Oktober 2016, 12:57

Re: Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

#4

Beitrag von kabelbrand » Donnerstag 1. Februar 2018, 13:36

Hallo zusammen,

auch ich stehe gerade vor dem Problem der sich nicht mehr abschaltenden Steckdose.

@Frank Wäre prima, wenn du dein Wissen hier teilen könntest:) Ich suche zwar auch nach der Lösung,
bisher aber ohne Erfolg.

Grüße,
Markus

Ntvfrank
Posting Junior
Posting Junior
Beiträge: 96
Registriert: Mittwoch 24. Dezember 2014, 19:33

Re: Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

#5

Beitrag von Ntvfrank » Donnerstag 1. Februar 2018, 19:49

Hallo Markus,

Du must mal im Sourcefile auf Github schauen, da gibt es ein Subdirectory mit einem Patch. Im originalen Code wurde für das Ausschalten auch der Einschaltbefehl benutzt, im Patch ist das richtig dargestellt.

Viele Grüße

Frank

kabelbrand
Posting Junior
Posting Junior
Beiträge: 69
Registriert: Donnerstag 6. Oktober 2016, 12:57

Re: Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

#6

Beitrag von kabelbrand » Freitag 2. Februar 2018, 11:09

Hallo zusammen,

ich habe hoffentlich den Fehler gefunden, Test steht noch aus.

Es gibt übrigens kein Patchfile, man muss die Änderung direkt in der Datei vornehmen.

In der Datei __init__.py steckt der Fehler in den letzten Zeilen:

def on(self, power=100):
self.send(self.onCommand)

def off(self):
self.send(self.onCommand)


Dort müsste meiner Meinung nach in der letzten Zeile self.send(self.offCommand) stehen. Ich habe das bei mir korrigiert,
kann aber erst heute Abend nach Feierabend testen. Warum das auf Github noch nicht gefixt wurde, sofern es tatsächlich
die Lösung ist, verstehe ich nicht.

Ich werde berichten und ggf. weiter nach der Lösung suchen.

Grüße,
Markus

kabelbrand
Posting Junior
Posting Junior
Beiträge: 69
Registriert: Donnerstag 6. Oktober 2016, 12:57

Re: Edimax SP-1101 W Craftbeerpi3 schaltet nicht aus

#7

Beitrag von kabelbrand » Freitag 2. Februar 2018, 17:43

OK, gerade eben frisch getestet, obiger Lösungsansatz ist korrekt und funktioniert. Die Steckdose schaltet wieder ein und aus:)

Grüße,
Markus

Antworten