Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

Antworten
Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#1

Beitrag von Fahrtwind » Montag 18. November 2019, 09:47

Hallo,
nachdem ich mich hier von den Brausteuerungen ausreichend habe inspirieren lassen, bin ich es angegangen und baue gerade meine Steuerung um. Seit 7 Jahren tut die Siemens Logo ihren Dienst. Link ins alte Forum: https://hobbybrauer.de/modules.php?name ... &tid=12878
Aus diversen Gründen habe ich mich entschieden die Steuerung zu überarbeiten. Leider konnte ich keine Platine über den Entwickler beziehen...Ein Sack Platinen in China waren für wenige Euro bestellt und schnell gelötet. Zeitgleich habe ich mich mit der Einrichtung von CBP 3 beschäftigt und an meine Hardware angepasst und Über mehrere Prototypen ein Gehäuse gezeichnet. Am Wochenende sind dann meine finalen Gehäuseteile aus dem Drucker gefallen:
IMG_4845.JPG
IMG_4847.JPG
IMG_4848.JPG
IMG_4849.JPG
Ich trenne den Controller von dem Schaltkasten, der 220V Teil ist damit separat. Verbunden wird mit einem 9 poligen Steuerungskabel mit Sub-D Stecker/Buchse. Oldschool...Der Status der Ausgänge wird über versteckte LEDs angezeigt.

Als nächstes kommt dann der Umbau des Schaltkastens. Vergangenen Freitag habe ich ausserdem ein neues Setup zum Läutern getestet (Läuterspirale vs. Lochblech direkt im Maischekessel) sowie einen Siphon mit Schnüffelrohr. Der muss noch angepasst werden, funktioniert aber prinzipiell...
IMG_8603.jpg
An dieser Stelle schon mal Danke für all die Arbeit die in das Projekt CBP geflossen ist!

Grüße
Manuel

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#2

Beitrag von Fahrtwind » Dienstag 19. November 2019, 07:41

Die Scroll Bars habe ich erfolgreich entfernen können. Kann mir vielleicht jemand mit einem helleren Theme behilflich sein? Vermutlich muss ich dafür /modules/ui/static/bootstrap.dark.css austauschen!? Da ich per PN nach Bezugsquellen für die erforderlichen Teile gefragt wurde: ich poste später mal eine BOM für das Gehäuse...

Grüße
Manuel

Citrist
HBCon Supporter
HBCon Supporter
Beiträge: 113
Registriert: Sonntag 29. Oktober 2017, 21:36
Wohnort: Aargau (CH), Rombach und Frankfurt

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#3

Beitrag von Citrist » Dienstag 19. November 2019, 14:11

Schicke Kiste haste Dir da gebastelt! Gefällt mir gut.
Helen kann ich Dir bei Deiner Frage leider nicht.
Dafür steht Dein Beitrag wieder oben :)
Griezi us dr Schwoiz.
Citrist
---
Mein (Jura)Wasser: https://tinyurl.com/yduv8yvr

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#4

Beitrag von Fahrtwind » Dienstag 28. April 2020, 10:43

Endlich verbaut, der finale Test steht noch aus...
IMG_5679.jpeg
IMG_5680.jpeg
Der Hochspannungs-Teil ist abgetrennt. Kann mir jemand einen Tip geben, wie das Rührwerk Drehzahl regle? Der Scheibenwischermotor will nicht so richtig mit meinem DC SSR zusammenarbeiten (PWM)

Grüße
Manuel

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1272
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#5

Beitrag von JackFrost » Dienstag 28. April 2020, 11:17

Was macht es denn nicht mit den DC SSR ?
Freilaufdiode vorhanden ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#6

Beitrag von Fahrtwind » Dienstag 28. April 2020, 11:21

Das könnte schon die Lösung sein

Wenn ich mit der PWM rumspiele, sehe ich dass Kontroll LED die Parallel am Ausgang zum SSR hängt gedimmt wird, auch messe ich das Spannungen kleiner 12V. Allerdings ist am SSR Ausgang eigentlich immer die volle Spannung Messbar, auch bei 10% PWM. Wenn ich in der Frequenz runter gehe, fängt der Motor nur an zu stottern...welche PWM Frequenz stellt man ein?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1272
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#7

Beitrag von JackFrost » Dienstag 28. April 2020, 11:30

Du brauchst eine sehr schnelle Diode, am besten direkt am Motor.
Den vollen Strom muss sie auch abkönnen.
Ich kann dir heute Abend mal einen Typ nennen, wenn du mir den Strom vom Motor schreibst.
Die Frequenz musst du ausprobieren.
1 kHz mal zum testen. Und dann raufgehenden wenn es zu sehr
quietscht.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
secuspec
HBCon Supporter
HBCon Supporter
Beiträge: 437
Registriert: Sonntag 9. Juli 2017, 06:31
Wohnort: Königstein
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#8

Beitrag von secuspec » Dienstag 28. April 2020, 12:14

Fahrtwind hat geschrieben:
Dienstag 19. November 2019, 07:41
Die Scroll Bars habe ich erfolgreich entfernen können. Kann mir vielleicht jemand mit einem helleren Theme behilflich sein? Vermutlich muss ich dafür /modules/ui/static/bootstrap.dark.css austauschen!? Da ich per PN nach Bezugsquellen für die erforderlichen Teile gefragt wurde: ich poste später mal eine BOM für das Gehäuse...

Grüße
Manuel
Hi Manuel,

ja, ist sehr einfach.

Du kannst Dich dabei einiger Online Bootstrap Konfigurationen bedienen. Dort die gewünschten Vorlagen direkt laden und austauschen, oder eben anpassen, erstellen lassen und dann an Deine eigenen Wünsche anpassen.

Ich bin auch auf ein helleres Design gewechselt.

Viele Grüße,
Steffen
Sudhaus auf Basis Brewpaganda 80l Töpfe,GGM Gastro Platte (Maischen),Ultra Low Power 8kW Heizelement (Kochen), 3,5kW Element für Nachguss. Gesteuert über CraftBeerPi.

HBST Rhein Main & Brausportgruppe e.V.
Bild

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1272
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#9

Beitrag von JackFrost » Dienstag 28. April 2020, 18:57

So eine Diode ist schnell genug für PWM und kann 8A.
Während der Off-Zeit der PWM fließt der Strom immer über die Diode. Daher muss du mindestens den Strom des Motors können.

Zudem wirst du sie kühlen müssen. Die hat eine Flussspannung von 1,25V macht bei 8 A also 10 W.

Ich denke ich bestelle bald wieder bei Mouser, da kann ich dir so eine mitbestellen wenn du möchtest, dann hast du als Versandkosten nur das
Briefporto zu dir.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#10

Beitrag von Fahrtwind » Dienstag 28. April 2020, 22:53

Großartig! Das Angebot nehme ich gerne an! Rest per PN?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1272
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#11

Beitrag von JackFrost » Dienstag 28. April 2020, 23:02

Fahrtwind hat geschrieben:
Dienstag 28. April 2020, 22:53
Großartig! Das Angebot nehme ich gerne an! Rest per PN?
Ja ist am einfachsten.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Stolbee
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Dienstag 14. April 2020, 18:49

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#12

Beitrag von Stolbee » Freitag 1. Mai 2020, 10:23

Hi sieht toll aus:)
ich suche einen Stromverteilerkasten und finde nichts nach meinem Geschmack. Deiner sieht gut aus. Darf ich nach Marke und Typ fragen?

Danke und Grüsse Tobias

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#13

Beitrag von Fahrtwind » Freitag 1. Mai 2020, 22:08

Hallo Tobias,
sorry, das kann ich absolut nicht mehr nachvollziehen! Ist halt schon 7 Jahre her, auf der Box steht nichts drauf...
Derweil habe ich etwas mit Bootsrap experimentiert. Ich bekomme es nicht hin. Wenn ich die Dateien bootsrap.dark.css oder bottstrap.min.css austausche, habe ich zwar ein neues Farbschema, jedoch wird die Formatierung komplett geändert...
Immerhin habe ich es geschafft die Original so zu modifizieren, dass ich eine helles Hintergrundbild verwenden konnte...

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#14

Beitrag von Fahrtwind » Samstag 2. Mai 2020, 15:59

Ok, ich habe mal einen kleinen Experimentiernachmittag eingelegt und bin der PWM Problematik auf die Schliche gekommen. Wenn die PWM Frequenz zu hoch ist, ist das SSR auch bei niedrigen PWM Anteilen "ganz auf". Bei 100Hz kann ich mit der Steuerung des Motors gut leben und er läuft rund. ABER. Es scheint einen Softwarebug zu geben. Wenn ich die PWM Frequenz einstelle, wird diese für das nächste mal Aktor einschalten verwendet. Schalte ich den Aktor einmal kurz aus und wieder an, wird ungeachtet des Werts unter "PWM Frequenz" eine Standard Frequenz verwendet die für mein SSR zu hoch ist. Einmal auf der Hardwareseite unter dem Aktor auf "update" geklickt, dann klappt es wieder ... merkwürdig...

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1272
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#15

Beitrag von JackFrost » Samstag 2. Mai 2020, 16:14

Fahrtwind hat geschrieben:
Samstag 2. Mai 2020, 15:59
Ok, ich habe mal einen kleinen Experimentiernachmittag eingelegt und bin der PWM Problematik auf die Schliche gekommen. Wenn die PWM Frequenz zu hoch ist, ist das SSR auch bei niedrigen PWM Anteilen "ganz auf". Bei 100Hz kann ich mit der Steuerung des Motors gut leben und er läuft rund. ABER. Es scheint einen Softwarebug zu geben. Wenn ich die PWM Frequenz einstelle, wird diese für das nächste mal Aktor einschalten verwendet. Schalte ich den Aktor einmal kurz aus und wieder an, wird ungeachtet des Werts unter "PWM Frequenz" eine Standard Frequenz verwendet die für mein SSR zu hoch ist. Einmal auf der Hardwareseite unter dem Aktor auf "update" geklickt, dann klappt es wieder ... merkwürdig...
Sonst kannst du es ja mal mit einer MosFET Platine mit Treiber drauf, die es bei ebay oder Amazon gibt probieren.
Wie ist der Typ von dem SSR ? Ggf braucht das einfach zu lange um zu Schalten.
Wieviel strom zieht dein Motor ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 104
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#16

Beitrag von Fahrtwind » Samstag 2. Mai 2020, 16:18

Der Motor braucht "in Luft" etwa 1,5A, in der Maische wird es sicher mehr sein - schlecht zu simulieren...an eine MOSFET Schaltung habe ich auch schon gedacht, werde mir mal eine ordern - ist vermutlich das Einfachste...
Fotek SSR-100-DD

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1272
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#17

Beitrag von JackFrost » Samstag 2. Mai 2020, 17:01

Fahrtwind hat geschrieben:
Samstag 2. Mai 2020, 16:18
Der Motor braucht "in Luft" etwa 1,5A, in der Maische wird es sicher mehr sein - schlecht zu simulieren...an eine MOSFET Schaltung habe ich auch schon gedacht, werde mir mal eine ordern - ist vermutlich das Einfachste...
Fotek SSR-100-DD
Das SSR braucht schon 1 ms um zu reagieren, da wird eine MosFET Schaltung einfacher sein. Braucht evtl eine Treiberschaltung das es schnell schaltet und dann GND schalten, da P-MosFETs mehr verlust haben und etwas schwieriger zu schalten sind.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1272
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#18

Beitrag von JackFrost » Samstag 2. Mai 2020, 17:18

Ich würd keine IRF520 nehmen, der ist erst ab 5V am Gate spezifiziert.

Den würd ich nehmen.Der hat bei 3,3V am Gate schon 0,036 RDSon. Damit ist der Verlust am MosFET bei 0,35W bei 3A. Da brauchst du keine Kühlung.
Zusammen mit einer Freilaufdiode ist dann alles easy. Der kann auch direkt vom Raspi gesteuert werden. Schaltzeiten hab ich aber noch nicht berechnet.

Wenn du hilfe bei der Platine brauchst, schreib mir eine PN

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Antworten