Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

Antworten
Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#1

Beitrag von Fahrtwind » Montag 18. November 2019, 09:47

Hallo,
nachdem ich mich hier von den Brausteuerungen ausreichend habe inspirieren lassen, bin ich es angegangen und baue gerade meine Steuerung um. Seit 7 Jahren tut die Siemens Logo ihren Dienst. Link ins alte Forum: https://hobbybrauer.de/modules.php?name ... &tid=12878
Aus diversen Gründen habe ich mich entschieden die Steuerung zu überarbeiten. Leider konnte ich keine Platine über den Entwickler beziehen...Ein Sack Platinen in China waren für wenige Euro bestellt und schnell gelötet. Zeitgleich habe ich mich mit der Einrichtung von CBP 3 beschäftigt und an meine Hardware angepasst und Über mehrere Prototypen ein Gehäuse gezeichnet. Am Wochenende sind dann meine finalen Gehäuseteile aus dem Drucker gefallen:
IMG_4845.JPG
IMG_4847.JPG
IMG_4848.JPG
IMG_4849.JPG
Ich trenne den Controller von dem Schaltkasten, der 220V Teil ist damit separat. Verbunden wird mit einem 9 poligen Steuerungskabel mit Sub-D Stecker/Buchse. Oldschool...Der Status der Ausgänge wird über versteckte LEDs angezeigt.

Als nächstes kommt dann der Umbau des Schaltkastens. Vergangenen Freitag habe ich ausserdem ein neues Setup zum Läutern getestet (Läuterspirale vs. Lochblech direkt im Maischekessel) sowie einen Siphon mit Schnüffelrohr. Der muss noch angepasst werden, funktioniert aber prinzipiell...
IMG_8603.jpg
An dieser Stelle schon mal Danke für all die Arbeit die in das Projekt CBP geflossen ist!

Grüße
Manuel

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#2

Beitrag von Fahrtwind » Dienstag 19. November 2019, 07:41

Die Scroll Bars habe ich erfolgreich entfernen können. Kann mir vielleicht jemand mit einem helleren Theme behilflich sein? Vermutlich muss ich dafür /modules/ui/static/bootstrap.dark.css austauschen!? Da ich per PN nach Bezugsquellen für die erforderlichen Teile gefragt wurde: ich poste später mal eine BOM für das Gehäuse...

Grüße
Manuel

Citrist
HBCon Supporter
HBCon Supporter
Beiträge: 136
Registriert: Sonntag 29. Oktober 2017, 21:36
Wohnort: Aargau (CH), Rombach und Frankfurt

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#3

Beitrag von Citrist » Dienstag 19. November 2019, 14:11

Schicke Kiste haste Dir da gebastelt! Gefällt mir gut.
Helen kann ich Dir bei Deiner Frage leider nicht.
Dafür steht Dein Beitrag wieder oben :)
Griezi us dr Schwoiz.
Citrist
---
Mein (Jura)Wasser: https://tinyurl.com/yduv8yvr

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#4

Beitrag von Fahrtwind » Dienstag 28. April 2020, 10:43

Endlich verbaut, der finale Test steht noch aus...
IMG_5679.jpeg
IMG_5680.jpeg
Der Hochspannungs-Teil ist abgetrennt. Kann mir jemand einen Tip geben, wie das Rührwerk Drehzahl regle? Der Scheibenwischermotor will nicht so richtig mit meinem DC SSR zusammenarbeiten (PWM)

Grüße
Manuel

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#5

Beitrag von JackFrost » Dienstag 28. April 2020, 11:17

Was macht es denn nicht mit den DC SSR ?
Freilaufdiode vorhanden ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#6

Beitrag von Fahrtwind » Dienstag 28. April 2020, 11:21

Das könnte schon die Lösung sein

Wenn ich mit der PWM rumspiele, sehe ich dass Kontroll LED die Parallel am Ausgang zum SSR hängt gedimmt wird, auch messe ich das Spannungen kleiner 12V. Allerdings ist am SSR Ausgang eigentlich immer die volle Spannung Messbar, auch bei 10% PWM. Wenn ich in der Frequenz runter gehe, fängt der Motor nur an zu stottern...welche PWM Frequenz stellt man ein?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#7

Beitrag von JackFrost » Dienstag 28. April 2020, 11:30

Du brauchst eine sehr schnelle Diode, am besten direkt am Motor.
Den vollen Strom muss sie auch abkönnen.
Ich kann dir heute Abend mal einen Typ nennen, wenn du mir den Strom vom Motor schreibst.
Die Frequenz musst du ausprobieren.
1 kHz mal zum testen. Und dann raufgehenden wenn es zu sehr
quietscht.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
secuspec
HBCon Supporter
HBCon Supporter
Beiträge: 631
Registriert: Sonntag 9. Juli 2017, 06:31
Wohnort: Königstein
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#8

Beitrag von secuspec » Dienstag 28. April 2020, 12:14

Fahrtwind hat geschrieben:
Dienstag 19. November 2019, 07:41
Die Scroll Bars habe ich erfolgreich entfernen können. Kann mir vielleicht jemand mit einem helleren Theme behilflich sein? Vermutlich muss ich dafür /modules/ui/static/bootstrap.dark.css austauschen!? Da ich per PN nach Bezugsquellen für die erforderlichen Teile gefragt wurde: ich poste später mal eine BOM für das Gehäuse...

Grüße
Manuel
Hi Manuel,

ja, ist sehr einfach.

Du kannst Dich dabei einiger Online Bootstrap Konfigurationen bedienen. Dort die gewünschten Vorlagen direkt laden und austauschen, oder eben anpassen, erstellen lassen und dann an Deine eigenen Wünsche anpassen.

Ich bin auch auf ein helleres Design gewechselt.

Viele Grüße,
Steffen
Sudhaus aus Brewpaganda 80l Töpfen,IDS2 Platte (Maischen),ULP 8kW Heizelement (Kochen), 3,5kW Element für Nachguss.
Gesteuert mit BREWBLOX (https://brewblox.netlify.app).

HBST Rhein Main & Brausportgruppe e.V.
Bild

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#9

Beitrag von JackFrost » Dienstag 28. April 2020, 18:57

So eine Diode ist schnell genug für PWM und kann 8A.
Während der Off-Zeit der PWM fließt der Strom immer über die Diode. Daher muss du mindestens den Strom des Motors können.

Zudem wirst du sie kühlen müssen. Die hat eine Flussspannung von 1,25V macht bei 8 A also 10 W.

Ich denke ich bestelle bald wieder bei Mouser, da kann ich dir so eine mitbestellen wenn du möchtest, dann hast du als Versandkosten nur das
Briefporto zu dir.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#10

Beitrag von Fahrtwind » Dienstag 28. April 2020, 22:53

Großartig! Das Angebot nehme ich gerne an! Rest per PN?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#11

Beitrag von JackFrost » Dienstag 28. April 2020, 23:02

Fahrtwind hat geschrieben:
Dienstag 28. April 2020, 22:53
Großartig! Das Angebot nehme ich gerne an! Rest per PN?
Ja ist am einfachsten.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Stolbee
Posting Junior
Posting Junior
Beiträge: 21
Registriert: Dienstag 14. April 2020, 18:49

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#12

Beitrag von Stolbee » Freitag 1. Mai 2020, 10:23

Hi sieht toll aus:)
ich suche einen Stromverteilerkasten und finde nichts nach meinem Geschmack. Deiner sieht gut aus. Darf ich nach Marke und Typ fragen?

Danke und Grüsse Tobias

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#13

Beitrag von Fahrtwind » Freitag 1. Mai 2020, 22:08

Hallo Tobias,
sorry, das kann ich absolut nicht mehr nachvollziehen! Ist halt schon 7 Jahre her, auf der Box steht nichts drauf...
Derweil habe ich etwas mit Bootsrap experimentiert. Ich bekomme es nicht hin. Wenn ich die Dateien bootsrap.dark.css oder bottstrap.min.css austausche, habe ich zwar ein neues Farbschema, jedoch wird die Formatierung komplett geändert...
Immerhin habe ich es geschafft die Original so zu modifizieren, dass ich eine helles Hintergrundbild verwenden konnte...

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#14

Beitrag von Fahrtwind » Samstag 2. Mai 2020, 15:59

Ok, ich habe mal einen kleinen Experimentiernachmittag eingelegt und bin der PWM Problematik auf die Schliche gekommen. Wenn die PWM Frequenz zu hoch ist, ist das SSR auch bei niedrigen PWM Anteilen "ganz auf". Bei 100Hz kann ich mit der Steuerung des Motors gut leben und er läuft rund. ABER. Es scheint einen Softwarebug zu geben. Wenn ich die PWM Frequenz einstelle, wird diese für das nächste mal Aktor einschalten verwendet. Schalte ich den Aktor einmal kurz aus und wieder an, wird ungeachtet des Werts unter "PWM Frequenz" eine Standard Frequenz verwendet die für mein SSR zu hoch ist. Einmal auf der Hardwareseite unter dem Aktor auf "update" geklickt, dann klappt es wieder ... merkwürdig...

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#15

Beitrag von JackFrost » Samstag 2. Mai 2020, 16:14

Fahrtwind hat geschrieben:
Samstag 2. Mai 2020, 15:59
Ok, ich habe mal einen kleinen Experimentiernachmittag eingelegt und bin der PWM Problematik auf die Schliche gekommen. Wenn die PWM Frequenz zu hoch ist, ist das SSR auch bei niedrigen PWM Anteilen "ganz auf". Bei 100Hz kann ich mit der Steuerung des Motors gut leben und er läuft rund. ABER. Es scheint einen Softwarebug zu geben. Wenn ich die PWM Frequenz einstelle, wird diese für das nächste mal Aktor einschalten verwendet. Schalte ich den Aktor einmal kurz aus und wieder an, wird ungeachtet des Werts unter "PWM Frequenz" eine Standard Frequenz verwendet die für mein SSR zu hoch ist. Einmal auf der Hardwareseite unter dem Aktor auf "update" geklickt, dann klappt es wieder ... merkwürdig...
Sonst kannst du es ja mal mit einer MosFET Platine mit Treiber drauf, die es bei ebay oder Amazon gibt probieren.
Wie ist der Typ von dem SSR ? Ggf braucht das einfach zu lange um zu Schalten.
Wieviel strom zieht dein Motor ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#16

Beitrag von Fahrtwind » Samstag 2. Mai 2020, 16:18

Der Motor braucht "in Luft" etwa 1,5A, in der Maische wird es sicher mehr sein - schlecht zu simulieren...an eine MOSFET Schaltung habe ich auch schon gedacht, werde mir mal eine ordern - ist vermutlich das Einfachste...
Fotek SSR-100-DD

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#17

Beitrag von JackFrost » Samstag 2. Mai 2020, 17:01

Fahrtwind hat geschrieben:
Samstag 2. Mai 2020, 16:18
Der Motor braucht "in Luft" etwa 1,5A, in der Maische wird es sicher mehr sein - schlecht zu simulieren...an eine MOSFET Schaltung habe ich auch schon gedacht, werde mir mal eine ordern - ist vermutlich das Einfachste...
Fotek SSR-100-DD
Das SSR braucht schon 1 ms um zu reagieren, da wird eine MosFET Schaltung einfacher sein. Braucht evtl eine Treiberschaltung das es schnell schaltet und dann GND schalten, da P-MosFETs mehr verlust haben und etwas schwieriger zu schalten sind.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#18

Beitrag von JackFrost » Samstag 2. Mai 2020, 17:18

Ich würd keine IRF520 nehmen, der ist erst ab 5V am Gate spezifiziert.

Den würd ich nehmen.Der hat bei 3,3V am Gate schon 0,036 RDSon. Damit ist der Verlust am MosFET bei 0,35W bei 3A. Da brauchst du keine Kühlung.
Zusammen mit einer Freilaufdiode ist dann alles easy. Der kann auch direkt vom Raspi gesteuert werden. Schaltzeiten hab ich aber noch nicht berechnet.

Wenn du hilfe bei der Platine brauchst, schreib mir eine PN

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#19

Beitrag von Fahrtwind » Donnerstag 17. September 2020, 11:49

Hallo zusammen,
ich habe lange nichts mehr von mir hören lassen. Leider habe ich keine guten Neuigkeiten: ein paar GPIO Pins des RPi habe das zeitliche gesegnet. Ich hatte bei dem DS18B20 Sensoren von Beginn an Probleme. Manche wurden nicht erkannt, einige wurden plötzlich im Betrieb warm(!), 40-50°C obwohl sie vorher über Stunden funktioniert haben. Auch eine erfolgreichen Brautag konnte ich endlich mal durchführen.
Erschreckt war ich dann über die vielen negativen Rezensionen meines Fühler Sparpacks von Amazon. Die Leute hatten dort teils die gleiche Problematik! Ich habe mir drei qualitäts Sensoren geordert und hoffe, dass sich damit das Problem erledigt hat.

Nun ein paar Fragen:
- hat schon mal jmd von Euch diese Problematik gehabt
- einen defekten Ausgang habe ich bereits erfolgreich umverdrahtet (GPIO 5->17). Wie sieht es mit dem standard Eingang GPIO 4 aus? Pullup ist klar, in der Config.txt dtoverlay auf den neuen Port ist auch klar. Aber wo kann ich den Standard GPIO für die Temperaturmessung in CBP einstellen?

Danke und Grüße

Manuel

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#20

Beitrag von JackFrost » Donnerstag 17. September 2020, 12:44

Ich musste mal einen tauschen der hatte im Betrieb 74‘C.
Das war auch kein originaler, konnte man an der ID erkennen.
Wenn die letzten zwei Bytes von der Adresse vor der CRC nicht 0x00 ( zz xx xx xx xx 0x00 0x00 yy ) sind ist es kein originaler.

Wenn sie billiger sind als der Stückpreis bei Abnahmen einer vollen 500er Rolle vom Authorisierten Händler sind es meist keine originalen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Innuendo
Posting Freak
Posting Freak
Beiträge: 745
Registriert: Freitag 2. März 2018, 09:43
Wohnort: Oberbergischer Kreis

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#21

Beitrag von Innuendo » Freitag 18. September 2020, 05:36

Ich hatte mit den günstigen DS18B20 von amazon auch Probleme:
- 100°C lassen den Kleber / Silikone in der Hülse aufweichen. Irgendwann kommt dann der DS18B20 Sensor aus der Hülse raus
- einige Sensoren meldeten immer wieder im laufenden Prozess die Standard Reset Temperatur 85°C
- unregelmäßig kam auch mal -127°C, also keine Temperatur
An CRC Fehler kann ich mich nicht erinnern. Hier kann auch eine Kabellänge über 3m Ursache sein.
Seit knapp 2 Jahren verwende ich etwas teurere DS18B20 von sensorshop24 und bin die Problemchen los. Meine Sensoren und Aktoren sind nicht direkt am CBPi angeschlossen.

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#22

Beitrag von Fahrtwind » Freitag 18. September 2020, 06:47

Danke für die Antworten. Genau da habe ich gestern auch bestellt. Ich habe mir fünf CBP Platinen in China machen lassen und selbst bestückt.
B9C6EFC6-2A92-413A-A2FD-D728F68AEF11.jpeg
3C41E36A-478F-444C-B15F-CDC3FAEC5B48.jpeg
Eigentlich kann man da nicht wirklich viel falsch machen - auch nicht wenn man sonst mit Elektronik wenig am Hut hat. Die Farben des Sensorkabels sind ja nun eindeutig. Und funktioniert hat es ja ursprünglich...
Der neue Pi kommt heute an. Meinen Brautag morgen kann ich wohl knicken - die Sensoren kommen frühestens am Montag...
Ich möchte die gerne steckbar machen. Hat jemand nen Tip für eine ordentliche Stecker/Buchse Kombination? Muss nicht wasserdicht sein (3 polig)
Als Alternative hatte ich schon über PT100 mit Amplifier nachgedacht. Ist aber der letzte Ausweg. Der Verkabelungsaufwand steigt halt...

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#23

Beitrag von JackFrost » Freitag 18. September 2020, 09:41

Hast du den DS18B20 direkt am Spannungswanderl angelötet oder ist das ein anderes Kabel ?

Was für eine Last hattest du an den GPIOs die defekt sind ? Kleine Lüfter oder Magnetventile ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#24

Beitrag von Fahrtwind » Freitag 18. September 2020, 09:48

Das ist ein zweiter Spannungswandler, hängt parallel zu dem aufgelöteten auf dem Board an 12V und versorgt ausschließlich das Touch-Screen. Die 5V greife ich direkt an der vorgesehenen Klemme ab, Anschlüsse rechts im Bild. Da sind zwei Leitungen: Data und 5V. GND kommt direkt von der 12V Quelle im Steuerungskasten. Die selbe Quelle speist auch die Platine.
Kaputt sind definitiv der GPIO 4 und 5. 4 ist der Eingang, an 5 hängt ein mechanisches Lastschütz für den NG Heizer. An einem zweiten Schütz habe ich die Hendi hängen

Benutzeravatar
Innuendo
Posting Freak
Posting Freak
Beiträge: 745
Registriert: Freitag 2. März 2018, 09:43
Wohnort: Oberbergischer Kreis

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#25

Beitrag von Innuendo » Freitag 18. September 2020, 10:40

Ich habe meine DS18B20 über XLR Stecker-Buchse angebunden. Schau dir mal das MQTTDevice an, vielleicht findest Du da noch Ideen. Die kleinen Gehäuse sind in unmittelbarer Nähe vom Kessel bzw Nachgus etc. untergebracht. Die Kabellänge der Sensoren sind entsprechend alle ziemlich kurz. Auf der kleinen Platine sind die DS18B20 an D3 angeschlossen. D3 ist über 4k7 auf VCC gezogen.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#26

Beitrag von JackFrost » Freitag 18. September 2020, 11:26

Fahrtwind hat geschrieben:
Freitag 18. September 2020, 09:48
Das ist ein zweiter Spannungswandler, hängt parallel zu dem aufgelöteten auf dem Board an 12V und versorgt ausschließlich das Touch-Screen. Die 5V greife ich direkt an der vorgesehenen Klemme ab, Anschlüsse rechts im Bild. Da sind zwei Leitungen: Data und 5V. GND kommt direkt von der 12V Quelle im Steuerungskasten. Die selbe Quelle speist auch die Platine.
Kaputt sind definitiv der GPIO 4 und 5. 4 ist der Eingang, an 5 hängt ein mechanisches Lastschütz für den NG Heizer. An einem zweiten Schütz habe ich die Hendi hängen
Hat der BC337 überlebt ? Wenn der auch kaputt ist , dann ist es vermutlich die Diode. Eine schnellere hilft da. Die 1N400x sind als Feilaudioden zu langsam.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#27

Beitrag von Fahrtwind » Freitag 18. September 2020, 11:33

Dann ist das Design/Bestückung der CBP Platine ja Käse. Das Schalten von Relais ist doch eine der Hauptanwendungen? Den BC337 werde ich wohl am einfachsten mit dem neuen Pi testen können...ich denke der kommt noch heute...
Ich sehe die Ursache für den Defekten GPIO an den warm werdenden Fühler. Zu dem Zeitpunkt fanden auch keine Schaltvorgänge an den Relais statt

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#28

Beitrag von JackFrost » Freitag 18. September 2020, 11:57

Fahrtwind hat geschrieben:
Freitag 18. September 2020, 11:33
Dann ist das Design/Bestückung der CBP Platine ja Käse. Das Schalten von Relais ist doch eine der Hauptanwendungen? Den BC337 werde ich wohl am einfachsten mit dem neuen Pi testen können...ich denke der kommt noch heute...
Ich sehe die Ursache für den Defekten GPIO an den warm werdenden Fühler. Zu dem Zeitpunkt fanden auch keine Schaltvorgänge an den Relais statt
Es muss nicht sein, aber die 1N400x sind Gleichrichter Dioden für 50Hz. Die 1N4148 ist besser aber nur wenn der maximale Strom nicht überschritten wird.

Es gibt auch Relais und Schütze mit integrietem Schutz.

Das der GPIO5 kaputt geht wenn der 4er zu viel Strom bekommt ist nicht sehr wahrscheinlich.

Der 4er kann am DS18B20 liegen oder Einstreuung.
Wenn der DS18B20 so kaputt ist das er Spannung auf den GPIO gibt dann geht der kaputt. Wenn er nur Zu warm wird und der DQ ein Open Collector bleibt, dann geht das nicht.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#29

Beitrag von Fahrtwind » Freitag 18. September 2020, 12:15

Kann ich zusätzlich diese Dioden direkt an den Eingang der Schütze anbringen? Oder muss ich die auf der Platine unterbrechen? Möchte da ungerne drauf rum löten...
Kathode Richtung plus? Danke!

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#30

Beitrag von JackFrost » Freitag 18. September 2020, 14:10

Der BC337 darf bis 45 VCEO wenn die Diode zu langsam ist , dann kann dieser Wert überschritten werden.

Eine bidirektionale TVS Diode direkt mit in die Anschlüsse geklemmt schützt den Transistor. 24 V sollten da reichen. Ich kann aber gerade den Typ nicht raussuchen.
Bei der Bidirektionalen TVS Diode ist die Polung egal.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#31

Beitrag von Fahrtwind » Samstag 19. September 2020, 14:32

Also, ich habe gestern den neuen Pi verbaut - es läuft wieder alles. Transistor ist in Ordnung. Nun warte ich auf die guten Fühler. Irgendwie ist man ja manchmal etwas blöd. Als Last für die Schütze im angezogenen Zustand habe ich 30mA gemessen. Das sollte den Transistor vor keine Probleme stellen. Die SSRs für den Motor und 12V Pumpe werden nicht mehr verbrauchen. Ich schiebe jetzt alles auf die Fühler. Nächste Woche werde ich es wissen. Ich habe übrigens jetzt noch einen Leistungsregler für das Rührwerk zwischen SSR und Motor.
Bild von iOS.jpg
Den verbaue ich direkt am Gehäuse des Motors. Ist für mich auch angenehmer als mit einem Schieber auf dem Touchscreen zu fummeln...

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#32

Beitrag von JackFrost » Samstag 19. September 2020, 23:14

Fahrtwind hat geschrieben:
Samstag 19. September 2020, 14:32
Also, ich habe gestern den neuen Pi verbaut - es läuft wieder alles. Transistor ist in Ordnung. Nun warte ich auf die guten Fühler. Irgendwie ist man ja manchmal etwas blöd. Als Last für die Schütze im angezogenen Zustand habe ich 30mA gemessen. Das sollte den Transistor vor keine Probleme stellen. Die SSRs für den Motor und 12V Pumpe werden nicht mehr verbrauchen. Ich schiebe jetzt alles auf die Fühler. Nächste Woche werde ich es wissen. Ich habe übrigens jetzt noch einen Leistungsregler für das Rührwerk zwischen SSR und Motor.
Bild von iOS.jpg
Den verbaue ich direkt am Gehäuse des Motors. Ist für mich auch angenehmer als mit einem Schieber auf dem Touchscreen zu fummeln...
Der Strom ist nicht das Problem, wichtig ist das die Freilaufdiode schnell genug ist, die Induktionspannung schnell genug "abzubauen". Damit sie die unter den 45 V bleibt die der Transistor maximal kann bis er durchbricht.
Eine 1N4007 kann reichen, es kann aber sein, das eine schneller Diode besser wäre. Für kleine Relais nimmt man gerne die 1N4148 die kann aber nur 125 mA.
Für PWM > 10 kHz induktiver Lasten ist die 1N4007 aber definitiv nicht geeignet. Sie ist eigentlich eine Gleichrichterdiode für 50 Hz.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#33

Beitrag von Fahrtwind » Samstag 19. September 2020, 23:52

Ok, danke, kapiert. Ich habe mir gerade ein paar bestellt - ich werde die zusätzlich direkt an den Lastschützen einlöten.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2027
Registriert: Dienstag 15. Mai 2018, 18:10

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#34

Beitrag von JackFrost » Sonntag 20. September 2020, 00:08

Fahrtwind hat geschrieben:
Samstag 19. September 2020, 23:52
Ok, danke, kapiert. Ich habe mir gerade ein paar bestellt - ich werde die zusätzlich direkt an den Lastschützen einlöten.
Lieber direkt mit in die Klemmen, sonst wirkt das Kabel wie eine Antenne und strahlt die Oberwellen beim abschalten ab.
Die "erzeugten" Oberwellen hängen nur von der Geschwindigkeit der Spannungsänderung ab.
Daher kann eine PWM mit 10 kHz auch im MHz Bereich abstrahlen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

fsl
Neuling
Neuling
Beiträge: 7
Registriert: Mittwoch 8. November 2017, 21:26

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#35

Beitrag von fsl » Sonntag 20. September 2020, 11:49

Fahrtwind hat geschrieben:
Montag 18. November 2019, 09:47
und Über mehrere Prototypen ein Gehäuse gezeichnet. Am Wochenende sind dann meine finalen Gehäuseteile aus dem Drucker gefallen:
Das schaut super aus, gerade auch mit den Standfüßen. Suche noch etwas in die Richtung. Würdest Du das noch etwas genauer vorstellen wollen und vielleicht die Daten zur Verfügung stellen?

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#36

Beitrag von Fahrtwind » Sonntag 20. September 2020, 19:56

Hi,
klar, das kann ich gerne machen. STL Files der gedruckten Teile und den Displaytyp kann ich anbieten. Sonst noch etwas?

fsl
Neuling
Neuling
Beiträge: 7
Registriert: Mittwoch 8. November 2017, 21:26

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#37

Beitrag von fsl » Sonntag 20. September 2020, 20:41

Top! Wenn Du es schaffst, noch ein paar Fotos von innen.

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#38

Beitrag von Fahrtwind » Sonntag 20. September 2020, 21:31

Hallo,
hier schon mal Bilder von innen und hinten.
IMG_6928.jpg
IMG_6927.jpg
Die Links zu den Teile. Hatte ich alle über Amazon bezogen:

DELOCK - 65522 Adapter Easy USB... https://www.amazon.de/dp/B00H83TX0A?ref ... b_ap_share

DeLock Sub-D 9-Polig... https://www.amazon.de/dp/B005FZEZQ0?ref ... b_ap_share

DB9 Breakout Board DB9 RS232... https://www.amazon.de/dp/B077M49KYQ?ref ... b_ap_share

Wentronic EDC 21 R DC Silber https://www.amazon.de/dp/B000L0VYLI?ref ... b_ap_share

LEICKE Netzteil 12V 3A |Ladegerät... https://www.amazon.de/dp/B01HRR96ZI?ref ... b_ap_share

StarTech.com 30cm USB A auf A... https://www.amazon.de/dp/B002M8RVKA?ref ... b_ap_share

Für Raspberry Pi 7 Zoll... https://www.amazon.de/dp/B07QKT6L58?ref ... b_ap_share

Und hier die STLs
Archiv.zip
(953.69 KiB) 17-mal heruntergeladen
Viel Spaß beim Bau. Ich kann Dir ansonsten auch die Teile drucken

Grüße
Manuel

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#39

Beitrag von Fahrtwind » Donnerstag 1. Oktober 2020, 22:53

Hallo.
mittlerweile habe ich erfolgreich einen Sud gebraut, verbaut sind die Messfühler von sensorshop24. Eine ganz andere Qualität die an da in den Händen hält!Jetzt kann ich mich endlich weiter austoben und meine kontrollierte Fermentation in der Garage angehen. Durch einen Kumpel aus dem Forum Grillsportverein und dem Thread über das MQTT Device 2, bin ich darüber gestolpert, dass ich eine MQTT fähige WLANThermo mein eigen nenne (ein WLAN Grillthermometer mit diversen Ein- und Ausgängen).
Ich habe es mittlerweile mit der Installation von Mosquitto und dem MQTT Plugin hin bekommen, dass ich JSON Files empfange. Es hapert an dem String für den Payload im Plugin. So sieht das JSON aus:

Code: Alles auswählen

{"system":{"time":"1601582103","unit":"C","soc":80,"charge":false,"rssi":-55,"online":0},"channel":[{"number":1,"name":"Sensor 1","typ":0,"temp":21.70,"min":20.00,"max":80.00,"alarm":0,"color":"#0C4C88"},{"number":2,"name":"Hähnchen g","typ":0,"temp":999.00,"min":75.00,"max":80.00,"alarm":0,"color":"#22B14C"},{"number":3,"name":"Test","typ":0,"temp":999.00,"min":100.00,"max":200.00,"alarm":0,"color":"#EF562D"},{"number":4,"name":"Kanal 4","typ":0,"temp":999.00,"min":10.00,"max":35.00,"alarm":0,"color":"#FFC100"},{"number":5,"name":"Kanal 5","typ":0,"temp":999.00,"min":10.00,"max":35.00,"alarm":0,"color":"#A349A4"},{"number":6,"name":"Kanal 6","typ":0,"temp":999.00,"min":10.00,"max":35.00,"alarm":0,"color":"#804000"},{"number":7,"name":"Kanal 7","typ":0,"temp":999.00,"min":10.00,"max":35.00,"alarm":0,"color":"#5587A2"},{"number":8,"name":"Kanal 8","typ":0,"temp":999.00,"min":10.00,"max":35.00,"alarm":0,"color":"#5C7148"}],"pitmaster":{"type":["off","manual","auto"],"pm":[{"id":0,"channel":1,"pid":2,"value":0,"set":50.00,"typ":"off","set_color":"#ff0000","value_color":"#000000"}]}}
Ich bekomme es hin die Systemzeit der WLANThermo in CBP anzuzeigen wenn ich als Payload "system.time" angebe. Letztlich möchte ich aber den Wert temp bei Channel number 1 ausgeben. Das ist wohl ein Array, ich habe aber echt keine Ahnung von der Materie. Vielleicht habt ihr ja die Erleuchtung für mich!

Danke und Grüße
Manuel

fctriesel
Posting Junior
Posting Junior
Beiträge: 74
Registriert: Donnerstag 4. Oktober 2018, 14:07
Wohnort: Vogelsberg

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#40

Beitrag von fctriesel » Montag 16. November 2020, 10:09

Fahrtwind hat geschrieben:
Dienstag 19. November 2019, 07:41
Die Scroll Bars habe ich erfolgreich entfernen können.
Kannst du für die Scrollbars einen Tip geben, wie du das gemacht hast?
Sent from my Nokia 3210

Benutzeravatar
Fahrtwind
Posting Klettermax
Posting Klettermax
Beiträge: 117
Registriert: Sonntag 7. Januar 2007, 14:57
Wohnort: Welver, Kreis Soest, NRW
Kontaktdaten:

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#41

Beitrag von Fahrtwind » Dienstag 17. November 2020, 06:54

Hi,
klar. In der Index.html im Craftbeerpi-Verzeichnis Folgendes abändern (zB. mit dem Editor Nano)

Code: Alles auswählen

 sudo nano /home/pi/craftbeerpi3/modules/ui/static/index.html
<style type="text/css">
    body {
        overflow: hidden;
    }
</style>  

fctriesel
Posting Junior
Posting Junior
Beiträge: 74
Registriert: Donnerstag 4. Oktober 2018, 14:07
Wohnort: Vogelsberg

Re: Nach 7 Jahren Siemens Logo: Umzug auf CraftBeerPi

#42

Beitrag von fctriesel » Dienstag 17. November 2020, 17:28

Danke dir. Habe mich dafür entschieden nur die X-Achse auszublenden, falls die Höhe der Steps überhand nehmen.

Code: Alles auswählen

<style type="text/css">
        body {
            overflow-x: hidden;
        }
 </style>
Sent from my Nokia 3210

Antworten