Brausteuerung AiO - Steckdose aus nach letzter Rast.

Antworten
Benutzeravatar
Steini
Posting Junior
Posting Junior
Beiträge: 20
Registriert: Samstag 14. Dezember 2019, 08:36
Wohnort: Heddesheim

Brausteuerung AiO - Steckdose aus nach letzter Rast.

#1

Beitrag von Steini » Freitag 17. April 2020, 19:27

Hi zusammen,

ich habe die Brausteuerung AiO (https://hobbybrauer.de/forum/wiki/doku. ... in_one_aio) umgesetzt.
Variante Arduino Mega mit Breshield, Relais zur Ansteuerung der Steckdose (Maische/Koche, Rührer, Nachguss).

Mein Problem ist, dass meine Anlage nach ende der letzten Rast irgendwie nicht mehr Heizt...
D.h. nachdem z.B. die Rast bei 72°C beendet ist und die Anlage zum Abmaischen auf 78°C heizen soll tut sie das nicht.
Bemerkt man das nicht kühlt die Maische immer schön weiter ab...
Siehe Protokoll
Brauprotokoll_20200417.png
Wenn man das nicht bemerkt - was ich glücklicherweise habe - dann kühlt die Maische immer weiter ab. Obwohl im Display steht "Heizen".
D.h. die Steckdose tut es nicht. In der Zusatzsoftware wir sehr wohl Steckdose aktiv gezeigt.


Ich habe bei der erstinbetriebnahme einen Fakesud (nur Wasser) laufen lassen - da war das auch so.
Ich dacht damals erst, dass eines der Relais hinüber wäre. Was aber nicht so war.
Die Anlage arbeitet nun wieder ganz normal...

Also echten Sud gestartet: Alle Rasten perfekt abgefahren. Nach der letzten Rast wieder: Software scheint zu sagen "steckdose an" aber am Kocher bleibt es dunkel.

Ich bin ein wenig ratlos... :Waa
Hat jemand das selbe Problem auch einmal einmal gehabt?

Wie gesagt, die Hardwäre schließe ich inzwischen aus, da die Anlage beim kommenden Sud wieder normal alle Rasten abarbeitet und beim Abmaischen das Problem auftritt.
Es ist ein bischen so als würde die Steuerung zu Jodprobe erinnern(auf die ich aber pfeife) und dann die Steckdose nicht mehr einschalten. (Lt. Doku sollte es aber nicht passieren.)

VG
Steini
Unser Brauwasser ist so hart, dass man darüber gehen kann.

Benutzeravatar
Bitter
Posting Freak
Posting Freak
Beiträge: 977
Registriert: Samstag 19. September 2015, 15:32
Wohnort: Bochum

Re: Brausteuerung AiO - Steckdose aus nach letzter Rast.

#2

Beitrag von Bitter » Samstag 18. April 2020, 14:54

Hallo Steini,

welche Version des Sketch hast du aufgespielt? Wie hast du denn die Rasten eingegeben, über die Software KBH2AiO oder über den Encoder? Da ich selber mit der Relaisvariante arbeite und beim letzten Sud alles einwandfrei funktionierte, kann ich mir nur einen Eingabefehler vorstellen.

Du kannst dich gerne via PN bei mir melden, damit wir ggf. gemeinsam der Ursache auf den Grund gehen.

Gruß Lothar

Benutzeravatar
Steini
Posting Junior
Posting Junior
Beiträge: 20
Registriert: Samstag 14. Dezember 2019, 08:36
Wohnort: Heddesheim

Re: Brausteuerung AiO - Steckdose aus nach letzter Rast.

#3

Beitrag von Steini » Sonntag 19. April 2020, 14:04

Hi Lothar,

es sind die mega-Version vom 24.12.2019 inkl. der Zusatzsoftware (auch die letztgültige) via UDP im Einsatz.
aio_mega_24_12_2019.zip
KBH2AiO64UDP (64 Bit!)

In den beiden Fällen, in denen mir das passiert ist fand die Eingabe über die Zusatzsoftware statt. (Rezept geladen aus der Kleinen-Brauhelfer-DB)
Ich habe gestern zum Test mal per manueller Eingabe über das Poti direkt an der AiO-Brausteuerungen einen Dummysud mit einer Rast eingegeben. Da hat die Steuerung nach Ende der Rast geheizt. D.h. die Steckdose lief...

VG
Steini.
Unser Brauwasser ist so hart, dass man darüber gehen kann.

Antworten