Raspberry PI Steuerung

Mic
Neuling
Neuling
Beiträge: 6
Registriert: Samstag 20. Mai 2017, 22:46

Re: Raspberry PI Steuerung

#1551

Beitrag von Mic » Sonntag 30. Juli 2017, 15:55

Bild

Hi!
Wo habt Ihr eigentlich diese coolen Boxen her...? :thumbup

Benutzeravatar
doldi
Posting Klettermax
Posting Klettermax
Beiträge: 158
Registriert: Mittwoch 24. Dezember 2014, 22:30

Re: Raspberry PI Steuerung

#1552

Beitrag von doldi » Sonntag 30. Juli 2017, 16:20


Mic
Neuling
Neuling
Beiträge: 6
Registriert: Samstag 20. Mai 2017, 22:46

Re: Raspberry PI Steuerung

#1553

Beitrag von Mic » Sonntag 30. Juli 2017, 16:32

Super, vielen Dank doldi! :)

VoelserBrauer
Posting Junior
Posting Junior
Beiträge: 74
Registriert: Samstag 8. August 2015, 13:09
Wohnort: Innsbruck

Re: Raspberry PI Steuerung

#1554

Beitrag von VoelserBrauer » Sonntag 30. Juli 2017, 22:34

Hat jemand erfahrung, mit dieses SSR von Amazon?

Bild

Benutzeravatar
Polyphem
HBCon Supporter
HBCon Supporter
Beiträge: 103
Registriert: Donnerstag 12. Dezember 2013, 21:25

Re: Raspberry PI Steuerung

#1555

Beitrag von Polyphem » Montag 31. Juli 2017, 21:14

Habe ich an meinem CBP, schaltet bei mir 2500W ohne Probleme

Mic
Neuling
Neuling
Beiträge: 6
Registriert: Samstag 20. Mai 2017, 22:46

Re: Raspberry PI Steuerung

#1556

Beitrag von Mic » Freitag 4. August 2017, 10:45

Habe CBP vers. 2.2 am Laufen und frage mich was der Unterschied zwischen 1Wire und 1Wire_v2 in der Konfiguration ist..?

Mic
Neuling
Neuling
Beiträge: 6
Registriert: Samstag 20. Mai 2017, 22:46

Re: Raspberry PI Steuerung

#1557

Beitrag von Mic » Dienstag 8. August 2017, 19:09

Mic hat geschrieben:
Freitag 4. August 2017, 10:45
Habe CBP vers. 2.2 am Laufen und frage mich was der Unterschied zwischen 1Wire und 1Wire_v2 in der Konfiguration ist..?
Keiner eine Idee? :Waa

borstel77
Posting Junior
Posting Junior
Beiträge: 37
Registriert: Freitag 11. August 2017, 10:59

Re: Raspberry PI Steuerung

#1558

Beitrag von borstel77 » Freitag 11. August 2017, 11:06

Moin,

eine kurze Frage. Ich habe eine Funksteckdose, die ich als Actor verwenden will, um die Heizplatte ein-/auszuschalten.
Die Funksteckdose ist in meinem SmartHome angebunden, welches ich über FHEM betreibe.

Ein Aus/Ein-Schalten der Steckdose ist für mich aus der command-line des PIs leicht durchzuführen.

Kann die CraftBeerPi-Server-PID-Implementierung sowas auch alternativ zu Relais durchführen?
Ich habe eine PI, Themometer und diese Steckdose rumliegen und wollte jetzt erstmal testen, bevor ich mit den Relais herumspiele.

Gruß

Björn

budize
Neuling
Neuling
Beiträge: 2
Registriert: Dienstag 25. Juli 2017, 13:09

Re: Raspberry PI Steuerung

#1559

Beitrag von budize » Freitag 25. August 2017, 23:01

Hallo Leute!
Habe heute CBPi zum ersten Mal installiert und gembird angeschlossen! Hat super funktioniert. Dann wollte ich kurz meine wlan steckdose ausprobieren, hab ich aber nicht geschafft, dann wollte ich wieder auf die gembird wechseln. Jedoch schaltete diese nicht mehr... :/ hab dann die DB Datei im CBPi Verzeichnis gelöscht und das setup erneut gemacht... Funktioniert trotz dieser Maßnahmen und Neustart nicht... Was soll ich tun?
Danke!

Gottfried
Posting Junior
Posting Junior
Beiträge: 27
Registriert: Donnerstag 18. August 2016, 21:33

Re: Raspberry PI Steuerung

#1560

Beitrag von Gottfried » Samstag 26. August 2017, 08:36

Hallo Budize,
welche Wlansteckdose verwendest du?
Welche CraftBeerPi – Version?
Alles richtig eingestellt?
viewtopic.php?p=164662#p164662
MfG. Gottfried

Rene
Neuling
Neuling
Beiträge: 9
Registriert: Montag 27. Juli 2015, 18:15

Re: Raspberry PI Steuerung

#1561

Beitrag von Rene » Dienstag 29. August 2017, 18:16

Hallo zusammen.
Frage: Raspberry Pi 3--> CraftbeerPi 2.2 einen pt100 Fühler mit Wandler max31865 anschließen?
was muss ich ändern um ihn in CBPi 2.2 verwenden zu können.
ich hab schon einiges probiert, jedoch bekomm ichs alleine nicht hin ! :Grübel
Die temperatur kann ich auslesen und funktioniert auch,
aber leider nicht in CBPi 2.2.
kann jemand helfen ?
Danke schonmal !
Gruß und gut Sud

walleri
Posting Junior
Posting Junior
Beiträge: 38
Registriert: Dienstag 1. März 2005, 11:03

Re: Raspberry PI Steuerung

#1562

Beitrag von walleri » Mittwoch 30. August 2017, 11:29

Hallo zusammen,

möchte einen BT 140 kaufen, gibt es bei Euch eine Liste, oder Beschreibung, was ich alles für eine Steuerung brauche, z.B. Raspberry Pi 3, Trafo, Fühler, usw?

Bierige Grüße,
Erwin

Bastelfuzzi
Neuling
Neuling
Beiträge: 3
Registriert: Dienstag 29. August 2017, 19:31

Re: Meine Platine CBPI Vers. 1.0 ist da

#1563

Beitrag von Bastelfuzzi » Donnerstag 31. August 2017, 16:56

Hallo Frank,

bin gerade neu in das Thema eingestigen (der Fred ist ja schon riesig...) und vielleicht habe ich es auch übersehen, aber woher bekommt man diese Craftbeerpi-Platine? Ein Link wäre prima! :Smile

Viele Grüße
Martin

Benutzeravatar
Profi-Laie
Posting Junior
Posting Junior
Beiträge: 51
Registriert: Sonntag 22. Februar 2015, 13:52
Wohnort: Mönchengladbach

Re: Meine Platine CBPI Vers. 1.0 ist da

#1564

Beitrag von Profi-Laie » Mittwoch 6. September 2017, 11:13

Bastelfuzzi hat geschrieben:
Donnerstag 31. August 2017, 16:56
... vielleicht habe ich es auch übersehen, aber woher bekommt man diese Craftbeerpi-Platine? Ein Link wäre prima! :Smile
Das müsste der korrekte Link sein:
https://www.powr.io/plugins/form-builde ... ?mode=page

So wurde es zumindest hier erwähnt:
viewtopic.php?p=196318#p196318

Das ganze funktioniert übrigens auch sehr gut ohne diese Platine. Mit dem Teil ist es allerdings etwas einfacher.

Prost, Dennis
Grüße aus Mönchengladbach, Dennis :Drink

Benutzeravatar
Pman
Posting Klettermax
Posting Klettermax
Beiträge: 255
Registriert: Samstag 24. Januar 2015, 14:08

Re: Raspberry PI Steuerung

#1565

Beitrag von Pman » Samstag 9. September 2017, 15:28

Hallo zusammen,
kann mir jemand vllt kurz erläutern, was ich unternehmen muss, um CBP zum Laufen zu bringen (kenn mich mit Raspberry bisher nicht aus). Hab Raspberry Pi 3, dort mach Anleitung CBP installiert. Aber ich kann das irgendwie nicht starten...

Danke.
Bis denne,
Pitt.

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1566

Beitrag von Seduceddirtguy » Sonntag 10. September 2017, 00:35

als windoof user hatte ich das selbe problem...
Terminal ->ifconfig
da steht derine wlan0 ip 192.blabla
die kopierst du in irgeneinen Browser und tippst :5000 dahinter.

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1567

Beitrag von Seduceddirtguy » Sonntag 10. September 2017, 00:45

Moinsen,
habe auch craftbbbepi3 instaliert.
Irgendwie werden die Sensoren nicht erkannt.
Konstillation:auf Gpio 4
2 Paralell einer wird erkannt der andere nicht. Der der erkannt wird zeigt 0°C...
1ner wird garnicht erkannt.
mit der anderen SD karte und CBP2 is alles gut.
Ist 3 doch noch sooo BETA??

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1568

Beitrag von Seduceddirtguy » Sonntag 10. September 2017, 00:59

Habe natürlich je Version den GPIO pin von 4 auf 7 gewechselt..

Bastelfuzzi
Neuling
Neuling
Beiträge: 3
Registriert: Dienstag 29. August 2017, 19:31

Re: Raspberry PI Steuerung

#1569

Beitrag von Bastelfuzzi » Sonntag 10. September 2017, 10:27

Hallo Dennis,
danke für den Tip - habe mir auch gleich eine bestellt 😁
Mal sehen wie lange die Lieferzeit ist und ob ich zum Zoll muss...

Gruß
Martin

Benutzeravatar
Pman
Posting Klettermax
Posting Klettermax
Beiträge: 255
Registriert: Samstag 24. Januar 2015, 14:08

Re: Raspberry PI Steuerung

#1570

Beitrag von Pman » Montag 11. September 2017, 22:31

Kurze Frage:
Stellen die grauen Kästen mit der orangefarbenen Verbindung Breadboards dar...?
IMG_0658.PNG
Bis denne,
Pitt.

cicero85
HBCon Supporter
HBCon Supporter
Beiträge: 207
Registriert: Samstag 5. Juli 2014, 22:23

Re: Raspberry PI Steuerung

#1571

Beitrag von cicero85 » Montag 11. September 2017, 22:44

Hätte nun behauptet dass das stilisierte WAGO-Klemmen sind (Wago 222-415) oder so...

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1572

Beitrag von Seduceddirtguy » Dienstag 12. September 2017, 22:32

Hier nun die zweite Baustelle.. Wenn ich nach dem Schema in Post #1634 2 DS18b20 anschließe wird keiner von beiden erkannt. Schließe ich nur einen an, funktoniert es.
Btw die Problematik ergibt sich unter Cbp3. unter 2 Läuft es.
BtBtw, warum wird bei der Installation von Cbp3 explizit darauf hingewiesen das der temp Sensor auf GPIO4 angeklemmt werden muss? war er doch unter 2.2 auch schon.?

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1573

Beitrag von Seduceddirtguy » Mittwoch 13. September 2017, 18:36

Hab es irgendwie in den griff bekommen... ab heute nachmittag war eine zu hohe Versorgungsspannung des PI schuld das nix an GPIO funzte...

odin23
Posting Klettermax
Posting Klettermax
Beiträge: 124
Registriert: Sonntag 15. Januar 2017, 16:36
Wohnort: Ferlach
Kontaktdaten:

Re: Raspberry PI Steuerung

#1574

Beitrag von odin23 » Mittwoch 4. Oktober 2017, 18:32

Hallo Leute,
ich glaube ich habe mein CBPi Extensions Board abgeschossen. Hatte es zuerst irrtümlich am 12V Eingang mit 5V angeschlossen was dazu führte das ich die Sensoren manchmal erkannte und dann wieder nicht.(meine Meinung)Kann es sein das ich durch die niedere Spannung erhöhten Strom auf dem Board hatte? Als ich dachte ich habe den Fehler entdeckt, habe ich es mit 12 Volt angeschlossen. Meanwell 12v 1,8A. Seitdem geht nichts mehr. Rasperry GPIO 4 zerstört, der Touchscreen bleibt weiss. Neuer Raspberry und die Schaltung von Manuel ohne Board und der Sensor Funktioniert. Ist noch was zu retten. Alter Raspberry wird als Medienserver herhalten müssen. Aber um das Board ist es schade. Ideen? Ach ja bin absoluter Anfänger was Raspberry und den Editor angeht. Kann gerade mal abtippen.

Chitaroni85
Posting Junior
Posting Junior
Beiträge: 25
Registriert: Samstag 22. Oktober 2016, 16:22

Re: Raspberry PI Steuerung

#1575

Beitrag von Chitaroni85 » Donnerstag 5. Oktober 2017, 18:05

Muss man das CBPi Extensions Board extra am Strom anschließen oder wird dieser über den raspberry versorgt?

Maddin
Neuling
Neuling
Beiträge: 1
Registriert: Freitag 28. Juli 2017, 12:57

Re: Raspberry PI Steuerung

#1576

Beitrag von Maddin » Donnerstag 5. Oktober 2017, 21:52

Anders'rum wird ein Schuh draus: das CBPi versorgt den raspi mit Energie, denn dafür ist ja der DC/DC Stepdown-Wandler drauf... :Wink

Benutzeravatar
Lumbanraja
Posting Senior
Posting Senior
Beiträge: 481
Registriert: Sonntag 19. Juni 2011, 12:55
Wohnort: Appen

Re: Raspberry PI Steuerung

#1577

Beitrag von Lumbanraja » Samstag 7. Oktober 2017, 09:34

Moin...
Ich hätte da mal eine Frage bezüglich des PID Autotune-Plugins (CBP 3.0). Wie sind den anderweitig Erfahrungen damit? Ich habe es versucht, doch der Prozess ist nach Stunden noch nicht beendet (irgendwo in den Beschreibungen stand was von 20 min). Liegt es daran, dass mein System zu langsam schwingt? Ich heize 70-80l in einem isolierten Milchtank mit Ceran-Strahlern unter dem Boden.
Ich habe die PID-Parameter nun händisch ermittelt und komme mit einem Kp(krit) von 105 und einer Amplitudendauer T(krit) von ca. 300s auf recht extreme Werte:
Kp=63;
Ki=0,42;
Kd=2368;

Damit es daraufhin einigermassen hinhaute, habe ich Ki aud 0,43 erhöht (blieb sonst eher knapp unterhalb des Solls) und auch Kd auf 2500, denn ein anfängliches Überschwingen von 0,8°C war mir zu viel. Ich bin aber vom gesamten Geschehen nicht so wirklich überzeugt... Was meinen die Regelungstechnikspezialisten?
VG Robin
Als er grade grade war, da knickt' er ab, was schade war...

cream3000
Neuling
Neuling
Beiträge: 2
Registriert: Dienstag 3. Oktober 2017, 10:45
Kontaktdaten:

Re: Raspberry PI Steuerung

#1578

Beitrag von cream3000 » Sonntag 8. Oktober 2017, 11:15

Servus Miteinander,

Ich plane gerade meine 50l Anlage mit CBPI. Soweit steht das Konzept, Komponenten sind fast alle da und es kann losgehen.
Was ich jedoch noch nicht rausgefunden habe ist eine Möglichkeit abgesetzte Temperatursensoren anzubinden.
Ich möchte z. B. einen Fühler im Kühlschrank platzieren welcher in einem anderen Raum steht. Gibt es hier schon Lösungen?
Bzw, kann man z. B. einen zweiten Pi als slave anbinden um abgesetzt von der Master Steuerung GPIOs bereit zu stellen?
Besten Dank und viele Grüße aus Bayern.

VoelserBrauer
Posting Junior
Posting Junior
Beiträge: 74
Registriert: Samstag 8. August 2015, 13:09
Wohnort: Innsbruck

Re: Raspberry PI Steuerung

#1579

Beitrag von VoelserBrauer » Montag 9. Oktober 2017, 22:18

beryll hat geschrieben:
Montag 15. Mai 2017, 09:04
Ich hab mir damals eine Diode mit Widerstand eingebaut, welche leuchtet, wenn ich den Stecker "falsch herum" in die Steckdose gesteckt hab... leuchtet das Ding, dreh' ich den Stecker rum und mein Gewissen ist beruhigt ;-)
sehr interessant! hast du ein Schaltbild vielleicht?

clmnsk
Posting Klettermax
Posting Klettermax
Beiträge: 243
Registriert: Freitag 10. März 2017, 00:12
Wohnort: Berlin

Re: Raspberry PI Steuerung

#1580

Beitrag von clmnsk » Dienstag 10. Oktober 2017, 09:50

cream3000 hat geschrieben:
Sonntag 8. Oktober 2017, 11:15
Servus Miteinander,

Ich plane gerade meine 50l Anlage mit CBPI. Soweit steht das Konzept, Komponenten sind fast alle da und es kann losgehen.
Was ich jedoch noch nicht rausgefunden habe ist eine Möglichkeit abgesetzte Temperatursensoren anzubinden.
Ich möchte z. B. einen Fühler im Kühlschrank platzieren welcher in einem anderen Raum steht. Gibt es hier schon Lösungen?
Bzw, kann man z. B. einen zweiten Pi als slave anbinden um abgesetzt von der Master Steuerung GPIOs bereit zu stellen?
Besten Dank und viele Grüße aus Bayern.
Das sollte gehen, allerdings brauchst du dazu keinen zweiten Pi sondern etwas wie ein ESP8266 reicht.
Grüße, Clemens
---
Hendi - 34L Topf - 32L Thermobehälter
10L Topf BIAB - Kühlschlange - Ikea 10L PP-Container

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1581

Beitrag von Seduceddirtguy » Donnerstag 12. Oktober 2017, 22:00

Moinsen,
sacht mal, is es möglich CBP3 unter Ubuntu zu instalieren und läuft das Ganze dann auch? Frickel immernoch an meiner Steuerung..
Unter Raspbian funzt das alles ganz gut. Würde aber gerne ubuntu Mate nutzen. Harmoniert das?
MFG *Prost*

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1582

Beitrag von Seduceddirtguy » Freitag 13. Oktober 2017, 23:21

:Greets
CPB3 service ist gestartet aber über keinen Browser erreichbar... Hat da wer ne Idee?? Installation lief problemlos.
Gibts es da log dateien aus denen man schlauer werden könnte?
@Manuel
Hab gestern erst mit der Raspbian SD die Aktoren in Betrieb genommen und bin echt begeistert was du da gezaubert hast! Sehr schöne Software! :thumbup

Benutzeravatar
Lumbanraja
Posting Senior
Posting Senior
Beiträge: 481
Registriert: Sonntag 19. Juni 2011, 12:55
Wohnort: Appen

Re: Raspberry PI Steuerung

#1583

Beitrag von Lumbanraja » Samstag 14. Oktober 2017, 11:42

Hast Du die richtige IP-Adresse eingegeben?
Zu ermitteln mit:
$ sudo ifconfig
Im Absatz "wlan0" dann die "inet addr:192.168.x.xx" so in der Adresszeile eingeben: 192.168.x.xx:5000
Nur für den Fall, dass das nicht ganz klar war...

VG Robin
Als er grade grade war, da knickt' er ab, was schade war...

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1584

Beitrag von Seduceddirtguy » Sonntag 15. Oktober 2017, 14:57

Jup. Die Problematik habe ich mittlerweile im griff..
Allerdings hatte ich den Installservice nicht beendet und fälschlicherweise diesen als den CPB3 service identifiziert...
Heisst soviel wie; CPB3 startet nicht obwohl mir der Installservice sagt das es gestartet ist und ich es über IP:5000 erreichen könnte.

VoelserBrauer
Posting Junior
Posting Junior
Beiträge: 74
Registriert: Samstag 8. August 2015, 13:09
Wohnort: Innsbruck

Re: Raspberry PI Steuerung

#1585

Beitrag von VoelserBrauer » Sonntag 15. Oktober 2017, 15:27

Es gibt ein Indentation Problem in beerxml.py. Hier

GriMa-Bräu
Posting Junior
Posting Junior
Beiträge: 19
Registriert: Montag 2. Oktober 2017, 13:05

Re: Raspberry PI Steuerung

#1586

Beitrag von GriMa-Bräu » Montag 16. Oktober 2017, 08:45

Hallo zusammen,
habe seit kurzem craftpeerpi 2.2 am laufen mit angeschlossenen Sensoren und Relays. Läuft auch alles gut soweit.
Nur habe ich jetzt probiert die ispindel damit zu verknüpfen. Dies hat leider nicht funktioniert.
Wenn ich in der ispindel die ip Adressse des CBP servers eintrage und auf save drücke, komme ich nicht mehr aus dem Konfigurationsmodus
und kann auch keine Verbindung zu CBP herstellen.
Hatte jemand schon mal das selbe Problem oder hat vielleicht sogar jemand ne Lösung parat ?

Bei CBP 2.2 ist ja der hydrometer branch schon implementiert ?? Muss da bei der Gärung auch ein hydrometer auswahlfeld sein ?

Vielen Dank im Vorraus

Benutzeravatar
Lumbanraja
Posting Senior
Posting Senior
Beiträge: 481
Registriert: Sonntag 19. Juni 2011, 12:55
Wohnort: Appen

Re: Raspberry PI Steuerung

#1587

Beitrag von Lumbanraja » Montag 16. Oktober 2017, 21:18

Moin,

ist das Problem mit der beerxml.py bereits behoben? Falls nicht, hier ein Walkaround. Das Problem ist, dass er Block "getmashintemp()" in der beerxml.py nicht eingerückt ist wie z.B. getboiltemp(). Das muss aber sein, damit das wieder funktioniert.
Dafür in das Verzeichnis gehen, in dem sich die Datei beerxml.py befindet:
cd craftbeerpi3/modules/recipe_import
Dann die Schreibberechtigung für die beerxml.py ändern:
sudo chmod 777 beerxml.py
Nun die beerxml.py über den Explorer des Pi öffnen und die Zeile "getmashintemp()" mit einem Tabstop einrücken, abspeichern und neu booten.
Fertig...

Dafür hilfreich ist übrigens die FB-Gruppe "CraftBeerPi User Group...da hab ich das her.

VG Robin
Als er grade grade war, da knickt' er ab, was schade war...

Benutzeravatar
Ernie
Posting Senior
Posting Senior
Beiträge: 355
Registriert: Donnerstag 24. März 2016, 15:04

Re: Raspberry PI Steuerung

#1588

Beitrag von Ernie » Dienstag 17. Oktober 2017, 11:02

Problem mit Import aus kleiner Brauhelfer

Moin allerseits,

Beim CraftbeerPi 3.0 habe ich folgenden Effekt:

Wenn ich ein Rezept aus dem kleinen Brauhelfer importiere, werden die Hopfengaben nicht übernommen.
Die Zeiten für die Hop-Additions sind leer.



Weiß jemand Rat ?

Danke im Voraus !

Gruß Ernie

Benns
Neuling
Neuling
Beiträge: 2
Registriert: Freitag 14. Juli 2017, 10:37

Re: Raspberry PI Steuerung

#1589

Beitrag von Benns » Mittwoch 25. Oktober 2017, 20:41

Halo,

ich bin gerade dabei unsere Brauanlage, im Wesentlichen bestehend aus einem Beeketal-Einkocher, mit einem CraftbeerPi auszustatten.

Allerdings verzweifele ich so langsam an dem Temperatursensor. Ich habe einen DS18B20 wie hier beschrieben angeschlossen: http://web.craftbeerpi.com/assets/images/wiring.png

Dieser hat auch zunächst funktioniert, dann wurde er mir nicht mehr angezeigt. Ich dachte ich hätte ihn vielleicht "gehimmelt" und habe eine neuen angeschlossen. Dieser zeigt leider dasselbe Verhalten. Es scheint etwas besser zu sein, also der Sensor funktioniert gefühlt zuverlässiger, wenn ein HDMI-Kabel an den PI3 angeschlossen ist. ABer das kann ja eigentlich nicht sein.

Dann dachte ich, dass der PI vielleicht irgend einen "Schlafmodus" aktiviert hat, konnte aber leider nicht entsprechendes finden. Gibt es so etwas überhaupt für den 1-Wire-Sensor?
Habt ihr einen Tipp für mich? Als der Sonsor mir erlaubte die Software zu testen fand ich sie schon sehr gut! Danke für die Idee und die Programmierung!

Beste Grüße

Benjamin

Benutzeravatar
Alien_TM
HBCon Supporter
HBCon Supporter
Beiträge: 410
Registriert: Montag 11. Januar 2016, 14:50

Re: Raspberry PI Steuerung

#1590

Beitrag von Alien_TM » Mittwoch 25. Oktober 2017, 22:43

Hallo Benjamin

versuch mal den Sensor wie im Bild 2 zu verkabeln. Das is die saubere Lösung. Der "parasitäre Modus" macht manchmal zicken. Geschirrmte Kabel für die Sensoren sind immer eine gute Idee.

https://www.raspiprojekt.de/images/anle ... 1temp1.png

...Alex

MikeSkril
Neuling
Neuling
Beiträge: 2
Registriert: Montag 30. Oktober 2017, 16:22

Re: Raspberry PI Steuerung

#1591

Beitrag von MikeSkril » Montag 30. Oktober 2017, 16:45

Hallo,

Ich habe mir eine Steuerung gebaut um mein E-HERMS (HLT, MLT, Boil kettle) System zu betreiben.

Hier könnt ihr meine Steuerung sehen: https://skrilnetz.net/how-to-build-a-br ... 0v-30-amp/

Bin jetzt auf craftbeerPI gestoßen und habe mir die Bauteile angeschaut die nötig wären um mein System mit craftbeerPI zu betreiben.

Ich habe ne Frage zum diesem Bild:

Bild

SSR’s gehen schon mal kaputt und wenn sie das tun sind sie oft geschlossen.
Ich verwende aus Sicherheitsgründen mechanische Relais zwischen SSR und dem Heizelement.

Bild

Ist es nicht gefährlich das ohne Sicherheitsnetz zu betreiben? Ein Heizelement könnte unter Strom stehen (SSR kaputt) ohne das der Betreiber davon weiß.

MikeSkril
Neuling
Neuling
Beiträge: 2
Registriert: Montag 30. Oktober 2017, 16:22

Re: Raspberry PI Steuerung

#1592

Beitrag von MikeSkril » Montag 30. Oktober 2017, 17:33

Oh, habe vergessen das ich nicht in Europa bin! Blau ist ohne Spannung, richtig? Hier in Nordamerika verwenden wir zwei 120V Phasen für 240V Verbraucher.

Chitaroni85
Posting Junior
Posting Junior
Beiträge: 25
Registriert: Samstag 22. Oktober 2016, 16:22

Re: Raspberry PI Steuerung

#1593

Beitrag von Chitaroni85 » Donnerstag 2. November 2017, 11:39

Hallo,

das Extension Board hat ja einen eigenen Buzzer auf dem Board. Benutze Craftbeerpi 3. Welchen GPIO hat dieser?

odin23
Posting Klettermax
Posting Klettermax
Beiträge: 124
Registriert: Sonntag 15. Januar 2017, 16:36
Wohnort: Ferlach
Kontaktdaten:

Re: Raspberry PI Steuerung

#1594

Beitrag von odin23 » Donnerstag 2. November 2017, 15:12

Hi,

benötige ich beim Craftbeerpi eigentlich für jeden DS18b20 Sensor einen 4,7k Widerstand ? Mein Problem das ich habe ist, das jeder Sensor für sich erkannt wird und auch die Temperatur anzeigt. Schließe ich jedoch 2 Sensoren an zeigt mir entweder einer oder beide 85 Grad. :Waa

Benutzeravatar
flensdorfer
Posting Freak
Posting Freak
Beiträge: 653
Registriert: Freitag 5. Februar 2016, 09:26
Wohnort: Flensburg

Re: Raspberry PI Steuerung

#1595

Beitrag von flensdorfer » Donnerstag 2. November 2017, 15:29

Aus dem Wiki auf github:
85 = internal sensor error. Maybe the cable is too long
Es reicht grundsätzlich ein Widerstand. Könnte ein Problem mit zu langen Kabeln sein, versuche doch mal den Tipp aus Post 1654: viewtopic.php?p=240932#p240932
Gruß, Arne

Anfänger in der 20l-Klasse

odin23
Posting Klettermax
Posting Klettermax
Beiträge: 124
Registriert: Sonntag 15. Januar 2017, 16:36
Wohnort: Ferlach
Kontaktdaten:

Re: Raspberry PI Steuerung

#1596

Beitrag von odin23 » Donnerstag 2. November 2017, 16:01

flensdorfer hat geschrieben:
Donnerstag 2. November 2017, 15:29
Aus dem Wiki auf github:
85 = internal sensor error. Maybe the cable is too long
Es reicht grundsätzlich ein Widerstand. Könnte ein Problem mit zu langen Kabeln sein, versuche doch mal den Tipp aus Post 1654: viewtopic.php?p=240932#p240932
Verstehe ich das richtig das ich ein Ende des Widerstands mit 3.3 Volt versorge, das zweite Ende an die Datenleitung hänge und die Sensoren extra mit 5V versorge. :Waa Elektronik ist nicht so ganz meins :puzz
Ich habe gerade mal 2 Sensoren a 3 Meter daran hängen!
Eine Neuinstallation brachte keine Änderung

Benns
Neuling
Neuling
Beiträge: 2
Registriert: Freitag 14. Juli 2017, 10:37

Re: Raspberry PI Steuerung

#1597

Beitrag von Benns » Donnerstag 2. November 2017, 20:57

Hallo Alex,
Alien_TM hat geschrieben:
Mittwoch 25. Oktober 2017, 22:43
versuch mal den Sensor wie im Bild 2 zu verkabeln.
https://www.raspiprojekt.de/images/anle ... 1temp1.png
das war dann die einfache und naheliegende Lösung. Eventuell sollte es direkt in der Anleitung zur Verkabelung auch so dargestellt werden?!

Gruß

Benjamin

Benutzeravatar
Alien_TM
HBCon Supporter
HBCon Supporter
Beiträge: 410
Registriert: Montag 11. Januar 2016, 14:50

Re: Raspberry PI Steuerung

#1598

Beitrag von Alien_TM » Freitag 3. November 2017, 00:39

odin23 hat geschrieben:
Donnerstag 2. November 2017, 16:01

Verstehe ich das richtig das ich ein Ende des Widerstands mit 3.3 Volt versorge, das zweite Ende an die Datenleitung hänge und die Sensoren extra mit 5V versorge.
genau :thumbup

@Benjamin: freut mich dass es geklappt hat. Im Prinzip is ja die Anleitung richtig, funktioniert halt nur net bei dir mit der Kombination aus Sensoren, Leitungslängen, Bauteiltolereanzen, mögliche äussere Störungen, ...etc.
Ich werd Manuel nen Hinweis schreiben, dass "Schaltung" 1 zu Problemen führen kann und ggfs. ein Vermerk auf "Schaltung 2" optional als Variante in der Anleitung sinnvoll wäre.

...Alex

Benutzeravatar
Neubierig
HBCon Supporter
HBCon Supporter
Beiträge: 1853
Registriert: Sonntag 4. November 2012, 19:28

Re: Raspberry PI Steuerung

#1599

Beitrag von Neubierig » Freitag 3. November 2017, 10:42

Cool, erst nach längere Zeit wieder in diesem Thread geschaut, und sofort was richtig hilfreiches! Das 85°C Problem bekomme ich auch ab und zu mal (manchmal auch 0°C) - das mit dem 5V werde ich auf jeden Fall probieren - danke!

Cheers,

Keith :-)
Beer - the only reason I get up in the afternoon

odin23
Posting Klettermax
Posting Klettermax
Beiträge: 124
Registriert: Sonntag 15. Januar 2017, 16:36
Wohnort: Ferlach
Kontaktdaten:

Re: Raspberry PI Steuerung

#1600

Beitrag von odin23 » Freitag 3. November 2017, 13:27

Leider hat auch die Schaltung mit den 5V nicht funktioniert. Wenn ich ein 20m Kabel anhänge, erkennt er gar keine Sensoren mehr. Alle auf 0 Grad und die Sensoren sind verschwunden. Als ich mein board mit einem sensor anbrachte erschien auch dieser nicht. Witzigerweise lieferte er mir eine Temperatur. Obwohl im craftbeerpi3 kein Sensor da war, hat er sich diesen anscheinend gemerkt. :puzz
Bin etwas ratlos.

Antworten