Raspberry PI Steuerung

Benutzeravatar
Ernie
Posting Senior
Posting Senior
Beiträge: 387
Registriert: Donnerstag 24. März 2016, 15:04

Re: Raspberry PI Steuerung

#1601

Beitrag von Ernie » Freitag 3. November 2017, 15:29

odin23 hat geschrieben:
Freitag 3. November 2017, 13:27
Wenn ich ein 20m Kabel anhänge, erkennt er gar keine Sensoren mehr.
Was machst Du denn mit einem 20m langen Kabel ?

Kein Wunder, dass da nichts mehr kommt.
Die deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

odin23
Posting Klettermax
Posting Klettermax
Beiträge: 124
Registriert: Sonntag 15. Januar 2017, 16:36
Wohnort: Ferlach
Kontaktdaten:

Re: Raspberry PI Steuerung

#1602

Beitrag von odin23 » Freitag 3. November 2017, 16:31

Wollte nur testen ob es an der Länge des Kabels liegt. Mit dem ds18b20 sollten Längen von 100 m kein Problem darstellen.

Benutzeravatar
Alien_TM
HBCon Supporter
HBCon Supporter
Beiträge: 418
Registriert: Montag 11. Januar 2016, 14:50

Re: Raspberry PI Steuerung

#1603

Beitrag von Alien_TM » Freitag 3. November 2017, 18:03

aber das is ein Bussystem

T__________T________T_______________________T

T soll den Sensor darstellen, _ die Leitung... dh, die Abzweigung zum eigentlichen Sensor sollte "kurz" sein


So NICHT!
T T
| |
| |20m
| |
| |
|_|__________________

ggfs ein abgeschirmtes Kabel wie z.B. n Netzwerkkabel mal anstelle nehmen.

...Alex

odin23
Posting Klettermax
Posting Klettermax
Beiträge: 124
Registriert: Sonntag 15. Januar 2017, 16:36
Wohnort: Ferlach
Kontaktdaten:

Re: Raspberry PI Steuerung

#1604

Beitrag von odin23 » Freitag 3. November 2017, 19:18

:Grübel Heisst das das vier Sensoren a 3 Meter nicht mehr funktionieren - in meinem Fall sogar bei zwei Schluss ist. Habe es wie im Post 1661 angeschlossen

kaiserstuhl123
Neuling
Neuling
Beiträge: 7
Registriert: Sonntag 5. Februar 2017, 14:51

Re: Raspberry PI Steuerung

#1605

Beitrag von kaiserstuhl123 » Sonntag 12. November 2017, 23:07

Hi Leute,
will mich über die Feiertage auch mal an den Craftbeer PI ranwagen :) :Bigsmile .
Kann man die Liste auf der erste Seite noch so übernehmen oder hat sich da in der Zwischenzeit was geändert?
Bzw. hat jemand Tipps wo man das ganze am besten bekommt? Reichelt?
Oder auch konkrete Tipps zu bewährten Teilen?

Raspberry PI - 23 Euro (Model A reicht vollkommen aus)
1 wire Thermometer - 3 Euro
1 Relais 10A fürs Rührwerk 5 Euro
1 SSR Relais 20 A für die Heizplatte 7 Euro
1 Kühlkörpern 5 Euro
+ ein paar Kabel

Zu Testzwecken wird erstmal nur ein Einkocher damit betrieben, evtl noch ein Rührwerk.

Vielen Dank schonmal im Vorraus :thumbsup

Braubruder
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Donnerstag 25. Februar 2016, 08:41

Re: Raspberry PI Steuerung

#1606

Beitrag von Braubruder » Dienstag 14. November 2017, 17:43

Hallo zusammen

habe seit geraumer Zeit ein Problem mit der Ansteuerung meiner SSR. In meiner Brausteuerung habe ich zwei 3-Phasen SSR (Steuerseitig 5-32V) verbaut. Leider schalten die irgendwie nicht die volle Leistung. Wenn ich das Steuersignal über einen GPIO schicke schaltete das Relais, aber ich habe Ausgangsseitig nur ca. 200V anstatt die vollen 400V. Wenn ich jedoch vom 3V3 Pin auf das SSR komme und den Steuerstrom mit einem mechanischen Schalter schalte habe ich Ausgangsseitig immer die vollen 400V. Das Relais sollte gemäss Datenblatt mit 20 mA bestromt werden um zu schalten. Das bringt ja ein GPIO nicht. Ich habe noch zwei weitere SSR bestellt mit steuerseitig 3-32V ebenfalls 30 - 50 mA. Diese schalten mit dem oberen Setting überhaupt nicht. Testweise habe ich sie mit einer 9V Batterie perfekt zum Schalten gebracht. Muss ich nun wirklich einen sekundären Steuerkreis (3V) einbauen um den primären Steuerkreis (z.B.12 V) zu schalten um dann damit meine Heizungen zu schalten? :Shocked :Waa . Hat jemand eine Idee für eine elegante Lösung?

Danke schon im voraus
Matthias

Benutzeravatar
Ernie
Posting Senior
Posting Senior
Beiträge: 387
Registriert: Donnerstag 24. März 2016, 15:04

Re: Raspberry PI Steuerung

#1607

Beitrag von Ernie » Dienstag 14. November 2017, 18:06

Hallo Matthias,

was sind das für SSR ?
Ich hatte ebenfalls Probleme mit China SSR aus der Bucht.

Habe jetzt etwas mehr Geld ausgegeben und SSR bei Pollin bestellt.

Jetzt funxt alles wie gewüscht !

LG
Ernie
Die deutsche Rechtschreibung ist Freeware, sprich, du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, d.h. du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

Braubruder
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Donnerstag 25. Februar 2016, 08:41

Re: Raspberry PI Steuerung

#1608

Beitrag von Braubruder » Dienstag 14. November 2017, 20:59

Ja, das sind SSR von Ali... hat denn Pollin 3 Phasen Relais? Welche hast du denn genau verbaut? Habe bei Pollin auf die Schnelle keine gefunden. Ein bisschen mehr bezahlen ist ja schon ok. Aber hier in der Schweiz kostet so ein Teil gut Faktor 10! Und kommen die die wir hier kaufen nicht auch aus China?

KZLTD-3-Phase-Halbleiterrelais-SSR-25A-SSR-25-DC-zu-AC-Solid-State-Relais-25-SSR-1.jpg_640x640.jpg
KZLTD-3-Phase-Halbleiterrelais-SSR-25A-SSR-25-DC-zu-AC-Solid-State-Relais-25-SSR-1.jpg_640x640.jpg (90.13 KiB) 11376 mal betrachtet

Gruss Matthias

Benutzeravatar
Alien_TM
HBCon Supporter
HBCon Supporter
Beiträge: 418
Registriert: Montag 11. Januar 2016, 14:50

Re: Raspberry PI Steuerung

#1609

Beitrag von Alien_TM » Dienstag 14. November 2017, 21:51

Braubruder hat geschrieben:
Dienstag 14. November 2017, 20:59
Ja, das sind SSR von Ali...
Gruss Matthias
Schaltet den das SSR bei 5V? Dann könnte hier das helfen, 5V sollten ja vom Raspi vorhanden sein:

https://www.mikrocontroller.net/article ... .87.92_5_V

...Alex

zauberflo
Posting Klettermax
Posting Klettermax
Beiträge: 140
Registriert: Montag 8. Juni 2015, 20:44

Re: Raspberry PI Steuerung

#1610

Beitrag von zauberflo » Dienstag 14. November 2017, 21:56

Nimm doch einfach das Craftbeerpi Extension Board. So kannst du die SSR mit 12 V ansteuern. LG
Gruß Florian

Braubruder
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Donnerstag 25. Februar 2016, 08:41

Re: Raspberry PI Steuerung

#1611

Beitrag von Braubruder » Mittwoch 15. November 2017, 10:01

Danke euch! Da meine elektrotechnische Grundausbildung doch schon ein paar Jahre zurück liegt versuche ichs mal mit dem Extension Board. Wo hast du das denn bestellt? Gruss Matthias

zauberflo
Posting Klettermax
Posting Klettermax
Beiträge: 140
Registriert: Montag 8. Juni 2015, 20:44

Re: Raspberry PI Steuerung

#1612

Beitrag von zauberflo » Mittwoch 15. November 2017, 11:51

Hallo!
Mittlerweile kannst du es hier bestellen:
https://www.facebook.com/henaotech/?fre ... tion=group
LG
Gruß Florian

Benutzeravatar
danieldee
HBCon Supporter
HBCon Supporter
Beiträge: 1570
Registriert: Montag 25. Juli 2016, 12:34
Wohnort: Bamberg

Re: Raspberry PI Steuerung

#1613

Beitrag von danieldee » Montag 20. November 2017, 08:26

Hallo Zusammen,

wollte am Samstag brauen, leider hat der Pi zwar sich mit einem Netzwerk verbunden es bestand aber keine Internet Verbindung.
Problem war eine leere Gateway Adresse.
Es hat 1 1/2 Jahre ohne Probleme funktioniert dann auf einmal nicht mehr!
Ich wäre fast durchgedreht, konnte es dann aber anhand dieser Anleitung fixen:

https://jankarres.de/2013/09/raspberry- ... -vergeben/

Falls jemand mal das gleiche Problem haben sollte.

Gruß Daniel
"Bier ist der überzeugende Beweis dafür,
dass Gott den Menschen liebt und ihn glücklich sehen will"
Benjamin Franklin

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1614

Beitrag von JollyJumper » Montag 20. November 2017, 10:52

Hi,
ich hab da mal fragen zur Version 3.0.
1. kann man hier irgendwie deutsch einstellen, bei der Vorgängerversion ging das?
2. gibt es eine Möglichkeit ein angepasstes Rezept wieder abzuspeichern?
Hinzufügen Pumpenlogic etc. muss man beim Import immer wieder neu anlegen.
3. die Hopfengaben werden beim Import nicht übernommen, hat jemand ne Idee?
Grüße aus Sinn,

Matthias

mbr
Posting Klettermax
Posting Klettermax
Beiträge: 141
Registriert: Sonntag 8. November 2015, 19:21

Re: Raspberry PI Steuerung

#1615

Beitrag von mbr » Dienstag 28. November 2017, 20:08

hallo zusammen,

Ich beobachte das Thema hier schon länger. Jetzt habe ich mir auch so ein Teil zulegen müssen.

Ich werde auf jedem Fall mit overshoot_by_Norn logic arbeiten. Mir stellt sich hier die Frage, wenn ich zu viel overshoot eintrage, wird die Temperatur dann jemals erreicht?
Ich lese das so, dass der Brenner unter Berücksichtigung des delta-Wertes abgschaltet wird. Nach dem erstmaligen Erreichen der Zieltemp durch den Überschwinger wird das delta auf Null gesetzt.
Was geschieht, wenn der Zielwert durch den Überschwinger nicht erreicht wird?

Derzeit habe ich noch eine andere Steuerung. Dabei habe ich für die Überschwinger immer einen kurzen Temperaturhaltepunkt mit dem Zeit- und Temperatur-Delta eingetragen. Wird auf die "echte" Temperaturstufe geschalten, ist die Temperatur bereits erreicht und es gibt auch keine Überschwinger mehr. Der Nachteil ist halt der doppelte Aufwand bei den Eingaben der Rastzeiten und Temperaturen.

(habe den Code schon angesehen; bin aber kein Programmierer :-) )

vielen Dank,
Martin

beocycris
Posting Junior
Posting Junior
Beiträge: 15
Registriert: Samstag 22. August 2015, 12:00

Re: Raspberry PI Steuerung

#1616

Beitrag von beocycris » Mittwoch 29. November 2017, 12:37

Hat jemand von euch auch das Problem, wenn er einen Brauvorgang startet und händisch andere Aktoren per Button bedienen will, dass diese unglaublich träge und langsam agieren?

Das nervt!
Kenn jemand ne Optimierung dazu?

Schnullux
Neuling
Neuling
Beiträge: 1
Registriert: Dienstag 5. Dezember 2017, 11:17

Induktionsplatte 3.5KW

#1617

Beitrag von Schnullux » Dienstag 5. Dezember 2017, 12:48

Moin Moin,
Ich bin neu und der Thread ist RIESIG lang... Sorry wenn ich dumpfbackige Fragen stelle.
Ich möchte meine 3.5KW Induktionsplatte und einen 60l Topf nutzen.

Wenn die Heizung via SSR oder Schütz ( Altes Wort für Leistungsrelais ;-) ) geschaltet wird, wie bringt ihr eure Induktionsplatten dazu beim Einschalten des Stromes auf "Ein" und maximale Leistung zu gehen? Zumal meist noch eine kleine Initialisierungsphase von 1-3 Sekunden im Spiel ist.

Beste Grüße
Schnullux

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1618

Beitrag von JollyJumper » Dienstag 5. Dezember 2017, 12:54

Hi,
die meisten von uns benutzen die manuelle Hendi 3,5kW Induktionsplatte.
Die geht beim Einschalten auf den eingestellten Wert.
Grüße aus Sinn,

Matthias

mbr
Posting Klettermax
Posting Klettermax
Beiträge: 141
Registriert: Sonntag 8. November 2015, 19:21

Re: Raspberry PI Steuerung

#1619

Beitrag von mbr » Donnerstag 7. Dezember 2017, 22:10

Hy Leute,

Ich verwende v 2.2
Bei mir läuft die Anzeige des Timers nicht mit. Die Zeiten stimmen jedoch.
Zur besseren Übersicht und Kontrolle hätt ich das schon gern in der Anzeige.
Uhrzeit stimmt. Bin auch online.

Hat jemand eine Idee?

Danke
Martin

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1620

Beitrag von JollyJumper » Donnerstag 21. Dezember 2017, 16:38

Hi,
wie bekomme ich das hin, dass mehrere Sensoren in einem Diagramm gezeigt werden?
Ich bekomme immer nur das Temperatur-Diagramm.(mit CBP 3.0)
Grüße aus Sinn,

Matthias

Aquinator
Posting Junior
Posting Junior
Beiträge: 23
Registriert: Donnerstag 21. August 2014, 22:05

Re: Raspberry PI Steuerung

#1621

Beitrag von Aquinator » Dienstag 2. Januar 2018, 21:49

Hi,

erstmal gutes Neues an Alle. Nun muss ich auch ne Frage loswerden. Bei Craftbeerpi 3 kann man meines Wissens ja auch Actors wie Pumpen mit PWM steuern, oder liege ich da falsch? Ich habe so ne 24V Pumpe von Topsflo, und die wollte ich via l298d mit PWM direkt mit CBPi3 steuern. Angeschlossen habe ich sie so: siehe PDF Anhang

Das PWM Signal kommt bei dem ENA-Pin des l298d an mit 3,3V. Allerdings kommt bei der Stromversorgung zur Pumpe nichts mehr an (direkt bei den Ausgängen der Platine gemessen - also kein Kabel Problem). 24 V Netzteil tut auch was es soll. Kann mir jemand weiterhelfen?

Vielen Dank im voraus.
Markus.
Dateianhänge
Pump PWM Control.pdf
(138.68 KiB) 104-mal heruntergeladen

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 138
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1622

Beitrag von Seduceddirtguy » Sonntag 7. Januar 2018, 00:02

Moin,
ich hätte da noch eine Bedienungsfrage.
Folgende Situation:
Ich möchte eine Steckdose (Chiller) über mehrere oder zumindest eine Temperatur schalten.
hab das nach meinem Verständis zu testzwecken konfiguriert und kann manuel (also softkey drücken) schalten. Aber egal was ich unter Hardware settings im Fermenter einstelle wird nicht aktiv geregelt.
Habe da wahrscheinlich ein Verständnis Problem...
IMG_20180106_233813.jpg
IMG_20180106_233846.jpg
Versuche das die Steckdose über 11 grad eingeschaltet wird.
Habe schon etliche Konstillationen durch und es nie hinbekommen das eine Automatisierte Regelung erfolgt..
Kann mir jemand da Hilfreiche tips geben?
Wenn ich manuel schalten kann sollte es ja auch automatisiert klappen...

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1623

Beitrag von JollyJumper » Sonntag 7. Januar 2018, 00:13

Hi,
wie ich das sehe hast du ein Offset von 11 und 10 angegeben.
Warum sollte er dann schalten?
10 soll plus 11 sind 21 und 10 soll minus 10 sind 0.
Oder hab ich jetzt einen Denkfehler?
Grüße aus Sinn,

Matthias

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 138
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1624

Beitrag von Seduceddirtguy » Sonntag 7. Januar 2018, 00:15

Wo ich schon dabei bin...
eine Frage hätte ich noch:
In meinem Fermenter kann ich mir ja nen chart anzeigen lassen.
Allerding wird mir nur eine Temperatur angezeigt obwohl 2 Fühler dran hängen.
IMG_20180107_001028.jpg
Müssten nicht beide Temperatufühler mit dem jeweiligen Namen angezeigt und ggf ausgeblendet werden können? Oder werden die Summiert und durch die Anzahl geteil?

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1625

Beitrag von JollyJumper » Sonntag 7. Januar 2018, 00:16

Das mit den Charts versteh ich auch noch nicht.
Bei mir wird auch nur eine Temperatur wiedergegeben.
Grüße aus Sinn,

Matthias

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 138
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1626

Beitrag von Seduceddirtguy » Sonntag 7. Januar 2018, 00:36

JollyJumper hat geschrieben:
Sonntag 7. Januar 2018, 00:13
Hi,
wie ich das sehe hast du ein Offset von 11 und 10 angegeben.
Warum sollte er dann schalten?
10 soll plus 11 sind 21 und 10 soll minus 10 sind 0.
Oder hab ich jetzt einen Denkfehler?
Stimmt! Offset bezieht sich ja auf etwas... Hab das irgendwie Absolut gesehen... Danke für den Tip!
Klappt leider trotzdem nicht..
Kann auch die "cooler power" auf egal was stellen. cbp schein es nicht zu speichern.
Wenn ich das Menü wieder aufrufe ist die Power immer bei 0%.

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1627

Beitrag von JollyJumper » Sonntag 7. Januar 2018, 00:40

Mach mal ein Bild des Setups der Steckdose, bitte.
Grüße aus Sinn,

Matthias

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 138
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1628

Beitrag von Seduceddirtguy » Sonntag 7. Januar 2018, 00:49

Yeeha! in Folgender konstillation wird aktiv geregelt!:
IMG_20180107_004417.jpg
IMG_20180107_004358.jpg
IMG_20180107_004340.jpg
verstehe noch nicht so recht warum..

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 138
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1629

Beitrag von Seduceddirtguy » Sonntag 7. Januar 2018, 00:56

Mein Aktor (also die Steckdose) wird mit 220v versorgt und hat ein relais drin. (irgendwas günstiges aus der Bay.. Schaltet bis 2400w)
das wird über ein USB port gesteuert den ich fest im Braurechner verbaut habe. im Braurechner ist noch ein Relais um mit den GPIOs genug Strom zu suggestieren. Also GPIO 26 schaltet das interne Relais welches dann Batterie oder Netz gen "steckdose" schaltet.
Hör das hier die Ganze zeit klacken.. Egal ob an oder aus. Es funzt, aber irgendwie noch nich gerade...

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1630

Beitrag von JollyJumper » Sonntag 7. Januar 2018, 00:57

Ich schaue morgen mal bei mir, ob das auch der Fall ist.
Hab nämlich auch ein Chiller nur mit einem Actor.
Grüße aus Sinn,

Matthias

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 138
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1631

Beitrag von Seduceddirtguy » Sonntag 7. Januar 2018, 01:11

Der Braurechner hat scheinbar mehr Probleme... Momentan wird die Maus nicht erkannt obwohl sie Strom bekommt und Touch geht auch nicht mehr...
Abgesehen davonschaltet das Interne Relais im sekunden takt wenn ich die Automatisiereung starte.
Man hätte mal Fernsehtechnicker lernen sollen....
Nach Neustart immernoch eigenartiges Verhalten..
Denke das ich zu viel strom über die GPIOs ziehe. werde dem mal auf den Grund gehen.
Aber danke das Du auf nem Samstag nichts besseres zu tun hattest!

Seduceddirtguy
Posting Klettermax
Posting Klettermax
Beiträge: 138
Registriert: Donnerstag 6. April 2017, 07:18
Wohnort: 38...

Re: Raspberry PI Steuerung

#1632

Beitrag von Seduceddirtguy » Donnerstag 11. Januar 2018, 07:02

Moin.
Also mein Problem mit der Regelung beruht auf der Tatsache das ich im Actor "Steckdose" GPIO simple eingestellt habe und nicht Relais Board.
Jetzt funzt das Grundsätzlich. Heut Abend nochmal genauer prüfen.

Braubruder
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Donnerstag 25. Februar 2016, 08:41

Re: Raspberry PI Steuerung

#1633

Beitrag von Braubruder » Montag 22. Januar 2018, 09:10

Hallo zusammen

Habe wieder das Problem das mir der Chart nicht angezeigt wird. Bei Version 2.2 habe ich mit Hilfe von euch den Code anpassen können dann hats wieder bestens geklappt. Nun habe ich das selbe Problem in Version 3.0. Ist das bekannt? Habt ihr eine Idee wie ich das fixen könnte? Besten Dank für einen Tipp!

Grüsse Matthias

sb11
Posting Freak
Posting Freak
Beiträge: 519
Registriert: Donnerstag 12. März 2015, 09:48

Re: Raspberry PI Steuerung

#1634

Beitrag von sb11 » Freitag 26. Januar 2018, 08:12

Hallo zusammen,

ich wollte mal fragen, ob es so beabsichtigt ist, dass der laufende Timer auf dem Dashboard nicht angezeigt wird, obwohl die Rasttemperatur erreicht ist:
CBP_Screenshot.png
Er ist dann zwar nach der eingestellten Zeit in die nächste Rast gesprungen, aber man hat so keinen Überblick, wie lange die Rast schon läuft. Ich hatte erwartet, dass der Timer ähnlich wie bei einer Stoppuhr los läuft.

Version ist 2.2.

Vielen Dank schonmal für eure Hilfe,
Sebastian

sb11
Posting Freak
Posting Freak
Beiträge: 519
Registriert: Donnerstag 12. März 2015, 09:48

Re: Raspberry PI Steuerung

#1635

Beitrag von sb11 » Freitag 26. Januar 2018, 09:01

Hallo Peter,

danke für deine Rückmeldung. Ich hätte wie gesagt auch erwartet, dass der Timer los läuft. Ich hatte dann sicherheitshalber noch den Küchentimer eingestellt, aber er ist trotzdem nach der richtigen Zeit in die nächste Rast gesprungen. Daher ist das vielleicht nur ein Anzeigeproblem auf dem Dashboard?

Hat jemand eine Idee was die Ursache dieses Problems sein kann und wie man es beheben kann?

Viele Grüsse,
Sebastian

schuessm
Posting Klettermax
Posting Klettermax
Beiträge: 176
Registriert: Dienstag 11. Oktober 2016, 09:42

Re: Raspberry PI Steuerung

#1636

Beitrag von schuessm » Freitag 26. Januar 2018, 09:09

Unter 2.2 gab es meines Wissens mal ein Problem bzgl. der Uhr des Raspberry. Ist wohl bekannt
https://github.com/Manuel83/craftbeerpi/issues/185

Und ich glaube mich erinnern zu können, dass ich das Problem damit gelöst habe
https://github.com/Manuel83/craftbeerpi/issues/149

Auf V3.0 habe ich aktuell dieses Problem nicht mehr beobachtet. Steig doch auch auf Version 3 um. Bei mir läuft die aktuelle Version problemlos

sb11
Posting Freak
Posting Freak
Beiträge: 519
Registriert: Donnerstag 12. März 2015, 09:48

Re: Raspberry PI Steuerung

#1637

Beitrag von sb11 » Freitag 26. Januar 2018, 09:18

Ich hatte das Dashboard sowohl auf meinem Android Smartphone (Crome Browser) als auch auf meinem Ubuntu Rechner (Firefox) aufgerufen. Bei keinem lief der Timer. Ich checke mal die Einstellungen und die beiden Issues die schuessm gepostet hat...

Edit: Im Firefox (Ubuntu) habe ich keine Einstellungen bzgl. JS-Script oder AJAX gefunden.

sb11
Posting Freak
Posting Freak
Beiträge: 519
Registriert: Donnerstag 12. März 2015, 09:48

Re: Raspberry PI Steuerung

#1638

Beitrag von sb11 » Freitag 26. Januar 2018, 10:47

Hallo Peter,

wäre es möglich, dass du mir das Script mal schicken könntest? Dann würde ich das mal ausprobieren.

Vielen Dank schonmal,
Sebastian

zauberflo
Posting Klettermax
Posting Klettermax
Beiträge: 140
Registriert: Montag 8. Juni 2015, 20:44

Re: Raspberry PI Steuerung

#1639

Beitrag von zauberflo » Freitag 26. Januar 2018, 11:23

Eine weitere Lösung ist der einbau einer RTC (Realtimeclock) mit Pufferbatterie - so behält der RasPi die Uhrzeit und das Datum un bezieht es nicht mehr vom Netz. LG
Gruß Florian

Benutzeravatar
JollyJumper
Posting Freak
Posting Freak
Beiträge: 659
Registriert: Dienstag 10. November 2015, 19:01
Wohnort: 35764 Sinn

Re: Raspberry PI Steuerung

#1640

Beitrag von JollyJumper » Sonntag 28. Januar 2018, 14:09

Hi,
hab heute mal ein Probelauf (Wasser) mit der neuen Steuerung gemacht.
Hat soweit funktioniert. Hab da aber noch Fragen.
Ist das normal das der Beeper kein laut von sich gibt beim erreichen der Hopfenzugabe?
Ein kleinen Beep fand ich gut, so als Hinweis.
Wie kann man ein Stop vor einen Timer setzen, oder einfach Timer manuell starten?
Warum werden die Sensoren die ausblenden will, nach dem Neustart wieder eingeblendet?
Dateianhänge
IMG_6223.JPG
Grüße aus Sinn,

Matthias

sb11
Posting Freak
Posting Freak
Beiträge: 519
Registriert: Donnerstag 12. März 2015, 09:48

Re: Raspberry PI Steuerung

#1641

Beitrag von sb11 » Dienstag 30. Januar 2018, 21:05

schuessm hat geschrieben:
Freitag 26. Januar 2018, 09:09
Und ich glaube mich erinnern zu können, dass ich das Problem damit gelöst habe
https://github.com/Manuel83/craftbeerpi/issues/149
Danke nochmal - das hat das Problem für mich ebenfalls gelöst. Schade, dass das dann nicht im Master gefixt wird...

Benutzeravatar
Ferndorfer79
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Montag 15. Januar 2018, 12:46

Re: Raspberry PI Steuerung

#1642

Beitrag von Ferndorfer79 » Mittwoch 31. Januar 2018, 12:47

Hallo,

ich habe mal eine Frage bezüglich der "Abtastrate" der Temperatursensoren.
Wenn ich richtig gezählt habe, wird die Temperatur in CraftbeerPi 3.0 alle 5 Sekunden aktualisiert.
Kann diese Zeit eingestellt werden? wenn ich eine kleine Menge Wasser erhitze, steigt die Temperatur schnell an und schießt über den eingestellten Wert hinaus. ( ich heize mit Gas ).
Habe trotz Suche leider nichts zu dem Thema gefunden.
Ich hoffe Ihr könnt mir helfen.

MfG Örni
:achtung Achtung :achtung

Kaffee ist die Ursache für Aggressivität.
Ich hatte gestern 15 Bier im Biergarten, meine Frau 3 Tassen Kaffee Zuhause.
Ihr könnt euch nicht vorstellen, wie aggressiv sie war, als ich nachts nach Hause kam.

Benutzeravatar
Ferndorfer82
Neuling
Neuling
Beiträge: 9
Registriert: Mittwoch 31. Januar 2018, 19:29

#1643

Beitrag von Ferndorfer82 » Mittwoch 31. Januar 2018, 20:45

Hallo :Greets Örni

Bin zwar absoluter Neuling in Sachen hobbybrauen. Bin mir gerade ne Brauanlage in der Einkocherklasse am bauen bzw. Bin ich gerade mit meinen Tests durch. Habe den Temp ist Wert bis auf +/- 0,3 Card an den soll Wert bekommen. Das habe ich über die Hystereseeinstellungen hin bekommen. War halt nen bischen spielerei und ran tasten. :Smile

Gruß Markus :P
:DrinkAuch Wasser ist ein edler Tropfen ,mischt man es mit Malz und Hopfen :Drink

schuessm
Posting Klettermax
Posting Klettermax
Beiträge: 176
Registriert: Dienstag 11. Oktober 2016, 09:42

Re: Raspberry PI Steuerung

#1644

Beitrag von schuessm » Donnerstag 1. Februar 2018, 11:58

@Ferndorfer82: Schreib doch mal bitte Deine Werte als Richtschnur für andere. Hilft evtl. beim Randtasten

Benutzeravatar
Ferndorfer79
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Montag 15. Januar 2018, 12:46

Re:

#1645

Beitrag von Ferndorfer79 » Donnerstag 1. Februar 2018, 12:49

Ferndorfer82 hat geschrieben:
Mittwoch 31. Januar 2018, 20:45
Hallo :Greets Örni

Bin zwar absoluter Neuling in Sachen hobbybrauen. Bin mir gerade ne Brauanlage in der Einkocherklasse am bauen bzw. Bin ich gerade mit meinen Tests durch. Habe den Temp ist Wert bis auf +/- 0,3 Card an den soll Wert bekommen. Das habe ich über die Hystereseeinstellungen hin bekommen. War halt nen bischen spielerei und ran tasten. :Smile

Gruß Markus :P
Hallo Markus :Greets

Das mit dem Einstellen der Hyterese ist mir schon klar. muss mich da auch noch ran tasten. :puzz
Mir geht es aber um die Frage, ob ich die Aktualisierungsrate von CraftbeerPi auf zB 1 Sekunde stellen kann?
Je geringer die Menge ist, die ich erhitzen möchte, desto schneller steigt die Temperatur.
Der Brenner jagt halt 8,5 kW raus.
Ich könnte natürlich den Brenner etwas drosseln oder die Hysterese neu einstellen.
Die Frage ist aber, ob es generell möglich ist, in kürzeren Abständen die Temperatur zu messen.

MfG Örni
:achtung Achtung :achtung

Kaffee ist die Ursache für Aggressivität.
Ich hatte gestern 15 Bier im Biergarten, meine Frau 3 Tassen Kaffee Zuhause.
Ihr könnt euch nicht vorstellen, wie aggressiv sie war, als ich nachts nach Hause kam.

Benutzeravatar
Ferndorfer79
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Montag 15. Januar 2018, 12:46

Re: Raspberry PI Steuerung

#1646

Beitrag von Ferndorfer79 » Donnerstag 1. Februar 2018, 13:31

beryll hat geschrieben:
Donnerstag 1. Februar 2018, 13:03
Ferndorfer79, Ferndorfer82... Kommen da noch ein paar um die Ecke?!? :puzz

Das Intervall einstellen kann man nicht, Du musst halt ein wenig im Code rumspielen . möglich ist dann vieles.
Wenn Du Dir das zutraust, schaue ich gerne mal drauf.

VG Peter
Hallo Peter,

wir nähern uns der Sache. Das die Einstellung nicht in der Benutzeroberfläche verstellt werden kann, habe ich mir leider schon gedacht.
Aber die Software muss ja irgendwo einen Code haben, welcher die "Aktualisierungsrate" betrifft.
Meine Hoffnung ist, das hier jemand weiß wo diese Zeile zu finden ist.
Wenn da irgendwo eine 5 steht, und ich die nur gegen eine 1 tauschen muss, bekomme ich das hin.
wenn es wirklich an´s Programmieren geht, reichen meine Kenntnisse nicht aus.

P.S.: ich glaube zwei Ferndorfer reichen hier im Forum. Aber man kann ja nie wissen. Bald reißen wir die Weltherrschaft an uns! :Bigsmile :thumbsup

MfG Örni
:achtung Achtung :achtung

Kaffee ist die Ursache für Aggressivität.
Ich hatte gestern 15 Bier im Biergarten, meine Frau 3 Tassen Kaffee Zuhause.
Ihr könnt euch nicht vorstellen, wie aggressiv sie war, als ich nachts nach Hause kam.

Benutzeravatar
Ferndorfer82
Neuling
Neuling
Beiträge: 9
Registriert: Mittwoch 31. Januar 2018, 19:29

Re: Raspberry PI Steuerung

#1647

Beitrag von Ferndorfer82 » Donnerstag 1. Februar 2018, 17:55

schuessm hat geschrieben:
Donnerstag 1. Februar 2018, 11:58
@Ferndorfer82: Schreib doch mal bitte Deine Werte als Richtschnur für andere. Hilft evtl. beim Randtasten
Hi
Mach ich gerne. Habe für die Rasten im Offset aus 0,2 und im Offset ein 0,25 damit ging es ganz gut meiner Meinung. Wie gesagt mit einem weck Einkocher. Beim Würzekochen habe ich die Offset Einstellungen beide auf null gesetzt, weil ich es als störend empfunden habe das da eine Regelung statt findet. Habe im Koch Step Temperatur und Hopfen gaben eingegeben. Und bei mir war es so das bei Zieltemperatur abschaltet/regelt, was die Steuerung eigentlich nicht müsste. Weil soll ja richtig kochen. Jetzt könnte man ja sagen man stellt eine höhere Temperatur ein zb. 101 C. Dann würde ja durchgängig geheizt bis der Einkocher abschaltet, aber dann läuft der Timer nicht an. Oder habe ich was falsch eingestellt?

Gruß Markus
:DrinkAuch Wasser ist ein edler Tropfen ,mischt man es mit Malz und Hopfen :Drink

schuessm
Posting Klettermax
Posting Klettermax
Beiträge: 176
Registriert: Dienstag 11. Oktober 2016, 09:42

Re: Raspberry PI Steuerung

#1648

Beitrag von schuessm » Freitag 2. Februar 2018, 07:31

Danke für Deine Infos. Das mit dem Timer beim Kochen, mache ich oft genau so, dass ich eine große Temperatur einstelle und dann den Timer schon bei 98°C manuell anstarte. Manchmal ist halt Handarbeit angesagt. ;-) Und beim Kochen bin ich gerade am Anfang gern dabei, zwecks Überkochen etc.

Braumeister999
Posting Junior
Posting Junior
Beiträge: 28
Registriert: Samstag 25. Juni 2016, 09:15
Wohnort: Konstanz

Re: Raspberry PI Steuerung

#1649

Beitrag von Braumeister999 » Sonntag 4. Februar 2018, 16:16

Hallo zusammen,

gerne möcht ich meine Steuerung von 2.2 auf die Version 3.0 upgraden, finde aber nirgends wo und wie ich diese herunterladen und installieren könnte, über einen Link würde ich mich sehr freuen.
Herzliche Grüße aus Konstanz- Andreas
Mit den besten Grüßen
Andreas

clmnsk
Posting Klettermax
Posting Klettermax
Beiträge: 249
Registriert: Freitag 10. März 2017, 00:12
Wohnort: Berlin

Re: Raspberry PI Steuerung

#1650

Beitrag von clmnsk » Sonntag 4. Februar 2018, 17:47

Braumeister999 hat geschrieben:
Sonntag 4. Februar 2018, 16:16
Hallo zusammen,

gerne möcht ich meine Steuerung von 2.2 auf die Version 3.0 upgraden, finde aber nirgends wo und wie ich diese herunterladen und installieren könnte, über einen Link würde ich mich sehr freuen.
Herzliche Grüße aus Konstanz- Andreas
https://github.com/Manuel83/craftbeerpi3
Grüße, Clemens
---
Hendi - 34L Topf - 32L Thermobehälter
10L Topf BIAB - Kühlschlange - Ikea 10L PP-Container

Antworten