iSpindel - Aufbau und Betrieb

Seitersbräu
Neuling
Neuling
Beiträge: 3
Registriert: Sonntag 27. Januar 2019, 09:57

Re: iSpindel - Aufbau und Betrieb

#3251

Beitrag von Seitersbräu » Freitag 26. Juni 2020, 12:25

Ja aber auch bei Philippo (cherryPhillip) gibt es nur noch die SMD Variante in lang. Keine Short Version . Bei PCBWays.com kann man die Lang Variante bestellen aber für über 30 $. Ich muss weitersuchen.

nPlusEins
Posting Junior
Posting Junior
Beiträge: 45
Registriert: Sonntag 7. Februar 2016, 17:03
Wohnort: Karlsruhe

Re: iSpindel - Aufbau und Betrieb

#3252

Beitrag von nPlusEins » Freitag 26. Juni 2020, 13:00

Seitersbräu hat geschrieben:
Freitag 26. Juni 2020, 12:25
Ja aber auch bei Philippo (cherryPhillip) gibt es nur noch die SMD Variante in lang. Keine Short Version . Bei PCBWays.com kann man die Lang Variante bestellen aber für über 30 $. Ich muss weitersuchen.
Ja ich hab die Lang Variante bestellt, aber eben bei JLCPCB für ca. 13€ statt für über 30€ bei PCBWays. Die Gerberdaten gibts bei Github (alter Commit): https://github.com/cherryphilip74/iSpin ... _Rev_A.zip

Das kann man einfach bei JLCPCB und co. hochladen und zahlt dann keinen überteuerten Preis.

Seitersbräu
Neuling
Neuling
Beiträge: 3
Registriert: Sonntag 27. Januar 2019, 09:57

Re: iSpindel - Aufbau und Betrieb

#3253

Beitrag von Seitersbräu » Freitag 26. Juni 2020, 22:16

Danke nPlusEins, das hat geholfen. :thumbup

Benutzeravatar
Luigi
HBCon Supporter
HBCon Supporter
Beiträge: 62
Registriert: Samstag 4. Februar 2017, 19:54
Wohnort: Kirchseeon

Re: iSpindel - Aufbau und Betrieb

#3254

Beitrag von Luigi » Sonntag 28. Juni 2020, 10:12

Seitersbräu hat geschrieben:
Donnerstag 25. Juni 2020, 21:29
Hallo und guten Abend,
ich wollte mit die Platine für die Spindel hier bestellen https://pcbs.io/share/zZwRq
Sieht alles gut aus, bis man auf bezahlen klickt (egal ob Paypal oder Kreditkarte).
Es geht ein Popup auf ... "Loading payment dialog"
Dann passiert nichts mehr, egal ob ich es mit Safari, Firefox, IE oder Crome probiere.
Popupblocker sind deaktiviert.

Hat das Jemand im neuen Jahr schon mal probiert ?

Gruß
Servus Dirk, :thumbup

also ich hatte ja bereits während Corona dort bestellt, per paypal bezahlt und nach knapp 2 Monaten kamen dann auch die Platinen an. Die lange Bearbeitungszeit könnte auch an Corona und dem Shutdown in den USA gelegen haben. Qualität ist super. Mag die kleinere Platinenversion irgendwie lieber. Aber ist sicher Geschmackssache...

Viele Grüße
Lui
Dateianhänge
img_2159.jpg
Lieber Bier im Bauch, als Wasser im Kopf! :Drink

ak59
Posting Klettermax
Posting Klettermax
Beiträge: 156
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3255

Beitrag von ak59 » Montag 29. Juni 2020, 10:29

Hallo,
ich hab zum 1. Mal eine (nicht feinkalibrierte) iSpindel im Gärfass und bisher (9 Tage) sah alles recht gut aus. Heute morgen sehe ich aber einen unerwarteten Anstieg:
spindel.jpg
Ich hätte 2 Erklärungen dafür
- irgendwas (Heferückstände?) an der Spindel hat sich gelöst, dadurch fehlt nun etwas Auftrieb
- irgendwas ist nicht mehr ok - Flüssigkeit in der Spindel?

Ohne Herausnehmen der Spindel kann ich letzteres wohl nicht prüfen, aber wenn ich es richtig sehe, hätte sich dann die Spindel wieder etwas mehr aufrichten müssen.

Soll ich die Spindel besser rausnehmen oder sieht das ok aus?

Viele Grüße,

Andreas

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6921
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3256

Beitrag von DerDerDasBierBraut » Montag 29. Juni 2020, 10:34

Kräusen fallen zusammen, anhaftende Brandhefe trocknet, anhaftende CO2 Bläschen lösen sich, schwebende Hefe sedimentiert ....
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

ak59
Posting Klettermax
Posting Klettermax
Beiträge: 156
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3257

Beitrag von ak59 » Montag 29. Juni 2020, 11:01

... dacht ich mir fast, danke für die Beruhigung ;-)

Gruß,

Andreas

ak59
Posting Klettermax
Posting Klettermax
Beiträge: 156
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3258

Beitrag von ak59 » Montag 29. Juni 2020, 11:15

Rockska hat geschrieben:
Donnerstag 25. Juni 2020, 07:24
Habe meine 2017er Spindel mit Schlitten gestern zusammen gelötet... war ansich kein Problem.
Schalte ich den Schalter nach rechts, blinkt es im Sekundentakt blau und ich finde auch das Wlan ESP*** kann dort jedoch keine Config-Seite aufrufen.
Vermute, weil nichts geflashed wurde.

Dafür wollte ich dann die Spindel über den Port des Wemos an den PC anschließen, aber es tut sich nix. Egal ob die Spindel an ist, aus ist etc... oder der Wemos alleine vom Rest getrennt. Mehrere USB-Ports probiert... Woran könnte das liegen?
Hi,

falls das noch akut ist: ich kann eigentlich nur für 'nen Mac sprechen - meine Windows-Kenntnisse sind etwas eingerostet. Müsste die HW nicht erkannt werden? Adequat zum Mac würde ich einen Treiber als nötig ansehen, der über den USB-Port eine serielle Schnittstelle einrichtet.

Gruß,

Andreas

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1396
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3259

Beitrag von JackFrost » Montag 29. Juni 2020, 11:52

Der Wemos alleine, wenn die Diode entfernt wurde läuft nicht ohne die anderen Platinen.

Hast du ein unbekanntes Gerät im Gerätemanager wenn der Wemos angesteckt ist ?

Hast du evtl. beim entfernen der Diode was anderes beschädigt neben der USB Buchse ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Rockska
Posting Junior
Posting Junior
Beiträge: 24
Registriert: Dienstag 17. Oktober 2017, 07:21

Re: iSpindel - Aufbau und Betrieb

#3260

Beitrag von Rockska » Montag 29. Juni 2020, 15:25

JackFrost hat geschrieben:
Montag 29. Juni 2020, 11:52
Der Wemos alleine, wenn die Diode entfernt wurde läuft nicht ohne die anderen Platinen.

Hast du ein unbekanntes Gerät im Gerätemanager wenn der Wemos angesteckt ist ?

Hast du evtl. beim entfernen der Diode was anderes beschädigt neben der USB Buchse ?

Gruß JackFrost
Danke für deine Rückmeldung.
Hab mir die Stelle mit der Diode genau angeschaut, dort ist, bis auf die fehlende Diode nichts zu sehen...
Auch ist nichts in Windows zu erkennen, kein Gerät, kein Piep, das etwas angesteckt wurde nix. Habe alle USB-Ports probiert,
dachte es liegt vllt an 2.0 oder 3.0... 3 verschiedene Kabel... die Batterie getauscht und auch direkt im Lademodus versucht.

Passiert leider nix... Ich hab früher in SMD Motorencontroller eines Mikrokopters gelötet... sooo schwer war das Projekt hier ja jetzt nicht.
mhhh.....

ak59
Posting Klettermax
Posting Klettermax
Beiträge: 156
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3261

Beitrag von ak59 » Montag 29. Juni 2020, 16:05

Rockska hat geschrieben:
Montag 29. Juni 2020, 15:25
JackFrost hat geschrieben:
Montag 29. Juni 2020, 11:52
Der Wemos alleine, wenn die Diode entfernt wurde läuft nicht ohne die anderen Platinen.

Hast du ein unbekanntes Gerät im Gerätemanager wenn der Wemos angesteckt ist ?

Hast du evtl. beim entfernen der Diode was anderes beschädigt neben der USB Buchse ?

Gruß JackFrost
Danke für deine Rückmeldung.
Hab mir die Stelle mit der Diode genau angeschaut, dort ist, bis auf die fehlende Diode nichts zu sehen...
Auch ist nichts in Windows zu erkennen, kein Gerät, kein Piep, das etwas angesteckt wurde nix. Habe alle USB-Ports probiert,
dachte es liegt vllt an 2.0 oder 3.0... 3 verschiedene Kabel... die Batterie getauscht und auch direkt im Lademodus versucht.

Passiert leider nix... Ich hab früher in SMD Motorencontroller eines Mikrokopters gelötet... sooo schwer war das Projekt hier ja jetzt nicht.
mhhh.....
Hi,

ich hab' da noch 'nen Verdacht: kann es sein, daß Dein USB-Kabel keine Daten durchschleift? Ich musste mir extra eins kaufen - alle meine 7 vorrätigen hatten ein Problem bzw. fehlten da wohl die Datenleitungen.

Gruß,

Andreas

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1396
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3262

Beitrag von JackFrost » Montag 29. Juni 2020, 16:15

Miss bitte mal die Spannungen wie in dem Wiki https://hobbybrauer.de/forum/wiki/doku. ... D=ispindel

Nur um sicher zugehen, das alle Spannungen passen.

Hast du einen zweiten Wemos den du testen könntest ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

wannenbraeu
Posting Klettermax
Posting Klettermax
Beiträge: 297
Registriert: Dienstag 9. Oktober 2012, 14:08

Re: iSpindel - Aufbau und Betrieb

#3263

Beitrag von wannenbraeu » Freitag 3. Juli 2020, 18:24

Hallo zusammen

Als ich die Teile bestellt habe, hatte es leider keine TP4056 Lademodule. Ich habe darum das Wemos D1 Battery Shield bestellt. Ich dachte, das passt gut :-)

Nun sieht es aber so aus als wäre das nicht ideal, da dieses Shield eine 5V Step-up Schaltung drauf hat, welche konstant den Akku etwas leert.

Ich habe nun den Schaltplan neu gezeichnet. Kann bitte jemand, der etwas mehr von Elektronik versteht als ich, den kontrollieren und ein Feedback geben?

Danke vielmals und Gruss
Dateianhänge
iSpindel mit Wemos Battery Shield_bb.jpg

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1396
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3264

Beitrag von JackFrost » Freitag 3. Juli 2020, 20:25

Der Stepup selber braucht auch Strom, und der Leckstrom der Kondensatoren wird dir die maximale Betriebszeit der iSpindel etwas senken.
Das Wemos D1 Battery Shield hat keinen Unterspannungsschutz. Du kannst also den Akku unter 2,5 V entladen, wenn du keine Zelle mit eigenem
Schutz nimmst. Wenn du die Zelle dann laden willst, kann sie sich aufblöhen oder gar das Brennen anfangen.

Daher lieber einen Laderegeler mit Unterspannungsschutz nehmen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

ak59
Posting Klettermax
Posting Klettermax
Beiträge: 156
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3265

Beitrag von ak59 » Freitag 10. Juli 2020, 16:05

Hallo zusammen,

nachdem ich eine gebrauchte iSpindel aus Zeitknappheit ohne weitere Kalibrierung in mein Gärfass gegeben hatte und der Kurvenverlauf eigentlich recht gut aussah, wollte ich mich mal dranmachen, sie besser zu kalibrieren, um dann auch weitere Werte zu erhalten. Im Leitungswasser zeigte sie etwa 25° an, aber geschätzt und grob nachgemessen waren es eher 45°. Nun steht sie aufrecht auf dem Tisch und zeigt etwa 13° an.

Sehe ich das richtig, daß das nur an dem bereits vorhandenem Poly-dingsbums liegen kann und nur nochmal von Anfang an neu kalibrieren muss? Natürlich ändere ich vorher alle Gewichte so ab, dass ich etwa 25° Abweichung von Senkrechten habe?

Viele Grüße,

Andreas

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1396
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3266

Beitrag von JackFrost » Freitag 10. Juli 2020, 17:40

ak59 hat geschrieben:
Freitag 10. Juli 2020, 16:05
Hallo zusammen,

nachdem ich eine gebrauchte iSpindel aus Zeitknappheit ohne weitere Kalibrierung in mein Gärfass gegeben hatte und der Kurvenverlauf eigentlich recht gut aussah, wollte ich mich mal dranmachen, sie besser zu kalibrieren, um dann auch weitere Werte zu erhalten. Im Leitungswasser zeigte sie etwa 25° an, aber geschätzt und grob nachgemessen waren es eher 45°. Nun steht sie aufrecht auf dem Tisch und zeigt etwa 13° an.

Sehe ich das richtig, daß das nur an dem bereits vorhandenem Poly-dingsbums liegen kann und nur nochmal von Anfang an neu kalibrieren muss? Natürlich ändere ich vorher alle Gewichte so ab, dass ich etwa 25° Abweichung von Senkrechten habe?

Viele Grüße,

Andreas
Das Polynom ist nur für die Umrechnung Winkel in Dichte.
Wenn die Spindel bei 0° und 90°nicht annähernd diese Werte ( +/- ein paar Grad ) anzeigt, dann passt was nicht.
Die SPindel sollte aber auf 10s Intervall stehen oder im Config Modus sein, damit die Werte oft gemessen werden und nicht noch
eine falsche Berechnung wegen evtl. Bewegung drinnen ist.
DIe Spindel auch mal für 10 Minuten ausschalten, bei meiner war es mal so das die WInkel nicht mehr gestimmt haben und dann ging es wieder.
Du kannst sie komplett zurücksetzen und damit auch die Kalibrierung des Sensors löschen, sofern diese mal gemacht wurde.
Wenn sie dann wieder nicht die Werte nicht richtig anzeigt dann am besten den Gyro tauschen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

ak59
Posting Klettermax
Posting Klettermax
Beiträge: 156
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3267

Beitrag von ak59 » Freitag 10. Juli 2020, 22:50

Hi,

erstmal danke. Ich hatte mal angefangen eine iSpindel nach Schaltplan zusammenzulöten, noch ohne Spindelsoftware. Ein Arbeitsschritt hatte ich so in Erinnerung, den GY samt Wemos möglichst ruhig liegen zu lassen und dabei Werte auszulesen - hatte nichts mit Dichte zu tun. Am Ende waren die Ergebnisse zurückzuschreiben - das meinte ich.

Anders ausgedrückt: ich kann ja den Sensor für eine andere Anwendung auch schräg einbauen. Dann muss ich aber doch noch festlegen, in welcher Stellung 0° liegen, oder.

Ich seh mir das erstmal an meiner Selbstbauspindel an. Wie gesagt waren die Winkelveränderungen an sich aus meiner Sicht plausibel.

Gruß,

Andreas

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6921
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3268

Beitrag von DerDerDasBierBraut » Freitag 10. Juli 2020, 23:06

Mach dich damit nicht fertig. "Tilt" ist nicht "Grad", sondern der absolute Wert eines berechneten eulerschen Winkels. Bedeutet, dass die Neigungen der X-, Y- und Z-Achse einen Wert zwischen 0 und 90 ergeben. Diese Idealwerte erreicht man nie und das ist auch gar nicht erforderlich für die allgemeine Funktion iSpindel oder die Genauigkeit Messung.
Sorge einfach dafür, dass Tilt in Leitungswasser über 10 liegt und in der Anstellwürze deiner stärksten Platobombe nicht über 80.
In den Grenzbereichen 0-10 und 80-90 ist die Genauigkeit recht grobkörnig.

Damals gab es in der iSpindel Konfiguration mal einen Punkt "Maintenance", in der man "Tilt" bei exakt waagerecht liegendem Schnitten auf 90 setzen konnte. Somit war "Tilt" bei senkrechtem Schlitten annähernd "0".
Ich weiß nicht, ob es diese Option in der aktuellen Firmware noch gibt. Sie war jedenfalls Spielerei und hatte keinerlei positive Effekte auf die Genauigkeit. Wenn die iSpindel schwamm, dann war diese Eichung gleich wieder obsolet, weil durch den Rollwinkel schon wieder Werte größer 0 gemessen wurden. Der Rollwinkel ist bei einer schwimmenden Spindel im wahren Leben nie "0", weil die Trimmgewichte und die horizontale Gewichtsverweilung der Bauteile nie 100% exakt ausbalanciert sind.

Kurz zusammengefasst:
Vergiss das Thema. Es bringt dir keine Vorteile.
Tilt ist KEIN Winkel in Grad. Wenn du beim Bewegen Werte <10 und > 80 erreichst, dann ist alles mehr als perfekt.

PS:
Die iSpindel ist ein unheimlich nützliches und vielseitig nutzbares Schätzeisen.
Versuch nicht ein Messgerät daraus zu bauen. Das kann nicht funktionieren!
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

ak59
Posting Klettermax
Posting Klettermax
Beiträge: 156
Registriert: Sonntag 20. Oktober 2019, 12:36
Wohnort: Emskirchen

Re: iSpindel - Aufbau und Betrieb

#3269

Beitrag von ak59 » Samstag 11. Juli 2020, 09:48

Hi,

wenn dort nicht der Winkel angezeigt werden soll, vereinfacht sich das alles auf die grobe Ausrichtung im Leitungswasser und ein paar Messungen. Und daß die anderen Werte nur Näherungen darstellen, war mir klar, aber alleine den Kurvenverlauf sah ich recht hilfreich an, um den Verlauf der Gärung zu beobachten.

Danke,

Andreas

Rockska
Posting Junior
Posting Junior
Beiträge: 24
Registriert: Dienstag 17. Oktober 2017, 07:21

Re: iSpindel - Aufbau und Betrieb

#3270

Beitrag von Rockska » Samstag 11. Juli 2020, 10:13

Ich bekomme meine Spindel einfach nicht ans Laufen... wenn jemand mal danach schauen mag,
ich zahle hin und Rückversand und natürlich was fürs danach schauen. Oder kaufe mir einfach den Tilt :)

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1396
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3271

Beitrag von JackFrost » Samstag 11. Juli 2020, 10:15

Rockska hat geschrieben:
Samstag 11. Juli 2020, 10:13
Ich bekomme meine Spindel einfach nicht ans Laufen... wenn jemand mal danach schauen mag,
ich zahle hin und Rückversand und natürlich was fürs danach schauen. Oder kaufe mir einfach den Tilt :)
Was läuft denn nicht ?
Ich kann sie mir schon anschauen wird aber bisserl dauern.
Wenn du willst, schreib mir eine PN, dann machen wir den Rest aus

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Römergärtenbier
Posting Junior
Posting Junior
Beiträge: 85
Registriert: Freitag 8. April 2016, 06:53
Wohnort: Niedernhausen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#3272

Beitrag von Römergärtenbier » Sonntag 12. Juli 2020, 22:09

Hallo zusammen,

Ich hatte die iSpindel 3 Monate nicht in Betrieb. Nachdem sie heute nun wieder Messwerte an Ubidots funkt, dort aber keine Messreihen gespeichert werden, habe ich das Device bei ubidots gelöscht und auch die Firmware 6.3.1 aufgespielt. Nun bietet mir die Configurationsseite der iSpindel ein Feld "Path / URI" an, bei dem ich nicht weiss, was dort einzutragen ist. Messwerte kommen zwar an, zumindest zeigt ubidots immer aktuelle Messwerte, aber eben keine Messreihen. Selbst ein neuer Token hat keinen Effekt. In der Übersicht der Variablen steht nur 'No Data Available'.

Jetzt weiss ich nicht, ob es an der iSpindel liegt oder an ubidots? Naja, auf jeden Fall bei mir, aber ich weiss nicht, wo ich noch suchen soll.

Ich habe einen ubidots for education account mit aktuell ca. 1800 credits.

Kennt jemand das Problem? Hat jemand einen Tipp? Muss ich, und wenn ja was, in "Path / URI" eintragen? Oder funktioniert Ubidots seit heute nicht?

Schönen Abend!

Jan

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6921
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3273

Beitrag von DerDerDasBierBraut » Sonntag 12. Juli 2020, 22:18

Verstehe ich nicht ganz.
Du siehst unter "Devices" die aktuellen Daten der iSpindel?
Falls ja, richte die Datenquelle in den Dashboard Widgets neu ein. Falls Nein ... Wo siehst du die iSpindeldaten in Ubidots?
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Römergärtenbier
Posting Junior
Posting Junior
Beiträge: 85
Registriert: Freitag 8. April 2016, 06:53
Wohnort: Niedernhausen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#3274

Beitrag von Römergärtenbier » Sonntag 12. Juli 2020, 22:34

DerDerDasBierBraut hat geschrieben:
Sonntag 12. Juli 2020, 22:18
Verstehe ich nicht ganz.
Du siehst unter "Devices" die aktuellen Daten der iSpindel?
Falls ja, richte die Datenquelle in den Dashboard Widgets neu ein. Falls Nein ... Wo siehst du die iSpindeldaten in Ubidots?
Ja, aktuelle Messwerte sehe ich, aber diese werden nicht in einer Messreihe abgespeichert:
Screenshot 2020-07-12 22.23.03.png
Screenshot 2020-07-12 22.27.03.png
Dort wo 'There is new data available' steht wird immer der gleiche Messwert angezeigt. Die Widgets habe ich auch gelöscht und erstelle sie wieder, wenn die Messreihen vorliegen.

Mir kommt es so vor, als ob das Problem bei Ubidots liegt. Das 5-Sekunden-Intervall habe ich nur testweise eingerichtet. Die iSpindel liegt hier am Arbeitsplatz.

Viele Grüße.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6921
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3275

Beitrag von DerDerDasBierBraut » Montag 13. Juli 2020, 00:04

Sorry. Keine Idee. Ich nutze Ubidots schon sehr lange nicht mehr.
Bitte hau den Support von Ubidots an und poste das Ergebnis hier, damit die anderen User Lösung finden.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Römergärtenbier
Posting Junior
Posting Junior
Beiträge: 85
Registriert: Freitag 8. April 2016, 06:53
Wohnort: Niedernhausen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#3276

Beitrag von Römergärtenbier » Montag 13. Juli 2020, 06:29

Römergärtenbier hat geschrieben:
Sonntag 12. Juli 2020, 22:09
Hallo zusammen,

Ich hatte die iSpindel 3 Monate nicht in Betrieb. Nachdem sie heute nun wieder Messwerte an Ubidots funkt, dort aber keine Messreihen gespeichert werden, habe ich das Device bei ubidots gelöscht und auch die Firmware 6.3.1 aufgespielt. Nun bietet mir die Configurationsseite der iSpindel ein Feld "Path / URI" an, bei dem ich nicht weiss, was dort einzutragen ist. Messwerte kommen zwar an, zumindest zeigt ubidots immer aktuelle Messwerte, aber eben keine Messreihen. Selbst ein neuer Token hat keinen Effekt. In der Übersicht der Variablen steht nur 'No Data Available'.

Jetzt weiss ich nicht, ob es an der iSpindel liegt oder an ubidots? Naja, auf jeden Fall bei mir, aber ich weiss nicht, wo ich noch suchen soll.

Ich habe einen ubidots for education account mit aktuell ca. 1800 credits.
[...]
Nach einem Wechsel zu, bzw. Neuanmeldung an einem STEM-Account funktioniert das Speichern der Datenreihen wieder. Offenbar war mein alter 'Ubidots for education'-Account nicht mehr zu gebrauchen.

In das Feld "Path / URI" habe ich "https://things.ubidots.com" eingetragen.

Der Hinweis zu dem STEM-Account kam von der FAQ auf Ubidots:
https://help.ubidots.com/en/articles/39 ... th-ubidots

Der STEM-Account scheint kostenlos zu sein und bietet auf den ersten Blick auch bessere Konfigurationsmöglichkeiten der Widgets.

Also im Moment alles wieder gut, bzw. sogar besser. Danke für die Rückmeldungen.

Jan

Benutzeravatar
bieratenschreck
HBCon Supporter
HBCon Supporter
Beiträge: 174
Registriert: Donnerstag 16. November 2017, 16:57
Wohnort: Nürnberger Land

Re: iSpindel - Aufbau und Betrieb

#3277

Beitrag von bieratenschreck » Montag 13. Juli 2020, 14:30

Danke @Römergärtenbier für die Info!
Bei mir das gleiche Verhalten: "No Data Available"
Wäre ja nett gewesen, wenn die Ubidotsler vorher Bescheid gegeben hätten. Einfach so im laufenden Betrieb die Verbindung kappen. Auch wenn es nix kostet. Macht man nicht.
Jetzt kann ich meine Spindel wieder aus der Würze fischen und neu konfigurieren. :Angry
Ich glaub', jetzt ist der Moment gekommen, auf die Brewfather-App umzusteigen.
Gruß
Christian

Benutzeravatar
Braufex
HBCon Supporter
HBCon Supporter
Beiträge: 886
Registriert: Montag 6. August 2018, 22:22
Wohnort: Kreis Augsburg

Re: iSpindel - Aufbau und Betrieb

#3278

Beitrag von Braufex » Montag 13. Juli 2020, 14:42

bieratenschreck hat geschrieben:
Montag 13. Juli 2020, 14:30
Bei mir das gleiche Verhalten: "No Data Available"
Servus Christian,
auch bei mir das gleiche Problem.
Er zeigt mir allerdings den letzten (neuesten) Wert immer noch im programmierten Intervall an; nur die Historie funktioniert nicht.
Wenn Du Dir für den aktuellen Sud die Werte mitschreibst, kannst Du sie noch schwimmen lassen.

Da bei mir die Werte aus der iSpindel von Stephans Rasp-Server abgerufen werden und von dort aus zwischengespeichert und dann an Ubidots weitergeleitet werden, muss ich mich wieder in die Server-Konfig einlesen :puzz
Graust mir jetzt schon davor ... :Pulpfiction

Schön, dass die Werte auf dem Rasp-Pi nicht verloren sind.
Danke Stephan (Tozzi) :thumbup

Gruß Erwin

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1396
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3279

Beitrag von JackFrost » Montag 13. Juli 2020, 14:59

Willst du die Daten per Server ändern ?
Wenn nein hast du doch alles auf dem Server und wenn sie frei ist
einfach schnell ändern.

Die Variante mit dem TCP Server hat den Charm das man nicht von externen abhängig ist.
Mit eine Fritzbox kann man ein VPN machen und die Daten auch von extern sehen.

Und für die meisten anderen Router kann man auf dem Raspi einen StrongSwan aufsetzen und da dann den VPN Server.

Oder halt ohne Verschlüsselung einfach den Port im Router freigeben und auch von extern die Daten sehen.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
Braufex
HBCon Supporter
HBCon Supporter
Beiträge: 886
Registriert: Montag 6. August 2018, 22:22
Wohnort: Kreis Augsburg

Re: iSpindel - Aufbau und Betrieb

#3280

Beitrag von Braufex » Montag 13. Juli 2020, 20:31

Servus JackFrost,
danke für Deine Antwort.
JackFrost hat geschrieben:
Montag 13. Juli 2020, 14:59
Willst du die Daten per Server ändern ?
Wenn nein hast du doch alles auf dem Server und wenn sie frei ist
einfach schnell ändern.
Wenn sie frei ist? Wen meinst Du?
Ich muss halt, nach Umstieg auf den STEM-Account, die neuen Ubidots-Anmeldedaten mit Token etc. auf dem Rasp-Server eingeben, damit er sie zu Ubidots weiterleitet.
Da für mich (als langjähriger C64/DOS/Windows-Nutzer) Linux leider immer noch ein fast schwarzes Loch in der Betriebssystemwelt ist, tu ich mir da halt ein bisserl schwer und muss mich mit Stephans Anleitung wieder komplett neu einlesen.
Die Variante mit dem TCP Server hat den Charm das man nicht von externen abhängig ist.
Genau, ist für mich eine Datensicherung im Haus, falls Ubidots nicht mehr läuft; wie jetzt gerade ...
Mit einer Fritzbox kann man ein VPN machen und die Daten auch von extern sehen.
Möchte eigentlich wegen einer leichte Paranoia keinen Zugang von außen auf die Fritz!Box freischalten.
Auch wenn der Gedanke komplett auf Ubidots zu verzichten, schon seinen Reiz hat.
Dann müsste ich allerdings eine Visualisierungs/Trend-Software installieren - und da ist sie wieder, meine Linux-Liebe :Wink
Und für die meisten anderen Router kann man auf dem Raspi einen StrongSwan aufsetzen und da dann den VPN Server.
Oder halt ohne Verschlüsselung einfach den Port im Router freigeben und auch von extern die Daten sehen.
Wie gesagt, hab da Bedenken mit Zugriffen von außen auf meine Fritz!Box ... :Pulpfiction

Gruß Erwin

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1396
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3281

Beitrag von JackFrost » Montag 13. Juli 2020, 21:07

Braufex hat geschrieben:
Montag 13. Juli 2020, 20:31
Servus JackFrost,
danke für Deine Antwort.


Wenn sie frei ist? Wen meinst Du?
Ich muss halt, nach Umstieg auf den STEM-Account, die neuen Ubidots-Anmeldedaten mit Token etc. auf dem Rasp-Server eingeben, damit er sie zu Ubidots weiterleitet.
Ich meinte die iSpindel.
Braufex hat geschrieben:
Montag 13. Juli 2020, 20:31
Da für mich (als langjähriger C64/DOS/Windows-Nutzer) Linux leider immer noch ein fast schwarzes Loch in der Betriebssystemwelt ist, tu ich mir da halt ein bisserl schwer und muss mich mit Stephans Anleitung wieder komplett neu einlesen.
in der Version von MrHyde ist alles drinnen,was man braucht. Einfach per Git clone ziehen und starten. Die Webseite ist da auch schon dabei. Ist also nicht so viel zum einlesen. Wenn du hilfe brauchst, melde dich einfach.
Braufex hat geschrieben:
Montag 13. Juli 2020, 20:31
Die Variante mit dem TCP Server hat den Charm das man nicht von externen abhängig ist.
Genau, ist für mich eine Datensicherung im Haus, falls Ubidots nicht mehr läuft; wie jetzt gerade ...
Mit einer Fritzbox kann man ein VPN machen und die Daten auch von extern sehen.
Möchte eigentlich wegen einer leichte Paranoia keinen Zugang von außen auf die Fritz!Box freischalten.
Auch wenn der Gedanke komplett auf Ubidots zu verzichten, schon seinen Reiz hat.
Dann müsste ich allerdings eine Visualisierungs/Trend-Software installieren - und da ist sie wieder, meine Linux-Liebe :Wink
Die Visualisierung ist beim TCP-Server schon dabei. Das ist ja das schöne.
Der Vorteil vom VPN ist das man ja einen Key und einen PW braucht. Es gibt das PSK das im Handy hinterlegt ist und ein Passwort das du immer eintippen musst. Ohne beides geht es nicht.
Vorallem brauchst du ja noch einen DNS Account der auf deine FB zeigt. Ohne die IP kann auch keiner per BruteForce Versuchen auf die Daten
zu kommen. Aber das PSK ist länger als 12 Zeichen. Das ist nicht ganz so einfach.
DEr große Vorteil an einem VPN ist, wenn man in einem anderen WLAN ist kann man sich per VPN nach Hause einwählen und die Verbindungn ist dann um längen sicherer als in einem anderen WLAN. Ich nutze das immer im Hotel. Ich trau keinem WLAN das ich nicht unter meiner Kontrolle habe.
Und für die meisten anderen Router kann man auf dem Raspi einen StrongSwan aufsetzen und da dann den VPN Server.
Oder halt ohne Verschlüsselung einfach den Port im Router freigeben und auch von extern die Daten sehen.
Wie gesagt, hab da Bedenken mit Zugriffen von außen auf meine Fritz!Box ... :Pulpfiction

Gruß Erwin
[/quote]
Mit einer FB bräuchte man eh keinen IPsec Server. Die FB könnte das schon von alleine.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Antworten