iSpindel - Aufbau und Betrieb

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1473
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3301

Beitrag von JackFrost » Mittwoch 29. Juli 2020, 09:14

Wenn das WLAN vom Wemos nicht erscheint wenn er per USB angeschlossen ist, dann ist was faul.

DIe DIode am Wemos hast du ausgelötet, oder ?
Wenn ja , dann darf der Wemos nicht an den USB wenn auf der Platine von der iSpindel drauf ist.
Wird es besser wenn du die Spindel lädst und versuchst dich mit dem WLAN zu verbinden ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 6980
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#3302

Beitrag von DerDerDasBierBraut » Mittwoch 29. Juli 2020, 09:42

Versuche es nach dem Laden mal mit einem Smartphone. Damit fällt es vielen leichter sich zu verbinden.

In der Advanced Pages des Flash-Tools braucht nichts konfiguriert zu werden.
https://braumagazin.de/article/ispindel-der-aufbau/
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Luv_ige
Neuling
Neuling
Beiträge: 9
Registriert: Dienstag 28. Juli 2020, 12:25

Re: iSpindel - Aufbau und Betrieb

#3303

Beitrag von Luv_ige » Mittwoch 29. Juli 2020, 21:16

JackFrost hat geschrieben:
Mittwoch 29. Juli 2020, 09:14
Wenn das WLAN vom Wemos nicht erscheint wenn er per USB angeschlossen ist, dann ist was faul.

DIe DIode am Wemos hast du ausgelötet, oder ?
Wenn ja , dann darf der Wemos nicht an den USB wenn auf der Platine von der iSpindel drauf ist.
Wird es besser wenn du die Spindel lädst und versuchst dich mit dem WLAN zu verbinden ?

Gruß JackFrost
Ich habe es nochmals ueberprueft und wenn er per USB angeschlossen ist erscheint das WLAN vom Wemos nicht. Sobald ich den USB Kabel entferne und die Reset taste druecke (2x/ 3x) erscheint wieder die iSpindel WLAN aber wenn ich drauf klicke kann er sich nicht verbinden.

Die Diode am Wemos habe ich entfernt.
Wie meinst du besser?

Luv_ige
Neuling
Neuling
Beiträge: 9
Registriert: Dienstag 28. Juli 2020, 12:25

Re: iSpindel - Aufbau und Betrieb

#3304

Beitrag von Luv_ige » Mittwoch 29. Juli 2020, 21:30

DerDerDasBierBraut hat geschrieben:
Mittwoch 29. Juli 2020, 09:42
Versuche es nach dem Laden mal mit einem Smartphone. Damit fällt es vielen leichter sich zu verbinden.

In der Advanced Pages des Flash-Tools braucht nichts konfiguriert zu werden.
https://braumagazin.de/article/ispindel-der-aufbau/
Ich habe es mit Android und iOS Smartphone versucht, leider immer gleicher resultat. Ich sehe die WLAN aber keine Verbindung moeglich.
Unterdessen habe ich schon alle konfigurationen in Advanced ausprobiert aber ohne loesung.

Noch ein paar infos dazu:
- Ich montiere den Wemos D1 Mini V3.0.0 WIFI Internet ESP8266 CH340G
- Habe noch folgende messungen auf den DS18B20 gemacht:
PIN 3 (VDD) - GND --> 3,6V
PIN 2 (DQ)- PIN 5 (WEMOS D6) hat verbindungen.

Schema, Part-list und instruction habe ich alles von hier genommen : https://www.opensourcedistilling.com/ispindel/

Ich lese ueberall das moeglicherweise den DS18B20 das problem sein kann, aber ich sehe hier nichts falsch.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1473
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3305

Beitrag von JackFrost » Mittwoch 29. Juli 2020, 21:32

Das WLAN vom ESP muss auch bleiben wenn er per USB mit dem PC verbunden ist.
Der PC geht ja blos auf den CH340 Chip.

Wenn du die Spindel am Ladecontroller lädst und auch am PC per USB bist, ist es dann besser. Ist das WLAN
dann auch da wenn du mit dem PC verbunden bist ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Luv_ige
Neuling
Neuling
Beiträge: 9
Registriert: Dienstag 28. Juli 2020, 12:25

Re: iSpindel - Aufbau und Betrieb

#3306

Beitrag von Luv_ige » Mittwoch 29. Juli 2020, 21:45

JackFrost hat geschrieben:
Mittwoch 29. Juli 2020, 21:32
Wenn du die Spindel am Ladecontroller lädst und auch am PC per USB bist, ist es dann besser. Ist das WLAN
dann auch da wenn du mit dem PC verbunden bist ?

Gruß JackFrost
Mit Ladecontroller und USB gleichzeitig verbunden geht es besser. Ich sehe das WLAN aber leider kann ich mich immer noch nicht verbinden.
Ich habe es unterdessen auch mit Putty untersucht und folgendes:

FW 6.3.1
2.2.2-dev(38a443e)
Worker run!
mounting FS... ERROR: failed to mount FS!

ERROR config corrupted
scanning for OW device on pin: 5
No devices found!
scanning for OW device on pin: 12
Found device with ROM = 28 8F 5E 35 C 0 0 95
Chip = DS18B20
Data = 1 CF 1 4B 46 7F FF 1 10 5D CRC=5D
Temperature = 28.94 Celsius,
offsets not available
Boot-Mode: External System
power-cycle or reset detected, config mode

Double Reset detected
...........
ERROR no Wifi credentials

going to Config Mode
ERROR: OW DISCONNECTED
OW Retry
*WM: Scan done
*WM: No networks found
*WM: Adding parameter
*WM: name
*WM: Adding parameter
*WM: sleep
*WM: Adding parameter
*WM: vfact
*WM: Adding parameter
*WM:
*WM: Adding parameter
*WM:
*WM: Adding parameter
*WM: tempscale
*WM: Adding parameter
*WM:
*WM: Adding parameter
*WM:
*WM: Adding parameter
*WM: selAPI
*WM: Adding parameter
*WM: token
*WM: Adding parameter
*WM: server
*WM: Adding parameter
*WM: port
*WM: Adding parameter
*WM: channel
*WM: Adding parameter
*WM: uri
*WM: Adding parameter
*WM: db
*WM: Adding parameter
*WM: username
*WM: Adding parameter
*WM: password
*WM: Adding parameter
*WM: job
*WM: Adding parameter
*WM: instance
*WM: Adding parameter
*WM:
*WM: Adding parameter
*WM: POLYN
started Portal
*WM: SET AP
*WM:
*WM: Configuring access point...
*WM: iSpindel
*WM: AP IP address:
*WM: 192.168.4.1
*WM: HTTP server started
ERROR: OW DISCONNECTED
OW Retry
ERROR: OW DISCONNECTED
OW Retry
ERROR: OW DISCONNECTED
OW Retry
ERROR: OW DISCONNECTED
OW Retry
ERROR: OW DISCONNECTED
OW Retry
ERROR: OW DISCONNECTED

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1473
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3307

Beitrag von JackFrost » Mittwoch 29. Juli 2020, 21:56

Der DS18B20 hat ein Problem und vermutlich der Ladecontroller.
Miss bitte mal ohne das der PC und das Ladekabelangeschlossen ist die Spannung zwischen B- und Out-.

Oder hast du einen anderen Ladecontroller ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Luv_ige
Neuling
Neuling
Beiträge: 9
Registriert: Dienstag 28. Juli 2020, 12:25

Re: iSpindel - Aufbau und Betrieb

#3308

Beitrag von Luv_ige » Donnerstag 30. Juli 2020, 17:23

JackFrost hat geschrieben:
Mittwoch 29. Juli 2020, 21:56
Der DS18B20 hat ein Problem und vermutlich der Ladecontroller.
Miss bitte mal ohne das der PC und das Ladekabelangeschlossen ist die Spannung zwischen B- und Out-.

Oder hast du einen anderen Ladecontroller ?

Gruß JackFrost
Ich vermute auch das es ein Problem der DS18B20 ist. Ich bin die Leiterplatte am untersuchen weil mein verdacht ist, das es hier mit den leiterbahnen etwas falsch ist (Polarität beim DS18B20 vielleicht Verkehrt). Ich muss das alles besser überprüfen und werde dann gleich alle Messungen hier aufschreiben.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1473
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#3309

Beitrag von JackFrost » Freitag 31. Juli 2020, 14:24

Ich hab die von mir erstellten Platinen bestellt.
Für die Platine braucht es einen Schlitten.

Mit einem Wemos ohne Diode, hat die Platine nur THT-Bauteile und eine Lötbrücke.
Wer die Diode nicht ausbauen will, der muss ein SMD Bauteil löten, das ist eine Ideale
Diode, die die Spannung vom Akku sperrt wenn der Wemos vom USB versorgt wird.

Und wenn es den Gyro nicht mehr gibt ( für neue Designs ist der nicht mehr empfohlen ),
dann kann der Nachfolger direkt auf die Unterseite gelötet werden.

Ich muss die Platinen noch testen.
Vom Preis her dürften es ~0,6 € / Platine sein, plus Versand als Großbrief.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Antworten