iSpindel -- Hilfe bei Problemen

Antworten
JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

iSpindel -- Hilfe bei Problemen

#1

Beitrag von JackFrost » Freitag 18. Juni 2021, 13:57

Damit der Thread "iSpindel - Aufbau und Betrieb" nicht so zerpflückt wird , hab ich den Thread hier aufgemacht.

Bitte die Infos vom Wikieintrag beachten.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#2

Beitrag von Thomas2905x » Montag 21. Juni 2021, 10:32

Hallo!
Hat leider ein bisschen gedauert, aber jetzt habe ich endlich ein Multimeter und konnte die Spannungen messen:
Akku 4,22V
Ladekontroller (B- B+) 4,22V
Ladekontroller (B- OUT-) 0,00V
Schalter 0V bzw 4,22V, also OK
Wemos (3V3 GND) 0V (ist bei mir auch irgendwie nicht verbunden)
Gyro 3,34V

Sieht also eigentlich ok aus, oder?
Was kann ich noch tun?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel -- Hilfe bei Problemen

#3

Beitrag von JackFrost » Montag 21. Juni 2021, 10:44

Von den Werten her sieht es gut aus.
Wichtig ist hier ein trace, der aber erst geht wenn die Diode draussen ist. Geht am besten mit einer Heissluftstation und bisser Kaptontape. Mit dem Lötkolben geht es auch ist nur fummeliger.

Wie gesagt, du kannst sie mir ohne Akku schicken, aber ich komme erst in ca. 2 Wochen dazu. Ich würde sie mir mal anschauen
ob was nicht passt. Ich löte dir dann auch die Diode und die LED raus wenn man an die noch rann kommt.

Das blöde ist das der Wemos nicht gesteckt ist, so das man mal alleine laufen lassen kann.

Evtl. gibt es da ein Problem mit dem Flash und man muss die Software neu flashen, aber auch das geht erst wenn die Diode draußen ist.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#4

Beitrag von Thomas2905x » Montag 21. Juni 2021, 10:49

Der Hersteller meiner iSpindel meinte, ich solle den Akku entfernen wenn ich sie anschließen will. Geht das so einfach mit nicht ausgebauter Diode?

btw: Hab nochmal 3V3 gegen GND am Wemos richtig gemessen und es kam 3,33V raus (falls das hilft).

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#5

Beitrag von Thomas2905x » Montag 21. Juni 2021, 10:56

Und so sieht das Flackern der LED am Wemos aus. Ist das ein "normales Signal"?
Dateianhänge
iSpindel flackern.mp4
(1.12 MiB) 9-mal heruntergeladen

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel -- Hilfe bei Problemen

#6

Beitrag von JackFrost » Montag 21. Juni 2021, 10:58

Thomas2905x hat geschrieben:
Montag 21. Juni 2021, 10:56
Und so sieht das Flackern der LED am Wemos aus. Ist das ein "normales Signal"?
Nein, das ist nicht normal, die leuchtet so lange sie aktiv ist und geht wieder aus. Vermutlich bootet sie und kommt über einen Punkt nicht raus.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel -- Hilfe bei Problemen

#7

Beitrag von JackFrost » Montag 21. Juni 2021, 11:01

Thomas2905x hat geschrieben:
Montag 21. Juni 2021, 10:49
Der Hersteller meiner iSpindel meinte, ich solle den Akku entfernen wenn ich sie anschließen will. Geht das so einfach mit nicht ausgebauter Diode?

btw: Hab nochmal 3V3 gegen GND am Wemos richtig gemessen und es kam 3,33V raus (falls das hilft).
Die 5V liegen dann am Ausgang vom Lade IC an. Lautdatenblatt darf am BAT Pin eine Spannung von maximal 7V anliegen. Du kannst es versuchen, ob dann was geht. Evtl. hat der Wemos ein Problem. Wenn du flashen kannst, dann nimmdie 6.5.1 und nicht die neueren.

Normal sollte man aber die Diode entfernen, da man dann den Akku nicht überladen kann.
Ich hab für den alten Schlitten eine Platine gemacht mit einer Idealen Diode, wo man die Diode vom Wemos nicht entfernen muss, aber da bin ich noch nicht zum bestellen der Platinen gekommen, nachdem die erste Version einen Fehler hatte.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#8

Beitrag von Thomas2905x » Montag 21. Juni 2021, 11:25

Ok, ich versuche es später mal mit neu flashen.

Einen Trace hatte ich letzte Woche schon versucht zu machen, aber das hatte auch nicht geklappt. (Es passierte einfach nichts wenn ich den Reset Knopf gedrückt habe. Allerdings hörte das Flackern der Wemos-LED auf sobald ich die Verbindung mit Putty geöffnet hatte.) Das könnte aber an einer geschrottetet Firmware liegen, oder?

Zum Entfernen der Diode: Heissluftstation und KaptontapeIst sind schon ganz spezielle Dinge, oder kann man das auch mit "Hausmitteln" bewerkstelligen? Ist das irgendwo erklärt oder kannst du darauf ggf. etwas genauer eingehen?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel -- Hilfe bei Problemen

#9

Beitrag von JackFrost » Montag 21. Juni 2021, 13:49

Thomas2905x hat geschrieben:
Montag 21. Juni 2021, 11:25
Ok, ich versuche es später mal mit neu flashen.

Einen Trace hatte ich letzte Woche schon versucht zu machen, aber das hatte auch nicht geklappt. (Es passierte einfach nichts wenn ich den Reset Knopf gedrückt habe. Allerdings hörte das Flackern der Wemos-LED auf sobald ich die Verbindung mit Putty geöffnet hatte.) Das könnte aber an einer geschrottetet Firmware liegen, oder?

Zum Entfernen der Diode: Heissluftstation und KaptontapeIst sind schon ganz spezielle Dinge, oder kann man das auch mit "Hausmitteln" bewerkstelligen? Ist das irgendwo erklärt oder kannst du darauf ggf. etwas genauer eingehen?
Mit dem Lötkolben gehts auch aber da braucht man besser eine Pinzette. Baumarkt Heissluftföhn soll auch gehen, aber da muss man gut geübt haben.
Der bläst sonst zu viele Bauteile weg. Umliegende Bereiche muss man da mit Alufolie abdecken.

Wenn der Wemos defekt sein sollte, dann muss man beim Auslöten die Stifte erst durschneiden und dann die Stifte einzeln auslöten, sonst läuft man Gefahr das man die Lötaugen abreisst.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#10

Beitrag von Thomas2905x » Dienstag 22. Juni 2021, 08:40

Moin,
ich habe gestern Abend versucht meine iSpindel zu flashen, aber das hat auch nicht funktioniert. Der Flasher hat zwar den COM-Port automatisch erkannt, aber keine MAC-Adressen angezeigt. Beim Flashen ist dann (wie auch beim Verbinden via Putty) die LED am Wemos ausgegangen, aber der Fortschrittbalken hat sich Minuten lang nicht bewegt.
Hilft das einzugrenzen, was genau kaputt ist? Wahrscheinlich der Wemos, oder?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel -- Hilfe bei Problemen

#11

Beitrag von JackFrost » Mittwoch 23. Juni 2021, 06:00

Thomas2905x hat geschrieben:
Dienstag 22. Juni 2021, 08:40
Moin,
ich habe gestern Abend versucht meine iSpindel zu flashen, aber das hat auch nicht funktioniert. Der Flasher hat zwar den COM-Port automatisch erkannt, aber keine MAC-Adressen angezeigt. Beim Flashen ist dann (wie auch beim Verbinden via Putty) die LED am Wemos ausgegangen, aber der Fortschrittbalken hat sich Minuten lang nicht bewegt.
Hilft das einzugrenzen, was genau kaputt ist? Wahrscheinlich der Wemos, oder?
Das sieht nach dem Wemos aus.
Versuche es nochmal und wenn sich der Balken nicht bewegt, dann drücke mal den Reset. Wenn er da keine Mac Adresse anzeigt, dann kann er den Wemos nicht starten.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#12

Beitrag von Thomas2905x » Mittwoch 23. Juni 2021, 09:27

Habe ich versucht. Schalter an, Schalter aus, Reset gedrückt, Stecker rein, raus ... Bringt leider alles nicht.
Also müsste ich den Wemos austauschen? :Shocked

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#13

Beitrag von Thomas2905x » Mittwoch 23. Juni 2021, 09:28

PS: alles ohne Akku, da bei mir die Diode ja nicht ausgebaut ist

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel -- Hilfe bei Problemen

#14

Beitrag von JackFrost » Mittwoch 23. Juni 2021, 17:32

Thomas2905x hat geschrieben:
Mittwoch 23. Juni 2021, 09:27
Habe ich versucht. Schalter an, Schalter aus, Reset gedrückt, Stecker rein, raus ... Bringt leider alles nicht.
Also müsste ich den Wemos austauschen? :Shocked
Dann ist es vermutlich der ESP. Wenn er ausgelötet ist kann man ihn nochmal testen.

Du brauchst :
Kleinen Seitenschneider
Lötkolben
Pinzette oder kleine Spitzzange
Entlötpumpe

Entlötlitze geht bei den doppelseitigen Platinen schlecht.

Die Pins auf der Seite der gelben Platine so nah wie möglich am schwarzen abschneiden. Wenn der Wemos dann weg ist , die Lötpunkte einzeln erwärmen und wenn das Zinn flüssig ist den Stift mit der Pinzette ziehen. Dann gleich mit der Entlötpumpe das Loch frei saugen.

Zum Einlöten dann:
Lötkolben
Bleifreies Zinn
Flussmittel

Wenn nur bleihaltiges da ist geht das auch, gibt aber eine Mischlegierung.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Thomas2905x
Posting Junior
Posting Junior
Beiträge: 16
Registriert: Freitag 18. Juni 2021, 00:46

Re: iSpindel -- Hilfe bei Problemen

#15

Beitrag von Thomas2905x » Freitag 25. Juni 2021, 23:26

Also erst nochmal: Danke für die viele Unterstützung!!!

Aber das ganze Werkzeug habe ich nicht und kann es wohl auch nicht bei jemand ausleihen. Und ich bin mir auch nicht sicher ob ich das überhaupt hin kriegen würde.
Deshalb: Mag jemand meine defekte iSpindel haben zum selbst reparieren?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 2292
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel -- Hilfe bei Problemen

#16

Beitrag von JackFrost » Samstag 26. Juni 2021, 07:59

Thomas2905x hat geschrieben:
Freitag 25. Juni 2021, 23:26
Also erst nochmal: Danke für die viele Unterstützung!!!

Aber das ganze Werkzeug habe ich nicht und kann es wohl auch nicht bei jemand ausleihen. Und ich bin mir auch nicht sicher ob ich das überhaupt hin kriegen würde.
Deshalb: Mag jemand meine defekte iSpindel haben zum selbst reparieren?
Schick sie mir ich repariere sie dir und ich schick sie dir zurück -Der Preis für einen Wemos sind ein paar € und der Versand.
Alles weitere dann per PN. wenn du willst.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Antworten