iSpindel - Aufbau und Betrieb

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2151

Beitrag von DerDerDasBierBraut » Dienstag 3. April 2018, 08:34

Das ist normal. Die Config wird nicht in den Flashspeicher geschrieben, wenn der Temperatursensor nicht erkannt wird. Sobald Das "-127°C Problem" weg ist wird es funktionieren.
Wegen des Zeitpunkts beim Anzeigen der MAC Adressen muss ich nochmal schauen und den Artikel im Braumagazin notfalls korrigieren. Danke für den Hinweis.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2152

Beitrag von wwershofen » Dienstag 3. April 2018, 20:28

So, das Problem mit dem Temp-Sensor ist gelöst. Damit war auch das Problem verbunden, dass er die Wifi-Einstellungen nicht abgespeichert hat.

Bei mir war es ein Kurzschluss, den ich beim Löten verursacht hatte. Konnte ich nur unter Einsatz einer Lupe erkennen... meine Augen sind auch nicht mehr das, was sie mal waren... :puzz

Nun schauen testen wir mal, wie wir das Teil getrimmt bekommen. :thumbsup

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2153

Beitrag von wwershofen » Mittwoch 4. April 2018, 16:28

Hab mal ne Frage zur Kalibirierung:

Die Spindel funktioniert jetzt einwandfrei, hat in Leitungswasser einen Tilt von ca. 23° und zur weiteren Kalibirierung habe ich den Petling jetzt mal in ein vor 3 Tagen gebrautes Jungbier verfrachtet. Mit dem Refraktometer habe ich dabei 6 Brix gemessen, die Stammwürze beim Anstellen waren 13,6 Brix gewesen.
Wenn ich jetzt den Refraktometer-Wert mit dem MMM-Rechner in Plato umrechne, welchen Restextrakt soll ich für die Bestimmung meiner Kalibrierungsformel verwenden - den scheinbaren oder den tatsächlichen? Mein Gefühl sagt mir, dass ich den scheinbaren verwenden sollte, weil dieser ja laut Beschreibung dem Messergebnis einer Bierspindel entsprechen sollte.

Irgendwelche Tipps?

Danke und viele Grüße
Wolfgang

P.S.: Mir ist klar, dass es natürlich keine idealen Ergebnisse mit einer mitten in der Gärung begonnenen Messreihe geben kann, aber mein nächster Sud ist erst in 2 Wochen geplant und so lange wollte(konnte) ich nicht warten. :Angel

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2154

Beitrag von DerDerDasBierBraut » Mittwoch 4. April 2018, 16:33

Moin Wolfgang,
du musst den scheinbaren Vergärungsgrad nehmen. Wie überall, falls es nicht explizit anders angegeben wurde.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2155

Beitrag von Pottkieker » Mittwoch 4. April 2018, 18:03

[]
https://hobbybrauer.de/forum/download/f ... w&id=39233
Unbenannt.jpg
Hallo Zusammen, ich habe hoffe ich alle Daten richtig eingetragen, die Spindel sendet regelmäßig, ich kann in den Cofik Modus. Ich sehe leider immer noch nichts.
Gruß
Horst

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2156

Beitrag von DerDerDasBierBraut » Mittwoch 4. April 2018, 18:47

Generiere dir mal einen neuen Token Horst. Deiner steht unten auch noch ein paarmal im Screenshot .

Vielleicht löst das auch gleich das Problem. Offenbar will Ubidots den Token nicht anerkennen und antwortet daher mit "Authentifizierungsfehler".
Das kann passieren, wenn der Token generiert wurde und dann bis zum Senden der ersten Daten relativ viel Zeit vergeht.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2157

Beitrag von Pottkieker » Freitag 6. April 2018, 15:53

Vielen Dank für den Hinweis, nach Erstellung eines neuen Token sendet sie jetzt an Ubidots. Jetzt muß ich Kalibrieren
Gruß
Horst

Benutzeravatar
igami
Posting Junior
Posting Junior
Beiträge: 54
Registriert: Mittwoch 21. Februar 2018, 05:34
Wohnort: Gütersloh

Re: iSpindel - Aufbau und Betrieb

#2158

Beitrag von igami » Freitag 6. April 2018, 20:09

Anbei mal ein Bild von meiner neusten Version. Die entgültige Version wird dieses Wochenende noch gedruckt (muss noch 1 mm gekürzt werden und die Taschen für die Kabelbinder können entfallen.
IMG_20180406_165653.jpg
Der Temp Sensor sitzt nicht im Kopf, da mir die Kabelverlegung nicht so recht gefallen wollte. Es kann aber mit Unterlegscheiben getrimmt werden :D

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 3753
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2159

Beitrag von Tozzi » Freitag 6. April 2018, 21:36

Pfiffige Idee. Gefällt mir. Bin selber auch bald stolzer Besitzer eines 3D Druckers und sammle auch noch Ideen für den "perfekten" Schlitten.
Viele Grüße aus München
Stephan

Snowman
Posting Klettermax
Posting Klettermax
Beiträge: 187
Registriert: Freitag 15. August 2014, 10:00

Re: iSpindel - Aufbau und Betrieb

#2160

Beitrag von Snowman » Montag 9. April 2018, 16:59

Hallo zusammen!
Durch die Braumagazin-Artikel bin ich mittlerweile motiviert mich an die Aufgabe zu machen, mir selbst auch die iSpindel zusammen zu stellen.
Echt klasse, was ihr alle da zaubert!!
Ich habe noch nie gelötet und habe auch ein bisschen Bammel davor. Da es ja einige Engstellen auf der Platine zum Löten gibt, wollte ich folgendes nachfragen:
1. Kann/darf man die Platine irgendwie abkleben, so dass nur ein einzelner Kontakt zum Löten der Stelle frei bleibt?
2. Es gibt mittlerweile eine Platine iSpindleV2.1, auf der die Lötstellen des Temperatursensors weiter auseinander sind. Ist diese schon bei 3D-Mecha im Kauf-Paket?
Vielen lieben Dank, schonmal im Voraus!

Brauerische Grüße

Björn

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2161

Beitrag von DerDerDasBierBraut » Montag 9. April 2018, 17:41

1:
Hilft leider nicht. Eine dünne Lötspitze, hohe Temperaturen, möglichst kurze Kontaktzeiten mit der Lötstelle und wenig Lötzinn helfen.
Übe sonst vorher an irgendeinem defekten elektronischen Teil ein paar Bauteile aus- und wieder einzulöten. Da findet sich ja meistens irgendwas. :-)
2:
Nein. Ich arbeite dran, aber Stand jetzt werden die DS18B20 Kontakte wohl leider so eng beieinander bleiben. Änderungen gibt es, falls der DS18B20 irgendwann offiziell in die Petlingspitze wandert oder falls sich mal die Komponenten ändern.
Hintergrund ist, dass das aktuelle Platinenlayout nicht von Sam, Herbert oder 3D Mechatronics stammt. Das ist Layout kommt von extern. 3D Mechatronics darf die Platine - genau so wie sie ist - im Shop anbieten.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Snowman
Posting Klettermax
Posting Klettermax
Beiträge: 187
Registriert: Freitag 15. August 2014, 10:00

Re: iSpindel - Aufbau und Betrieb

#2162

Beitrag von Snowman » Montag 9. April 2018, 18:09

Danke für Deine schnelle Hilfe!
Ich werd mich dann mal ranwagen...

Liebe Grüße

Björn

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2163

Beitrag von wwershofen » Montag 9. April 2018, 20:54

Snowman hat geschrieben:
Montag 9. April 2018, 18:09
Danke für Deine schnelle Hilfe!
Ich werd mich dann mal ranwagen...

Liebe Grüße

Björn
Ist eigentlich auch für absolute Lötlaien nicht so schwierig zu bewerkstelligen. Ich hab's auch hinbekommen, auch wenn ich mir für den Temp-Sensor eine Lupe besorgen musste, um den Kurzschluss rauszubekommen, den ich beim ersten Versuch (ohne Lupe) produziert hatte.

Viel Erfolg! :thumbup

Benutzeravatar
igami
Posting Junior
Posting Junior
Beiträge: 54
Registriert: Mittwoch 21. Februar 2018, 05:34
Wohnort: Gütersloh

Re: iSpindel - Aufbau und Betrieb

#2164

Beitrag von igami » Dienstag 10. April 2018, 21:33

Anbei mal die scad und stl Datei von meiner Finalen Version.
Die Platine sitz dabei noch etwas locker, aber eigentlich stört das kaum.
Dateianhänge
iSpindel_onepart.zip
(1.43 MiB) 66-mal heruntergeladen

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2165

Beitrag von Pottkieker » Mittwoch 11. April 2018, 17:16

Kalibrieren.jpg
Hallo,
ich habe jetzt hoffentlich alles richtig gemacht ???? Die Spindel kalibriert und die Ergebnisse hoffentlich richtig eingetragen. Wie komme iche denn jetzt an eine Darstellung der Messungen?
Gruß
Horst

Benutzeravatar
Dyrdlingur
Posting Freak
Posting Freak
Beiträge: 563
Registriert: Sonntag 17. November 2013, 08:31
Wohnort: Höhenkirchen bei München

Re: iSpindel - Aufbau und Betrieb

#2166

Beitrag von Dyrdlingur » Mittwoch 11. April 2018, 18:43


Pitty
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Mittwoch 11. April 2018, 20:37

Re: iSpindel - Aufbau und Betrieb

#2167

Beitrag von Pitty » Mittwoch 11. April 2018, 21:18

Hallo,
jetzt habe ich auch die iSpindle zusammengelötet, war nach der Anleitung von 3Dmechanics gar kein Problem. Diode und LED entfernt, Akku laden - rote Diode leuchet, Akku voll blaue Diode leuchtet.
Soweit so gut. Hardware kein Problem, aber nun fängt das Drama an...
Ich habe ein MAC, deswegen habe ich mir in weiser voraussicht ein Windows Laptop ausgeliehen. Nach der Vorgehensweise von http://braumagazin.de/article/ispindel-der-aufbau/ den Treiber, das Installationstool und die Firmware gezogen, Treiber installiert Flash­tool ESP8266Flasher gestartet - aber die Spindel wird nicht erkannt!
Keine MAC Adresse die Felder bleiben schwarz. Auch ein Klicken auf Flash bringt keine Erkenntnis...
Ich habs geahnt. Immer derselbe Mist mit sowas, das verfolgt mich irgendwie.

Wo mache ich denn jetzt was falsch? Die Platine ist genau nach Schaltplan, nach Anleitung sauber verlötet. Akku lädt ja auch. Das verwendete USB Kabel wird auch zur Datenübertragung von Handys verwendet, ist wohl ein 4 adriges.

Ich weiß nicht weiter :(

Wer wollte eine montierte Spindel haben? Ich würde sie auch abgeben, wenn ich das nicht auf die Reiche bekomme!

Hammer
Posting Junior
Posting Junior
Beiträge: 32
Registriert: Donnerstag 8. Dezember 2016, 12:28

Re: iSpindel - Aufbau und Betrieb

#2168

Beitrag von Hammer » Mittwoch 11. April 2018, 21:34

Nicht verzagen wird schon werden.
Was macht den der Wemos wenn du reset drückst?
Blinkt die LED blau?

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2169

Beitrag von DerDerDasBierBraut » Mittwoch 11. April 2018, 21:50

Und... taucht dem im Windows Gerätemanager ein neuer COM Port unter "Anschlüsse COM und LPT" auf, wenn du das USB Kabel an den Wemos steckst und die iSpindel einschaltest?
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Pitty
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Mittwoch 11. April 2018, 20:37

Re: iSpindel - Aufbau und Betrieb

#2170

Beitrag von Pitty » Mittwoch 11. April 2018, 22:05

Also wenn ich es einschalte blinkt die blaue LED.

Ja, unter Anschlüsse COM und LPT erscheint USB-Seral CH340 (COM11).

Hab jetzt mal in dem Firmware Programmer den COM' Port auf COM11 umgestellt und Flash gedrückt, jetzt klappts! :)

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2171

Beitrag von DerDerDasBierBraut » Mittwoch 11. April 2018, 22:18

Schräg. Welches Windows hast du auf dem Notebook? Irgendwas uraltes?
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Pitty
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Mittwoch 11. April 2018, 20:37

Re: iSpindel - Aufbau und Betrieb

#2172

Beitrag von Pitty » Mittwoch 11. April 2018, 22:30

lach, ja WIN 7. Jedenfalls nicht 10.
Wie gesagt, ich arbeite normal am MAC, das Notebook brauche ich nur für solche Sachen, die nur unter Windows gehen...
Die Hardware der Spindel ist jedenfalls okay, wird auch nun per WIFI dargestellt.
Jetzt Kämpfe ich mit Ubidots usw ... :(

Benutzeravatar
brennenhorster
Posting Junior
Posting Junior
Beiträge: 11
Registriert: Montag 13. November 2017, 16:03
Wohnort: Langenhagen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2173

Beitrag von brennenhorster » Donnerstag 12. April 2018, 07:48

Moin,

ich hab den Schlitten von 3D Mechatronics und versuche diesen gerade zu tarieren. Ich hab aktuell einen Tilt von 21,5, was ich garnicht schlecht finde.
Ich hab allerdings das Gefühl, dass die Spindel etwas zu Tief im Wasser hängt, oder ist das egal?

Gruß

Benni
Dateianhänge
IMG_4648.jpg
Wind is erst wenn die Schafe keine Locken mehr haben....

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2174

Beitrag von DerDerDasBierBraut » Donnerstag 12. April 2018, 07:55

Das sieht ideal aus. :-)
Der schwarze Ring unterm Deckel muss nur noch ab. Sonst züchtest du dir eine Universalhaushefe in den Rillen :Wink
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
brennenhorster
Posting Junior
Posting Junior
Beiträge: 11
Registriert: Montag 13. November 2017, 16:03
Wohnort: Langenhagen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2175

Beitrag von brennenhorster » Donnerstag 12. April 2018, 08:00

Cool! Danke für die schnelle Antwort!

gruß

Benni
Wind is erst wenn die Schafe keine Locken mehr haben....

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2176

Beitrag von wwershofen » Samstag 14. April 2018, 15:26

Mal ne andere Frage: Welche Temperaturen hält die iSpindel eigentlich aus? Könnte man die auch direkt nach dem Kochen und Hopfenseihen in den Gärbottich reinschmeißen um die Abkühlung zu verfolgen und den richtigen Zeitpunkt für das Anstellen mitzubekommen? Oder würde der Petling die ca. 70-80° nicht aushalten?

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2177

Beitrag von DerDerDasBierBraut » Samstag 14. April 2018, 17:32

Nein, das geht nicht. Der Akku kann die Temperatur nicht ab.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
stefan9113
Posting Klettermax
Posting Klettermax
Beiträge: 217
Registriert: Montag 10. Juli 2006, 15:59
Wohnort: Bad Aibling

Re: iSpindel - Aufbau und Betrieb

#2178

Beitrag von stefan9113 » Samstag 14. April 2018, 18:19

Hallo zusammen,

ich brauche bitte Eure Hilfe, ich hab da mal ne dumme Frage, ich hab mir die neue Firmware draufgebügelt. Soweit gut. Kalibriert mit Gewichten im Konfigmodus, da sieht mal ja immer den Tiltwert wie er sich verändert. Bei Unibots kommt aber nur eine waagrechte Linie an, also egal im welchen Winkel die Spindel steht. Ich hab das dann im trockenen simuliert und halt entsprechend lang gewartet bis das nächste Singnal gesendet wird und den Winkel halt verändert. Was kann ich denn da falsch gemacht haben, wie gesagt im Konfigmodus ändert sich das.

viele Grüße Stefan

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2179

Beitrag von wwershofen » Samstag 14. April 2018, 19:16

DerDerDasBierBraut hat geschrieben:
Samstag 14. April 2018, 17:32
Nein, das geht nicht. Der Akku kann die Temperatur nicht ab.
Ok, ab welcher Temperatur etwa kann man die Spindel einsetzen?

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2180

Beitrag von DerDerDasBierBraut » Samstag 14. April 2018, 19:22

Ich habe kein Datenblatt zum Akku. Die grünen von Panasonic dürfen bis 45°C geladen werden, bis 50°C gelagert und bis 60 °C entladen. Das sind Maximalwerte, die keinesfalls überschritten werden sollen.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2181

Beitrag von DerDerDasBierBraut » Samstag 14. April 2018, 19:54

stefan9113 hat geschrieben:
Samstag 14. April 2018, 18:19
Bei Unibots kommt aber nur eine waagrechte Linie an, also egal im welchen Winkel die Spindel steht. Ich hab das dann im trockenen simuliert und halt entsprechend lang gewartet bis das nächste Singnal gesendet wird und den Winkel halt verändert. Was kann ich denn da falsch gemacht haben, wie gesagt im Konfigmodus ändert sich das.
Hi Stefan,

Mach das bitte noch einmal und erstelle dabei ein Trace.
Das kannst du mir per PN schicken. Möglichst in Textform und nicht als Screenshot.
https://www.youtube.com/watch?v=6xDW5Gb ... ffqmK8Je9N
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Benutzeravatar
stefan9113
Posting Klettermax
Posting Klettermax
Beiträge: 217
Registriert: Montag 10. Juli 2006, 15:59
Wohnort: Bad Aibling

Re: iSpindel - Aufbau und Betrieb

#2182

Beitrag von stefan9113 » Sonntag 15. April 2018, 07:54

danke Jens, ich versuchs und melde mich bei Dir.

viele Grüße Stefan

Benutzeravatar
PalmPower
Posting Klettermax
Posting Klettermax
Beiträge: 137
Registriert: Sonntag 3. September 2017, 11:10
Wohnort: Graz

Re: iSpindel - Aufbau und Betrieb

#2183

Beitrag von PalmPower » Sonntag 15. April 2018, 10:22

Bin jetzt auch mit der iSpindelsucht infiziert.
Leider sind die Einzelteile der iSpindel derzeit? bei Mechantronics nicht verfügbar. Ist eigentlich bekannt ob das nochmals geliefert werden kann?
LG Peter

waldi1509
Neuling
Neuling
Beiträge: 2
Registriert: Donnerstag 8. März 2018, 18:28

Re: iSpindel - Aufbau und Betrieb

#2184

Beitrag von waldi1509 » Sonntag 15. April 2018, 11:09

Hallo Leute,
ich habe ein Problem bei dem ich nicht mehr weiter komme.

Ich bin seit März im Forum eingeschrieben und hatte zwischenzeitlich zum Thema „iSpindel“ auch schon einen Kontakt mit DerDerDasBierbraut, welcher mir auch helfen konnte (Widerstand ist ausgewechselt worden, iSpindel sendet nun Daten). Nochmals dafür vielen Dank an Jens!

Aber ich habe neue Probleme mit meiner iSpindel bekommen. Wer kann mir helfen?

Der Lagesensor war ausgefallen, mir wurde im Wert Tilt nur eine 0 angezeigt. Ich hatte mich dafür entschieden nicht nur den Lagesensor, sondern auch den Wemos zu ersetzen. Nach dem Löten habe ich die Firmware 5.8.5 geflasht und die iSpindel funktionierte, die Werte wurden in Ubidots angezeigt.
Anschließend habe ich die Kalibrierung entsprechend der Excel-Tabelle vorgenommen,
siehe Anhang „Kalibrierung in Excel“
Dann die Formel aus der Excel-Tabelle in die iSpindel-Konfiguration eingetragen.

Um zu prüfen ob die Daten korrekt gesendet werden, habe ich die iSpindel erneut in reines Leitungswasser getan = 0°Plato/ Sacchariemetermessung. In Ubidots wurde der Wert -1.14°P angezeigt. Worauf ich die Polynominale in der iSpindel-Konfiguration überprüfte, in der Annahme, dass ich bei der Formelübertragung einen Wert verkehrt eingeschrieben hätte. Dabei fiel mir auf, dass in die Polynominale nach den 2. Tilt nur wirre Zeichen eingetragen sind. Siehe Anlage Polynominale nach Speichern. Auch nachdem ich die Formel erneut und vollständig eingetragen hatte, wurde mir nach dem Speichern wieder nur Wirrwarr nach den 2. Tilt angezeigt.

Was ist hier verkehrt? Was muss ich tuen damit ich korrekte Daten übermittelt bekomme?

zur Info: die gesendeten Temperaturwerte liegen nur ein Zehntel Grad über die Vergleichsmessung mit einem digitalen Küchenthermometer.

Allen die sich die Mühe machen und mir Antworten werden, schon jetzt ein dickes Dankeschön.

Allerbeste Grüße, vielen Dank und Prost!
waldi1509
Dateianhänge
iSpindl Info.jpg
iSpindl Info.jpg (29.62 KiB) 4661 mal betrachtet
Kalibrierung in excel.jpg
derived expression.jpg
Polynominal_vor Speichern.jpg
Polynominal_nach Speichern.jpg

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2185

Beitrag von DerDerDasBierBraut » Sonntag 15. April 2018, 11:32

Das Abschneiden des Polynoms in der iSpindel Konfigutation ist leider ein bekanntes Problem in den neueren Firmwareversionen. Ganz sicher ist Sam da dran. Du kannst eigentlich nur auf die Platoberechnung in Ubidots ausweichen und das Polynom (und Gravity) der iSpindel außer Acht lassen, bis eine gefixt Firmware verfügbar ist.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

waldi1509
Neuling
Neuling
Beiträge: 2
Registriert: Donnerstag 8. März 2018, 18:28

Re: iSpindel - Aufbau und Betrieb

#2186

Beitrag von waldi1509 » Sonntag 15. April 2018, 11:49

Hallo Jens,

vielen Dank für die schnelle Rückantwort. Dann warte ich mal die nächste Firmwareversion ab.

Ich habe die iSpindel zurzeit zwecks Überprüfung der Werte in Ubidots, in eine Gährung mit hinein gelegt. Die Platoberechnung in Ubidots ist zurzeit sehr ungenau. Die Werte hüpfen im 15 Minuten wild hin und her. Anbei die letzten 24 Stunden.
Dateianhänge
Kurve iSpindel.jpg
Tilt  iSpindel.jpg

Snowman
Posting Klettermax
Posting Klettermax
Beiträge: 187
Registriert: Freitag 15. August 2014, 10:00

Re: iSpindel - Aufbau und Betrieb

#2187

Beitrag von Snowman » Sonntag 15. April 2018, 14:25

Liebe iSpindel-Experten,

ich habe mir das DIY-Set ohne Schlitten bestellt und muss leider feststellen, dass zwei Teile vergessen wurden (Petling und Kabelbinder) und außerdem zwei Bauteile anders aussehen, als in der Lötanleitung.
Könnt ihr mal die Bilder begutachten und mich bestärken, dass ich richtig liege.
iSpindel alle Teile.JPG
alle Teile der Bestellung
DHT Shield.JPG
Aufschrift DHT Shield
Power3.6V.JPG
Aufschrift Power:3.6-6V
LG Björn

Benutzeravatar
Ernie
Posting Klettermax
Posting Klettermax
Beiträge: 276
Registriert: Donnerstag 24. März 2016, 15:04

Re: iSpindel - Aufbau und Betrieb

#2188

Beitrag von Ernie » Sonntag 15. April 2018, 15:04

Moin,

das DHT Shield ist ein Temperatur und Luftfeuchtigkeitssensor.
Der ist mit Sicherheit nicht richtig.

Ich sehe auf den Bilder auch kein WEMOS Modul.

Und die letzte Tüte gehört auch nicht zur ISpindle.

Da ist wohl voll was in die Hose gegangen.

Gruß
Ernie

Snowman
Posting Klettermax
Posting Klettermax
Beiträge: 187
Registriert: Freitag 15. August 2014, 10:00

Re: iSpindel - Aufbau und Betrieb

#2189

Beitrag von Snowman » Sonntag 15. April 2018, 15:51

Hallo Ernie,
danke für die schnelle Antwort.
Kann ja mal passieren... Dann wart ich einfach noch ein paar Tage. Es ging ja eh überraschend schnell.

LG Björn

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2190

Beitrag von DerDerDasBierBraut » Sonntag 15. April 2018, 17:54

Melde dich bitte bei 3D Mechatronics über das Shop Kontaktformular. Warten wird da wenig nützen :-)
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Snowman
Posting Klettermax
Posting Klettermax
Beiträge: 187
Registriert: Freitag 15. August 2014, 10:00

Re: iSpindel - Aufbau und Betrieb

#2191

Beitrag von Snowman » Sonntag 15. April 2018, 19:56

Hab ich schon erledigt. Ich meinte ja das Warten auf die richtigen/fehlenden Teile ;-)

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2192

Beitrag von wwershofen » Sonntag 15. April 2018, 22:11

Also ich bin total begeistert von der iSpindel... :thumbup

Quasi Live zu sehen, wie die Notti in der zweiten Führung nach 2 Stunden ankommt und den Sud innerhalb von 10 Stunden von knapp 11°P auf unter 4°P aufknabbert, ist schon echt faszinierend.

Bild

Wie konnte ich bisher nur ohne das Ding brauen! :thumbsup


Danke an alle, die daran mitgearbeitet haben.

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2193

Beitrag von Pottkieker » Montag 16. April 2018, 14:57

Hallo wwershofen,
wie hast du diese wunderschöne Grafik hergestellt?
Meine Spindel funktioniert wunderbar dank Hilfe aus diesem Forum, dafür nochmals vielen Dank. Aber wenn man kein Informatiker ist hat man so seine Probleme.
Gruß
Horst

Benutzeravatar
wwershofen
Posting Junior
Posting Junior
Beiträge: 86
Registriert: Dienstag 13. Dezember 2016, 22:28
Wohnort: Süderheistedt, Dithmarschen
Kontaktdaten:

Re: iSpindel - Aufbau und Betrieb

#2194

Beitrag von wwershofen » Montag 16. April 2018, 23:28

Die ist aus meinem Ubidots-Dashboard.

Ist eigentlich keine Hexerei und Informatik braucht man dafür auch nicht studiert haben (obwohl ich das tatsächlich mal getan habe. :Smile )

Viele Grüße
Wolfgang

Pottkieker
Posting Junior
Posting Junior
Beiträge: 14
Registriert: Dienstag 6. März 2018, 10:17

Re: iSpindel - Aufbau und Betrieb

#2195

Beitrag von Pottkieker » Dienstag 17. April 2018, 14:42

Hallo Wolfgang,
vielen Dank für die schnelle Antwort. Ich bekomme "nur" die Informationen aus den Devices dargestellt, die Berechnung in Plato leider nicht.
Gruß
Horst

Benutzeravatar
DerDerDasBierBraut
Posting Freak
Posting Freak
Beiträge: 4396
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2196

Beitrag von DerDerDasBierBraut » Dienstag 17. April 2018, 14:57

Moin Horst.

Hier ist die passende Lektüre:
https://github.com/universam1/iSpindel/ ... .md#formel

Nach dem Einlesen und dem bestimmen des Polynoms (Plato Formel) gibt es hier noch ein kurzes Video:
https://youtu.be/p8WC3nD3rYk?list=PLtYV ... ffqmK8Je9N
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Snowman
Posting Klettermax
Posting Klettermax
Beiträge: 187
Registriert: Freitag 15. August 2014, 10:00

Re: iSpindel - Aufbau und Betrieb

#2197

Beitrag von Snowman » Samstag 21. April 2018, 13:40

Hallo!
Ich möchte mich an dieser Stelle mal so richtig ausgiebig bedanken bei allen, die zu diesem tollen Projekt beitragen! Ihr seid echt der Wahnsinn! Was mich so begeistert, ist euer Enthusiasmus allen Lesern euer Wissen und Können gratis weiter zu geben. Wow! Danke, Danke.
Ich habe mir diese Woche meine erste iSpindel erfolgreich zusammengebaut, obwohl ich davor noch nie einen Lötkolben in der Hand hatte.

Mein Tipp für den Temperatursensor: Nehmt drei einzelne Stifte und lötet diese auf die Platine. Vorher Stift anzinnen und einsetzen. Sitzt der Stift fest in der Platine, kann man davon ausgehen, dass auch der Kontakt passt. Und man hantiert nicht mit dem Lötzinn auf der Platine rum.
So hat man ein bisschen mehr Raum beim Arbeiten und kann es gemütlich in mehreren Schritten machen.
Außerdem ist so auch die Verlegung des Temperatursensors in die Spitze leicht möglich.


Lg Björn
Dateianhänge
63F6C848-1E61-4EC2-95FF-18B0DA399EA3.jpeg
649BDA67-2A54-46DE-8B51-064572287ECC.jpeg

rollie
Posting Junior
Posting Junior
Beiträge: 37
Registriert: Dienstag 3. Januar 2012, 15:27

Re: iSpindel - Ubidots

#2198

Beitrag von rollie » Dienstag 24. April 2018, 21:06

Hallo,

habe heute meine fertig gebaute iSpindel bekommen. Da ich leider der englischen Sprache nicht mächtig bin, habe ich jetzt das Problem das gute Stück mit Ubidots zu verbinden und richtig einzustellen.
Gibt es hier irgendwo eine allgemein verständliche Anleitung? Habe selber leider nichts verständliches für mich gefunden.

Danke für jeden Hinweis bzw. ausführliche Beschreibungen.

Gruß
Wolfgang

Hammer
Posting Junior
Posting Junior
Beiträge: 32
Registriert: Donnerstag 8. Dezember 2016, 12:28

Re: iSpindel - Aufbau und Betrieb

#2199

Beitrag von Hammer » Dienstag 24. April 2018, 21:10

Hallo Wolfgang,

Meinst du so etwas?

https://youtu.be/p8WC3nD3rYk?list=PLtYV ... ffqmK8Je9N

Jens hat hierfür mal ein Video gemacht.
Grüße
Stefan

rollie
Posting Junior
Posting Junior
Beiträge: 37
Registriert: Dienstag 3. Januar 2012, 15:27

Re: iSpindel - Aufbau und Betrieb

#2200

Beitrag von rollie » Dienstag 24. April 2018, 21:23

Hallo Stefan,

danke, aber das reicht mir noch nicht. Gibt es so etwas auch Schritt für Schritt in schriftlicher Form von Anfang an? (ab Anmeldung bei Ubidots)

Gruß
Wolfgang

Antworten