iSpindel - Aufbau und Betrieb

Benutzeravatar
quasarmin
Posting Senior
Posting Senior
Beiträge: 451
Registriert: Montag 25. Januar 2016, 18:14
Wohnort: Eckernförde

Re: iSpindel - Aufbau und Betrieb

#2251

Beitrag von quasarmin » Mittwoch 13. Juni 2018, 20:44

JackFrost hat geschrieben:
Mittwoch 13. Juni 2018, 06:40

Hi,

Bei dem DS18B20 klingt das nach einem Timingproblem. Ggf. Ist an dem Wemos was anders so das die Bitzeiten für den Onewire Bus nicht mehr passen.

Ich gehe davon aus das du keinen billigen Logicanalyser oder gar ein Oszilloskop hast ?

Kannst du mal ein Bild von der Oberseite des Wemos D1 Mini Posten ? Nicht das es durch die beiden Revisionen Probleme gibt.

Gruß JackFrost
Anbei ein Bild von dem Wemos D1 Mini. Das Problem tritt wie gesagt immer bei der selben Hardware auf, je nachdem welche Firmware ich aufspiele.
Mit der Version 4.1.2 konnte ich inzwischen Verbindung mit dem Lokalen Server herstellen, da lag der Fehler zwischen den Ohren.
Nur die 5+ Versionen wollen die Konfiguration einfach nicht speichern.

Gruß
Armin
IMG_1307.jpg

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2252

Beitrag von DerDerDasBierBraut » Mittwoch 13. Juni 2018, 21:42

Hi Armin, die Rückseite des Wemos offenbart die Version :-)
V1 und V2 kann man an den SMD Widerständen unterscheiden. V3.0 wäre aufgedruckt.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1555
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#2253

Beitrag von JackFrost » Mittwoch 13. Juni 2018, 22:36

Hi,

#define DEVICE_DISCONNECTED_C -127

Die Meldung wird gebracht wenn die Adresse vom DS18b20 nicht gelesen werden kann, oder wenn die Daten nicht passen. Du kennst keinen der dir die Bitzeiten mal messen kann, oder ?


need to format SPIFFS: 0

Code: Alles auswählen



void formatSpiffs()
{
  CONSOLE(F("\nneed to format SPIFFS: "));
  SPIFFS.end();
  SPIFFS.begin();
  CONSOLELN(SPIFFS.format());
}

bool FS::format() {
    if (!_impl) {
        return false;
    }
    return _impl->format();
}

 // if SPIFFS is not usable
  if (!SPIFFS.begin() || !SPIFFS.exists(CFGFILE) ||
      !SPIFFS.open(CFGFILE, "w"))
    formatSpiffs();
Es sieht so aus als gäbe es den Pointer _impl nicht bzw es scheint ein Nullpointer zu sein.

Code: Alles auswählen

bool FS::begin() {
    if (!_impl) {
        return false;
    }
    return _impl->begin();
}

CONSOLE(F("mounting FS..."));

  if (SPIFFS.begin())
  { ... }
  
   else
  {
    CONSOLELN(F(" ERROR: failed to mount FS!"));
    return false;
  }
Das gleiche ist hier.

Welche Einstellungen ist beim Firmwareupdater bei Advanced drinnen ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
quasarmin
Posting Senior
Posting Senior
Beiträge: 451
Registriert: Montag 25. Januar 2016, 18:14
Wohnort: Eckernförde

Re: iSpindel - Aufbau und Betrieb

#2254

Beitrag von quasarmin » Donnerstag 14. Juni 2018, 22:45

Danke, aber leider kann ich mit diesen Codes leider gar nichts anfangen.
Zu dem "Wemos" muss ich noch ergänzen, das ich bei meinen iSpindeln diese kompatiblen Clone im Einsatz habe, den es bei Amazon oder ebay zu kaufen gibt. Es ist diese Ausführung die Herbert schon seit Anfang dieses Thread im Einsatz hat, also keinen Original Wemos D1 Mini, sondern nur D1 Mini (Kopie).
Heute habe ich einen noch original verpackten dieser Clones ausgepackt, Pins gelötet, Diode raus und die FW 5.8.6 geflash. Auf eine Spindelplatine gesteckt .... -127°C, auf eine andere Platine gesteckt ... ebenfalls -127°C. Das beide DS18B20 abgeraucht sind kann ich ausschliessen, denn mit den 4+ Versionen wird die Temperatur erfasst. Kann das an diesen Clones liegen, das die nicht mehr mit der aktuellen FW kompatibel sind weil hier Timimgprobleme o.ä. vorliegen? Ich weiss mir jetzt nicht weiter zu helfen, ausser zu versuchen irgendwo einen Original Wemos aufzutreiben, oder notgedrungen bei 4.1.2 zu bleiben und auf dem Lokalen Server halt den Winkel aufzuzeichnen.
Gruß
Armin

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2255

Beitrag von DerDerDasBierBraut » Donnerstag 14. Juni 2018, 22:55

Ich denke nicht das es an den Klonen liegt. Du meinst diese Wagat oder Wygat oder so ähnlich, richtig?
Bei mir tritt das WLAN Problem sowohl mit den Original Wemos als auch mit den Klonen auf. Kein Unterschied im Verhalten, egal welches Hardware Release oder ob Klon bzw. Original.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1555
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#2256

Beitrag von JackFrost » Donnerstag 14. Juni 2018, 23:03

Ich kann dir anbieden die Timings zu messen, dann müsstest du mir einen der beiden schicken. Wie schwer ist der ? Geht das als Brief ? Wenn nicht , dann lohnt es sicher als Packet nicht. Läuft die Spinlde ohne Akku am USB ? ist der Akku leicht entfernbar ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2257

Beitrag von DerDerDasBierBraut » Donnerstag 14. Juni 2018, 23:08

Das läuft nur auf Akku. Über den USB Port bekommt er keine Spannung mehr, weil die Eingangsdiode entfernt werden muss.
Du kannst natürlich den Akku entfernen und zum Messen direkt 4V auf den VCC Pin legen.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1555
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#2258

Beitrag von JackFrost » Donnerstag 14. Juni 2018, 23:15

Ich meinte alle Teile bis auf den Akku, der DS18b20 ist nicht direkt auf dem Wemos sonder auf der Platine , oder ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Pitty
Posting Junior
Posting Junior
Beiträge: 18
Registriert: Mittwoch 11. April 2018, 20:37

Re: iSpindel - Aufbau und Betrieb

#2259

Beitrag von Pitty » Dienstag 19. Juni 2018, 17:58

DerDerDasBierBraut hat geschrieben:
Dienstag 12. Juni 2018, 19:01
Direkt von Sam (universam). Funk ihn mal per PN an.
Ich habe leider nur noch diverse 5er Versionen hier.

Leider gehen meine PN an ihn nicht durch. Und ich möchte mich nicht extra bei githup registrieren nur um ihm da eine Mail senden zu können, am Ende ist da auch alles blockiert....

Kann mir vlt jemand anderes weiterhelfen?

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1555
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#2260

Beitrag von JackFrost » Dienstag 19. Juni 2018, 18:20

Soll ich ihn per github anschreiben ob er in den Thread wegen der alten Firmware schauen kann ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Benutzeravatar
quasarmin
Posting Senior
Posting Senior
Beiträge: 451
Registriert: Montag 25. Januar 2016, 18:14
Wohnort: Eckernförde

Re: iSpindel - Aufbau und Betrieb

#2261

Beitrag von quasarmin » Dienstag 19. Juni 2018, 21:17

Hallo Pitty

schick mir per pn deine email-Adresse, dann sende ich die die 3.4.4, 4.0.1 und 4.1.2 zu.

Sam ist wahrscheinlich, durch die Publikation der iSpindel mit Anfragen zugeballert. Ich hatte früher mal als Selbstbauprojekt eine Teleskopsteuerung vorgestellt, das hat mich dann viel Zeit gekostet.

Bei mir funktioniert jedenfalls bei 3 iSpindeln der Temperatursensor ab der Version 5.x nicht mehr. Die Sensoren sind alle aus der gleichen Charge, habe jedenfalls 10 Stk in einer Tüte gekauft. Ich besorge mir mal andere und probiere es damit. Die meisten scheinen mit den 5+ Versionen ja keine Probleme zu haben.

Gruß
Armin

Benutzeravatar
quasarmin
Posting Senior
Posting Senior
Beiträge: 451
Registriert: Montag 25. Januar 2016, 18:14
Wohnort: Eckernförde

Re: iSpindel - Aufbau und Betrieb

#2262

Beitrag von quasarmin » Mittwoch 20. Juni 2018, 21:45

Moin

könnte bitte jemand bei dem die 5.x.x Firmware Versionen funktioniert nachschauen was auf dem Temperatursensor der iSpindel aufgedruckt ist?

Bei meinen ist folgende Bezeichnung aufgedruckt:
Dallas
18B20
1635C4
+233AA

Gruß
Armin

Benutzeravatar
mwx
Posting Freak
Posting Freak
Beiträge: 765
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2263

Beitrag von mwx » Mittwoch 20. Juni 2018, 22:27

Hi

auf meinen steht

Dallas
18B20
1718C4
+158AC

ich hatte noch nie ein Problem mit denen (auch nicht in anderen Projekten). Was die beiden letzten Zeilen bedeuten konnte ich nicht herausfinden.

Ich kann Dir auch gerne ein oder zwei davon schicken. Vielleicht hilft es ja den Fehler zu finden.

Gruß, Michael
Gruß, Michael

Gerührt und nicht geschüttelt: Magnetrührer Controller

Benutzeravatar
quasarmin
Posting Senior
Posting Senior
Beiträge: 451
Registriert: Montag 25. Januar 2016, 18:14
Wohnort: Eckernförde

Re: iSpindel - Aufbau und Betrieb

#2264

Beitrag von quasarmin » Donnerstag 21. Juni 2018, 00:15

Danke für die Info. Die unteren Nummern sind sicher Serien/Chargen Nummern.
Ich besorge mir eine paar andere 18B20, vielleicht liegt es ja an der Charge ich ich als 10er Pack gekauft hatte.

Viele Grüße
Armin (bin erstmal paar Tage unterwegs)

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1555
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#2265

Beitrag von JackFrost » Donnerstag 21. Juni 2018, 06:34

Hast du einen anderen Arduino bzw. zwei zuhause , das du die Bitzeiten messen kannst ?

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Matt
Posting Senior
Posting Senior
Beiträge: 331
Registriert: Sonntag 28. September 2014, 18:49
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2266

Beitrag von Matt » Donnerstag 21. Juni 2018, 21:24

Hallo zusammen,

nach einigem Zögern habe ich mir vor zwei Wochen das aktuelle Set bei 3d Mechatronics besorgt. Bausatz nach Anleitung zusammengelötet, Treiber, aktuellste Firmware und Nodemcu Flashtool runtergeladen, Treiber installiert, Firmware geflashed und nach Reset mit einem Tablet zur Funktionsüberprüfung verbunden. Bis dahin alles bestens. Lage und Temperatur werden korrekt an das Tablet ausgegeben und ändern sich beim "Spiel" mit der Spindel.

Dann habe ich ein Account in ubidots eröffnet, den Token sowie SSID und Netzwerkschlüssels meines Heimnetzwerkes eingetragen und die Configuration gespeichert. Dann aus-/eingeschaltet und festgestellt, dass bei ubidots nichts ankommt. Die iSpindle erscheint nicht mal als WLAN Gerät in meinem Heimnetzwerk (Fritzbox).

Woran kann es liegen, dass sich die Spindel nicht mit meinem Heimnetzwerk verbindet? SSID und Netzwerkschlüssel habe ich schon x-Mal überprüft, auch schon ein zweites Mal geflashed. Ich habe zuletzt per putty das Protokoll der Spindle ausgelesen - leider kann ich mit den Angaben nichts anfangen :-(

Kann jemand helfen?

Beste Grüße,

Matt
"Ohne Frage ist Bier die größte Erfindung der Menschheit. Gut, ich gebe zu, das Rad war auch keine schlechte Idee, aber zu einer Pizza passt es nicht halb so gut wie ein Bier." (Dave Barry)

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1555
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#2267

Beitrag von JackFrost » Donnerstag 21. Juni 2018, 21:36

Du kannst das Log hier mal posten ggf. kann man daran sehen was der Fehler ist

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Matt
Posting Senior
Posting Senior
Beiträge: 331
Registriert: Sonntag 28. September 2014, 18:49
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2268

Beitrag von Matt » Donnerstag 21. Juni 2018, 21:53

Hier das Log (Token, SSID und Passwort habe ich durch xxx ersetzt):

sd$ܟ|▒l▒|

$▒c<ǃ▒s▒b▒
c▒▒'o▒dog▒▒▒cx▒▒l;l{lx▒n▒
▒l▒▒
c
n▒|$▒▒b▒▒og▒$▒▒l`▒
d`gs▒▒▒'
c
▒l{ۓn
c
▒d▒
d`▒g▒
FW 5.8.6
2.2.1(cfd48f3)
Worker run!
Boot-Mode: 5
mounting FS... mounted!
reading config file
opened config file

parsed json
offsets not available
parsed config:
{"Name":"iSpindel000","Token":"xxx","Sleep":900," Server":"","API":0,"Port":80,"URL":"","DB":"ispindel","Job":"ispindel","Instance ":"000","Vfact":191.8,"TS":0,"SSID":"xxx","PSK":"xxx","POLY":"-0.00031*tilt^2+0.557*tilt-14.054","aX":0,"aY":0,"aZ":0}
woken from deepsleep, normal mode
Spl 0: 70.53
Spl 1: 75.52
Spl 2: 77.13
Spl 3: 72.97
Spl 4: 71.27
Spl 5: 70.03
Spl 6: 69.36

a: -6188 14416 2258 absTilt: 71.59 T: 25.63 V: 4.29 owT: 25. 50 Gravity: 24.23
After waiting 0ms, result 3
IP: 192.168.178.52

calling Ubidots
{"tilt":71.58572,"temperature":25.5,"battery":4.290928,"gravity":24.23065,"inter val":900,"RSSI":-72}Sender: Ubidots posting
POST /api/v1.6/devices/iSpindel000?token=xxx HTTP /1.1
Host: things.ubidots.com
User-Agent: ESP8266
Connection: close
Content-Type: application/json
Content-Length: 100

POST /api/v1.6/devices/iSpindel000?token=xxx HTTP /1.1
Host: things.ubidots.com
User-Agent: ESP8266
Connection: close
Content-Type: application/json
Content-Length: 100

HTTP/1.1 403 Forbidden
Server: nginx
Date: Thu, 21 Jun 2018 19:41:24 GMT
Content-Type: application/json
Transfer-Encoding: chunked
Connection: close
Vary: Accept-Encoding
Vary: Cookie
Allow: GET, POST, HEAD, OPTIONS

3b
{"detail": "Authentication credentials were not provided."}
0


Final-sleep: 900s; RT:2532
"Ohne Frage ist Bier die größte Erfindung der Menschheit. Gut, ich gebe zu, das Rad war auch keine schlechte Idee, aber zu einer Pizza passt es nicht halb so gut wie ein Bier." (Dave Barry)

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2269

Beitrag von DerDerDasBierBraut » Donnerstag 21. Juni 2018, 22:54

Klarer Fall. Ubidots sagt dir
HTTP/1.1 403 Forbidden
...
{"detail": "Authentication credentials were not provided."}
Das kann 3 Ursachen haben.
1. Du hast den API Key anstatt des Tokens in der iSpindel hinterlegt
2. Tippfehler im Token
3. Der Token wurde lange Zeit vor dem Senden der ersten Daten generiert und ist ungültig geworden.
In diesem Fall kannst Du unter "API Cedentials" einen neuen Token generieren.

PS: Sind vier mögliche Ursachen ... :Wink
4. Du hast eine ältere Firmware geflasht. Die Ubidots Token wurden irgendwann länger und die neuen Token werden in der alten Firmware abgeschnitten.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Matt
Posting Senior
Posting Senior
Beiträge: 331
Registriert: Sonntag 28. September 2014, 18:49
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2270

Beitrag von Matt » Freitag 22. Juni 2018, 09:01

Ok das hilft mir schon mal auf der ubidot Seite. Besten Dank und werde ich heute abend überprüfen. Dennoch frage ich mich warum die Spindel nicht als WLAN Gerät in meinem Heimnetzwerk sichtbar ist. Da sollte sie doch als erstes zu sehen sein (unabhängig von dem Senden der Daten an ubidots)?

LG

Matt
"Ohne Frage ist Bier die größte Erfindung der Menschheit. Gut, ich gebe zu, das Rad war auch keine schlechte Idee, aber zu einer Pizza passt es nicht halb so gut wie ein Bier." (Dave Barry)

JackFrost
HBCon Supporter
HBCon Supporter
Beiträge: 1555
Registriert: Dienstag 15. Mai 2018, 18:10

Re: iSpindel - Aufbau und Betrieb

#2271

Beitrag von JackFrost » Freitag 22. Juni 2018, 09:24

Die Spindel ist ja immer nur kurz im WLAN. Und ist dann wieder am schlafen. Daher siehst die als aktives Gerät nur wenn sie gerade sendet unschuldige Seite gleichzeitig aktualisierst.

Gruß JackFrost
Meine Hardware:
eManometer
IDS2 ohne CBPi
Magnetrührer
Ss-Brewtech 10 Gal Topf
IDS2 Induktionsplatte

Matt
Posting Senior
Posting Senior
Beiträge: 331
Registriert: Sonntag 28. September 2014, 18:49
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2272

Beitrag von Matt » Freitag 22. Juni 2018, 18:38

Vielen Dank Jens!

1. Ich habe den Token nochmals (und diesmal per copy paste) übertragen
2. Der Token wurde vor wenigen Tagen mit Einrichtung meines Ubidots Accounts generiert
4. Aktuellste Firmware ist geflashed

Nach einem neuerlichen Test kommen die Daten nun an. War wohl doch ein Tippfehler im Token, oder Verwirrung bezüglich "O" oder "0" (großem O oder Null).

Auch an Dich vielen Dank JackFrost - darauf hätte ich selbst kommen können...

Noch eine Frage bezüglich austarieren: ich habe mit Felgengewichten (4x5 gr an den beiden Seiten des Akkus + 1x 5gr auf der Rückseite des Schlittens) einen Tilt von 16,56 Grad erreicht (ohne den 5gr auf der Rückseite waren es 33,20 Grad). Leider ließ der Schlitten kein Eingießen von Kügelchen in der Spitze mehr zu. Komme ich mit 16,56 Grad zurecht oder was würdet ihr empfehlen?

Beste Grüße,

Matt
"Ohne Frage ist Bier die größte Erfindung der Menschheit. Gut, ich gebe zu, das Rad war auch keine schlechte Idee, aber zu einer Pizza passt es nicht halb so gut wie ein Bier." (Dave Barry)

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2273

Beitrag von DerDerDasBierBraut » Freitag 22. Juni 2018, 19:41

Ja, 16,5° ist OK. Den Rest gleicht das Polynom aus.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
quasarmin
Posting Senior
Posting Senior
Beiträge: 451
Registriert: Montag 25. Januar 2016, 18:14
Wohnort: Eckernförde

Re: iSpindel - Aufbau und Betrieb

#2274

Beitrag von quasarmin » Mittwoch 27. Juni 2018, 18:50

quasarmin hat geschrieben:
Mittwoch 20. Juni 2018, 21:45
Moin

könnte bitte jemand bei dem die 5.x.x Firmware Versionen funktioniert nachschauen was auf dem Temperatursensor der iSpindel aufgedruckt ist?

Bei meinen ist folgende Bezeichnung aufgedruckt:
Dallas
18B20
1635C4
+233AA

Gruß
Armin

Moin

Ich habe heute 5 neue Sensoren 18B20 erhalten, mit anderer Serien- bzw. Chargennummer.
Habe einen dieser Sensoren gleich in einer iSpindel gegen den alten ausgetauscht.

Auf dem Wemos ist gerade die Version 5.2.3 geflasht, bei der hat der alte Sensor (Seriennummer im Beitrag oben) ungemütliche -127°C angezeigt, und liess sich nicht mit dem Heimnetz verbinden.

Mit dem neuen Sensor wurden dann im Testmode gleich gemütliche 24°C angezeigt, und die Verbindung zum Heimnetz klappte auf Anhieb.
Auch die TCP Verbindung zu Tozzy's lokalen Server funktioniert tadellos. Es war tatsächlich der Temperatursensor.
iSpindel_Server.jpg
Alle die mit dem Konfigurieren der 4er und 5er Firmware Versionen Probleme haben, empfehle ich Temperatursensoren einer anderen Charge auszuprobieren, da gibt es wohl Unterschiede. Der Aufdruck sieht schon ganz anders aus, scheint ein anderer Hersteller zu sein. Letztendlich hat mich der "Timing" Hinweis von JackFrost auf die Idee gebracht. Messen kann ich das Timing zwar nicht, aber die Sensoren tauschen.

Gruß
Armin

Benutzeravatar
Tozzi
Moderator
Moderator
Beiträge: 4702
Registriert: Montag 22. Februar 2016, 23:17
Wohnort: München

Re: iSpindel - Aufbau und Betrieb

#2275

Beitrag von Tozzi » Mittwoch 27. Juni 2018, 19:58

Schön zu hören, dass es endlich klappt.
Bei den Bauteilen gibt es halt doch deutliche Schwankungen, da kann man durchaus mal Pech haben.
Ich musste gestern auch eine iSpindel aussortieren, die aus dem Unitank einfach nicht funken wollte, ansonsten aber einwandfrei funktioniert.
Getauscht gegen eine andere, und es klappt perfekt.
Viele Grüße aus München
Stephan

Adrian S
Posting Freak
Posting Freak
Beiträge: 505
Registriert: Mittwoch 7. März 2018, 18:58
Wohnort: Zürich

Re: iSpindel - Aufbau und Betrieb

#2276

Beitrag von Adrian S » Sonntag 1. Juli 2018, 21:02

Hat jemand aus der Schweiz interesse für Laderegler? Mini- und micro-usb. Habe noch ca 12 Stück die ich nicht mehr brauche... :Bigsmile
Kann abgeholt oder versendet werden, wie man möchte. Natürlich kostenlos!

Grüsse
Adrian
Grüsse
Adrian

________________________________________________________________

"Geduld - Die Wurzel ist bitter, die Frucht ist süss"
Ein Leitspruch für Hobbybrauer

JoGr
Posting Klettermax
Posting Klettermax
Beiträge: 172
Registriert: Freitag 4. August 2017, 15:29
Wohnort: Maulburg

Re: iSpindel - Aufbau und Betrieb

#2277

Beitrag von JoGr » Montag 30. Juli 2018, 18:54

Hallo zusammen,

habe jetzt einige Zeit hier mitgelesen und war von der ISpindel so angetan, dass ich mir einen Bausatz bestellt habe...und nun suche ich die neueste Löt­an­lei­tung von 3D Mecha­tro­nics. Finde aber nur ältere Versionen.
Habt Ihr einen Tip für mich?

Grüße aus Lörrach
Joachim

Benutzeravatar
mwx
Posting Freak
Posting Freak
Beiträge: 765
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2278

Beitrag von mwx » Montag 30. Juli 2018, 18:59

Gruß, Michael

Gerührt und nicht geschüttelt: Magnetrührer Controller

pugdog1
Neuling
Neuling
Beiträge: 1
Registriert: Mittwoch 1. August 2018, 12:40

Re: iSpindel - Aufbau und Betrieb

#2279

Beitrag von pugdog1 » Mittwoch 1. August 2018, 12:48

mwx hat geschrieben:
Donnerstag 22. Februar 2018, 18:29
Fertig und funkt:

IMG_1032 1M.jpgIMG_1036M.jpg
Hi MWX,

sorry if this doesn't translate well, i am from Australia and i have tried to print your sled on 3d hubs however it appears to not work. i have included the message from the guy who was doing the printing for me. if you are able to shed any light on my situation i would appreciate it :) . i just used PLA and 200 μm for the height?

"Hi,

The parts are printed but the quality is not good. The thread is warped because of how small they are and the overhang in the slots are distorted as it is not possible to put supports in there.

It is possible that a 0.1mm layer height may help but I think a material like ABS might be a better fit for these parts.

I can print them on another printer with ABS but if they turn out okay I will need to charge an additional fee, as these are design issues."

Benutzeravatar
mwx
Posting Freak
Posting Freak
Beiträge: 765
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2280

Beitrag von mwx » Mittwoch 1. August 2018, 13:45

Hi

You have to use at least 0.1 mm layers otherwise the resolution is too low for the thread. It is also possible that the print quality of your printer is not enough. In my case the thread looks not perfect but works very well. ABS is not required because finaly there is no mechanical load on this parts. I have used my favourite print material PolyMax PLA (available in Australia too: https://www.3dprintergear.com.au/filaments/polymaker/).

Regards, Mike
Gruß, Michael

Gerührt und nicht geschüttelt: Magnetrührer Controller

irrwisch
Posting Freak
Posting Freak
Beiträge: 974
Registriert: Sonntag 21. Januar 2018, 08:33

Re: iSpindel - Aufbau und Betrieb

#2281

Beitrag von irrwisch » Sonntag 12. August 2018, 12:38

So nachdem ich im Januar den iSpindel Bausatz gekauft habe, kam es nun endlich mal dazu das Teil in einem richtigen Sud einzusetzen. :Bigsmile

Hat auch geklappt, aber heute beim Abfüllen musste ich doch leider feststellen, dass mein Petling nicht dicht ist. Sind doch ein paar Tropfen in den Petling gekommen die natürlich dann prompt auch geschimmelt sind. Zum Glück gabs keinen Kurzschluss, waren wirklich nur ein paar wenige Tropfen.
Der Deckel ist aber auch ziemlich labberig und dreht sehr leicht durch wenn man ihn festschraubt. Kein Wunder, dass das nicht dicht werden kann.

Da muss ich irgendwas ändern. Hat eine eine Idee obs Petlinge in besserer Qualität gibt (vor allem der Deckel) in dem der Schlitten von 3d Mechatronics noch rein passt? Oder besser wär natürlich nur nen neuer Deckel. Sonst muss ich am Ende das Ding wieder neu kalibrieren :puzz :Shocked

Benutzeravatar
mwx
Posting Freak
Posting Freak
Beiträge: 765
Registriert: Mittwoch 11. Oktober 2017, 07:37
Wohnort: Berlin

Re: iSpindel - Aufbau und Betrieb

#2282

Beitrag von mwx » Sonntag 12. August 2018, 12:46

Moin,
irrwisch hat geschrieben:
Sonntag 12. August 2018, 12:38
Der Deckel ist aber auch ziemlich labberig und dreht sehr leicht durch wenn man ihn festschraubt. Kein Wunder, dass das nicht dicht werden kann.
Wenn das passiert nehme ich einen neuen Deckel. Du kannst auch mal schauen ob die Kante vom Petling eine Macke hat. Ansonsten sind die Petlinge eigentlich ok, habe ich bisher nie einen undichten gehabt (~30 Sude)

Gruß, Michael
Gruß, Michael

Gerührt und nicht geschüttelt: Magnetrührer Controller

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2283

Beitrag von DerDerDasBierBraut » Sonntag 12. August 2018, 12:51

Bei 3D Mechateinics kannst du Ersatzdeckel bestellen. Hast du die Kanten vom Schlitten abgeschrägt? Das ist meistens die Ursache für solche Probleme, dass der Schlitten gegen die Dichtlippe im Deckel drückt.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

irrwisch
Posting Freak
Posting Freak
Beiträge: 974
Registriert: Sonntag 21. Januar 2018, 08:33

Re: iSpindel - Aufbau und Betrieb

#2284

Beitrag von irrwisch » Montag 13. August 2018, 07:30

Danke für den Tipp. Der Schlitten hat tatsächlich nen mm oder so über die Kante rausgeragt. Hab ich etwas abgedremelt und der Deckel scheint jetzt schonmal besser zu sitzen.

Hab mir außerdem aus ner 1mm Silikonmatte ne Dichtung für den Deckel geschnitten.
Mal schauen ob’s jetzt besser is.

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2285

Beitrag von DerDerDasBierBraut » Montag 13. August 2018, 07:47

Ich würde den Deckel an deiner Stelle trotzdem ersetzen. Bei mir wurden die Deckel, die einmal vergriesgnaddelt waren, nie wieder dicht.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

michi83
Neuling
Neuling
Beiträge: 3
Registriert: Mittwoch 22. August 2018, 08:15

Re: iSpindel - Aufbau und Betrieb

#2286

Beitrag von michi83 » Mittwoch 22. August 2018, 09:55

Hi, ich bin ein sehr großer Fan des Projekts. Was mich nur stört ist dieser Deckel. Damit das jetzt endlich aufhört hier etwas druckbares:
https://www.thingiverse.com/thing:3061717

Beste Grüße
Michi

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2287

Beitrag von DerDerDasBierBraut » Mittwoch 22. August 2018, 10:11

Schick. Der Deckel könnte ziemlich sicher den Leuten helfen, die die iSpindel im Drucktank einsetzen. Im Fermentosaurus sind einem Hobbybrauerkollegen schon Spindeln vollgelaufen.

Die originalen Deckel von Bericap, die mit dem Petling geliefert werden, sind aber wirklich nicht schlecht. Meistens gehen die nur kaputt, weil der Schlitten gegen die innere Dichtlippe drückt. Das kann man im Vorwege ganz einfach verhindern: >> https://hobbybrauer.de/forum/viewtopic. ... 20#p239620
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1647
Registriert: Mittwoch 1. Juli 2015, 11:50
Wohnort: Gunskirchen OÖ

Re: iSpindel - Aufbau und Betrieb

#2288

Beitrag von glassart » Mittwoch 22. August 2018, 14:01

Danke Michi -liegt gerade am Drucker und ich werde es mir im Detail anschauen. Hast du eine Standarddichtung verwendet oder selbst was "geschnitzt" ?
Sonst druck ich mir eine, geht auch.
lg Herbert

michi83
Neuling
Neuling
Beiträge: 3
Registriert: Mittwoch 22. August 2018, 08:15

Re: iSpindel - Aufbau und Betrieb

#2289

Beitrag von michi83 » Mittwoch 22. August 2018, 14:14

Hallo Herbert,
das war eine Standarddichtung aus einem 419 Teile Set von "BGS technic". Nummer R-29. Drucken mit Flex-PLA sollte auch möglich sein. Ich weiß bei dem Flex-PLA nur nicht ob diese Lesensmittelecht sind und verwendet werden dürfen. Bei reinem PLA kein Problem. ABS sollte nicht verwendet werden, weder für den Deckel noch für sonst was. ;)

EDIT: die STL Datei für die Dichtung habe ich dir auf Thingiverse hochgeladen. Kannst du gerne mal mit Flex-PLA versuchen.

@Jens: Der Petling sollte damit Druckdicht sein. Ich hatte bei mir das Problem, dass der originale HDPE Deckel nicht besonders Wärmeresistent ist. Beim einweichen in warmen Wasser ist dieser irgendwie weich geworden und lässt sich nun "durchdrehen".

LG
Michi

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1647
Registriert: Mittwoch 1. Juli 2015, 11:50
Wohnort: Gunskirchen OÖ

Re: iSpindel - Aufbau und Betrieb

#2290

Beitrag von glassart » Mittwoch 22. August 2018, 14:52

Danke Michi,

ich drucke mit GreenTec Pro, das ist lebensmittelecht und bis 160° temperaturbeständig.
Für die Dichtung würde ich Rubberjet TPE32 nehmen falls ich keine geeignete Dichtung herum liegen habe.

lg Herbert

michi83
Neuling
Neuling
Beiträge: 3
Registriert: Mittwoch 22. August 2018, 08:15

Re: iSpindel - Aufbau und Betrieb

#2291

Beitrag von michi83 » Mittwoch 22. August 2018, 15:05

glassart hat geschrieben:
Mittwoch 22. August 2018, 14:52
Danke Michi,

ich drucke mit GreenTec Pro, das ist lebensmittelecht und bis 160° temperaturbeständig.
Für die Dichtung würde ich Rubberjet TPE32 nehmen falls ich keine geeignete Dichtung herum liegen habe.

lg Herbert
Ich bin auf das Ergebnis gespannt. Habe momentan kein Flex-Material da. Dicht sein sollte das auf jeden Fall. Zu der Lebensmittelechtheit kann ich nichts sagen. Das hängt von der Herstellung des Materials ab und ob PAKs (polyzyklische aromatische Kohlenwasserstoffe) verwendet wurden. Da müssten wir mal die Chemiker hier fragen ;)

Ein Bild von meinem Dichtigkeitstest im Wasserglas (ja ich weiß,... nicht sonderlich professionell, aber es war/ist dicht), ist auch auf Thingiverse.

LG
Michi

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1647
Registriert: Mittwoch 1. Juli 2015, 11:50
Wohnort: Gunskirchen OÖ

Re: iSpindel - Aufbau und Betrieb

#2292

Beitrag von glassart » Mittwoch 22. August 2018, 15:15

ich werde es unter Druck testen (natürlich ohne Elektronik drinnen :Bigsmile ) wenn es fertig ist.

lg Herbert

Sulog
HBCon Supporter
HBCon Supporter
Beiträge: 23
Registriert: Montag 4. Juli 2016, 07:01
Wohnort: Steyr

Re: iSpindel - Aufbau und Betrieb

#2293

Beitrag von Sulog » Montag 27. August 2018, 17:14

Hi Leute

Hat wer eine Plan wiso meine Ispindel Probleme bei der Akkuspannung hat , das sie einfach von 4,05 volt auf ~3 volt abfällt

Das Problem hatte ich bei der letzten Gärung auch das sie einfach abfiel dann sendete sie plötzlich eine unbestimmte Zeit nicht mehr und plötzlich ging sie wieder in Betrieb und die Akkuspannung stieg

Hatte jetzt die Lötstellen beim Akku nochmals nachgelötet da die Vermutung wegen einer kalten Lötstelle da war

Leider hatte das nicht wirklich einen erfolg

Wär interessant wenn wer eine Lösung hätte
Dateianhänge
CED90DE0-2224-4C84-902C-90EFD5AC7A62.png

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2294

Beitrag von DerDerDasBierBraut » Montag 27. August 2018, 17:31

Sowas habe ich noch nicht gesehen. Die Kennlinie des Akkus verläuft normal ganz anders, mit einem großen Bereich von rund 3,7V.

Hast du in der Konfiguration mit dem ‚Batterie Korrekturfaktor‘ rumgespielt? Welche Firmware ist drauf? Ist der Akku beim Löten heiß geworden?
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1647
Registriert: Mittwoch 1. Juli 2015, 11:50
Wohnort: Gunskirchen OÖ

Re: iSpindel - Aufbau und Betrieb

#2295

Beitrag von glassart » Montag 27. August 2018, 17:36

noch eine Zusatzfrage -welcher Akku ist es ? Ich hatte einmal chinesische 6800 mAh die fast du aus Luft bestanden (aber auch günstig waren :Ahh )

lg Herbert

Sulog
HBCon Supporter
HBCon Supporter
Beiträge: 23
Registriert: Montag 4. Juli 2016, 07:01
Wohnort: Steyr

Re: iSpindel - Aufbau und Betrieb

#2296

Beitrag von Sulog » Montag 27. August 2018, 17:45

Ist der 2600mAh von 3d-mechatronics
das mit der Konfiguration kann ich nochmals nachsehen ob ich da versehentlich etwas verstellt habe
Zurzeit ist entweder die 5.8 oder die 5.9 Firmware oben

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2297

Beitrag von DerDerDasBierBraut » Montag 27. August 2018, 18:02

Unverbindlich: Lademodul und Akku tauschen. Tippen würde ich eher auf ein defektes Lademodul, weil die Kennlinie zu untypisch für den Akku ist.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Sulog
HBCon Supporter
HBCon Supporter
Beiträge: 23
Registriert: Montag 4. Juli 2016, 07:01
Wohnort: Steyr

Re: iSpindel - Aufbau und Betrieb

#2298

Beitrag von Sulog » Montag 27. August 2018, 18:39

Den akku müsste man ja irgentwie Testen können oder ?

Benutzeravatar
DerDerDasBierBraut
HBCon Supporter
HBCon Supporter
Beiträge: 7181
Registriert: Donnerstag 2. Juni 2016, 20:51
Wohnort: Ahrensburg

Re: iSpindel - Aufbau und Betrieb

#2299

Beitrag von DerDerDasBierBraut » Montag 27. August 2018, 18:56

Klar. Trenne ihn vom Lademodul, lade ihn mit einem Charger für 18650 Zellen auf, hänge eine kleine Last dran und miss in Intervallen die Spannung mit einem Multimeter. Ist er i.O., dann wird er die meiste Zeit bei rund 3,7V entladen.
"Da braut sich was zusammen ... "
"Oh, Bier ;-) !"
"Nein! Was Böses!"
"Alkoholfreies Bier??? ..."
-----------
Viele Grüße
Jens

Interesse an Flüssighefen ... ? Aus Zeitgründen derzeit kein Hefeversand.

Sulog
HBCon Supporter
HBCon Supporter
Beiträge: 23
Registriert: Montag 4. Juli 2016, 07:01
Wohnort: Steyr

Re: iSpindel - Aufbau und Betrieb

#2300

Beitrag von Sulog » Dienstag 28. August 2018, 12:08

Also in der Konfiguration stehen folgende werte
Dateianhänge
59568525-2888-43B5-9DAB-37BEF56AF011.png

Antworten