Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#51

Beitrag von emilio » Freitag 22. März 2019, 19:05

Hoppla, da wurde wohl die Schriftart nicht installiert. Muss mal nachschauen warum. Du kannst einfach in den Brauerei-Ordner gehen und die Schriftart "DS-DIGIB.TTF" doppel-klicken und anschließend "installieren" klicken. Die Fenstergröße ist fixiert. Die kannst du nicht aufziehen.

Gruß
Andreas

Acosti
Posting Klettermax
Posting Klettermax
Beiträge: 109
Registriert: Donnerstag 13. März 2008, 13:20
Wohnort: Nordhorn

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#52

Beitrag von Acosti » Freitag 22. März 2019, 21:37

Hallo Andreas,

hat geklappt. :thumbup

Archie
Posting Senior
Posting Senior
Beiträge: 333
Registriert: Montag 4. Mai 2015, 19:56

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#53

Beitrag von Archie » Samstag 23. März 2019, 14:26

Hallo emilio,
ich habe ein kleines Problemchen mit deiner neuen (und vorzüglichen) Software.
Mein Sonoff TH16 (Tasmotafirmware & nach deiner Anleitung konfiguriert) schaltet nicht. Ich nehme die Temperaturmessung über die iMinibrauerei vor und ich möchte meine Kochplatte mit dem Sonoff schalten.

Im Webinterface des Sonoff ist alles i.O., ich kann ihn auch über das Webinterface und manuell schalten.

Ich habe mal einen Screenshot gemacht.
Screen.JPG
Hast du eine Idee?

Viele Grüße
Archie

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#54

Beitrag von emilio » Samstag 23. März 2019, 16:45

Die IP ist richtig? Welche Version der Tasmota FW verwendest du denn? Wie testest du das Schalten? Manuell schalten?

Archie
Posting Senior
Posting Senior
Beiträge: 333
Registriert: Montag 4. Mai 2015, 19:56

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#55

Beitrag von Archie » Samstag 23. März 2019, 18:39

Hallo emilio,

die IP (xxx.xxx.xxx.160) des Sonoff ist korrekt, mit manuellem Schalten meinte ich, dass ich über das Webinterface des Sonoff ein und ausschalten kann. Ich habe die neueste Firmware geflasht (6.5.0), dafor hatte ich die 5.4 drauf, glaube ich, mit der hat es aber auch nicht geklappt.

Kann es denn sein, dass ich mit dem Sonoff auch die Temperatur messen muss damit die Steuerung funktioniert?
Mein Eindruck ist, dass mein Sonoff kein Signal zum Schalten bekommt, gibt es da einen Trick mit UDP-OUT?

Viele Grüße
Olaf

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#56

Beitrag von emilio » Samstag 23. März 2019, 18:52

Hab gerade genau deine Konfiguration aufgebaut. Funktioniert bei mir einwandfrei. Der Sonoff wird nicht über UDP geschaltet sondern über http.
Du kannst den Sonoff mit dem Befehl
http://192.168.178.160/cm?cmnd=Power%20On
bzw.
http://192.168.178.160/cm?cmnd=Power%20Off
in deinem Browser schalten. Genau das macht die Brauerei. Prüf mal ob das funktioniert.

Gruß
Andreas

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#57

Beitrag von emilio » Samstag 23. März 2019, 19:25

Du hast in der Brauerei nicht zufällig ein Leerzeichen hinter die IP gemacht? Habe gerade festgestellt, dass der Somoff dann nicht mehr schaltet

Archie
Posting Senior
Posting Senior
Beiträge: 333
Registriert: Montag 4. Mai 2015, 19:56

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#58

Beitrag von Archie » Samstag 23. März 2019, 20:13

Hallo emilio,
vielen Dank für deine Mühen. Der Sonoff schaltet mit den beiden Befehlen, bzw. Links, die du in deinem Beitrag angegeben hast.
Mit der Brauereisoftware geht gar nichts. Ich warte dann mal auf meinen Temperatursenor für den Sonoff, der kommt sicher bald aus China und mal sehen, ob es dann geht.

Schönen Abend wünscht
Archie.

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#59

Beitrag von emilio » Samstag 23. März 2019, 20:20

Na mit dem Temperatursensor hat das ja nichts zu tun. Der nächtse Versuch wäre dann herauszufinden ob curl im Brauerei-Ordner richtig installiert wurde und ob der Sonoff mit
curl.exe http://192.168.178.160/cm?cmnd=Power%20Off
curl.exe http://192.168.178.160/cm?cmnd=Power%20On
in der Eingabeaufforderung schaltet.

Gruß
Andreas

Archie
Posting Senior
Posting Senior
Beiträge: 333
Registriert: Montag 4. Mai 2015, 19:56

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#60

Beitrag von Archie » Samstag 23. März 2019, 20:32

Hallo emilio,
ich habe im Verzeichnis Curl deinen Befehl eingegeben und ich habe die Fehlermeldung erhalten, dass die curl.exe nicht mit meinem System kompatibel ist. Das ist wohl der Fehler, auf meinem Laptop läuft Win7, 32 bit.
Ich versuche es mal auf meinem PC, da ist ein 64 bit Version drauf. Ich melde mich dann.
Grüße
Archie


Archie
Posting Senior
Posting Senior
Beiträge: 333
Registriert: Montag 4. Mai 2015, 19:56

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#62

Beitrag von Archie » Samstag 23. März 2019, 20:42

Hallo emilio,
bevor ich die ganze Sache an meinem PC getestet habe, hatte ich eine Idee: Ich habe mir curl for Windows in der 32 bit Version heruntergeladen und nur die curl.exe ausgetauscht--> es funktioniert!!!!!

Ganz großes Kino, vielen Dank!
Wie gesagt, mein Angebot auf ein Selbstgebrautes steht noch, wenn du mal in Berlin bist (oder in der Nähe).

Schönen Abend wünscht
Archie

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#63

Beitrag von emilio » Samstag 23. März 2019, 20:52

Sehr seltsam. Ich hab die curl Version seit der ersten Version nicht verändert. Das ist in jedem Fall keine 64bit Version. Auf meinem Uralt-Laptop mit Windows XP läuft die Brauerei mit curl auch. Ich hab jetzt mal die aktuelle Version eingebaut.

Gruß
Andreas

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#64

Beitrag von emilio » Samstag 23. März 2019, 20:55

Das mit dem Selbstgebrauten werde ich mir merken, falls es mich mal wieder nach Berlin zieht. :Wink

Archie
Posting Senior
Posting Senior
Beiträge: 333
Registriert: Montag 4. Mai 2015, 19:56

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#65

Beitrag von Archie » Samstag 23. März 2019, 21:01

Hallo emilio,
ich habe es gerade noch einmal getestet, es liegt an der curl.exe. Vielleicht habe ich nicht die aktuelle Version deiner Software (Entschuldigung), ich habe mir den intaller am 8.3. heruntergeladen.

Gruß
Archie

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#66

Beitrag von emilio » Samstag 23. März 2019, 21:42

Wie gesagt, ich hab die curl.exe in den letzten 3 Jahren nicht verändert. Vielleicht gab's ein Windows 7 update, welches die curl.exe unbrauchbar gemacht hat. Also keine Sorge, an deiner Brauerei-Version liegt das nicht.
Ich hab die aktuelle 32Bit Version von curl in den Installer für die nächste Version aufgenommen. Die funktioniert bei mir auch unter 64Bit problemlos.
War vielleicht eh mal höchste Zeit die zu aktuallisieren.

Gruß
Andreas

Brauwig
Neuling
Neuling
Beiträge: 4
Registriert: Mittwoch 27. März 2019, 09:44

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#67

Beitrag von Brauwig » Mittwoch 27. März 2019, 10:34

Hallo zusammen!
Erst einmal recht herzlichen Dank für diese tolle Arbeit, habe sehr lange nach genau so einer Lösung gesucht. Auch toll, dass gleich mehrere Hardware-Lösungen mit empfohlen werden, einfach perfekt!
:thumbsup
Ich habe mir also die Software auf meinen Win 10 64 Bit PC installiert und einen Sonoff th16 und einen s20 besorgt. Damit wird mein Einkocher mit Rührwerk betrieben.
Im Ersten Brauversuch mit der 1. Version war ich grundsätzlich zufrieden, aber ein paar Kleinigkeiten, die mir aufgefallen sind:
1. Nach erfolgreichem Test am Stand-PC wollte ich mit einem anderen PC brauen, doch die Sonoffs ließen sich nicht schalten. Nach langer Ursachenforschung dürfte es wie hier bereits erwähnt an der 32-Bit Win 10 Version gelegen haben.
2. Bei der Funktion "Sensor überwachen" ertönte andauernd in Abständen unter einer Minute ein Alarm "Seit min. 1 Minute kein Temperaturupdate! Sensor überprüfen!". Alledings waren die Temp.-Werte ok!? EIn Deaktivieren der Funktion verhinderte den Alarm nicht, nur ein Neustart der Software. Damit wurde der Brauvorgang leider mehrmals unterbrochen.
3. Einstellungen werden nur gespeichert, wenn ich das Programm als Administrator ausführe.
4. Ich habe mir jetzt die Version 2.01 Trial installiert und in Sachen Heizen/Rühren einige Simualtionen laufen lassen.
Meine Ziel würde so aussehen:
+ Aufheizen Hauptguss: Rührwerk läuft getaktet in Intervallen nur hin und wieder.
+ Einmaischen(Rühren)
+ Rast halten, Rührwerk getaktet in Intervallen um die Maische hin und wieder zu durchmischen. Wenn die Temp. abfällt wird nachgeheizt und automatisch das Rührwerk zugeschalten um ein Anbrennen zu verhindern. Nach Erreichen der Zieltemp. wird noch ein paar Sekunden weiter gerührt und dann ist wieder Pause.
+ Aufheizen nach Rastende wie vorher mit durchgehendem Rühren in der Heizphase usw.
Wenn ich alles richtig verstehe ist meine Wunschvorstellung derzeit nicht umsetzbar, oder?
Wenn ich "Rührwerk durchgehend an" aktiviere, kann ich beim Aufheizen des Hauptgusses nicht takten.(Ist jetzt nicht so ein großes Problem, aber hier durchgehend zur rühren ist meiner Meinung nach unnötig)
Beim Takten in den Ruhephasen hingegen wird in der Simulation in der Nachheizphase trotz "Rührwerk durchgehend an" nicht gerührt sondern nur die Taktung ausgeführt.
Die Ausschaltverzögerung scheint soweit ich das beobachtet habe nicht wirklich zu funktionieren?
Nachdem ich mir nicht sicher bin, ob das alles so gewollt ist oder hier noch der eine oder ander Bug vorliegt, habe ich mir gedacht ich schreibe meine Erfahrungen hier rein. Hoffe es hilft!

Vielen Dank jedenfalls noch einmal, das ist meine erste automatisierte Maischerfahrung und ich bin daher für alle Einstellungstipps dankbar!

Ach ja, was auf jeden Fall noch fehlt ist ein Spenden-Button!!
:Bigsmile
LG und weiter so!

Benutzeravatar
saschabouchon
Posting Freak
Posting Freak
Beiträge: 858
Registriert: Freitag 28. Februar 2014, 11:27
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#68

Beitrag von saschabouchon » Mittwoch 27. März 2019, 10:54

Hallo Brauwig,

du solltest das Rührwerk auf jeden Fall während des Maischens durchlaufen lassen. Andernfalls bildet sich je nach Dauer auf dem Topfboden ein schön fester Treber, ähnlich wie beim Läutern, indem das Paddel steckt. Das kann schon sehr fest und massiv sein. Wenn das Rührwerk jetzt wieder loslaufen soll, kann es sein, dass der Motor / das Netzteil es nicht packt.

Also: durchlaufen lassen.

Und nun zurück zum Thema :-)

VG
Sascha
http://www.brauhardware.de
Rührwerk selber bauen, von der Einkocher- bis zur 70l Brauklasse! Läuterfreund, Edelstahlhähne etc...

Brauwig
Neuling
Neuling
Beiträge: 4
Registriert: Mittwoch 27. März 2019, 09:44

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#69

Beitrag von Brauwig » Mittwoch 27. März 2019, 16:54

Danke Sascha für den Tipp!
Ich war aber bis jetzt der Auffassung, dass die Maische so wenig wie möglich und nur so viel wie nötig bewegt werden soll!? Zu viel rühren bringt durch den Sauerstoffeintrag und die damit verbundenen Oxidationsreaktionen negative Eigenschaften mit sich, zumindest behauptet das Hanghofer in seinem Buch.
Ist die Maische zu stark ist das Rührwerk zu schwach! Und ich habe hier ein qualitativ hochwertiges und sehr robustes von Brauhardware!!
:Wink

LG

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#70

Beitrag von emilio » Mittwoch 27. März 2019, 20:54

Hallo Brauwig.

Mal schauern, was ich auf die schnelle beanworten kann...
Brauwig hat geschrieben:
Mittwoch 27. März 2019, 10:34
1. Nach erfolgreichem Test am Stand-PC wollte ich mit einem anderen PC brauen, doch die Sonoffs ließen sich nicht schalten. Nach langer Ursachenforschung dürfte es wie hier bereits erwähnt an der 32-Bit Win 10 Version gelegen haben.
Ja, das ist doof, hab keine Ahnung warum das bisher noch keinem Aufgefallen ist. Das ist immernoch die erste Curl Version von vor Jahren. Bisher wurde die zwar nur bei Edimax-Steckdosen benötigt aber es wundert mich doch, dass das nie aufgefallen ist. Ich packe nachher noch eine Version mit den aktuellen Bug-Fixes. Da ist dann auch ne aktuelle 32Bit-Version mit bei.
Brauwig hat geschrieben:
Mittwoch 27. März 2019, 10:34
2. Bei der Funktion "Sensor überwachen" ertönte andauernd in Abständen unter einer Minute ein Alarm "Seit min. 1 Minute kein Temperaturupdate! Sensor überprüfen!". Alledings waren die Temp.-Werte ok!? EIn Deaktivieren der Funktion verhinderte den Alarm nicht, nur ein Neustart der Software. Damit wurde der Brauvorgang leider mehrmals unterbrochen.
Das muss ich mir erst mal anschauen. Die Funktion hab ich bisher nur mit dem IThermometer getestet. Oder war das beim Kochen und über 100°C? Da habe ich bereits einen Bug gefixt.
Brauwig hat geschrieben:
Mittwoch 27. März 2019, 10:34
3. Einstellungen werden nur gespeichert, wenn ich das Programm als Administrator ausführe.
Dann scheint dein Standard-User keine Schreibberechtigungen für den Speicherort der Brauerei zu haben. Mach mal einen Rechts-Click auf den Ordner, Klicke Eigenschften\Sicherheit\Erweitert und schau ob dein user Vollzugriff hat, wenn nicht, dann vergib den mit dem Admin.
Brauwig hat geschrieben:
Mittwoch 27. März 2019, 10:34
4. Ich habe mir jetzt die Version 2.01 Trial installiert und in Sachen Heizen/Rühren einige Simualtionen laufen lassen.
Meine Ziel würde so aussehen:
+ Aufheizen Hauptguss: Rührwerk läuft getaktet in Intervallen nur hin und wieder.
+ Einmaischen(Rühren)
+ Rast halten, Rührwerk getaktet in Intervallen um die Maische hin und wieder zu durchmischen. Wenn die Temp. abfällt wird nachgeheizt und automatisch das Rührwerk zugeschalten um ein Anbrennen zu verhindern. Nach Erreichen der Zieltemp. wird noch ein paar Sekunden weiter gerührt und dann ist wieder Pause.
+ Aufheizen nach Rastende wie vorher mit durchgehendem Rühren in der Heizphase usw.
Wenn ich alles richtig verstehe ist meine Wunschvorstellung derzeit nicht umsetzbar, oder?
Wenn ich "Rührwerk durchgehend an" aktiviere, kann ich beim Aufheizen des Hauptgusses nicht takten.(Ist jetzt nicht so ein großes Problem, aber hier durchgehend zur rühren ist meiner Meinung nach unnötig)
Beim Takten in den Ruhephasen hingegen wird in der Simulation in der Nachheizphase trotz "Rührwerk durchgehend an" nicht gerührt sondern nur die Taktung ausgeführt.
Alle deine Vorstellungen lassen sich leider nicht abbilden. Das ist ja je nach Rast ein vollkommen anderes Verhalten. Wie du schreibst ist das was du möchtest eigentlich größtenteils mit dem Rührwerk in Heizphasen durchgehend an in Kombination mit der Pulsung wärend der Rast zu erreichen.
Brauwig hat geschrieben:
Mittwoch 27. März 2019, 10:34
Die Ausschaltverzögerung scheint soweit ich das beobachtet habe nicht wirklich zu funktionieren?
Muss ich mir auch mal anschauen. Ich glaube schon das die funktioniert. Nartürlich nur, wenn sie auch der Heizung folgt
Brauwig hat geschrieben:
Mittwoch 27. März 2019, 10:34
Ach ja, was auf jeden Fall noch fehlt ist ein Spenden-Button!!
hab ich schon mal drüber nachgedacht. Ist mir aber irgendwie peinlich. :Smile

Gruß
Andreas

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#71

Beitrag von emilio » Mittwoch 27. März 2019, 21:48

Noch ein Zwischenupdate zum Testen. Für die Bugs-Fündigen...
- Abfrage Relais-Automatik-Rückstellung nach Rast-Ende integriert
- Netz-Trafic für Sonoff und Edimax-Komponenten reduziert
- "Rührwerk in Heizphasen AN"-Option reaktiviert
- Temperaturempfangsprobleme kleiner 10 und größer 99.9 gefixt
- IP-Felder gegen Fehleigaben verriegelt -> Danke für die Bug-Meldung an Archie
- Curl Version aktuallisiert -> Danke für die Bug-Meldung an Archie
- Bug bei Rührwerksverzögerung beim Ausschalten behoben -> Danke für die Bug-Meldung an Brauwig
- Bug bei Sensorüberwachung von Tasmota-Hardware behoben -> Danke für die Bug-Meldung an Brauwig
http://www.schopfschoppe.de/Download/Br ... taller.exe

Gruß
Andreas

Brauwig
Neuling
Neuling
Beiträge: 4
Registriert: Mittwoch 27. März 2019, 09:44

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#72

Beitrag von Brauwig » Montag 1. April 2019, 15:43

Hallo Andreas!

Danke für deinen Einsatz, deine Antworten und die Weiterentwicklungsarbeit!

Um alle eventuellen Missverständnisse auszuräumen, hier noch genauere Beschreibung des/meines Problems:
Alle deine Vorstellungen lassen sich leider nicht abbilden. Das ist ja je nach Rast ein vollkommen anderes Verhalten. Wie du schreibst ist das was du möchtest eigentlich größtenteils mit dem Rührwerk in Heizphasen durchgehend an in Kombination mit der Pulsung wärend der Rast zu erreichen.
Theoretisch ja, praktisch nein. Bei mir verhält es sich in der Simulation so, dass beim Aufheizen die "Rührwerk in Heizphasen durchgehend an"-Funktion die Taktung deaktiviert(ok soweit), beim Nachheizen in der Rast allerdings verhält es sich umgekehrt, die Taktung wird priorisiert, weil hier nicht automatisch gerührt wird, wenn sich die Heizung einschaltet!(die Taktung läuft wie eingestellt weiter) Ich würde aber eine Funktion "Rührwerk in Heizphasen durchgehend an" so verstehen, dass hier immer gerührt wird, sobald die Heizplatte läuft, oder?(Zumindest wenn das Häkchen "Rührwerk" im Hauptfenstrer aktiviert ist) Daher meine Frage, ist das so gewollt oder handelt es sich um einen Bug?
Muss ich mir auch mal anschauen. Ich glaube schon das die funktioniert. Nartürlich nur, wenn sie auch der Heizung folgt
Ich kann immer noch kein Nachlaufen beobachten, sobald auch die Taktung aktiv ist.
Bei "Rührwerk an Heizung koppeln" ohne Taktung verhält sich der Nachlauf wie er soll. Bei "Rührwerk in Heizphasen durchgehend an" ohne Taktung läuft das Rührwerk bei Erreichen der Zieltemperatur einfach endlos weiter, obwohl die Heizung abschaltet.

Wenn diese Wünsche jetzt nur mich betreffen, frage ich mich, wie machst du das eigentlich? "Rührwerk in Heizphasen durchgehend an" scheinst du ja nicht zu verwenden! Brennt da nichts an? Heizt du in den Rasten nicht nach?
hab ich schon mal drüber nachgedacht. Ist mir aber irgendwie peinlich. :Smile
Ich sehe da nichts peinliches!
:Drink

Vielen Dank!

LG Brauwig

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#73

Beitrag von emilio » Montag 1. April 2019, 16:27

Die letzte Frage kann ich dir einfach beantworten. Die anderen muss ich mir anschauen. Ich persönlich verwende weder eine Taktung noch ein Koppelung. Bei mir läuft das Rührwerk beim Maischen durch.

Als Heisphase bezeichne ich die Phase zwischen den Rasten. Innerhalb der Rast ist die Funktion nicht wirksam. Vielleicht sollte ich das Aufheizphase nennen.
Von dem her glaube ich das passt zu deiner Beschreibung. Wählst du Heizung folgen, sollte im jeweils eingestellten Takt gerührt werden sobald die Heizung an ist.

Grüße
Andreas

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#74

Beitrag von emilio » Montag 1. April 2019, 18:49

So gerade nochmal geprüft. Bei mir funktioniert alles wie ich mir das vorstelle.
Rührwerk an Heizung Koppeln:
Das Rührwerk wird gemeinsam mit der Heizung geschaltet. Ist eine Pulsung eingestellt, wird diese in den Einschaltphasen verwendet. Ist eine Ein- bzw. Ausschaltverzögerung eingestellt, dann wird der entsprechende Zeitversatz zur Heizung verwendet.
Rührwerk durchgehend an in Heizphasen:
Während Aufheizphasen zwischen den Rasten ist das Rührwerk durchgehend eingeschaltet. Während der Rast wird mit dem eingestellten Puls getaktet.

Wenn ich dich richtig verstehe dann möchtest du eine Mischung aus beidem.
Rührwerk ist immer an wenn die Heizung an ist (ggf. auch noch zeitversetzt) und pulst wenn die Heizung aus ist.

Gruß
Andreas

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#75

Beitrag von emilio » Montag 1. April 2019, 19:43

Ich hab mal was gebastelt. Schau mal ob das eher deinen Vorstellungen entspricht...
- Abfrage Relais-Automatik-Rückstellung nach Rast-Ende integriert
- Netz-Trafic für Sonoff und Edimax-Komponenten reduziert
- "Rührwerk in Heizphasen AN"-Option reaktiviert
- Temperaturempfangsprobleme kleiner 10 und größer 99.9 gefixt
- IP-Felder gegen Fehleigaben verriegelt -> Danke für die Bug-Meldung an Archie
- Curl Version aktuallisiert -> Danke für die Bug-Meldung an Archie
- Bug bei Rührwerksverzögerung beim Ausschalten behoben -> Danke für die Bug-Meldung an Brauwig
- Bug bei Sensorüberwachung von Tasmota-Hardware behoben -> Danke für die Bug-Meldung an Brauwig
- Buildnumber eingeführt
- Zusätzliche Rührwerksoption eingeführt
http://www.schopfschoppe.de/Download/Br ... taller.exe

Gruß
Andreas

Brauwig
Neuling
Neuling
Beiträge: 4
Registriert: Mittwoch 27. März 2019, 09:44

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#76

Beitrag von Brauwig » Montag 1. April 2019, 20:39

:Shocked
:Bigsmile
:thumbsup
Wahnsinn!!!!
Wollte noch schreiben, dass ich nicht in dein Programm reinpfuschen will und und wenn das für dich so passt, dann ist es halt so und ich werde sicher irgendwie damit zurechtkommen...

Aber jetzt, einfach perfekt! Das nenn ich Service!
:Wink
Recht herzlichen Dank, freu mich schon sehr auf den nächsten Sud, um alles in der Praxis auszuprobieren!!!

LG

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#77

Beitrag von emilio » Montag 1. April 2019, 20:47

Kein Problem. Die beschriebene Option macht ja Sinn. Irgendwie hat halt jeder eine andere Vorstellung was das Rührwerk so machen soll. Auf die paar Zeilen Code kommt es dann nicht mehr an. Vielleicht hat ja noch der ein oder andere die Selbe Vorstellung wie du. :Wink

Grüße
Andreas

Acosti
Posting Klettermax
Posting Klettermax
Beiträge: 109
Registriert: Donnerstag 13. März 2008, 13:20
Wohnort: Nordhorn

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#78

Beitrag von Acosti » Samstag 6. April 2019, 13:00

Hallo zusammen,

ich wollte nur kurz das Ergebnis der Bastelei präsentieren.

Völlig autarke Brausteuerung zum mitnehmen.

Einzupacken sind Laptop, Brausteuerung, die Kessel und ne Gasflasche. Mal abgesehen von den Zutaten fürs Bier.

Anschlüsse für 12V Rührwerk, Brennerzündung, Brennerüberwachung und Temperaturfühler sind alle bequem von außen zu erreichen.

Erste Tests haben ergeben, dass das Ding sehr stabil läuft.
Stabiler als die Vorgängerversion wo doch ab und an mal der Ardunio abgeschmiert ist.
Ich vermute, dass die Brennerzündung mit der Hochspannung hier die Ursache ist.
Passiert aber höchstens bei jedem zehnten Sud und daher mache ich da nichts mehr dran, außer das ich immer überwache.

Danke Andreas, wieder mal einen Hobbybrauer glücklich gemacht. :thumbsup

Gruß
Hermann

https://hobbybrauer.de/forum/download/f ... w&id=50118

https://hobbybrauer.de/forum/download/f ... w&id=50119

https://hobbybrauer.de/forum/download/f ... w&id=50120
Dateianhänge
1.gif
2.gif
3.gif

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#79

Beitrag von emilio » Samstag 6. April 2019, 20:13

Ich werd verrückt... Mit integrierter Fritzbox. Schickes Teil.
Ich glaub ich muss mal etwas am Wemos Sketch basteln. Eigentlich könnte man den auch wahlweise als Accsesspoint konfigurieren. Für die, welche nicht über einen Router gehen möchten. Theoretisch könnte der Brauerei Sketch auch auf dem Sonoff laufen. Ich glaub aber das bringts nicht wirklich ohne Display.

Grüße
Andreas

woel
Neuling
Neuling
Beiträge: 9
Registriert: Montag 28. Januar 2019, 15:33

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#80

Beitrag von woel » Mittwoch 10. April 2019, 21:44

Hi Andreas,

ich hab grad deine SW mit einem Wemos und OLED in Betrieb genommen. Fnuktioniert super, wenn ich jedoch ein SSR auf den Ausgang D5 lege und dann die Heizung anmache, und mal Testhalber meinen Lötkolben ein und auszuschalten, dann scheint da eine schnelle gepulste Ansteuerung stattzufinden.

Hab die gepulste Heizung auch ausgeschalten, und auch testhalber den D5 verwendet.

Kann es irgendwie an der Stromversorgung (über USB-Kabel vom Laptop) liegen?`
Danke.

LG
Ewald

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#81

Beitrag von emilio » Mittwoch 10. April 2019, 22:06

Hallo Ewald.

Was bedeutet denn für dich eine schnelle Pulsung? Im Sekunden Takt oder schneller? Es gibt wohl SSRs die bei 5V nicht sauber durchschalten, auch wenn sie das laut Spec sollten. Schau mal hier... LINK
Miss doch mal nach ob die 5V am Eingang des SSR sauber anliegen. Wichtig wäre vielleicht auch eine kleine Schaltplanskizze, wie du dein SSR und den Lötkolben angeschlossen hast.

Gruß
Andreas

woel
Neuling
Neuling
Beiträge: 9
Registriert: Montag 28. Januar 2019, 15:33

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#82

Beitrag von woel » Dienstag 16. April 2019, 14:05

Hi Andreas,

hab leider erst jetzt messen können. Also das LED des SSR leuchtet wenn es schaltet.Es liegen 4,6V an wenn angesteuert. Wenn ich eine Last dranhänge fällt es manchmal auf 4,5V. Angeschlossen hab ich wie bei dir am Schaltplan zu sehen. 5V auf + Schaltpin auf - vom SSR. Hab auch andere Lasten (Laptop-Netzteil) probiert. Leider ohne Erfolg.

Danke.

LG

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1444
Registriert: Mittwoch 1. Juli 2015, 11:50

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#83

Beitrag von glassart » Dienstag 16. April 2019, 14:19

hat evt. das SSR lastseitig ein Problem ?
Wenn die Led leuchtet sollte es eigentlich durchschalten. Probiere es einmal ohne Wemos einfach nur mit 5 und 12 V zu schalten. Alle meine SSR´s schalten ansich beim Wemos problemlos wobei ich jetzt einen ULN 2803 "zwischengeschaltet " habe und somit highaktiv mit 12 V schalte (hat verschiedene Gründe, Piezzo ,ect.) :Smile

lg Herbert :Drink

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#84

Beitrag von emilio » Dienstag 16. April 2019, 18:56

Ich selber benutze keine SSRs sondern Relais Boards. Hab das Problem von Woel aber gerade in einem Zestaufbau nachstellen können. Auch die SSR-40 DA welche ich hier rum liegen habe, scheinen zu viel Strom zu ziehen um vom Wemos sauber geschaltet werden zu können. LED brennt, Hendi macht nichts. Mit einem ULN 2803 dazwischen ist das natürlich kein Problem.
Hat hier jemand mehr Erfahrung mit SSRs, die auch vom Wemos sauber unter Last geschaltet werden? Das ist doch gerade der Vorteil von SSRs. Das muss doch funktionieren.

Grüße
Andreas

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#85

Beitrag von emilio » Dienstag 16. April 2019, 19:12

@Herbert:
Die von dir verwendeten Poltechnic SSR aus dem anderen Thread schalten sauber direkt am IO? Hast du da noch welche und kannst das mal testen? Oder bist du noch im Urlaub? Wenn nicht bestelle ich mal eins.

Grüße
Andreas

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1444
Registriert: Mittwoch 1. Juli 2015, 11:50

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#86

Beitrag von glassart » Dienstag 16. April 2019, 19:51

Hallo Andreas,

vorübergehend wieder zuhause :Bigsmile ( bis zum nächsten Urlaub)
-die von Poltechnik mit 40A haben auch ohne ULN sauber geschaltet, die chinesischen ( von den Temperaturreglern die da teils dabei sind) kann ich dzt. nicht beurteilen wie sauber sie am IO arbeiten. Ob ich noch dazu komme das zu testen ist nicht ganz sicher -dzt. ist ja mit der neuen Platine alles auf den ULN aufgebaut - ich müsste was "fliegend" zusammenstöpseln . :Grübel

lg Herbert

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#87

Beitrag von emilio » Dienstag 16. April 2019, 21:48

Hallo Herbert.

Lass mal, kein Stress, ich bestell mir mal sei ein Ding. Ich baue meine Brauanlage im Moment eh auch um. Hab hier eh noch einen fliegenden Aufbau mit dem ich das testen kann.

Grüße
Andreas

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1444
Registriert: Mittwoch 1. Juli 2015, 11:50

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#88

Beitrag von glassart » Dienstag 16. April 2019, 22:23

Hallo Andreas,

wenn ich dazu komme würde ich rein aus Interesse die "noname-SSR´s" gerne testen. Für mich persönlich ( allerdings etwas aufwändiger) ist die Verwendung des ULN im Vordergrund ( high-aktiv, Piezzo mit 12 V gibt ordentlich Gas :thumbsup )
Wobei die von Poltechnik sicher auch von einem chinesischwen Produzenten kommen aber sehr gut sind. Alle meine Schmelzöfen haben die drinnen und die laufen Monate lang auf "Dauerregelbetrieb".

lg Herbert

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#89

Beitrag von emilio » Dienstag 16. April 2019, 22:58

Danke Herbert für den Hinweis mit dem high-aktiv. Meine SSRs funktionieren doch. Ich hatte nur ausgeblendet, dass man die low-aktiv anschließen muss, damit der Wemos die treiben kann. Und ich wette das ist auch das Problem bei Ewald-

@Ewald:
Hast du das SSR wirklich angeschlossen wie in meinem Schaltplan. Also vom GPIO an SSR- und von SSR+ an +5V? Nicht vom GPIO an SSR+ und von SSR- an Masse?
Dann musst du allerdings auch noch in der IMiniBrauerei im Config-Modus die GPIOS auf low-aktiv umstellen.

Gruß
Andreas

Benutzeravatar
glassart
Posting Freak
Posting Freak
Beiträge: 1444
Registriert: Mittwoch 1. Juli 2015, 11:50

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#90

Beitrag von glassart » Mittwoch 17. April 2019, 07:41

Hallo Andreas,

hab mir gerade meine Brauerei 2 + 3 - Hardware angesehen und dort werden die SSR´s nicht mit dem ULN angesteuert sondern direkt vom GPIO. Da sie jetzt schon über 2 Jahre problemlos läuft hatte ich dies vergessen - dort sind 2 Stk AIKS- 40A -SSR´s eingebaut.

Wahrscheinlich liegt bei Ewald der Fehler in der Configuration :Grübel

lg Herbert

woel
Neuling
Neuling
Beiträge: 9
Registriert: Montag 28. Januar 2019, 15:33

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#91

Beitrag von woel » Mittwoch 17. April 2019, 10:06

Hallo Andreas, Herbert,

vielen Dank für Eure Mühe. Ich habe gerade nochmals die Konfiguration angesehen. War leider schon auf Low active. Wie gesagt das Relais schaltet auch, zumindest leutet die LED. Bei kleinen Lasten dürfte das auch funktionieren. Möglicherweise ist auch ein Problem wenn die Last zu induktiv ist? Alexa geht, Staubsauger nicht....Die Dinger sind wohl eher Müll....Muss ich wohl mal andere besorgen...

LG

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#92

Beitrag von emilio » Samstag 11. Mai 2019, 21:52

MoinMoin.

Update der Wemos-FW mit Access-Point-Option auf GitHub....
https://github.com/emilio77

Grüße
Andreas

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#93

Beitrag von emilio » Sonntag 12. Mai 2019, 10:47

Uuuups, ganz vergessen:
SSID und Passwort in der Hotspot Option ist
IMiniBrauerei

Grüße
Andreas

Gimbel
Posting Junior
Posting Junior
Beiträge: 93
Registriert: Dienstag 8. Januar 2008, 20:02

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#94

Beitrag von Gimbel » Sonntag 12. Mai 2019, 20:53

Hallo Andreas,
habe mir die neue IMiniBrauerei Software herruntergeladen. Wemos arbeitet einwandfrei,aber welchen Port muß ich
bei Port Out und Port IN einstellen in der Brauerrei2Wifi Software.

Grüße

Robert

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#95

Beitrag von emilio » Sonntag 12. Mai 2019, 22:42

Hallo Robert.

Die Ports kannst du in der Config des Wemos frei wählen. Sollten halt an deinem Rechner nicht von einem anderen Dienst belegt sein. 5000 und 5001 sind meist keine schlechte Wahl.
Falls du im Hotspot Mode arbeitest kannst du auch einfach im Browser die IP Adresse des Wemos eingeben (192.168.4.1). Da werden dir auch die eingestellten Ports angezeigt. Da könnte aber nach dem ersten mal flaschen ein ziemlicher Unsinn drinnen stehen.
Und nicht vergessen. Port-In am Wemos ist Port-Out in der Brauerei und umgekehrt.

Grüße
Andreas

Gimbel
Posting Junior
Posting Junior
Beiträge: 93
Registriert: Dienstag 8. Januar 2008, 20:02

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#96

Beitrag von Gimbel » Montag 13. Mai 2019, 07:23

Danke Andreas, für die schnelle Antwort
Grüße
Robert

Gimbel
Posting Junior
Posting Junior
Beiträge: 93
Registriert: Dienstag 8. Januar 2008, 20:02

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#97

Beitrag von Gimbel » Montag 13. Mai 2019, 21:10

Hallo Andreas,
habe kurzzeitig Verbindung mit Brauerei2WiFi gehabt.
Dann ist Verbindungung mit PC abgebrochen. Bei Wlanverbindung erscheint keine IMiniBrauerei Wifi.
Wemos spring wieder in Hotspotmodus. Was läuft hier Falsch ?

Grüße
Gimbel

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#98

Beitrag von emilio » Montag 13. Mai 2019, 21:43

Wie meinst du das. War nie eine IMiniBrauerei Wifi da oder bricht die Verbindung nach kurzer Zeit ab und der Wemos landet wieder im Config-Modus? Langzeittests habe ich keine gemacht. Nur einige Minuten auf dem Tisch. Das funktioniert jetzt aber auch. Ich probier das gerade nochmal etwas länger. Welchen Sketch hast du denn geflasht?

Hier nochmal die Kurzanleitung zur Inbetriebnahme...
  • Zwei mal Reset am WEMOS drücken, dazwischen ein zwei Sekunden Pause lassen.
  • WEMOS spannt ein eigenes WLAN-Netzwerk auf, die LED am WEMOS leuchtet durchgehend.(Name des Netzwerks ESPxxxxx)
  • Mit geeignetem Gerät mit dem WLAN des WEMOS verbinden ( z.B. Handy, Tablet, Laptop.... )
  • Browser an dem verbunden Gerät öffnen.
  • Wenn die Config-Seite nicht automatisch öffnet im Browser die Adresse 192.168.4.1 eingeben
  • Auf Config clicken und den Haken bei Create HotSpot setzen und die Ports einstellen - anschliessend "SAVE" drücken
  • Der WEMOS prüft jetzt, ob die Eingaben stimmen und spannt dann sein Netzwerk auf (Name und Passworts des Netzwerks IMiniBrauerei)
  • Mit dem Brau-Rechner mit dem Netzwerk IMiniBrauerei verbinden und in der Brauerei2Wifi die Ports und die IP einstellen
Fertig

Grüße
Andreas

Gimbel
Posting Junior
Posting Junior
Beiträge: 93
Registriert: Dienstag 8. Januar 2008, 20:02

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#99

Beitrag von Gimbel » Dienstag 14. Mai 2019, 18:05

Hallo Andreas,
habe aktuellen Sketch herruntergeladen. Auf Wemos aufgespielt.
Dann Config aufgerufen.In der Config gibt es den Punkt "Creat Hotspot nicht.
Siehe Anhang.
Grüße
Robert
Config.jpg
Config.jpg (36.11 KiB) 346 mal betrachtet

Benutzeravatar
emilio
Posting Freak
Posting Freak
Beiträge: 867
Registriert: Mittwoch 25. Dezember 2013, 09:17
Wohnort: Schopfheim, Wiechs
Kontaktdaten:

Re: Meine Brausoftware die zweite - Brauerei2WiFi V02.xx

#100

Beitrag von emilio » Dienstag 14. Mai 2019, 19:12

Hallo Robert.

Das ist ziemlich sicher nicht der aktuelle Sketch. Wann hast du den denn runter geladen? Ich bin gerade unterwegs. Welcher der drei IMiniBrauerei Sketche hast du denn heruntergeladen. Den normalen oder einer der OLED Varianten?
Zuhause kann ich nochmal prüfen, ob die BIN auch aktuell sind auf GitHub. Die INOs sind es. Das hab ich von hier prüfen können. Ich gehe auch davon aus, dass die BINs i. O. sind. Bitte nochmal neu runter laden und flashen.

Grüße
Andreas

Antworten